09:00:02 <priteau> #startmeeting blazar
09:00:03 <openstack> Meeting started Tue Oct 16 09:00:02 2018 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:06 <openstack> The meeting name has been set to 'blazar'
09:00:14 <priteau> #topic Roll call
09:01:12 <tetsuro> o/
09:01:22 <priteau> Hi tetsuro
09:01:42 <masahito> o/
09:01:50 <priteau> Hi masahito
09:02:03 <priteau> I also see bertys is online
09:02:59 <priteau> Agenda for today:
09:03:01 <priteau> 1. Project Update @ Berlin Summit
09:03:05 <priteau> 2. Forum @ Berlin Summit
09:03:07 <priteau> 3. Changes to release cycle process
09:03:10 <bertys> o/
09:03:10 <priteau> 4. stein-1 milestone
09:03:12 <priteau> 5.
09:03:14 <priteau> AOB
09:03:19 <priteau> Hi bertys
09:03:21 <bertys> Hi all
09:03:48 <priteau> #topic Project Update @ Berlin Summit
09:04:16 <priteau> Our talk is taking shape
09:04:25 <priteau> #link https://docs.google.com/presentation/d/1nsuiQe72E0cYELSI8qLmNwVm4SOXzuf01akzqKEZ1TE/edit
09:05:00 <priteau> I added preliminary content for "What is Blazar?" and completed the Stein slide
09:05:16 <priteau> Tetsuro wrote a slide on cross-project work with placement
09:05:24 <tetsuro> :)
09:05:28 <priteau> Bertrand wrote one on how to give feedback
09:05:35 <priteau> Thank you both
09:06:04 <priteau> masahito: Are you still planning to write content for the Rocky slide? If you don't have time, I can help
09:06:34 <masahito> Sorry, I didn't have much time to write last week. I'll do this in this week.
09:06:57 <priteau> That's fine. We started early, still almost a month :-)
09:07:23 <priteau> Exactly four weeks actually
09:07:36 <masahito> I uploaded the Vancouver summit's one.
09:07:52 <priteau> I see it now, thanks!
09:08:07 <priteau> Could you please also add a little bit of information about the NFV use case on the first slide?
09:08:21 <priteau> Well, on slide #2
09:08:23 <masahito> got it.
09:08:42 <priteau> Thanks!
09:09:27 <priteau> I'll take care of the "Beyond Stein" slide.
09:10:01 <priteau> bertys: Will you take care of the "How to contribute" slide as well?
09:10:20 <bertys> priteau: yes, as agreed.
09:10:43 <priteau> All looks good then, thanks everyone :-)
09:10:48 <priteau> Any comment on this topic?
09:12:48 <priteau> Let's move to the next one
09:12:59 <priteau> #topic Forum @ Berlin Summit
09:13:26 <priteau> The Forum schedule is now up:
09:13:34 <priteau> #link https://www.openstack.org/summit/berlin-2018/summit-schedule/#track=262
09:13:45 <priteau> The two sessions we submitted have been accepted!
09:13:52 <priteau> #link https://www.openstack.org/summit/berlin-2018/summit-schedule/events/22807/extending-blazar-reservations-to-new-resource-types
09:13:56 <priteau> #link https://www.openstack.org/summit/berlin-2018/summit-schedule/events/22806/python-bindings-for-the-placement-api
09:14:15 <priteau> Now is the time to check for any schedule conflict
09:15:21 <priteau> A good thing is that our placement session is right after "Update on placement extraction from nova", in the same room
09:15:22 <masahito> Both are accepted! Nice!
09:15:41 <priteau> So we should have lots of people interested in placement attend!
09:16:28 <masahito> sounds good.
09:17:33 <priteau> The Summit schedule is now mostly complete. Apparently just some BoFs and WGs are not yet up.
09:18:36 <tetsuro> Would you mind if I put some topics about the host-reservation with placement to that Forum if we have time?
09:19:52 <masahito> I don't mind if the topics is needed for the Forum.
09:20:07 <masahito> s/if/unless/
09:20:39 <priteau> tetsuro: Preferably only if we have time at the end of the session, as it is potentially of interest for lots of projects consuming placement (Neutron, Cinder, Cyborg), not just Blazar + Placement
09:21:16 <tetsuro> Yup, that's fair.
09:22:58 <priteau> We should start Etherpads for each Forum session
09:23:30 <priteau> I will create one for Blazar reservations. tetsuro, can you do the placement one?
09:24:06 <tetsuro> Sure.
09:24:37 <priteau> #action Create Etherpads for Forum @ Berlin Summit
09:25:12 <priteau> Anything else to say about this?
09:26:06 <priteau> Moving on
09:26:09 <priteau> #topic Changes to release cycle process
09:26:37 <priteau> You may have seen on the mailing list, there are some changes being made to the release process
09:27:50 <priteau> The cycle-with-milestones model will stop tagging milestones (i.e. for stein-1, stein-2, stein-3)
09:27:55 <priteau> #link http://lists.openstack.org/pipermail/openstack-dev/2018-October/135706.html
09:29:02 <priteau> This has impact on people testing upgrades because of versioning between stable branch and master (more detailed in the email thread), so the proposed solution is to use PBR Sem-Ver tagging
09:29:17 <priteau> A commit has been proposed on each project, here's ours: https://review.openstack.org/#/c/610568/
09:30:48 <priteau> It automatically bumps our version number to 2.1.0
09:31:12 <priteau> See pip2 freeze output of the Zuul job: http://logs.openstack.org/68/610568/1/check/blazar-devstack-dsvm/1ed406c/logs/pip2-freeze.txt.gz
09:31:43 <priteau> Compared to before the PBR commit: http://logs.openstack.org/78/610678/1/check/blazar-devstack-dsvm/4bfb0fa/logs/pip2-freeze.txt.gz
09:31:53 <priteau> If there's no objection I will approve this patch
09:33:33 <priteau> There's also a proposed change for library releases
09:33:34 <masahito> I missed the ML thread, so not fully understand yet.
09:33:59 <bertys> I am also wondering if we need patch for blazar-dashboard?
09:34:31 <priteau> bertys: blazar-dashboard is cycle-with-intermediary, not cycle-with-milestones
09:35:21 <bertys> priteau: I see, thanks
09:35:33 <priteau> See https://releases.openstack.org/reference/release_models.html#cycle-with-intermediary vs https://releases.openstack.org/reference/release_models.html#cycle-with-milestones
09:36:02 <priteau> masahito: A short summary is:
09:36:26 <priteau> To reduce release overhead, they propose to stop tagging milestones, instead tagging only RCs
09:37:15 <priteau> This has an impact on people testing upgrades from Rocky release to Stein development, as the version number has not bumped and Rocky release is seen as newer
09:37:54 <priteau> Solution is to bump the release number early in the cycle, this is done via PBR Sem-Ver tag in a commit
09:38:44 <priteau> There's not much impact for us. We merge this patch and continue working on our milestones as usual.
09:39:15 <masahito> Thanks the summary. I'm fine to the change.
09:39:23 <priteau> There is also a proposed change for cycle-with-intermediary library
09:39:26 <priteau> #link http://lists.openstack.org/pipermail/openstack-dev/2018-October/135689.html
09:39:49 <priteau> They will force a release at each milestone if there are changes and a release has not been done already
09:41:03 <priteau> We have a few changes in python-blazarclient, but only internal infra (Zuul job) to small README change
09:41:21 <priteau> I am not sure if that will trigger a release, we'll see
09:43:09 <priteau> They are also thinking of requiring a person for each team to add their name to a "manifest" of sorts for the release cycle.
09:43:28 <priteau> "That "final release liaison" person would be the designated person to follow through on finishing out the releases for that team, and would be designated ahead of the final release phases."
09:43:54 <priteau> It can be the PTL but it doesn't have to be. I am happy to take this role unless someone wants to do it.
09:44:38 <priteau> That was a rather long "For Your Information" really.
09:44:53 <priteau> We need to move on as we have just 15 minutes left
09:44:57 <priteau> #topic stein-1 milestone
09:45:12 <priteau> #link https://launchpad.net/blazar/+milestone/stein-1
09:45:18 <priteau> stein-1 is next week
09:45:53 <priteau> There's lots to do that we won't be able to complete, so we'll have to move them to stein-2
09:46:10 <priteau> Let's focus on reviewing what's ready
09:46:37 <masahito> +1
09:46:58 <priteau> I have these two patches ready to review: https://review.openstack.org/#/q/topic:bug/1797940+(status:open+OR+status:merged)
09:47:28 <priteau> I also gave a +2 to masahito's patches for instance reservation scenarios, we need another review: https://review.openstack.org/#/q/status:open+project:openstack/blazar-tempest-plugin+branch:master+topic:bug/1714438
09:47:59 <priteau> I am hoping to review tetsuro's code soon
09:48:32 <priteau> bertys: Would you be able to review masahito's tempest code?
09:48:40 <tetsuro> I rebased it today
09:48:58 <tetsuro> ^just FYI
09:49:07 <masahito> For s-1 milestone 4 series of my patch are ready to review.
09:49:24 <masahito> https://review.openstack.org/#/q/status:open+project:openstack/blazar+branch:master+topic:bug/1304435
09:49:27 <masahito> https://review.openstack.org/#/q/status:open+project:openstack/blazar+branch:master+topic:bp/resource-availability-api
09:49:32 <masahito> https://review.openstack.org/#/q/status:open+project:openstack/blazar+branch:stable/queens+topic:bug/1786007-stable/queens
09:49:36 <masahito> https://review.openstack.org/#/q/status:open+project:openstack/blazar+branch:master+topic:bp/basic-network-plugin
09:50:56 <priteau> Thanks for the reminder masahito
09:51:17 <masahito> Most of tetsuro's patches looks good to me. If there're no objection, I'd like to merge the patches.
09:52:07 <bertys> priteau: ok, will do today or tomorrow on best effort basis. I am not available on Thursday / Friday
09:52:18 <masahito> Especially, the patches under blazar.utils doesn't affect current Blazar code.
09:52:49 <priteau> masahito: I'll try to take a look at tetsuro's code later today
09:55:06 <priteau> masahito: Thanks for the floating IP spec. I left a comment on Gerrit, wondering if there's an approach that would allow users to still associate IPs via Horizon rather than updating reservation params
09:56:41 <masahito> priteau: That's what I ask you. The another approach is creating external networks for each reservations, right?
09:58:06 <masahito> meaning one reservation is mapped to one external network.
09:58:17 <priteau> That's an alternative, but as you explain in the spec, it is complex to configure for operators.
09:58:50 <masahito> right.
09:58:59 <priteau> I was wondering if there was an approach that would take a floating IP out of a single external network and assign it to the project which made the reservation
09:59:17 <priteau> Like we drafted in Dublin
10:00:27 <priteau> It may need some advanced configuration of Neutron policies. I found an approach for VLANs where I can create networks as Blazar using trusts, which makes them owned by the reserving project.
10:00:41 <priteau> We're running out of time. I will share the details with you.
10:00:48 <priteau> #topic AOB
10:00:48 <masahito> priteau: do you have time after the meeting? I want to check my understand is correct.
10:00:52 <priteau> Any AOB?
10:01:03 <priteau> masahito: Unfortunately I have to go in another meeting right after
10:01:54 <masahito> Got it.  I also checked your one, but hit an issue. I'll reply it on the gerrit.
10:02:02 <priteau> I can be on IRC tomorrow morning or we can discuss by email.
10:02:12 <masahito> thanks.
10:02:12 <priteau> Thanks!
10:02:31 <priteau> We need to end. Have a good rest of the week.
10:02:38 <priteau> #endmeeting