09:00:00 <priteau> #startmeeting blazar
09:00:01 <openstack> Meeting started Tue Sep 18 09:00:00 2018 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:04 <openstack> The meeting name has been set to 'blazar'
09:00:11 <priteau> #topic RollCall
09:00:44 <masahito> o/
09:00:53 <bertys_> o/
09:01:12 <priteau> Hello Masahito and Bertrand
09:01:27 <priteau> No Tetsuro today?
09:01:46 <priteau> I guess we can start then
09:01:57 <priteau> The agenda for today is:
09:02:00 <priteau> 1. PTG meeting summary
09:02:06 <priteau> 2. python3-first goal
09:02:09 <priteau> 3. Blazar specifications
09:02:14 <priteau> 4. Forum Topic Submission
09:02:16 <priteau> 5. AOB
09:02:19 <priteau> Anything else?
09:03:17 <priteau> #topic PTG meeting summary
09:04:00 <priteau> I did a quick summary of our priorities for Stein
09:04:16 <priteau> It's at the end of the Etherpad
09:04:21 <priteau> #link https://etherpad.openstack.org/p/blazar-ptg-stein
09:05:52 <priteau> I've ordered them roughly in decreasing priority as I see them, but we can move them around
09:06:06 <masahito> Lots of tasks :-)
09:06:53 <masahito> I think it misses soft-delete one.
09:07:38 <priteau> Good catch! It's because there is no blueprint that I missed it.
09:07:45 <priteau> I will create a soft-delete blueprint.
09:08:12 <priteau> #action priteau will create a soft-delete blueprint
09:08:37 <priteau> We have lots of tasks for Stein, but the cycle is longer.
09:09:08 <priteau> If we can at least complete the higher priority ones, I will be happy :-)
09:10:06 <priteau> This week I will go over the meeting notes in more details to check for anything important and move the information to blueprint or bugs
09:10:47 <priteau> We had a good meeting in Denver, thank you for travelling all the way there and participating!
09:10:55 <priteau> Any other comment?
09:11:11 <masahito> Thanks.
09:11:17 <masahito> nothing from my side.
09:11:48 <priteau> #topic python3-first goal
09:12:20 <priteau> We need to finish the python3-first goal
09:12:45 <masahito> yup.
09:12:49 <priteau> I have merged many patches yesterday which had an existing +2
09:13:31 <bertys_> we need to discuss now 602465 versus 602722
09:13:39 <priteau> masahito: I see you're trying to use the checkout-override for the tempest plugin. I am not sure why you are still trying though, since I have a solution which works for queens and even for pike
09:14:23 <masahito> IMO, it works only for CURRENT tempest plugin.
09:14:28 <priteau> My approach is to skip Gabbi API tests using a Tempest regex: https://review.openstack.org/#/c/602465/
09:15:16 <priteau> That's true, it may break in the future if we add or change scenarios so that they are not compatible with Queens
09:15:30 <masahito> Let's think the case where we add a new scenario test which calls the Query reservation candidates API in Rocky. It causes gate failure.
09:15:45 <priteau> But, we could change the regex to ignore them, or write scenarios so that they're compatible with either version
09:16:31 <masahito> I figured out the override-checkout only works for a tag or branch name.  http://git.openstack.org/cgit/openstack-infra/zuul/tree/zuul/executor/server.py#n1022
09:17:19 <masahito> So my idea for the queens and the pike is adding the override-checkout with 0.1.0 and excluding api tests.
09:19:17 <priteau> On the other hand, when we add an instance reservation scenario, it could be useful to execute it on Queens to test that it works fine
09:20:01 <masahito> I'm not a fun of adding ignoring regrex every time to all stable branch when we update master tempest pluguin. It's easy for us to forget doing that.
09:20:17 <masahito> priteau: it makes sense.
09:20:40 <masahito> How about adding 0.1.1 or 0.2.0 to the plugin?
09:20:59 <masahito> when we added an instance reservation scenario.
09:21:07 <priteau> I see, we can always bump the plugin tag to test with a newer version
09:21:13 <priteau> OK, I am happy with this approach
09:21:27 <priteau> 0.1.0 is newer than I thought anyway
09:21:50 <priteau> It's almost the latest commit
09:22:02 <masahito> I try to add instance reservation scenario first.
09:22:42 <priteau> Can we finish python3-first first though?
09:23:01 <priteau> And bump the plugin checkout once you have instance reservation tested
09:23:26 <priteau> We need a solution that works for Ocata, Pike, and Queens anyway
09:23:31 <masahito> I think so.
09:23:31 <priteau> Ocata doesn't have instance reservation
09:24:12 <masahito> Okay, we now doesn't hit the problem with your patch. so I'll abandon my patch now.
09:24:42 <priteau> As you want.
09:25:12 <priteau> If you have the instance reservation scenario ready soon, we can reopen your patch to use 0.1.1 or 0.2.0
09:26:15 <priteau> You've convinced me that it's useful to stick to a specific version, I just didn't want that version to be too old
09:27:19 <priteau> Now we need to finish review
09:27:37 <masahito> right.
09:27:55 <priteau> Try this query: https://review.openstack.org/#/q/is:open+reviewer:self+topic:python3-first
09:28:21 <priteau> It should show you all Blazar patches (maybe other projects too if you're reviewer on non-Blazar projects) that are still open for this topic
09:28:50 <priteau> In particular masahito could you please check:
09:28:53 <priteau> https://review.openstack.org/#/c/596236/
09:29:55 <masahito> Done :-)
09:30:25 <priteau> For Pike I added back tempest tests in https://review.openstack.org/#/c/603200/
09:30:31 <priteau> I will do the same for Ocata (not done yet)
09:31:03 <priteau> I only added python2 tempest tests, as there is no point in running a full python3 devstack with pike, we know it's going to fail
09:31:09 <priteau> I will do the same for Ocata
09:31:18 <bertys_> +1
09:31:30 <priteau> masahito: Could you please also review https://review.openstack.org/#/c/602465/
09:31:52 <masahito> Just now added +2 :-)
09:33:20 <priteau> Thank you!
09:33:42 <priteau> If you are around for a little longer today, I will ping you when I have the Ocata patches ready
09:34:07 <priteau> I will merge the zuul changes first anyway, and add back DevStack Tempest on top
09:34:19 <priteau> Anything else to discuss for python3-first?
09:34:39 <masahito> sorry after this meeting I need to be AFK today.
09:35:07 <bertys_> We are almost done, so I am happy
09:35:32 <priteau> OK, then could you please review https://review.openstack.org/#/c/596243/ and https://review.openstack.org/#/c/596239/
09:36:21 <priteau> Or bertys_
09:36:27 <priteau> I need another +2 to merge
09:43:23 <priteau> Gerrit is quite slow for me right now
09:43:42 <priteau> Just need review for https://review.openstack.org/#/c/596239/
09:45:49 <priteau> masahito, bertys_: Are you looking at this patch?
09:46:23 <bertys_> I am looking at https://review.openstack.org/#/c/603200. Gonna merge now
09:46:33 <priteau> Thanks
09:46:53 <priteau> It needs a review of its parent to merge though: https://review.openstack.org/#/c/596239/
09:48:41 <priteau> I think we have it all, thanks!
09:48:53 <priteau> I will push the remaining patch for Ocata later today
09:49:04 <priteau> Can we move to the next topic?
09:49:11 <priteau> Only 11 minutes left
09:49:13 <bertys_> ok for me
09:49:17 <priteau> #topic Blazar specifications
09:49:30 <priteau> I requested the blazar-specs repo in https://review.openstack.org/#/c/602783/
09:49:54 <priteau> There was a reply from Andreas Jaeger saying that some projects have stopped using -specs repos
09:50:32 <priteau> Basically there is no preferred way of using specs. We are free to keep using our docs folder if we want, or we can go ahead and request the repo if we prefer.
09:51:21 <priteau> What would you prefer? There is a small overhead in having to manage another repo, but not much.
09:51:49 <masahito> priteau: Do you know where the projects write down its new specification instead of its spec repo?
09:52:52 <priteau> I think some don't use specs file at all but write details in Launchpad blueprints (I think Horizon is an example)
09:53:12 <masahito> I'm fine either one if we have a place to discuss details of a new feature/specification.
09:53:46 <priteau> Looks like Swift is an example of a project that has stopped using its -specs repo: http://specs.openstack.org/openstack/swift-specs/
09:53:53 <priteau> I am trying to find where they work now
09:54:07 <bertys_> As I said in Denver, I'm fine to create blazar-specs repo
09:55:23 <priteau> OK, then I will go ahead and request the repo. It will give us a presence on specs.openstack.org that we can clearly separate from docs.
09:56:17 <priteau> Next topic
09:56:20 <priteau> #topic Forum Topic Submission
09:56:54 <priteau> The Forum topic submission period has started
09:57:05 <priteau> It runs until the 26th of September (Wednesday next week)
09:57:47 <priteau> Any new topic that you've thought about since last week?
09:57:57 <priteau> Reminder that our current topic list is
09:57:59 <priteau> #link https://etherpad.openstack.org/p/Berlin-stein-forum-blazar-brainstorming
09:59:13 <priteau> I will prepare text for the proposed topics and we can review at the next meeting
09:59:23 <priteau> Just one minute to go for AOB
09:59:26 <priteau> #topic AOB
09:59:29 <priteau> Anything else?
10:00:03 <masahito> I wouldn't join the next meeting because of ONS summit.
10:00:23 <priteau> OK, then I will send by email for you to review
10:01:37 <masahito> I try to login the channel but will not be active... because of its keynote
10:01:48 <priteau> OK no problem
10:01:58 <priteau> If no AOB we can end the meeting
10:02:25 <priteau> #endmeeting