15:00:20 <bauzas> #startmeeting blazar
15:00:20 <openstack> Meeting started Fri May 30 15:00:20 2014 UTC and is due to finish in 60 minutes.  The chair is bauzas. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:24 <openstack> The meeting name has been set to 'blazar'
15:00:32 <bauzas> hi all
15:00:34 <cmart> o/
15:00:42 <cmart> hello
15:00:48 <DinaBelova> o/ (50% of my time)
15:00:55 <bauzas> cmart: is pafuent there ?
15:01:24 <cmart> he is coming
15:01:31 <bauzas> ok cool
15:01:36 <DinaBelova> winter is coming..
15:01:38 <DinaBelova> sorry
15:01:56 <bauzas> DinaBelova: you're right, but Summer has to come in before :)
15:02:07 <cmart> hahaa
15:02:14 <bauzas> DinaBelova: GoT fan, eh ;)
15:02:17 <cmart> coming in 3... 2 ... 1...
15:02:29 <cmart> 1/2.....
15:02:45 <bauzas> ok, we'll be quick then
15:03:00 <cmart> 1/4?
15:03:00 <bauzas> I guess that scroiset should not attend
15:03:02 <cmart> there!
15:03:20 <DinaBelova> hehe!
15:03:25 <DinaBelova> pafuent, o/
15:03:43 <bauzas> pafuent: o/
15:03:54 <pafuent> o/
15:04:01 <bauzas> so, I guess we can start
15:04:07 <pafuent> Yes
15:04:27 <bauzas> https://wiki.openstack.org/wiki/Meetings/Climate#Agenda_for_May_30_2014
15:04:50 <bauzas> #topic Action items from the last meeting + reviews queries
15:05:06 <bauzas> well, IIRC, there are no last actions items
15:05:31 <pafuent> Yes
15:05:50 <bauzas> at least, I just sent the unittests for client in trunk
15:05:56 <bauzas> this morning
15:05:59 <cmart> :)
15:06:09 <bauzas> thanks for the work, btw.
15:06:39 <cmart> thanks to niko :)
15:06:43 <bauzas> there is still one big review in my backlog : https://review.openstack.org/84158
15:07:12 <pafuent> Yes, that is mine
15:07:28 <pafuent> The last patch is only a small rebase
15:07:33 <bauzas> ok, will try to do it by next week
15:08:21 <cmart> what about https://review.openstack.org/#/c/91455/?
15:08:41 <bauzas> cmart: I was about to speak about it
15:08:48 <cmart> OK
15:08:52 <bauzas> cmart: that one is really important
15:09:38 <bauzas> cmart: I left this review with a -2
15:09:50 <bauzas> cmart: due to some way to implement discovery for versions
15:10:03 <bauzas> cmart: what's the high-level status of this patch ?
15:10:42 <cmart> I would say that it is the same as two weeks ago..
15:10:59 <cmart> I did the changes that you guys requested.. and that´s it
15:11:21 <pafuent> We talk about this patch with cmart and the idea is that I'll continue working on that
15:11:25 <cmart> I'd to add the unit tests stuff as well
15:11:49 <cmart> yes
15:12:21 <bauzas> pafuent: cmart: well, my question is : can I go thru the patch and review it ?
15:12:35 <bauzas> pafuent: cmart: is there any left work to do ?
15:13:22 <cmart> yes, the discovery version part
15:13:34 <cmart> but that would be on the climate module side"
15:13:58 <cmart> and the client would have to call that api to check versions and so on (similar to what keystoneclient is doing)
15:14:44 <bauzas> cmart: ok, so, I'll review the patch to see how versions are dealt, and change my -2 to something else
15:15:09 <bauzas> cmart: provided some work has to be done on climate for autodiscovery, but your workaround is working
15:15:14 <bauzas> cmart: is that OK ?
15:15:29 <cmart> bauzas: yes.. the workaround works for now
15:15:57 <bauzas> cmart: ok cool
15:16:13 <bauzas> cmart: feel free to open a blueprint for autodiscovery
15:16:22 <bauzas> cmart: as it is a cross-repo thing
15:16:32 <bauzas> cmart: we will need to track it correctly
15:16:41 <cmart> cmart: OK.
15:17:08 <bauzas> #action cmart to create a blueprint for API versioning discovery
15:17:16 <pafuent> Another old patch that we need to review is this one https://review.openstack.org/#/c/78309/
15:17:26 <pafuent> This is yours bauzas
15:17:34 <bauzas> pafuent: indeed
15:17:43 <pafuent> I'll check the last patch
15:17:44 <bauzas> I had twice 2x +2
15:17:53 <bauzas> but ran twice with merge problems
15:17:57 <pafuent> Yes
15:18:18 <bauzas> so pafuent and DinaBelova feel free to quickly review it
15:18:27 <bauzas> but that's only a rebase thing
15:18:27 <DinaBelova> bauzas, ok
15:18:32 <pafuent> I'll do that after the metting
15:18:37 <bauzas> pafuent: cool
15:19:08 <bauzas> I don't have anything to add on that topic
15:19:11 <bauzas> can we move?
15:19:52 <pafuent> There are two "Updated from global requirements" pending
15:20:30 <bauzas> pafuent: well, that's not that urgent, but will go thru them
15:20:30 <pafuent> They are related to sphinx
15:21:15 <pafuent> That's true, but I feel bad if they remain for a long time ;)
15:21:35 <bauzas> pafuent: I gave +2 to them
15:21:47 <bauzas> pafuent: we only need sphinx for doc generation
15:21:53 <pafuent> bauzas: :)
15:21:55 <bauzas> pafuent: I'm fine
15:22:05 <bauzas> ok, let's move to the next topic
15:22:12 <bauzas> oh, one last thing
15:22:32 <bauzas> nah, nevermind, I'll speak about it during open discussion
15:22:38 <pafuent> OK
15:22:44 <cmart> :)
15:22:57 <bauzas> #topic Climate -> Blazar renaming status
15:23:23 <bauzas> so, thanks to SergeyLukjanov, our repos are now called Blazae
15:23:27 <bauzas> Blazar
15:23:39 <bauzas> there are still pending tasks
15:23:42 <pafuent> SergeyLukjanov: Thanks for the renaming
15:24:03 <SergeyLukjanov> you're welcome folks ;)
15:24:10 <pafuent> One thing is to get Blazar on readthedocs.org
15:24:13 <bauzas> the top high priority is to change the base package
15:24:26 <SergeyLukjanov> I'm still feeling blazar a project I've been involved in :)
15:24:32 <bauzas> from climate to blazar
15:24:39 <pafuent> https://bugs.launchpad.net/blazar/+bug/1311746
15:24:40 <uvirtbot> Launchpad bug 1311746 in blazar "Climate Client should be renamed to Blazar Client" [High,Triaged]
15:24:42 <pafuent> https://bugs.launchpad.net/blazar/+bug/1311747
15:24:43 <uvirtbot> Launchpad bug 1311747 in blazar "Climate Nova extension should be renamed to Blazar Nova extension" [High,Triaged]
15:24:49 <pafuent> https://bugs.launchpad.net/blazar/+bug/1311761
15:24:50 <uvirtbot> Launchpad bug 1311761 in blazar "Climate should be renamed to Blazar" [High,Triaged]
15:25:04 <SergeyLukjanov> pafuent, you should just create a blazar project at readthedocs.org and copy-paste configs
15:25:05 <bauzas> SergeyLukjanov: what's your opinion for that move (ie. change all-in-once, or keep two separate packages ?)
15:25:30 <SergeyLukjanov> pafuent, ping me with your rtfd id and I'll add you as admin to climate-project
15:25:34 <bauzas> SergeyLukjanov: and do incremental moves ?
15:25:45 <pafuent> SergeyLukjanov: OK
15:25:58 <SergeyLukjanov> bauzas, for sahara we do rename keeping everything working
15:26:06 <SergeyLukjanov> bauzas, so, we've added aliases for the new names
15:26:16 <SergeyLukjanov> and than swap the alias and code itself
15:26:21 <bauzas> SergeyLukjanov: in one single big patch to rule them all ?
15:26:24 <SergeyLukjanov> so, savanna was the alias after it
15:26:29 <SergeyLukjanov> not in one
15:26:41 <SergeyLukjanov> it was about 2 weeks of patches ;)
15:26:50 <bauzas> SergeyLukjanov: I harldy guess so
15:26:56 <SergeyLukjanov> there were patches like rename package
15:26:58 <SergeyLukjanov> rename vars
15:27:01 <SergeyLukjanov> rename classes
15:27:02 <SergeyLukjanov> and etc
15:27:22 <bauzas> SergeyLukjanov: so you created a new package called sahara
15:27:26 <SergeyLukjanov> and than when everything was working ok we've removed the old alias and announce renaming completed
15:27:31 <bauzas> SergeyLukjanov: left the old savanna package
15:27:47 <SergeyLukjanov> bauzas, just add aliases in to setup.cfg
15:28:01 <bauzas> SergeyLukjanov: ok, cool, any review I could take a look on ?
15:28:02 <SergeyLukjanov> entry_points]
15:28:02 <SergeyLukjanov> console_scripts =
15:28:02 <SergeyLukjanov> sahara-all = sahara.cli.sahara_all:main
15:28:02 <SergeyLukjanov> sahara-api = sahara.cli.sahara_api:main
15:28:02 <SergeyLukjanov> sahara-engine = sahara.cli.sahara_engine:main
15:28:03 <SergeyLukjanov> sahara-db-manage = sahara.db.migration.cli:main
15:28:05 <SergeyLukjanov> _sahara-subprocess = sahara.cli.sahara_subprocess:main
15:28:22 <SergeyLukjanov> bauzas, there were too many reviews I'm afraid...
15:28:44 <SergeyLukjanov> bauzas, we have blueprints named savanna-rename-*
15:28:53 <SergeyLukjanov> bauzas, you can find CRs under the blueprints
15:28:53 <bauzas> ok, will take a look
15:29:00 <bauzas> SergeyLukjanov: thanks
15:29:38 <pafuent> bauzas: I can work on those patches too
15:31:00 <bauzas> pafuent: your help is welcome
15:31:11 <bauzas> pafuent: we just need to define a strategy
15:31:27 <pafuent> bauzas: OK
15:31:35 <bauzas> pafuent: and anyway, I won't have too much time for doing that :)
15:31:51 <pafuent> bauzas: :)
15:31:54 <bauzas> pafuent: so let's discuss that next week in our channel to see how things go
15:32:04 <pafuent> bauzas: OK
15:32:14 <bauzas> pafuent: I'll try to find out some sahara examples
15:33:55 <pafuent> Keystoneclient bug?
15:34:02 <bauzas> #action bauzas pafuent to define a strategy for renaming Climate package and modules into Blazar
15:34:25 <bauzas> #topic Keystoneclient bug
15:34:34 <bauzas> well, that's basically a FYI
15:34:37 <DinaBelova> folks, sorry, I need to go
15:34:46 <bauzas> DinaBelova: sure, bye
15:34:49 <DinaBelova> see u!
15:34:55 <pafuent> DinaBelova: Bye
15:35:01 <cmart> DinaBelova: bye
15:35:16 <bauzas> https://bugs.launchpad.net/blazar/+bug/1324903
15:35:17 <uvirtbot> Launchpad bug 1324903 in blazar "Fix tests gates failing due to keystone client 0.9.0" [Critical,Fix committed]
15:35:38 <bauzas> there was a bug, but the fix has been committed
15:35:49 <bauzas> so, the topic is just for the records now :)
15:36:02 <pafuent> Ok
15:36:29 <bauzas> pafuent: the problem was basically that we implement a FakeMemcache driver for testing keystoneclient auth
15:36:47 <bauzas> pafuent: and the interfaces changed
15:37:07 <pafuent> bauzas: :'(
15:37:10 <bauzas> I think we can move to open discussion ?
15:37:14 <pafuent> Yes
15:37:19 <bauzas> #topic Open discussion
15:37:20 <cmart> +1
15:37:25 <cmart> I want to mention that my situation changed after summit.. Priorities as well so I'll be moving from project to project until someone tells me to stop :(. I'll love to stay here, but priorities are priorities :S
15:37:50 <cmart> pafuent will be taking my patches
15:37:54 <bauzas> cmart: life is always about priorities :)
15:37:57 <cmart> (or not :))
15:38:27 <bauzas> cmart: no problem, we're all living with different concerns
15:38:30 <cmart> bauzas: not my priorities, but hey, disagree and commit
15:38:34 <cmart> :D
15:38:55 <bauzas> :)
15:39:25 <bauzas> anyway,let's move on
15:40:34 <bauzas> I have nothing else to add on Climate
15:40:41 <cmart> bauzas: what was the thing that you wanted to say?
15:40:53 <bauzas> https://review.openstack.org/90755
15:40:55 <cmart> [12:22] <bauzas> nah, nevermind, I'll speak about it during open discussion
15:41:16 <bauzas> now that we have Statuses, I should amend the calls for using them
15:41:34 <bauzas> so, if people have time for helping me, I'm OK with that
15:42:02 <bauzas> that's it for me
15:42:33 <pafuent> bauzas: When I finish some other things, I can do it
15:42:51 <bauzas> pafuent: that's not high priority
15:43:05 <bauzas> pafuent: just something I don't want to loose the scope
15:43:18 <pafuent> I know
15:43:27 <bauzas> anyway, that's it for me
15:43:33 <bauzas> anything to add ?
15:43:40 <pafuent> From my side I contacted a guy inside of Intel that is interested in use Blazar
15:44:03 <bauzas> pafuent: cool
15:44:06 <pafuent> I'll meet with him to see if Blazar satisfy all his needs
15:44:14 <bauzas> pafuent: some IBM people also sound interested in the concept
15:44:29 <pafuent> The idea is to use Blazar in our internal OS deployment
15:44:38 <bauzas> pafuent: ok
15:44:42 <cmart> pafuent: maybe the priorities could changed after your meeting.. and I could come back :D:D
15:44:57 <pafuent> pafuent: Maybe
15:45:03 <pafuent> cmart: Maybe
15:45:10 <cmart> hahaha
15:45:11 <pafuent> Sorry for talk to myself
15:45:14 <bauzas> :)
15:45:28 <bauzas> ok, let's see how things are going then
15:45:54 <bauzas> priorities are stabilizing code, renaming stuff and do some blueprints possibly
15:46:06 <pafuent> +1
15:46:33 <bauzas> ok, good to talk to you all folks
15:46:54 <cmart> bauzas: thanks to you!
15:46:57 <bauzas> ending the meeting
15:47:03 <pafuent> bauzas: thanks to you!
15:47:07 <bauzas> #endmeeting