15:01:46 <matrohon> #startmeeting bgpvpn
15:01:47 <openstack> Meeting started Tue Oct 13 15:01:46 2015 UTC and is due to finish in 60 minutes.  The chair is matrohon. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <doude> hi
15:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:51 <openstack> The meeting name has been set to 'bgpvpn'
15:01:54 <tmorin> hello everyone
15:02:03 <pcarver> hi
15:02:15 <matrohon> hi
15:02:47 <matrohon> janscheurich, doude vthapar : around?
15:03:22 <matrohon> I've updated the agenda :
15:03:35 <tmorin> timirnich_ maybe around too ?
15:03:36 <matrohon> https://wiki.openstack.org/wiki/Meetings/BGPVPN#Agenda
15:03:43 <doude> matrohon: yes
15:03:46 <vthapar> hi everyeone, just wrappingup another meeting
15:04:24 <matrohon> #topic : subresources
15:04:46 <matrohon> the the patch to move associations to subresources is out
15:04:58 <matrohon> #link  https://review.openstack.org/#/c/232798
15:05:24 <matrohon> vthapar, doude you both can review it, it will impact your driver
15:06:07 <matrohon> I's still WIP, since it doesn't manage DB resources correctly
15:06:09 <tmorin> the neutronclient has been updated to this changed API to create associations
15:06:18 <vthapar> matrohon: can't comment much from a review perspective, am just keeping an eye on it and tracking to know what updates needed in driver.
15:06:36 <matrohon> vthapar, fine
15:06:42 <tmorin> it can be used for testing perfectly well,  the thing that breaks is deleting associations
15:07:10 <tmorin> I will update bagpipe driver this week
15:07:21 <matrohon> the client review is here : https://review.openstack.org/#/c/233613/
15:07:26 <vthapar> tmorin: that was going to be my next question. so I can use it to try out driver changesin create path, right?
15:07:26 <matrohon> #link https://review.openstack.org/#/c/233613/
15:07:38 <tmorin> vthapar: yes
15:08:08 <matrohon> tmorin : I've included the changes in the bagpipe driver
15:08:20 <matrohon> tmorin, but didn't test is yet
15:08:28 <tmorin> matrohon: oh good, I'll just have to test then
15:08:28 <matrohon> UT works at least
15:08:59 <matrohon> #topic mitaka summit
15:09:16 <tmorin> #topic API spec
15:09:22 <matrohon> I saw that armax sent a mail concerning design session yesterday
15:09:55 <matrohon> tmorin, you wanted to talk about the spec?
15:10:08 <tmorin> can be after, nevermind
15:10:14 <matrohon> tmorin fine
15:10:49 <matrohon> last time I check armax's link,  etherpad was down...
15:11:14 <matrohon> pcarver, did you follow discussion around mitaka summit
15:11:45 <pcarver> matrohon: if you mean mailing list discussion, I'm way behind
15:11:53 <tmorin> I can't fing bgpvpn in any session
15:12:27 <matrohon> I'll add a proposal for ligthning talks
15:12:33 <matrohon> https://etherpad.openstack.org/p/mitaka-neutron-labs-lighting-talks
15:13:00 <tmorin> +1
15:13:09 <tmorin> I was just reading this page
15:14:11 <tmorin> the Lab track has a "NFV foundation elements" session -- maybe we might fit there
15:14:43 <tmorin> because BGPVPN are largely a telco tool and can appear at the edge of NFV use cases
15:15:13 <matrohon> tmorin, we can add a proposal here
15:15:27 <matrohon> there are unplugged tracks too :
15:15:33 <matrohon> https://etherpad.openstack.org/p/mitaka-neutron-unplugged-track
15:15:41 <matrohon> on friday
15:16:04 <tmorin> I think we should add BGPVPN there
15:16:43 <matrohon> done
15:16:52 <matrohon> ok let's move on
15:17:04 <matrohon> #topic API spec
15:17:17 <matrohon> tmorin?
15:17:25 <tmorin> yes
15:17:34 <tmorin> with the recent change
15:17:41 <tmorin> pending review and merge
15:17:51 <tmorin> I think we now have our stable API
15:18:03 <tmorin> I plan to update the API on the current gerrit topic
15:18:14 <tmorin> #link https://review.openstack.org/177740
15:18:34 <tmorin> And I will also publish the spec as part of the "doc" directory of networking-bgpvpn
15:18:52 <tmorin> It will then appear under http://docs.openstack.org/developer/networking-bgpvpn/
15:19:03 <matrohon> tmorin : we have to lighten it
15:19:10 <tmorin> And we will have a fix pointer for the readable version of the spec
15:19:32 <tmorin> matrohon: yes, possibly
15:19:47 <tmorin> I think I would push the file as-is, and make changes later
15:20:12 <tmorin> possibly I will trim now the parts of the specs we don't care that much about
15:20:36 <matrohon> tmorin, we should remove the router association part too
15:21:03 <tmorin> matrohon: I see two options
15:21:19 <matrohon> tmorin, any feature that is not implemented should be removed
15:21:24 <tmorin> keep all the not-yet-implemented parts, but mark them as not-implemented yet
15:21:28 <tmorin> (option 1)
15:21:42 <tmorin> or option 2:  remove them, but document them in a separate file (more editorial work)
15:22:19 <tmorin> we need to keep what has been discussed somewhere easier to find and look at, than a gerrit change
15:22:38 <matrohon> I'm in favor of option 2. The doc file will be packaged with our first release
15:23:15 <matrohon> what is not implemented should be split in new lueprint
15:23:40 <matrohon> that will be easier to track progress on each items
15:24:16 <tmorin> ok, agreed
15:25:08 <pcarver> I agree as well, as long as we don't lose it. Putting it into a separate file makes sense.
15:26:00 <matrohon> #agreed split unimplemented items of the spec 177740 in bgpvpn blueprints
15:26:47 <tmorin> we'll have to decide what we do about half-implemented things (e.g. supported in a db, but without any driver supporting it...)
15:27:14 <matrohon> tmorin : any example?
15:27:28 <tmorin> auto-aggregate and route-distinguishers
15:27:53 <matrohon> oh
15:27:54 <tmorin> ( maybe route-distinguishers will soon be supported by the ODL driver)
15:28:07 <tmorin> maybe auto-aggregate as well
15:28:19 <matrohon> we have to implement it in the ref driver too
15:28:31 <matrohon> otherwise we can't say it's a ref driver
15:28:34 <tmorin> yes
15:29:28 <matrohon> vthapar, do you implement the route-distinguisher attribute already in ODL?
15:29:48 <tmorin> vthapar: same question for auto-aggregate
15:31:39 <matrohon> those items should be tracked by bugs
15:32:03 <matrohon> if nobody implements those features in our liberty release, we should remove it
15:32:16 <matrohon> let's coodinate with the ODL team on that
15:32:21 <tmorin> ok, agreed
15:32:43 <matrohon> #topic diver status
15:33:14 <matrohon> on bagpipe we'rre on the way to adapt it for subresources management
15:33:39 <matrohon> vthapar, doude : any update on your driver?
15:34:09 <doude> matrohon: nothing new, I've to update it with subresources
15:34:21 <matrohon> doude : fine
15:34:47 <doude> and I slowly continue to work on the contrail implementation (no feedbacks from the opencontrail community)
15:35:24 <matrohon> doude : hope you can have good discussions on that during the summit
15:35:32 <matrohon> doude, with OC guys
15:35:40 <tmorin> tmorin: I hope as well
15:36:01 <matrohon> #topic gat jobs
15:36:18 <matrohon> tmorin wrote oujr first gate job
15:36:35 <matrohon> it is running in the experimental queue
15:36:53 <tmorin> yes, a simple job doing the installation of the service plugin with the dummy driver
15:37:10 <matrohon> it deploys neutron along with the bgpvpn service plugin
15:37:15 <tmorin> as a starting point to create even more useful jobs
15:37:54 <matrohon> #topic open discussion
15:38:15 <matrohon> anyone wants to speak?
15:39:24 <matrohon> ok, that's all for today's meeting
15:39:29 <matrohon> thanks all
15:39:37 <matrohon> #endmeeting