12:02:14 <xek> #startmeeting barbican
12:02:14 <opendevmeet> Meeting started Tue Jul 18 12:02:14 2023 UTC and is due to finish in 60 minutes.  The chair is xek. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:02:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:02:15 <opendevmeet> The meeting name has been set to 'barbican'
12:02:23 <xek> #topic Roll Call
12:02:32 <xek> Courtesy ping for dmendiza[m] ade_lee d34dh0r53 Luzi tosky tobias-urdin jjung mharley
12:02:43 <mharley> o/
12:03:41 <dmendiza[m]> 🙋‍♂️
12:03:58 <xek> Hello everyone!
12:04:06 <xek> As usual our agenda can be found here:
12:04:14 <xek> #link https://etherpad.openstack.org/p/barbican-weekly-meeting
12:04:18 <xek> #topic Review Past Meeting Action Items
12:04:38 <xek> #link https://meetings.opendev.org/meetings/barbican/2023/barbican.2023-07-11-12.04.html
12:04:54 <xek> There were none
12:04:57 <Luzi> o/
12:05:07 <xek> #topic Liaison Updates
12:05:14 <xek> No updates from me
12:06:40 <xek> #topic Open Discussion
12:07:52 <dmendiza[m]> The stable/victoria gate is dead :(
12:08:00 <dmendiza[m]> I'm trying to figure out how to fix it
12:08:32 <dmendiza[m]> #link https://zuul.opendev.org/t/openstack/build/178fcf36af4e45fd99ee8ce6006e3978
12:08:43 <dmendiza[m]> It's the Tempest tests that are failing
12:08:45 <dmendiza[m]> because of
12:09:35 <dmendiza[m]> #link https://opendev.org/openstack/barbican-tempest-plugin/commit/6d76a0868c890997be7ae592e23d08cbc9937039
12:09:52 <dmendiza[m]> seems the stable/victoria gate doesn't have a new enough Tempest for this patch to work
12:10:26 <xek> @dmendiza thanks for looking into it!
12:11:37 <xek> On a different note, I saw a series of patches from stephenfin for migrating to SQLAlchemy 2.0
12:11:45 <xek> I'll be reviewing those
12:11:50 <xek> beginning with:
12:12:28 <xek> #link https://review.opendev.org/q/topic:sqlalchemy-20+project:openstack/barbican+status:open
12:14:06 <xek> We recently merged similar patches for Keystone, and it looks like Barbican is lagging behind compared to other maintained OpenStack projects
12:15:24 <xek> stephenfin's work is very welcome :)
12:15:35 <xek> (I don't think he's in the chatroom)
12:19:50 <xek> There is some issue with the unit tests that hopefully get's resolved by a change in oslo.db
12:19:52 <xek> #link https://review.opendev.org/c/openstack/oslo.db/+/888580
12:21:36 <xek> Ok, let's check if there are any new bugs reported
12:21:37 <xek> #topic Bug Review
12:22:43 <xek> There are no new bugs reported since our last meeting :)
12:24:52 <xek> @dmendiza is it ok if I put an action item for you, just so that we remember to check in on the stable/victoria gate issue?
12:25:04 <dmendiza[m]> Sure
12:25:59 <xek> #action dmendiza checking how to fix Tempest tests failing in stable/victoria gate
12:26:54 <xek> Ok, that concludes our meeting
12:27:01 <xek> Enjoy the rest of the week!
12:27:05 <xek> #endmeeting