13:00:24 <redrobot> #startmeeting barbican
13:00:25 <openstack> Meeting started Tue Feb  5 13:00:24 2019 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:28 <openstack> The meeting name has been set to 'barbican'
13:01:00 <redrobot> #topic Roll Call
13:01:29 <redrobot> Courtesy ping for ade_lee hrybacki jamespage Luzi lxkong moguimar raildo rm_work xek
13:01:41 <Luzi> o/
13:01:50 <redrobot> As usual our agenda can be found here: https://etherpad.openstack.org/p/barbican-weekly-meeting
13:02:40 <redrobot> Mornin' Luzi
13:02:52 <redrobot> I think it's just the two of us again.
13:03:07 <redrobot> #topic Review Past Meeting Action Items
13:03:21 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2019/barbican.2019-01-29-13.00.html
13:03:26 <Luzi> morning redrobot
13:03:35 <redrobot> First action item:
13:03:38 <redrobot> * redrobot to update the Barbican Wiki page and eavesdrop link to agenda
13:03:52 <redrobot> I did this! 😁
13:04:21 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
13:04:33 <redrobot> The meetings wiki page is mostly up-to-date
13:04:54 <Luzi> yeah :D
13:04:54 <redrobot> It has the current meeting time, link to the etherpad, myself as chair, etc.
13:05:14 <redrobot> I also archived all those old agenda items
13:05:30 <redrobot> I doubt anyone will ever care, but here they are:
13:05:32 <redrobot> #link https://wiki.openstack.org/wiki/Barbican/Archive/Agenda
13:06:16 <redrobot> I also submitted a patch to update the eavesdrop page:
13:06:18 <redrobot> #link https://review.openstack.org/#/c/634927/
13:07:47 <Luzi> +1
13:08:23 <jamespage> o/ (sorry a bit late)
13:08:27 <graeb> o/
13:08:36 <redrobot> ok, next action item:
13:08:54 <redrobot> 2. redrobot to add stories for permanent fixes to the gate workarounds
13:09:00 <Luzi> hi jamespage
13:09:02 <redrobot> I also did this!
13:09:09 * redrobot waves at jamespage and graeb
13:09:48 <redrobot> #link https://storyboard.openstack.org/#!/story/2004915
13:10:01 <redrobot> that's the main story
13:10:07 <redrobot> I also added a few tasks for it
13:10:12 <redrobot> including:
13:10:16 <redrobot> * fixing the kmip gate
13:10:30 <redrobot> * Adding a gate where multiple_backends = True
13:10:39 <redrobot> * fixing and re-enabling grenade gate
13:12:03 <redrobot> Any questions about the story?
13:12:09 <redrobot> Or additional tasks that need to be added?
13:13:17 <redrobot> I'll take that as a no
13:13:18 <redrobot> moving on
13:13:24 <redrobot> #topic Functional Tests
13:14:00 <redrobot> I've been helping some folks on my team set up a functional test job on a downstream CI system
13:14:18 <redrobot> and found some nasty bits in our functional tests
13:14:53 <redrobot> there's stuff that only passes on the devstack gate, but fails on a more complex deployment
13:15:13 <redrobot> most notably, none of the orders functional tests actually wait for orders to be complete before executing tests against the results
13:15:54 <redrobot> multiple-backends are not tested at the gate at all
13:16:19 <redrobot> since they all look for "secret-stores" in the API responses, but the API schema uses "secret_stores"
13:16:55 <redrobot> some tests are hardcoded to use "http://localhost/..." for secret refs
13:18:03 <redrobot> so I have a few patches up to fix some of the issues:
13:18:08 <redrobot> #link https://review.openstack.org/#/q/project:openstack/barbican+topic:fix-functional-tests
13:18:50 <redrobot> The last one is a doozy...  none of the quota tests are written to be run in parallel
13:19:39 <redrobot> I'm sure y'all have noticed occasional failures where 1 != 3 in a paging test, or a forbidden response instead of a 200 on a quota test
13:19:52 <redrobot> for now I changed the functional tests to run sequentially in the last patch
13:20:04 <redrobot> but the real fix is to make the tests smarter
13:20:13 <redrobot> I have some ideas
13:20:27 <redrobot> for example,
13:21:05 <redrobot> I don't think we need to define the 8 tests accounts that are set up in devstack.   I think a better approach would be to have the functional test create users on deman
13:21:07 <redrobot> *demand
13:21:22 <redrobot> that way each test can run in the context of its own user/project/whatever
13:22:20 <redrobot> any questions/comments?
13:22:40 <redrobot> I should probably add a story for that
13:22:59 <redrobot> #action redrobot to add a story to fix functional tests to be run in parallel
13:23:59 <redrobot> bueller?
13:24:06 <redrobot> ok, moving on
13:24:20 <redrobot> #topic Vote for Summit Topics
13:24:24 <redrobot> #link https://review.openstack.org/#/q/project:openstack/barbican+topic:fix-functional-tests
13:24:36 <redrobot> Voting is open for proposed talks for Denver
13:25:06 <redrobot> Please take some time to vote for every single one of my talks 😬😬😬
13:25:09 <redrobot> Just kidding
13:25:22 <redrobot> but really, if they look interesting to you, please vote.
13:26:31 <redrobot> Any qustions/comments about the upcoming summit?
13:27:48 <redrobot> Ok, moving on
13:27:58 <redrobot> There doesn't seem to be anything else on the agenda.
13:28:06 <redrobot> #topic Open Discussion
13:28:12 <redrobot> Anything else y'all want to talk about?
13:31:57 <redrobot> ok, sounds like we're done for the day
13:32:03 <redrobot> thanks for coming, everyone!
13:37:03 <jamespage> redrobot: actually I did have something (but got distracted)
13:37:23 <redrobot> jamespage, what's up?
13:37:32 <jamespage> can we do a new release of castellan to include the new vault features?  I can then do the work in barbican to expose those options
13:37:40 <jamespage> if I'm not to late this cycle
13:37:57 <redrobot> I'll have to check with ade_lee
13:38:13 <redrobot> Castellan is owned by the oslo team now, so I _think_ they have to release it
13:38:58 <redrobot> #action redrobot to check with ade_lee about adding Vault features to Barbican for Rocky
13:39:07 <jamespage> thanks!
13:39:19 <redrobot> #action redrobot to check with ade_lee about releasing Castellan
13:39:44 <redrobot> jamespage, any time! 😁
13:39:57 <redrobot> Ok, I think now we're done for real
13:40:15 <redrobot> thanks for coming, everyone!
13:40:16 <jamespage> thanks for driving redrobot 😄
13:40:20 <redrobot> #endmeeting