03:00:49 <alee> #startmeeting barbican
03:00:50 <openstack> Meeting started Tue Apr 17 03:00:49 2018 UTC and is due to finish in 60 minutes.  The chair is alee. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:00:53 <openstack> The meeting name has been set to 'barbican'
03:00:58 <alee> #topic roll call
03:02:14 <liujiong> hi alee
03:02:25 <alee> liujiong, hey there
03:02:45 <alee> anyone else here for the barbican meeting?
03:03:15 <alee> nguyenhai, ?
03:04:07 <nguyenhai> hi
03:04:16 <alee> hey there
03:04:23 <alee> lets get started
03:04:31 <openstackgerrit> Jeremy Liu proposed openstack/barbican master: fix lower constraints  https://review.openstack.org/560582
03:04:40 <alee> #topic barbican meeting time
03:05:12 <alee> so with the advent of daylight savings time in the states, its pretty later for dave and I over here.
03:05:29 <alee> would it be possible to move the meeting time back an hour?
03:05:41 <alee> that would be 10 pm over here instead of 11
03:06:06 <liujiong> ok for me
03:06:47 <liujiong> alee: sorry for the inconvenience
03:07:15 <alee> ok - cool - I'll propose it in the mailing list and will start at the new time as of next week
03:07:43 <alee> no biggie -- it makes sense for us to have the meeting around now, but it just gets a little late when dst started
03:08:11 <alee> # action alee to announce new meeting time
03:08:11 <alee> #action alee to announce new meeting time
03:08:12 <liujiong> yep
03:08:37 <alee> #topic rocky
03:08:55 <alee> the milestone 1 release is due this week
03:09:09 <openstackgerrit> Merged openstack/castellan master: pypy is not checked at gate  https://review.openstack.org/554912
03:09:33 <alee> I originally thought I needed to get it in today, and so you might have seen a flurry of reviews/ merges from dave /me today
03:10:08 <alee> the actual release is due by the end of this week which gives us a little more time to get things in
03:10:19 <liujiong> yes, received lots of email notification
03:10:50 <alee> I plan to meet again with dave on wednesday - and to look at doing some stable branch releases too on thurs / friday
03:11:20 <alee> it looks like we're in pretty good shape - but lets take a look at the tracker ..
03:11:37 <alee> https://etherpad.openstack.org/p/barbican-tracker-rocky
03:12:16 <liujiong> I see the question on policy-in-code goal
03:12:17 <alee> liujiong, you mentioned something was missing in policy in code/ doc of policy in code?
03:12:40 <alee> yeah - I was a little confued about exactly what was missing
03:12:54 <alee> but figured you knew this best
03:13:15 <alee> liujiong, perhaps you can update with more details
03:14:00 <liujiong> Yes, we missed docs of each policy
03:15:36 <liujiong> alee: see https://github.com/openstack/nova/blob/master/nova/policies/admin_actions.py#L25 how Nova does
03:16:02 <alee> liujiong, ah - I see
03:16:49 <alee> liujiong, I'm going to put that link in there as a reminder to me mostly
03:17:39 <alee> other than that - it looks like we're tracking mostly ok
03:17:44 <liujiong> ok
03:17:55 <alee> I may or may not be able to get the pycrypto done ..
03:18:21 <alee> and dave is going to try to get the client side changes done by wed
03:18:21 <alee> I alse looked at this ..
03:18:46 <alee> https://tinyurl.com/yctfozgh
03:19:10 <alee> which is a nice representation of the sate of things and went through a bunch with dave today
03:19:51 <liujiong> That helps review a lot
03:20:11 <alee> liujiong, yeah - its the view dave was using
03:20:44 <alee> liujiong, are there any patches which you're looking at getting in in particular this week?
03:21:18 <liujiong> not exactly
03:21:43 <liujiong> but I hope this one will get passed in gate - https://review.openstack.org/#/c/453829/
03:22:41 <alee> liujiong, yeah - I noticed that one - I want to understand though why its failing the tripleo gate
03:23:03 <alee> liujiong, and planned to look at that.
03:23:23 <liujiong> alee: thanks
03:23:32 <alee> if I pass it and it breaks tripleo, it will cause pain for me next week
03:23:49 <alee> I'd rather treat the pain pre-mepitvely
03:24:08 <alee> so yeah -- I 'll look inot that probably tommorow
03:25:08 <alee> liujiong, anyways if you see any others that look good and you approve, they'll bubble up and get reviewed this week on wednesday
03:25:28 <alee> anything else on rocky m-1?
03:26:23 <alee> #topic OVO patches
03:26:52 <alee> there are a bunch of OVO patches that we should get to soon.
03:27:04 <alee> or they'll keep getting put off.
03:27:57 <liujiong> indeed, seems not all of them get passed in gate
03:28:16 <alee> I found that I had a few questions on how the patches were constructed -- and I think it would be useful to have a google hangout in which Nam walks through the patches
03:28:40 <alee> in the past , that has heped with larger patch sets
03:29:12 <alee> I was going to propose we do that during the barbican meeting next week
03:29:21 <liujiong> cool
03:29:45 <alee> nguyenhai, is that you?
03:30:29 <nguyenhai> no, not me
03:30:41 <alee> nguyenhai, sorry :)
03:31:08 <alee> ok well - I'll send out an email
03:31:30 <alee> #topic anything else?
03:32:00 <liujiong> that's all from me
03:32:21 <alee> liujiong, cool - see ya next week!
03:32:31 <liujiong> see you
03:32:34 <alee> #endmeeting