19:59:46 <redrobot> #startmeeting barbican
19:59:46 <igueths> o/
19:59:47 <openstack> Meeting started Mon Jun 15 19:59:46 2015 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:50 <openstack> The meeting name has been set to 'barbican'
20:00:08 <redrobot> #topic Roll Call
20:00:15 <igueths> o/
20:00:16 <chellygel> ╭ (o^‿ ^#)ᕗ
20:00:18 <jkf> Greetings
20:00:26 <jvrbanac> o/
20:00:31 <kfox1111> o/
20:00:37 <Daviey> \o
20:00:59 <rellerreller> o/
20:01:22 <elmiko> yo/
20:01:30 <redrobot> as usual the meeting agenda can be found here:
20:01:31 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:02:00 <redrobot> ok, let's get started
20:02:13 <redrobot> #topic Blueprint Review Google Hangouts
20:02:23 <redrobot> chellygel was asking about this earlier today
20:02:32 <jaosorior> o/
20:02:39 <redrobot> and I just wanted to give a heads up that we can schedule google hangouts to talk about Blueprints whenever
20:02:39 <woodster_> o/
20:03:00 <redrobot> Our goal is to try and land all blueprints for Kilo by kilo-1
20:03:14 <redrobot> derr  s/kilo/liberty
20:03:14 <jvrbanac> liberty?
20:03:16 <jvrbanac> lol
20:03:22 * redrobot is living in the past
20:03:27 <elmiko> hehe
20:03:51 <arunkant> o/
20:04:12 <redrobot> so, if there's any blueprints that may benefit from real time (google hangout or similar) discussion, please bring those up during this meeting, and we can get some time scheduled to talk about it
20:04:46 <chellygel> :) sounds great to me!
20:04:54 <jvrbanac> +1
20:05:16 <rellerreller> +1
20:05:33 <redrobot> Also, a reminder that anyone can add agenda items to the agenda
20:06:00 <redrobot> otherwise, y'all will be stuck with the topics I make up as I go along ;)
20:07:08 <redrobot> any questions/comments about scheduling Google Hangouts for BP reviews?
20:07:33 <kfox1111> redrobot: how about the container acl blueprint?
20:07:37 <rellerreller> redrobot will there be an etherpad page or anything with the schedule?
20:07:59 <kfox1111> is it well defined enough not to need a google hangout?
20:08:48 <redrobot> kfox1111 I haven't had a chance to look at it.
20:09:03 <kfox1111> ok. want to punt a week? (link here: https://blueprints.launchpad.net/barbican/+spec/container-acl)
20:09:31 <redrobot> kfox1111 sure thing... we'll try to get some reviews on this, and see if a google hangout is needed next week?
20:09:40 <kfox1111> ok. sounds good. thanks.
20:09:57 <redrobot> #action redrobot to review container-acl spec for possible hangout
20:10:24 <redrobot> rellerreller usually I advertise upcoming hangouts in the #openstack-barbican channel topic
20:10:39 <rellerreller> redrobot sounds good
20:10:41 <redrobot> rellerreller but I could add a wiki page in openstack wiki if you think that would be better?
20:11:12 <redrobot> maybe ML announcement + Channel Topic ?
20:11:48 <rellerreller> redrobot I was curious.
20:11:51 <elmiko> would it be worth it to have a hangout to talk about the wsgi wrapper stuff, or can that be hashed out in a review? (i'm not sure if there are any big questions that need to get resolved)
20:12:18 <rellerreller> I did not know how to know when they would happen. Chat channel is ok.
20:12:58 <redrobot> elmiko I think in-review first would be good... if the review seems to be taking too long, then we can schedule something
20:13:08 <elmiko> redrobot: awesome, thanks
20:13:33 <redrobot> alrighty, seems like we're all in agreement then
20:13:34 <redrobot> moving on
20:13:40 <redrobot> #topic Mid-Cycle Lodging
20:13:53 <redrobot> #link http://www.jhuapl.edu/aboutapl/visitor/lodging.asp
20:14:01 <redrobot> rellerreller I had an action item for you for this
20:14:16 <redrobot> rellerreller is the above link correct?  Or is there other info we need?
20:14:20 <rellerreller> redrobot I thought that action item was closed. kfarr posted a link.
20:14:35 <redrobot> rellerreller awesome, just making sure...
20:14:47 <rellerreller> redrobot that is a good link.
20:15:11 <kfarr> When you make your reservations, make sure you mention you're staying for APL business, and they should have a special rate
20:15:19 <redrobot> kfarr awesome!
20:15:22 <kfarr> at the ones listed on that page, at least :D
20:15:36 <redrobot> #info call the hotels and mention you're visiting for APL business
20:15:53 <redrobot> and if anyone needs more details for the mid-cycle sprint, you can find them here:
20:15:55 <redrobot> #link https://wiki.openstack.org/wiki/Sprints/BarbicanLibertySprint
20:16:39 <redrobot> That's all I have on the agenda for today.  Are there any topics y'all want to discuss?
20:17:23 <rellerreller> Anyone figure out why the unit tests were failing?
20:17:38 <redrobot> #topic Failing Tox on HEAD
20:17:40 <rellerreller> We had that issue where you had to run devstack to get the unit tests to run.
20:18:15 <redrobot> thanks for the reminder rellerreller.  there was a lot of discussion on the channel last week about this.
20:18:41 <rellerreller> I was also wondering why they are taking so long.
20:20:01 <redrobot> someone else was also seeing these?  maybe jaosorior
20:20:02 <redrobot> ?
20:20:44 <redrobot> Bueller?
20:20:44 <rellerreller> alee was seeing it as well.
20:20:50 <jaosorior> Still have this issue
20:20:57 <jvrbanac> redrobot, I couldn't replicate the issue
20:21:51 <rellerreller> It's strange. It's like you go back to an older version, run devstack, and tests. Then go to latest version and run test and it fails.
20:22:12 <elmiko> is there a restack in there, or same devstack?
20:22:14 <rellerreller> I have not had a good way to replicate, but I feel like it usually happens in that order.
20:22:52 <rellerreller> After devstack is run then unstack and test.
20:23:02 <elmiko> ah, ok
20:23:27 <elmiko> i had some weird issues running db migrations depending on the backend, seemed like i was getting similar errors. but i couldn't replicate it with the unit tests.
20:23:42 <rellerreller> It's bizarre because the output makes it look like it is trying to connect to some local service. I did not understand that. That's why I started to run devstack.
20:23:53 <elmiko> weird
20:26:08 <redrobot> very weird... doesn't seem like we have any answers though :(
20:26:10 <redrobot> more digging I suppose
20:26:36 <rellerreller> Ya, if it happens again to me then I will probably start investigating.
20:26:39 <redrobot> any other topics we want to talk about?  If not we can all go back to work early...
20:26:43 <arunkant> Can folks review Audit spec as it has been carried over from Kilo and has been pending for inputs for quite a while.
20:26:58 <redrobot> #topic Reviews
20:27:18 <redrobot> #link https://review.openstack.org/#/c/159938/
20:27:32 <redrobot> ^^ Auditing Spec
20:28:05 <arunkant> I see jaosorior has provided some inputs and I can incorporate the details. Will be helpful to see if there are any further comments/ inputs
20:28:23 <redrobot> arunkant agreed.
20:28:46 <redrobot> Also please review kfox1111 's spec
20:28:48 <redrobot> #link https://review.openstack.org/#/c/190404/
20:28:52 <rellerreller> arunkant I can take a look. It looks interesting.
20:29:23 <arunkant> thanks rellerreller
20:29:50 <redrobot> oh one last topic I just remembered
20:29:57 <redrobot> #topic Library Releases
20:30:14 <redrobot> so the Release Management team is taking ownership of the libraries
20:31:05 <redrobot> so instead of releasing directly, we'll be asking the relmgt team to release for us
20:31:12 <elmiko> interesting
20:31:37 <redrobot> they'll be making sure SemVer is correct... apparently some libraries don't follow SemVer correctly
20:32:02 <redrobot> also they want to have the ability to release libs around cycle release time, to fix dependency issues like the ones at the end of Kilo
20:32:23 <redrobot> for us that means they'll be releasing python-barbicanclient, castellan, and python-kiteclient
20:32:42 <elmiko> cool
20:33:26 <woodster_> hmmm...is Kite still a thing?
20:33:46 <redrobot> woodster_ good question... actually someone was asking about it on the ML last month
20:34:17 <redrobot> maybe we should reach out to Jamie Lennox to inquire?
20:35:08 <redrobot> #action redrobot to figure out if Kite is still alive or if we should deprecate it
20:35:20 <redrobot> any other questions/comments/topics?
20:35:29 <arunkant> redrobot: is there a interest or need to add caching support in barbican ? I am not sure how is the barbican performance in production to worry about this aspect.
20:36:51 <redrobot> #topic Caching in Barbican
20:37:19 <redrobot> I recall having talked about it briefly a long time ago, but my impression is that we do not want to cache keys
20:37:22 <arunkant> we will be using barbican in our environments soon so will know whether its needed or not by then. Wondering if folks have encountered related issue around that.
20:38:29 <redrobot> arunkant it's definitely a tradeoff between security and performance
20:38:45 <arunkant> yes..it will be more on read calls and we can exclude secret payload read calls. Caching support will be selectively added.
20:39:54 <arunkant> I have seen keystone uses dogpile which provides support for various type of backends like memcache, redis etc.
20:40:22 <morganfainberg> arunkant: please use dogpile over rolling some of the others.
20:40:42 * morganfainberg disappears again
20:40:48 <redrobot> morganfainberg hehe
20:41:37 <redrobot> arunkant we (Rackspace) still have not gotten to the point where we need caching, but it could possibly be useful.
20:42:08 <redrobot> arunkant I think it would depend on backend choices and such
20:42:34 <redrobot> we'll hopefully have more performance metrics soon
20:42:44 <redrobot> maybe we can revisit this topic at a later time?
20:43:40 <arunkant> redrobot, okay. So will look into more details around this in case we may need this in near future.
20:44:02 <redrobot> arunkant sounds good
20:44:22 <redrobot> Any other topics?  I think we may have time for one or two more.
20:44:29 <arunkant> redrobot: one more thing, are ACL changes backported to Kilo?
20:45:17 <redrobot> arunkant not yet... I really need to do that.
20:45:57 <redrobot> arunkant there's a huge discussion on stable point releases going on in the ML, so I'm not sure when/if the release will happpen.
20:46:27 <arunkant> redrobot, okay. Thanks for the update.
20:46:40 <redrobot> arunkant I'll get the fixes backported today though
20:46:57 <redrobot> anything else?
20:47:58 <redrobot> going once...
20:48:34 <redrobot> ok, looks like that's all for today.  Thanks for coming guys!
20:48:38 <redrobot> #endmeeting