19:00:47 <shamail> #startmeeting auc
19:00:49 <openstack> Meeting started Thu Sep  1 19:00:47 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:53 <openstack> The meeting name has been set to 'auc'
19:01:01 <shamail> Hi everyone, who's here today?
19:01:10 <MeganR> Hi
19:01:14 <maishsk> o/
19:01:17 <maishsk> Hello All
19:01:19 <ildikov> o/
19:01:20 <maishsk> long time no see
19:01:25 * ildikov is lurking :)
19:01:46 <shamail> :) !
19:01:57 <shamail> Yeah, it's been a while maishsk
19:02:14 <shamail> #chair maishk
19:02:15 <openstack> Warning: Nick not in channel: maishk
19:02:16 <openstack> Current chairs: maishk shamail
19:02:27 <maishsk> #chair maishsk
19:02:27 <shamail> #link https://wiki.openstack.org/wiki/AUCRecognition#Meeting_Information
19:02:33 <shamail> #chair maishsk
19:02:33 <openstack> Current chairs: maishk maishsk shamail
19:02:38 <shamail> Sorry
19:02:55 <SWDevAngel> Lisa is here.
19:02:56 <maishsk> np
19:02:57 <shamail> #topic Review Ops Meetup AUC feedback
19:03:07 <shamail> Hi SWDevAngel
19:03:27 <shamail> #link https://etherpad.openstack.org/p/NYC-ops-AUC
19:03:45 <SWDevAngel> Hello my dear friend. :)
19:04:36 <shamail> MeganR, ildikov, SWDevAngel, and I were at Ops meetup and we discussed AUC with operators to get feedback on other ways we could capture their contributions
19:04:55 <shamail> The etherpad has some of the ideas that were brought up
19:05:25 <shamail> Do we foresee any of them being simple to implement and, therefore, expand the criteria for the first batch of AUCs?
19:05:41 * maishsk skims over the etherpad
19:06:10 <SWDevAngel> FYI, gonna be driving for 15 mins. Can check etherpad and will be more active after that.
19:06:12 <maishsk> Add my comments there - or here?
19:06:31 <shamail> I really like the suggestion about Women of OpenStack but it would probably have to be organizers or active participants.  I am certain others might already be eligible for AUC based on activities.
19:06:41 <shamail> I think here would be good maishsk
19:06:58 <MeganR> I need to reach out to the WOS, agree that will be a great addition
19:07:07 <shamail> We should at least contact the WOO team to ask whether it makes sense for them to become a UC WG
19:07:23 <MeganR> shamail +1
19:07:26 <maishsk> So Mailing list - I would say no - How do we quantify this? As helpful ? active ? useful
19:07:37 <shamail> #action MeganR will contact WOO
19:07:54 <shamail> maishsk: +1, that's a difficult one
19:08:07 <maishsk> Openstack-vagrant provider - should come under OSOps contribution - dont think it needs to be seperate
19:08:19 <shamail> MeganR: can you try to close the WOO discussion (for this cycle) in the next week or so please?
19:08:38 <maishsk> WOO - as long as they are active participants - just being there - I do not think warrants
19:08:46 <maishsk> The same for people who attend meetups
19:08:53 <MeganR> shamail: I'll send an email, but we won't meet again until 9/12
19:08:55 <shamail> maishsk: this was brought up as an example of complimentary tools that are on independent repositories outside of OpenStack
19:09:29 <shamail> MeganR: our next meeting is 9/8 I believe but please feel free to email as well
19:09:54 <maishsk> shamail: Works for me
19:10:06 <MeganR> maishsk: can we look at treating the Women of OpenStack as a "work group" in which we are mainly tracking active participation
19:10:19 <shamail> maishsk: the conversation about WOO is focused on active participants... We realized that the team is not under TC or UC at the moment so they wouldn't get counted on either side
19:10:41 <maishsk> MeganR: shamail: agree to both the statements :)
19:10:59 <maishsk> People who travelled and attended ops meetups - I would say no
19:11:23 <maishsk> or a really big maybe
19:11:43 <shamail> maishsk: this was brought up by Tom... He was acknowledging that these people dedicated at least 2 whole days to focus on operator needs
19:11:52 <maishsk> Why would they be any different to someone who attends an OpenSTack summit
19:11:56 <shamail> And join the conversation (Ops meetups are not successful otherwise)
19:12:57 <shamail> Fair point, I think the difference is that we know for certain these people are using OpenStack and their feedback gets collected during these events but not documented
19:13:15 <shamail> I can see your point as well maishsk
19:13:23 <maishsk> Openstack summits - people fork out cash
19:13:30 <maishsk> more than an ops summit
19:13:33 <shamail> This was suggested since AUC count is pretty low overall still
19:13:36 <maishsk> it is longer than 2 days
19:13:43 <shamail> Yep.
19:13:53 <shamail> We can defer this one
19:14:04 <shamail> Anyone else have a different point of view?
19:14:09 <maishsk> Case Studies - who initiates them?
19:14:15 <maishsk> the foundation?
19:14:18 <maishsk> for what purpose?
19:14:21 <shamail> Normally the foundation or sometimes users
19:14:37 <shamail> For highlighting OpenStack success stories and best practices that work
19:14:39 <MeganR> I would be curious to know how many of the people that attended the mid-cycle would already fall under TC or AUC, since the majority are active in the community.
19:14:58 <mrhillsman> o/
19:15:02 <mrhillsman> sorry so late
19:15:05 <shamail> MeganR: I can try to determine that but I don't know if they will share attendee list
19:15:11 <shamail> Hi mrhillsman
19:15:17 <maishsk> So I agree - it will be hard to quantify - who gets the AUC - as a result of a case study - becuase usually it will be a marketing representative who speaks to the foundation
19:15:37 <shamail> It's usually technical and business leaders (not marketing)
19:15:41 <MeganR> shamail: that makes sense, and is understandable - not trying to create more work for you  :)
19:15:44 <maishsk> Ops meetup sponsor - we spoke about this if I remember - can recall what we decided
19:15:45 <shamail> We generally try to get something substantial
19:16:21 <shamail> The AUC is trying to capture activities that we want to encourage in the community and more success stories seem beneficial.  That is why they were proposed
19:16:27 <maishsk> code review / bug reports
19:16:30 <shamail> It's really no different than a superuser article
19:17:09 <maishsk> So I would like to see this - in - again it is just a matter of how this can be quantified
19:17:31 <shamail> That's another hard one maishsk... My take is that code reviews/bug reports are subjective (I could easily review something just to be AUC without providing an objective view)
19:17:42 <maishsk> And also how to measure that the contribution is meaningful - and not just someone making noise
19:17:50 <maishsk> shamail: my thoughts exactly
19:18:04 <shamail> Secondly, I would think ATC should encourage this as well.
19:18:11 <maishsk> Refstack Test Results - not familiar - can someone explain?
19:18:20 <shamail> MeganR: np, ill try :)
19:19:02 <shamail> Organizations submit RefStack results to validate their OpenStack implementations follow interoperability guidelines.
19:19:27 <shamail> Generally executing these tests is time consuming and everyone benefits from the data that is (anonymously) collected
19:19:57 <maishsk> Again - who get’s status - I would assume that those who actually make the time and effort to contribute this info - is already active in some other way?
19:20:02 <shamail> RefStack is a tool for validating OpenStack clouds against established interoperability guidelines (in a nutshell)
19:20:08 <maishsk> or am I wrong to assume?
19:20:33 <shamail> Based on feedback so far, I would say that is not normally the case
19:20:59 <shamail> These are usually QA teams in the organization who don't get to participate in other upstream activities normally due to limited cycles
19:21:10 <ildikov> I don't think either, I mean there are several companies using and testing OpenStack, but not really active in the community so far
19:21:43 <ildikov> either QA teams or operators from different segments
19:21:48 <maishsk> So if we can find a way to wauntify who gets the recognition for this - I think this would be a good addition
19:22:05 <maishsk> Recognize people who share best practices - Sharing how? How do we quantify?
19:22:06 * shamail apologizes that he will have to drop off in 8 minutes
19:22:56 <shamail> maishsk: this might be captured by Superuser, case study, or OSOps contributions
19:23:01 <shamail> It feels like a duplicate
19:23:03 * maishsk is going shut up now - and let us continue with the agenda - can get back to each point later - if need be - or I will add it to the etherpad
19:23:09 <maishsk> shamail: I would agree
19:23:17 <shamail> Please don't, this is a good discussion :)
19:24:34 <shamail> Anything else?  So far (please correct me if I'm wrong) the list of activities we would want to add based on this feedback is: WOO as a WG, RefStack submission, case studies.
19:24:58 <shamail> We deferred on attending ops meet up, bug reports/code reviews, and sharing best practices
19:25:12 <maishsk> SDK developers - wouldn’t these be covered under the big tent?
19:25:36 <ildikov> I like the initial list, I would guess we can always extend it
19:25:39 <shamail> Unfortunately, no.  Most SDKs are outside the OpenStack namespace (with the exception of shade)
19:25:57 <shamail> ildikov: absolutely, Barcelona is just the first pass :)
19:25:59 <maishsk> Folks within organization who assist but would otherwise not pursue AUC - so this would be covered by nominations to a comittee (like the extra ATC)
19:26:10 <shamail> maishsk: +1
19:26:30 <maishsk> ildikov: +1
19:26:44 <maishsk> I think that is all from me on the list
19:26:49 <ildikov> shamail: coolio! :)
19:27:17 <shamail> Thanks maishsk
19:27:34 <shamail> I have to drop off soon... Would you like to continue the meeting and move to agenda #2?
19:27:43 <shamail> Or do we want to regroup next week?
19:27:45 <maishsk> shamail: sure
19:27:50 <maishsk> So just to summarize
19:27:50 <shamail> Awesome, thanks!
19:28:26 <maishsk> And ask your thoughts - should we leave these additional items for expansion for the next pass?
19:28:38 <maishsk> i.e. after Barcelona?
19:28:58 <shamail> I think a lot of the ones we agreed on are fairly easy to add and we can maybe pursue them even before Barcelona
19:29:13 <shamail> I'll be glad to help with case studies and RefStack
19:29:21 <shamail> Megan volunteered for WOO
19:29:42 <maishsk> #action shamail will pursue adding case studies and Refstack to eligible criteria for AUC
19:30:20 <maishsk> MeganR: I see that you already got the action above - not going to repeat :)
19:30:34 <MeganR> :)
19:31:02 <shamail> I'll catch up on the rest of the meeting later
19:31:22 <maishsk> #action maishsk will look into the support SDK and project outside OpenStack
19:31:28 <maishsk> Let’s move on
19:31:29 <shamail> Context: Tom would like the list of AUCs for Barcelona in the next 2-3 weeks so we should build a plan to finish our work
19:31:37 <shamail> See you later!
19:31:40 <maishsk> #topic Develop plan to close out WG in next 2-3 weeks
19:32:47 <maishsk> if we look at the milestones on the Wiki we have to complete 4+5 and prepare a readout.
19:33:03 <maishsk> I think that the work for 4+5 are complete - we just have to finalise
19:33:15 <MeganR> +1
19:33:45 <maishsk> so for 4 - I think we just need to write this up in presentable way
19:33:51 <maishsk> I can take that one
19:34:02 <MeganR> great - thank you
19:34:13 <maishsk> #action maishsk compile a concise list of metrics for eligibility
19:34:37 <maishsk> 5 - review board
19:34:45 <maishsk> #link https://etherpad.openstack.org/p/uc-recog-m5-output
19:35:05 <maishsk> If anyone has any addiitonal comments on this one?
19:35:36 <MeganR> We had previously discussed that the review board should be the UC, and it will be their decision to identify anyone additional.
19:36:18 <maishsk> Only UC ?
19:37:00 <MeganR> and their decision if they want additional personnel to review
19:37:25 <maishsk> How many people currently on the UC - 3?
19:37:28 <maishsk> 4?
19:37:29 <MeganR> yes
19:38:18 <maishsk> Personlly I would like to that a larger forum of people decide on this
19:38:43 <maishsk> not only just the 3
19:38:43 <MeganR> I think we can make the recommendation - what number are you thinking of?
19:38:59 <maishsk> in the link above I mentioned
19:39:06 <maishsk> 3 members of the UC as board members.
19:39:12 <maishsk> 2 current AUC's
19:39:17 <maishsk> 1 TC member
19:39:26 <maishsk> 1 Openstack Employee (Foundation)
19:39:33 <maishsk> 2 AUC community leads (ambassadors,WG chairs, Ask Openstack Mods, Meetup organizers)
19:40:01 <MeganR> right, but who makes the decision on the additional individuals, the UC?
19:40:04 <SWDevAngel> Hi, sorry to be late on this. Back on line now and trying to catch up with the thread (y'all type fast). For the Ops Summit vs OpenStack Summit, I agree they are different. And also, many people self-funded to get to the the ops summit which shows an extra level of dedication and willingness to participate.
19:40:45 <maishsk> diverse commitee - majority decision
19:40:47 <SWDevAngel> Also, for WOS I'm meeting with Ildiko and Nithya in about a week to discuss this, among other things. Ildiko and I will have more to report back after then.
19:41:04 <maishsk> SWDevAngel: Thanks
19:41:29 <SWDevAngel> And yes, Megan should bring it up at the next meeting, although with the cross-section we get on there, it might not be the best forum to discuss it (might not have the same level of understanding)
19:42:13 * maishsk appologizes but I have to drop in 8 miutes as well
19:42:31 <maishsk> MeganR: What do think regarding the numbers?
19:42:59 <maishsk> remember this is for people who do fit under the regular criteria - similar to the Extra ATC
19:43:10 <maishsk> who do not *
19:44:03 <MeganR> maishsk: I think that is a good recommendation - not certain who will make the decision on the 6 people outside of the UC
19:44:58 <maishsk> So let’s write up the recommendation - again concise and short - to prepare fo rthe final readout
19:45:02 <maishsk> Any takers?
19:45:51 <maishsk> ok then
19:46:16 <maishsk> #action maishsk compile a concise list of recommendations for a review board for ‘Extra AUC’
19:46:26 <MeganR> sorry - I am still catching up on a couple of other items
19:46:36 <maishsk> :)
19:46:36 <MeganR> thank you for taking that action!
19:46:53 <maishsk> I woul dprepare them for next weeks meeting
19:46:58 <maishsk> (hopefully before)
19:47:04 <maishsk> would=will
19:47:30 <maishsk> From there we can prepare the final readout
19:47:40 <MeganR> sounds good
19:47:49 <maishsk> share with committee and deem this WG a huge success
19:48:06 <MeganR> that is a great plan!
19:48:27 <maishsk> (we previously agreed that milestone 7 should be removed)
19:48:53 <MeganR> yes
19:49:02 <maishsk> One last action that I will give to shamail
19:50:05 <maishsk> #action shamail will coordinate a readout to the UC
19:50:21 <maishsk> perhaps invite them to participate in the WG meeting in two/3 weeks to close out the WG
19:50:46 <MeganR> sounds good - I like that timeframe
19:51:04 <maishsk> I have to drop - so please attend to your actions
19:51:08 <maishsk> and see you all next week
19:51:15 <MeganR> bye
19:51:19 <maishsk> #endmeeting