19:01:05 <shamail> #startmeeting auc
19:01:05 <openstack> Meeting started Thu Jun 23 19:01:05 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:08 <openstack> The meeting name has been set to 'auc'
19:01:27 <shamail> Hi everyone.  Who is here for the AUC recognition WG meeting?
19:01:37 <MeganR> o/
19:01:43 <shamail> Hi MeganR!
19:02:11 <shamail> Blah, notice didn’t make it out. :[
19:02:21 <MeganR> Hi - oh, oops
19:02:21 <shamail> #link https://wiki.openstack.org/wiki/AUCRecognition#Meeting_Information
19:02:42 <maishsk> o/
19:02:48 <shamail> Hi maishsk
19:02:51 <shamail> #chair maishsk
19:02:52 <openstack> Current chairs: maishsk shamail
19:02:56 <maishsk> Hi Shamail
19:03:21 <MeganR> Hi maishsk
19:03:26 <maishsk> Hi MeganR
19:03:35 <shamail> ping maishk MeganR dabukalam dc_mattj
19:03:51 <shamail> Let’s wait a couple of minutes and then we will get going
19:04:24 <MeganR> sure - going to look at the doc Tom sent
19:04:35 <MeganR> *have been meaning to all day
19:04:38 <shamail> Yeah, it’s thorough
19:04:51 <shamail> I have some feedback that I will be sending tonight
19:05:03 <shamail> maishsk: I am forwarding you the document
19:05:18 <shamail> We can share the link/draft in the meeting once we have a little more discussion
19:06:17 <shamail> maishsk: sent.
19:06:24 <shamail> Okay, let’s get started
19:06:36 * maishsk feverishly scrambles to look at his inbox
19:06:39 <shamail> #topic Review milestone-4 etherpad
19:06:49 <shamail> #link https://etherpad.openstack.org/p/uc-recog-metrics
19:07:24 <shamail> I think we are good on most of these items
19:07:45 <shamail> I had taken an action to send an email to user-committee and operators to get a broader community perspective but I didn’t get to it yet
19:07:58 <shamail> I will do that tonight/early tomorrow so please look out for it
19:08:13 <MeganR> ok
19:08:15 <shamail> #action shamail to send summary of milestone-4 etherpad on mailing lists for discussion
19:08:46 <shamail> No other action items on this etherpad from my end, anyone else want to highlight anything?
19:09:12 <shamail> Moving on ;)
19:09:16 <shamail> #topic Update on AskOpenStack metrics (maishk)
19:09:57 <shamail> maishsk: You had taken the action to think more about how we could track AskOpenStack w/o granting a long-term AUC entitlement
19:10:04 <maishsk> So I was looking and thinking that we have perhaps a pickle
19:10:22 <maishsk> So there is a script to get active moderators
19:10:53 <maishsk> #link https://github.com/openstack/uc-recognition/blob/master/tools/get_active_moderator.py
19:11:29 <maishsk> But I dont think that this info can be measured on a periodical basis
19:11:32 <shamail> Ah nice
19:11:50 <shamail> I just quickly looked through it and it does seem to associate some level of activity
19:12:11 <shamail> Basically it is saying that the user has X karma and has been “last seen” (e.g. active) in the past 180 days
19:12:12 <maishsk> So from what I undertstand Karma is activity
19:12:34 <shamail> look at lines 64 - 70
19:12:50 <maishsk> ths has nothing to do with moderation - in the usual sense of the word with forums
19:13:01 <shamail> right
19:13:10 <shamail> moderation means responding
19:13:14 <maishsk> But karma is cummulative
19:13:14 <shamail> in this sense
19:13:17 <shamail> exactly
19:13:23 <shamail> That is the one existing loop hole
19:13:44 <maishsk> So for example someone has 1000 karma and has been active for the last six months
19:13:49 <shamail> so a person would have to put in the effort to get past the Karma threshold but, once that is done, they would only have to answer 1 question and they would qualify
19:13:54 <shamail> which is a loop hole
19:13:56 <maishsk> Exactly
19:14:34 <shamail> We can ask FifieldT about possible solutions and find out if there is a way to track Karma activity in a given window
19:14:38 <maishsk> So if we could measure the number of points that a user accumulated over the last 6 months
19:14:43 <MeganR> well, except that they have to do a fair amount to reach that level - right?
19:14:48 <maishsk> and set a minimum threshold
19:15:05 <maishsk> MeganR: correct
19:15:14 <shamail> Our criteria shouldnt be absolute (e.g. X > karma, Y < days) but relative (Range: Y days, obtained karma: X)
19:15:16 <maishsk> but once they are there - they dont have to be active any more
19:15:30 <maishsk> or barely active
19:15:33 <shamail> obtained Karma > X
19:16:24 <shamail> It’s a one-time effort MeganR, afterwards they can renew with almost negligible activity
19:16:44 <shamail> We need to find out from Tom if we can extract Karma obtained in a date range
19:17:12 <MeganR> if we can't extract the data within certain dates - do we need to remove this one?
19:17:17 <MeganR> at least initially?
19:17:57 <shamail> maishsk: Would it be fair to say that we can move forward with it initially (since people that have put in the effort to obtain that Karma should be recognized) but would need to find a way to do certain dates by next cycle or else it gets dropped
19:18:11 <shamail> I think the first cycle for this one doesnt raise the loophole
19:18:16 <shamail> but going forward it could
19:18:25 <maishsk> shamail: That sounds like a good plan
19:18:32 <MeganR> I like that!
19:18:36 <maishsk> we make the caveat
19:18:38 <shamail> Let’s recognize but flag as in danger
19:19:09 <shamail> perfect! Can you capture the proposal in the etherpad under AskOpenStack?
19:19:25 <shamail> This would complete the final open role in the etherpad
19:19:37 <shamail> Thanks maishsk!
19:19:56 <maishsk> Will do
19:20:01 <shamail> #topic Update on centralized data source proposal by Tom Fifield (MeganR)
19:20:03 <MeganR> Awesome!
19:20:20 <shamail> Have you had a chance to browse the document MeganR or should I summarize?
19:20:40 <shamail> Just looking for a summary here, we can provide feedback via email
19:20:59 <MeganR> I looked it over - really cool
19:21:39 <maishsk> Had a quick browse over it
19:21:41 <shamail> I agree
19:22:15 <shamail> The main objective is to basically get all of the relevant metrics to be included in OpenStack Foundation member profiles.
19:22:31 <shamail> Which would help us with extraction immensely in the future
19:23:22 <shamail> Having said that, we should probably plan on using the methods/sources we discussed in milestone-3 for this cycle since they believe they won’t have it ready before Barcelona.
19:23:23 <MeganR> I like having centralized information - especially for historical purposes
19:23:34 <shamail> Would you agree with this approach MeganR?
19:23:37 <MeganR> +1
19:23:56 <shamail> MeganR: +1, history is good
19:24:26 <shamail> MeganR: once I send the email to the mailing lists, could you share the specific metrics with Tom and Jimmy?
19:24:51 <maishsk> What exactly are the specific metrics ?
19:25:06 <shamail> I think in their document they have captured the sources so far but don’t expand on what are the qualifying metrics… They would need to include that information too in order to make decision on AUC eligibility
19:25:07 <MeganR> you beat me to it - I was just about to ask  :)
19:25:34 <MeganR> got it ok, and I was also thinking of the groups that don't currently use IRC
19:25:40 <shamail> Specific metrics are the items we have in milestone-4 etherpad (e.g. how many WG meetings, how many lines of text, how many articles, etc)
19:25:53 <shamail> That too MeganR
19:26:00 <MeganR> got it - will do
19:26:32 <shamail> So maishsk they mention WG members (role) but don’t specify “what makes someone an active WG member?" (metrics)
19:26:43 <shamail> We should capture both in the doc
19:26:57 <maishsk> understood
19:27:57 <shamail> They might come back and say that is out of scope (analysis is done by UC rather than automated) but it can’t hurt to mention the criteria to determine if its feasible to automate eligibility as well
19:28:22 <shamail> MeganR, anything else on this topic?
19:28:32 <MeganR> nope
19:28:37 <shamail> When you reply can you please add maishsk to the email thread as well?
19:28:59 <maishsk> Why would they say that is out of scope ?
19:29:03 <MeganR> yes - can you post your email, so I have it at hand?
19:29:17 <MeganR> *maishsk - can you post your email?
19:29:35 <maishsk> just sent it to in private
19:29:42 <MeganR> ty
19:29:45 <maishsk> np
19:29:55 <shamail> maishsk: They are trying to build a centralized data source for us to use.  They might say using that data source for decision-making is up to us.
19:30:19 <shamail> The scope of the document is not to automated AUC eligbility checks but rather just provide a central data source for the process
19:30:54 <shamail> thats the only reason I could see it being out of scope but would be happy if its in scope!
19:31:54 <shamail> #action MeganR will share eligibility criteria with Tom and Jimmy based on email to UC
19:32:10 <shamail> #topic Open
19:32:57 <maishsk> So just to clarify the doc is to say we want a place to store data - how it is collected - and what the thresholds are - not interesting.
19:33:10 <maishsk> to put it bluntly :)
19:34:18 <shamail> Makes sense
19:34:34 <maishsk> ok
19:34:52 <shamail> I am going to work with Tom F. to see if we can run a prelimenary count of AUC based on our criteria so far… I hope to be able to have that info to share next week
19:35:32 <MeganR> that would be great
19:35:33 <shamail> Tom had sent an email last week to ask whether he can run the numbers, so he just needs criteria… I will also try to help with sources that are not automated
19:36:01 <shamail> #action Goal: create prelimenary count of AUCs for next meeting
19:36:24 <shamail> We can then revisit our criteria to adjust if the pool is too big or too small
19:36:46 <MeganR> do we have any idea of what would be too big?
19:37:07 <shamail> ¯\_(ツ)_/¯
19:37:22 <shamail> I would defer that to the UC since they would know the cost implications
19:37:29 <MeganR> well, that answers that!  :)
19:37:41 <shamail> We haven’t been told anything about benefits, etc
19:37:46 <MeganR> ok
19:38:04 <maishsk> one sec - cost implications?
19:38:27 <shamail> maishsk: I mean like if they are considering free passes or nifty badges etc (just as examples)
19:38:34 <shamail> then the number of AUCs would have a cost associated with it
19:39:53 <maishsk> Has there been any discussion about benefits / rights etc . ?
19:39:54 <shamail> Things like voting rights in UC, etc. won’t have a cost but other items might (even if nominal on an individual basis) and an estimate would help the foundation with budgeting
19:40:25 <shamail> Not as far as I know (beyond UC voting right)… The charter that the UC put together still has that section as ‘pending'
19:41:08 <shamail> We can ask emagana or jproulx
19:41:11 <maishsk> I know that is not part of the charter of this group
19:41:34 <emagana> hi there!
19:41:38 <emagana> What's the question?
19:41:40 <shamail> Hi emagana!
19:41:52 <shamail> The question: “maishsk: Has there been any discussion about benefits / rights etc . ?"
19:42:05 <maishsk> but I would hope that would mean either immediate ATC status (or at the bare miminimum eligibility to vote in the TC elections)
19:42:12 <shamail> I mentioned that the number of AUCs might have cost implications and we started discussing this topic
19:42:25 <emagana> the straight forward one on being AUC is the free access to the conference and be recognized
19:42:38 <emagana> once we have voting in place for UC, you will be able to vote
19:42:45 <shamail> passes are being considered?
19:42:50 <emagana> I can't think of anything else at this moment
19:42:53 <shamail> I dont recall if I saw that section filled out in the charter
19:43:02 <maishsk> But I thought they were looking for removing the free pass - or at least raising the bar for ATC ?
19:43:06 <emagana> passes will be granted, yes!
19:43:11 <shamail> nice
19:43:15 <MeganR> great
19:43:19 <maishsk> :)
19:43:31 <emagana> again, we need to run numbers, if we end up with 4000 passes obviously it will not work.
19:43:32 <shamail> So the size of AUC will definitely have a cost implication
19:43:36 <shamail> exactly emagana
19:43:39 <emagana> working with the Foundation on the numbers
19:44:04 <shamail> We hope to be able to have an early count of AUCs based on criteria by next week or so emagana
19:44:18 <emagana> shamail: excellent. Reach out to me directly
19:44:21 <shamail> We’ll make sure you have that data
19:44:23 <shamail> Sounds good
19:44:24 <emagana> I want to present the numbers ASAP
19:44:30 <shamail> I know, sorry for the delay
19:45:26 <shamail> maishsk: They are raising the bar I believe but AUC is a different program from a different budget pool.  I am sure criteria will change over time for us as well but this is year 1. :)
19:46:08 <maishsk> has that been officially verbalized - I do not recall seeing anything about that
19:46:40 <shamail> Not that I am aware of maishsk… I would suggest asking on the mailing list or reaching out to ttx for confirmation
19:46:55 <shamail> Or were you asking about the AUC passes?
19:47:11 <shamail> my first answer was for ATC pass eligibility
19:47:32 <maishsk> I was asking about ATC
19:47:37 <maishsk> thanks
19:47:39 <shamail> Okay :)
19:47:46 <shamail> Thanks emagana, maishsk, and MeganR
19:48:03 <emagana> cool!
19:48:09 <MeganR> yw - thanks for keeping us on task!
19:48:31 <shamail> Have a great day
19:48:33 <shamail> #endmeeting