19:01:01 <shamail> #startmeeting auc
19:01:02 <openstack> Meeting started Thu Jun 16 19:01:01 2016 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:07 <openstack> The meeting name has been set to 'auc'
19:01:16 <shamail> Hi everyone.  Who’s here for the AUC meeting?
19:01:22 <MeganR> o/
19:01:30 <maishsk> o/
19:01:39 <shamail> Hi MeganR and maishsk
19:01:47 <maishsk> Nice to see the AUC plastered all over :)
19:01:54 <shamail> :]
19:01:55 <MeganR> Hi Shamail and maishsk
19:02:15 <maishsk> Hi all
19:02:18 <maishsk> anyone else here?
19:02:37 <shamail> Let’s give it a couple of minutes and then we’ll start… I was hoping we would have a larger turn-out but at this point we have to continue making progress against the agenda.
19:03:01 <shamail> Tom needs to run prelimenary numbers by next week, we can discuss and share via ML
19:04:01 <shamail> #chair maishsk
19:04:02 <openstack> Current chairs: maishsk shamail
19:04:19 <shamail> Okay, let’s start… the agenda for today can be found at:
19:04:20 <shamail> #link https://wiki.openstack.org/wiki/AUCRecognition#Meeting_Information
19:04:32 <shamail> #topic Updates on action items from 6/2
19:05:18 <shamail> I just went through the logs, no action items from 6/2 (yay) so moving on
19:05:20 <shamail> :)
19:05:29 <shamail> #topic Review draft of milestone-3 output
19:05:45 <shamail> Is the bot not working again?
19:05:52 <shamail> oh well...
19:05:55 <maishsk> Way to go Shamail
19:06:00 <shamail> lol
19:06:23 <shamail> So we had really good discussions during milestone-3
19:06:38 <shamail> I summarized our conversations and decisions into an etherpad
19:06:39 <shamail> #link https://etherpad.openstack.org/p/uc-recog-m3-output
19:07:11 <shamail> Please review the draft output from milestone-3… if majority agrees, we can mark it as final and move to milestone-4
19:09:12 <shamail> Please let me know when you have reviewed it
19:09:41 <maishsk> ack - looks fine to me
19:09:50 <MeganR> Looks good to me
19:09:58 <shamail> Thanks
19:10:10 <shamail> We can always iterate later
19:10:28 <shamail> #agreed milestone-3 can be marked as completed
19:11:06 <shamail> We can move on to milestone-4 now!
19:11:20 <MeganR> Woo hoo!
19:11:31 <shamail> This is probably the last major milestone and then its downhill :)
19:11:34 <shamail> #topic Kick-off milestone-4
19:11:55 <shamail> #link https://etherpad.openstack.org/p/uc-recog-metrics
19:12:49 <shamail> I went ahead and documented some of the metrics that we already discussed in milestone-3 and added them as starting points to foster discussion
19:13:30 <shamail> Should we walk through each role on the list and discuss the criteria/questions?
19:13:33 <maishsk> Sure
19:13:37 <shamail> Thanks
19:13:41 <MeganR> please
19:13:50 <shamail> So for Official User Group organizers we have a pretty clear-cut metric
19:13:57 <shamail> “Listed as an organizer or coordinator for an official OpenStack user group"
19:14:23 <maishsk> +1 - just the fact is what happens to changes over time
19:14:49 <maishsk> Which means we have to define a period over which the status is valid. When it starts, and when it ends
19:14:53 <shamail> One thought i had was what about if organizers/contributors change during the course of the six months
19:15:36 <shamail> I don’t think this will happen often so it might be overthinking the problem
19:15:59 <shamail> if it does happen, I am sure the new (or former) organizers could just let us know via the self-nomination process
19:16:21 <maishsk> That sounds like a plan - good idea
19:16:29 <shamail> Awesome.
19:16:43 <MeganR> true, and hopefully if they are involved enough to plan/coord. user groups, they are also active in other areas.
19:16:45 <shamail> Moving on to “Active members of official UC Working Groups”
19:16:54 <shamail> MeganR: +1
19:17:42 <shamail> For this one, I added to initial metrics:
19:17:44 <shamail> Attend 25% of the meetings over the last six months
19:17:45 <shamail> Contributed at least (100 if OR, 25 if AND) lines in meetings (based on logs) over the last six months
19:17:48 <shamail> just as a starting point
19:17:52 <maishsk> Mind elaborating on  — Contributed at least (100 if OR, 25 if AND) lines
19:17:57 <shamail> Absolutely
19:18:46 <shamail> My thought process here was that most working groups meet weekly (some don’t) but 25% attendance even in the weekly WGs would mean roughly about 6 meetings in 6 months which should be easy for active members
19:19:10 <shamail> The second line was about the fact that simply showing up does not make someone “Active”, it’s about collaboration and discussion
19:19:43 <maishsk> But I dont get how the numbers work
19:19:43 <shamail> to that end, I was thinking that we would state that you have to show up to 25% of the meetings AND have logged at least 25 lines over six months
19:19:47 <maishsk> :(
19:20:00 <shamail> That ensures that just saying “hello” and “bye” in each meeting won’t let you make the cut
19:20:16 <shamail> Oh, eavesdrop logs the number of lines each person says in a meeting
19:20:39 <MeganR> ok, that makes sense, so is it no less than 25 lines?
19:20:53 <shamail> Think of this as being the total count of lines said by someone in 6 months and if > 25 AND they show up in the log for 25% of the meetings then they are included
19:21:00 <shamail> Yes MeganR
19:21:27 <shamail> I did that because it would prevent “hello”, “bye”, and a single “+1” from meeting the threshold
19:21:34 <shamail> if they only attended 6 meetings and did that
19:21:35 <MeganR> ok, I am good with that number, thank you
19:22:08 <maishsk> That works
19:22:13 <MeganR> Playing Devil's Advocate - what about teams that don't use IRC - initially, are we relying on their attendance to mean active participation?
19:22:17 <shamail> The “100 if OR” reference was regarding whether we would consider someone an active member of the WG (regardless of how many meetings they attended) if they have over 100 lines logged
19:22:40 <shamail> meaning they couldve shown up for 1 or 2 meetings only but made significant contributions towards topic(s)
19:23:12 <MeganR> hmm, I like that idea = we certainly have seen active contributors that aren't always able to attend every meeting.
19:23:35 <shamail> MeganR: I forgot to list the criteria for those teams… I think we are relying on the WG chairs for this groups and therefore we don’t have additional criteria beyond the WG chair saying someone is active
19:23:55 <shamail> Can you add the criteria for non-IRC WGs?
19:24:11 <maishsk> regarding those who dont use IRC - I think that relying on the chair to update their minutes somewhere and the minutes should include participants
19:24:11 <MeganR> sure
19:24:38 <shamail> maishsk: +1, most of those WGs use etherpads so attendance is logged
19:24:53 <maishsk> It could be me - but maybe we should reword the IRC criteria - I did not find it sraightforward to understand
19:25:12 <shamail> we would just ask the chairs though to reduce burden on the people determining AUC (otherwise we would have to mine all etherpads which could be a labor intensive process)
19:25:22 <shamail> maishsk: +1
19:25:37 <shamail> I did the initial wording to put down my thoughts
19:25:52 <MeganR> and the etherpads don't always identify who was speaking, since someone else may be taking notes
19:26:11 <MeganR> just who attended
19:26:27 <shamail> It seems we all agree with the explanation so I will go back and rephrase appropriately
19:26:47 <maishsk> #agreed
19:27:39 <shamail> maishsk: does line 17 capture the idea better now?
19:28:20 <maishsk> Much clearer - thanks!
19:28:26 <shamail> thanks!
19:28:26 <MeganR> yes, that looks good!
19:28:40 <shamail> Perfect, thanks for the addition MeganR!
19:28:44 <shamail> On to “Ops meetup moderators”
19:28:59 <shamail> The initial criteria here is listed as:
19:29:04 <shamail> Moderate a session at the operators meetup over the last six months
19:29:05 <shamail> Host the operators meetup (limit 2 people from the hosting organization) over the last six months
19:30:14 <maishsk> I think the limit is fine - just who decided which two they actually are? first come first served? They duel it out themselves? At dawn? With featherdusters ?
19:30:23 <shamail> I added a response on the etherpad but the “2 maximum” is arbitary
19:30:27 <shamail> Oh
19:30:35 <shamail> The hosting organization would decide
19:30:54 <maishsk> Works for me!
19:30:56 <MeganR> I personally am voting for the featherdusters idea!
19:31:04 <shamail> so, for example, in Manchester… Matt was the main point of contact… we would’ve asked him if another person from his company helped.
19:31:15 <shamail> lol MeganR
19:31:15 <MeganR> what about people moderating the actual sessions?
19:31:22 <shamail> That is the other set of criteria
19:31:28 <shamail> “Moderate a session at the operators meetup over the last six months"
19:31:35 <shamail> basically this is an OR situation
19:31:49 <MeganR> ah ha - that's what I was missing - thank you
19:32:01 <shamail> you can get eligibility in this category by moderating a session or hosting the meetup (but max 2 for hosts)
19:32:16 <shamail> Is 2 a good number?
19:32:26 <shamail> I could reasonably see this being anywhere from 2-10
19:32:35 <MeganR> yes, I think 2 is a good number and I like making the host company decide
19:32:40 <maishsk> Agreed
19:32:49 <shamail> Cool
19:32:59 <MeganR> there are usually a lot of people involved, but not all participate in OpenStack
19:33:06 <shamail> We should share this information regarding host eligibilty with the Meetup-Admin WG
19:33:17 <shamail> hopefully they will see it on the mailing list
19:33:25 <shamail> MeganR: +1
19:33:48 <shamail> Moving on to “Contributions to any repository under UC governance (ops repositories, user stories repository, etc.)”
19:34:13 <maishsk> So I have made one correction there
19:34:13 <shamail> The intial set here:
19:34:14 <shamail> Submitted two or more patches to a UC governed repository over the last six months
19:34:15 <shamail> Host the operators meetup (limit 2 people from the hosting organization)
19:34:20 <maishsk> two or more.
19:34:23 <shamail> Thanks maishsk, saw the “or more"
19:34:37 <shamail> It is not the same as the ATC criteira
19:34:40 <shamail> criteria*
19:34:57 <maishsk> and I dont understand why the Host Operators meetup is there?
19:34:59 <shamail> I believe that criteria is at least one change in the last two releases
19:35:24 <shamail> maishsk: that’s an easy one, because this etherpad was made with 3 hours of sleep
19:35:25 <shamail> xD
19:35:30 <maishsk> LOL!
19:35:35 <MeganR> lol - makes perfect sense now!
19:35:52 <shamail> Removed it, good catch :
19:35:52 <maishsk> Should we not keep the criteria the same as ATC ?
19:36:18 <MeganR> is ATC changing?
19:36:21 <shamail> That would mean that we are tracking AUC for 12 months versus 6 months of eligibility (as all other categories are)
19:36:30 <shamail> I kept the two part the same but just made it over one release
19:36:44 <maishsk> it conforms with the rest of the Openstack
19:37:06 <maishsk> is ATC changing - I have been hearing rumors / rumblings… ?
19:37:28 <shamail> It would align with TC governed projects in that case but get unaligned with all other AUC categories
19:37:46 <shamail> everything else we are tracking is over 6 months
19:38:06 <shamail> I am fine either way on this..
19:38:14 <maishsk> And the term for an AUC is for 6 or 12 months?
19:38:22 <shamail> 6 months, summit to summit
19:39:01 <MeganR> I think we need to keep it consistent with everything else, but make a note about the difference
19:39:07 <maishsk> So if that is the case - I am fine with the criteria - as they are on the etherpad
19:40:03 <shamail> MeganR: Can you eloborate?  Is this a note about the fact that it’s different from ATC criteria?
19:40:46 <MeganR> yes, that this is based upon a 6 month cycle
19:40:49 <shamail> maishsk: I have heard some changes for ATC but they were discussed at the board meeting and I don’t know if it was brainstorming, executed plans, or intended plans.  I think it will change but I don’t think the formal conversations have started?
19:40:57 <shamail> Got it, will do MeganR
19:41:02 <MeganR> ty
19:42:17 <shamail> Next one: “Track chairs for OpenStack Summits”
19:42:32 <shamail> Identified track chair for the upcoming OpenStack Summit (based on when data is gathered) [this is a forward-facing metric]
19:43:02 <shamail> The criteria is easy but the one decision point is who gets AUC, the track chairs after the summit they chaired or track chairs for the upcoming summit
19:43:08 <MeganR> Question: will this be Track chairs for the current or previous summit?
19:43:20 <shamail> That is the question indeed
19:43:29 <MeganR> ok, I am reading that right
19:43:42 <MeganR> I think this looks good, and we will figure out that nuance
19:43:55 <shamail> Basically, do you have to chair and then get recognized after the fact at the next summit or do we recognize track chairs for the current/upcoming summit once we know who they are
19:44:10 <shamail> I am leaning towards forward-facing/current
19:44:33 <MeganR> Ideally: recognize those for the current summit - if there is time - but at the very least recognized at the following summit.
19:44:34 <shamail> This would allow Barcelona track chairs to be in the initial AUC list
19:45:12 <shamail> Agreed MeganR, but it would eventually be one or the other… (e.g. track chairs do not get recognized for more than 6 months either)
19:45:14 <maishsk> I think that it should be for the upcoming summit
19:45:16 <MeganR> My hesitation for the recognition at the following summit is how often people and positions change in between summits.
19:45:26 <shamail> MeganR: +1
19:45:51 <shamail> I think this is why forward-facing/current makes more sense… it also allows effort/reward to more closely aligned
19:46:01 <MeganR> +1
19:46:24 <shamail> next: “Contributors to Superuser (articles, interviews, user stories, etc.)”
19:46:36 <shamail> Criteria: “Listed as author in at least one publication at superuser.openstack.org over the last six months”
19:46:47 <maishsk> This is an easy one
19:46:54 <shamail> Is one publication sufficient?
19:47:02 <MeganR> yes
19:47:04 <shamail> I dont think there are that many superuser articles
19:47:06 <shamail> cool
19:47:14 <shamail> agreed maishsk
19:47:26 <shamail> Next: “Submission for eligibility to review panel”
19:47:30 <maishsk> acutally there are at least 2-3 per week
19:48:09 <shamail> so 48-72 in six months
19:48:12 <shamail> roughly
19:48:18 <shamail> which isn’t bad…
19:48:35 <shamail> Even if we make the criteria single publication, it’s not a massive amount
19:48:48 <MeganR> I am good with one
19:49:15 <shamail> We can always revisit the required count after we run the initial total AUC count
19:49:23 <maishsk> And we are talking about articles?
19:49:28 <shamail> maishsk: yes
19:49:34 <maishsk> And not posts about Video interviews?
19:49:36 <shamail> but I think it is broader
19:49:54 <shamail> Those count too… most videos also have an associated article
19:50:11 <shamail> the person might not be the author but would be mentioned as the source of content
19:50:38 <maishsk> shamail: I am not sure about that
19:50:40 <MeganR> I think that is fine to start, and we can always revisit
19:50:44 <shamail> I think people actually wanted to remove SuperuserTV, etc from the criteria
19:50:46 <maishsk> take this for example - http://superuser.openstack.org/articles/going-from-startup-to-established-in-the-openstack-ecosystem
19:51:02 <shamail> because they didnt feel one 5-10 min interview was on-par with the effort required for other categories
19:51:08 <shamail> article at least takes longer
19:51:32 <shamail> Yeah, so if we say it counts then Jesse and Boris would be AUC
19:51:45 <shamail> Most people said don’t count it because the effort is minimal
19:51:53 <MeganR> don't underestimate the stress associated with an interview  :)
19:51:58 <maishsk> :)
19:52:00 <shamail> lol MeganR
19:52:02 <maishsk> been there done that :)
19:52:09 <MeganR> +1000
19:52:30 <shamail> So should we include it for now and revisit if people object?
19:52:49 <MeganR> no, I think the articles are fine
19:53:06 <maishsk> I am fine with also excluding for now and adding it in later - if people object
19:53:14 <shamail> Great
19:53:25 <maishsk> and I think that is exactly what MeganR also just said
19:53:32 <shamail> next: “Submission for eligibility to review panel”
19:53:34 <maishsk> or perhaps not?
19:53:35 <MeganR> lol
19:53:41 <shamail> criteria: “No formal criteria, anyone can self-nominate, and nominations will be reviewed per guidance established in milestone-5”
19:54:07 <shamail> basically for this one the answer is that there are no hard and fast rules and the process will be defined in the next milestone
19:54:22 <MeganR> I like this one as it stands, but in the future would like to develop a template - so certain information is obtained and submitted, making it easier for the UC to review.
19:54:42 <shamail> MeganR: +1, you can take the action item in milestone-5 ;)
19:54:48 <maishsk> :)
19:55:17 <MeganR> lol - I will keep quiet from here on out!
19:55:21 <shamail> jokes aside, that should definitely be an output of milestone-5.. common questions
19:55:31 <MeganR> +1
19:55:45 <shamail> Aaaand last one: “Active moderators on ask.openstack”
19:55:52 <shamail> Criteria: “Listed as moderator on Ask OpenStack and have over 500 karma”
19:56:10 <shamail> I checked out the ask moderator karma ranks
19:56:16 <maishsk> What does 500 karma mean?
19:56:30 <shamail> You get karma when people like your answer or accept it
19:56:57 <maishsk> is 500 karma a lot ? a whole lot? how active ?
19:56:59 <shamail> If the threshold is 500 then approxiately 35 moderators would get AUC
19:57:21 <shamail> It is a decent amount, there is a huge tail on karma in Ask OpenStack
19:57:26 <shamail> the #1 has like 10,000
19:57:33 <shamail> by #35, we are at 501
19:57:47 <shamail> and there are over 500+ people overall
19:57:56 <MeganR> oh wow - I think that is a good place to start, and can refine if we find there is more active participation.
19:58:06 <maishsk> +1
19:58:09 <shamail> cool
19:58:17 <shamail> the only other issue here is time horizon
19:58:29 <MeganR> The time frame for this I think should be 6 mo as well, based on everything else
19:58:38 <shamail> Ask OpenStack doesn’t show how much karma someone obtained in 6 months so we can say “earn 100 karma in six months”
19:58:39 <MeganR> does that fit the 500?
19:58:50 <MeganR> how about 250
19:59:02 <shamail> if the criteria is “500 karma” then that makes anyone with over 500 permanently eligibke
19:59:13 <maishsk> But karma does not measure on a 6 month cycle - it from the day they started until now
19:59:29 <shamail> #link https://ask.openstack.org/en/users/?sort=reputation
19:59:35 <maishsk> I think this one might need some more thought
19:59:40 <shamail> each page has 30 people
19:59:46 <MeganR> hmm, what if they started within the past 6 months?
19:59:58 <shamail> so 250 would mean about 100 people
20:00:10 <shamail> exactly maishsk
20:00:32 <shamail> MeganR: then if they achieve the karma threshold they would be eligible, otherwise not
20:00:41 <maishsk> let’s defer this point to next week?
20:00:53 <shamail> there is no way in ask.openstack.org to say “show me the karma for user over this date range"
20:00:54 <MeganR> I agree with maishsk - need to think about this more
20:01:05 <maishsk> I can take an AI to think of possible ways to measure this and present next meeting
20:01:20 <shamail> The counter-point here is that once you’ve answered a question
20:01:29 <shamail> the solution could be valid for a long time
20:01:46 <shamail> so, in theory, something you answered a year ago could still be helping people today
20:02:00 <shamail> thanks maishsk
20:02:11 <maishsk> I have to drop
20:02:21 <shamail> #action maishsk to propose metrics for ask openstack
20:02:22 <maishsk> This was really productiive (As always!!)
20:02:25 <shamail> sounds good maishsk
20:02:28 <shamail> We are done!
20:02:38 <shamail> I will send out this etherpad over the ML to get more feedback from the community
20:02:42 <MeganR> Great!
20:02:51 <shamail> and let Tom know that he can run initial numbers using this set of requirements
20:03:03 <shamail> Thanks for joining MeganR and maishsk
20:03:09 <MeganR> sounds good - interested in seeing the numbers
20:03:18 <maishsk> thanks for Chairing shamail
20:03:22 <shamail> #action shamail to send etherpad via ML for further community discussion
20:03:23 <MeganR> thank you for pulling all of this together - really helped move things along!
20:03:34 <shamail> Same here! looking forward to prelim numbers
20:03:49 <shamail> Thank you both for helping with the process!  We are getting there!!
20:03:51 <shamail> bye
20:03:56 <shamail> #endmeeting