19:01:45 <SpamapS> #startmeeting arch_wg
19:01:46 <openstack> Meeting started Thu Nov  3 19:01:45 2016 UTC and is due to finish in 60 minutes.  The chair is SpamapS. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:49 <openstack> The meeting name has been set to 'arch_wg'
19:01:56 <SpamapS> Courtesy ping for dtroyer jlk ijw joehuang maishsk katomo bkero ttx takashin edleafe flaper87 takashi samueldmq saitou coolsvap devananda boltR denaitre Qiming scottda GheRivero ricolin tkatarki xek jimbaker sadasu rlpple csatari phschwartz hu jie DinaBelova mdarnell r1chardj0n3s dgonzalez sileht
19:02:23 <auggy> o/
19:02:28 <GheRivero> o/
19:02:29 <auggy> hrm somehow my name dissappeared
19:02:32 <SpamapS> Courtesy ping as well for usual suspects for arch_wg nikhil, harlowja, dstanek, kragniz, auggy, rockyg, rocky_g
19:02:36 <harlowja> oh hi
19:02:42 <auggy> aha
19:02:48 <SpamapS> auggy: that first list was the list from the summit session :)
19:03:02 <SpamapS> #link https://wiki.openstack.org/wiki/Meetings/Arch-WG#Agenda
19:03:12 <rockyg> o/
19:03:22 <SpamapS> welcome, I hope, many newcomers!
19:03:47 <SpamapS> #topic Summit recap
19:04:01 <SpamapS> I wanted to really quick recap the summit fishbowl experience before we get into the usual agenda.
19:04:25 <harlowja> k
19:04:35 <SpamapS> First, it was great to see such a dense turnout for the session in Barcelona. We had a great cross section of OpenStack come by to take a look.
19:04:35 <cdent> o/
19:04:38 <harlowja> \o
19:04:59 <bkero> o/
19:05:08 <SpamapS> I actually feel that the questions asked, and the group's responses, helped me to refine our message and mission even more, and I hope we can get that recorded and written down very soon.
19:05:32 <SpamapS> Did anyone else have some impressions from the summit session (and summit in general) they wanted to share?
19:05:40 <SpamapS> #link https://etherpad.openstack.org/p/BCN-architecture-wg
19:06:00 * harlowja eagerly awaits the recap
19:06:00 <harlowja> ha
19:06:24 <DinaBelova> o/
19:07:27 <SpamapS> So the main thing I got from that session is that what seems to be missing from OpenStack in general is a recording of the intended theory of operations of the authors of the bits that form the architecture.
19:07:37 <rockyg> frekin' missed it.  Missed most of the sessions.  Grumble.
19:08:08 <harlowja> i missed it to, oops :-/
19:08:29 <SpamapS> Everyone has an idea of how they thing things work, and there are plenty of functional docs on how each piece should work, but details on the overall way that these pieces are intended to be used are largely gleaned from code examples that form a very strong cargo cult.
19:08:39 <SpamapS> s/thing/think/
19:08:47 <cdent> SpamapS: I read your blog posting and while I agree with your decision on what needs to happen I didn't really feel like anyone felt like there was a cogent theory of operation(s)
19:09:01 <SpamapS> #link http://fewbar.com/2016/10/openstack-architecture-wg-because-we-all-arent-gaudi/
19:09:05 <cdent> but yes, there are lots of different ideas on how things work (which is not quite the same thing)
19:09:51 <SpamapS> Right, many have _Strong_ opinions that something should work one way or another, and the point we brought to their attention is that this is not recorded in OpenStack itself.
19:10:40 <DinaBelova> it looks we miss mapping (or whatever documented) between reasons (whatever - workloads, business reasons, etc.) and actual solutions
19:11:05 <SpamapS> DinaBelova: correct, that is definitely a missing piece.
19:11:10 <DinaBelova> ideally this mapping needs to be not only "documented", but also somehow "proved"
19:11:12 <SpamapS> So there was some talk of where we might record these things.
19:11:43 <SpamapS> There's a systems architecture manual for end-users.. but we really need an internal architecture manual targetted at engineering.
19:11:56 <DinaBelova> ++
19:12:00 <harlowja> +1 from me,though i want to make sure those things we record actually are useful for <the wider community> (vs just being useful to this group)
19:12:29 <SpamapS> DinaBelova: oh that's a good point that I may have discounted a bit. There is a strong desire to make sure we're not just being "astronaut architects" but that we are proving out our findings and recommendations.
19:12:59 <rockyg> ++
19:13:11 <auggy> +1 from me too, it can also help to focus reviews
19:13:25 <SpamapS> So, we'll need to work toward that in our process discussions, as I think right now our only planned outputs are our recommendations, and direct patches to the projects to implement them. But it sounds like we may actually need to also think about writing documentation specifically for architecture.
19:13:28 <harlowja> i nominate SpamapS for being the openstack cat herder :-P
19:13:47 <DinaBelova> SpamapS indeed, from our team (performance team) experience - everything needs to be proved. If that is about scalability / performance - that can be easily enough tested. If there is purely "dev-friendly" architecture solutions, that's more subjective, but also can be measured
19:14:14 <SpamapS> DinaBelova: +1
19:14:26 <SpamapS> ok, so before we move on to our usual meeting agenda. Did anyone else have more to add?
19:15:37 <SpamapS> #topic previous meeting action items
19:15:43 <SpamapS> #link http://eavesdrop.openstack.org/meetings/arch_wg/2016/
19:16:11 <SpamapS> - SpamapS continue driving repo creation forward
19:16:18 <SpamapS> I'm happy to report that this is _done_, and we have a repo!
19:16:44 <SpamapS> it is, unfortunately, empty at this time, but we will fill it up soon with a structure for working on proposals
19:16:55 <SpamapS> #link https://git.openstack.org/openstack/arch-wg
19:17:01 <SpamapS> clone that to participate :)
19:17:17 <SpamapS> - SpamapS submit base services etherpad contents to arch-wg repo upon its creation.
19:17:26 <SpamapS> didn't get a chance to do that just yet, so will carry forward
19:17:31 <SpamapS> #action SpamapS submit base services etherpad contents to arch-wg repo upon its creation.
19:17:50 <SpamapS> - SpamapS email openstack-dev architecture tag when the repo is available for submissions
19:17:54 <SpamapS> oops, forgot to do that too
19:17:57 <SpamapS> #action SpamapS email openstack-dev architecture tag when the repo is available for submissions
19:18:12 <SpamapS> - SpamapS email ttx with update to Fishbowl text and links.
19:18:25 <SpamapS> That sort of got done, but also didn't, but we did a fishbowl, so it's done
19:18:38 <SpamapS> - Pre-populate etherpad with mission statement
19:18:53 <SpamapS> Also part of fishbowl, and it kind of didn't happen. Oh well, irrelevant now
19:19:22 <SpamapS> #topic Proposal Process Review
19:19:55 <SpamapS> So this is still only recorded here:
19:20:00 <SpamapS> #link https://etherpad.openstack.org/p/arch-wg-draft
19:20:10 <SpamapS> anybody want to sign up to submit that into arch-wg?
19:20:24 <SpamapS> I'm already pretty full on arch-wg tasks so unlikely I'll get it done :-P
19:20:56 <SpamapS> #action Submit https://etherpad.openstack.org/p/arch-wg-draft as text for arch-wg repo
19:21:03 <SpamapS> if somebody wants to pick that up I'd be grateful
19:21:13 <DinaBelova> SpamapS I'll try to do that this week :)
19:21:25 <SpamapS> DinaBelova: thank you!!
19:21:25 <DinaBelova> I have Friday :D
19:21:39 <SpamapS> #topic Proposals for work
19:21:51 <SpamapS> As yet we still only have base services on our list
19:22:01 <SpamapS> and the summit kind of stopped us from talking about it so I think we'll just keep that for now
19:22:59 <SpamapS> it also sounds like we might want to start taking on just general documenting of the state of architecture theory of operation in each oslo library.
19:23:47 <harlowja> yup
19:23:49 <harlowja> +1 from me
19:23:50 <SpamapS> I also think we need to poll the Product Working Group to get ideas for what they have trouble talking about
19:23:55 <harlowja> i haven't yet started that ML thread
19:23:59 <harlowja> others are more than welcome to
19:24:12 <SpamapS> I'm going to just leave this as "we need more proposals"
19:24:32 <SpamapS> #topic Open Discussion
19:24:41 <SpamapS> Quick meeting, I know everybody is still in summit recovery mode
19:25:32 <SpamapS> DOesn't seem like there's much chatter.. so I want to just release everyone from their IRC screens ... any discussion can of course continue in #openstack-architecture
19:25:43 <SpamapS> going once?
19:26:12 <SpamapS> twice...
19:26:17 <DinaBelova> yep, it looks like that's all :)
19:26:23 <SpamapS> #endmeeting