22:02:54 <docaedo> #startmeeting app_ecosystem_wg
22:02:55 <openstack> Meeting started Mon Nov 21 22:02:54 2016 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:02:58 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:03:08 <docaedo> Patifa: thats what we have meeting bot for!
22:03:26 <docaedo> Welcome, todays agenda:
22:03:33 <docaedo> #link https://etherpad.openstack.org/p/2016_Nov_21_App_Dev_Enablement
22:03:52 <docaedo> #topic Improve developer.openstack.org and/or www.openstack.org/appdev
22:04:07 <docaedo> ping reed :)
22:04:22 <docaedo> not sure of any other IRC handles from folks volunteered for that work
22:04:41 <docaedo> but I suspect with this being a big holiday week in the US a lot of people are taking time off
22:04:42 <Patifa> I'm not sure Alejandra is here
22:05:30 <docaedo> It looks like it's just the three of us - are there any topics from the barcelona agenda that are worth discussing?
22:05:52 <docaedo> or plan B, we have a short meeting and try to drive this conversation on the mailing list?
22:05:55 <Patifa> How about the survey?
22:05:58 <cbsterrett> I guess I will ask my question, are we still going to open the meeting with app_ecosystem_wg to keep the logs together?
22:06:01 <docaedo> actually regardless, here comes an action for me:
22:06:17 <docaedo> #action docaedo to start mailing list thread re: "Improve developer.openstack.org and/or www.openstack.org/appdev"
22:06:59 <docaedo> cbsterrett: I thought I'd do that for this meeting for the sake of consistency, but I could be talked out of it pretty easily - does seem valuable though to keep all the meetings in the same place on the log server
22:07:18 <docaedo> (consistency, or maybe continuity is more the point)
22:07:33 <cbsterrett> It made me laugh when you asked Patifa to run the meeting I was thinking not me, I wouldn't know how to start it :)
22:07:57 <docaedo> hahaha
22:08:15 <docaedo> #topic The Survey (patifa)
22:08:35 <Patifa> #link https://etherpad.openstack.org/p/AppEco_WG_BCN
22:09:29 <Patifa> Under 1.1.3.2... We though about creating this survey to collect data from app devs in various events
22:10:14 <docaedo> Yep, I do remember this
22:10:15 <Patifa> I guess this is something we can brainstorm a little bit about.. and than take it to the mailing list
22:10:26 <docaedo> Agreed
22:11:07 <Patifa> So.. mapping the events...
22:11:41 <docaedo> That part of the issue is not meaningful/useful to me
22:11:42 <Patifa> I listed a few there.. hackathons, meetups, traing...
22:12:15 <docaedo> Sure - I think the more important thing though is coming up with the questions and then blasting the mailing list regularly (as well as having the foundation send a note to all user group organizers)
22:12:21 <Patifa> besides creating the survey we need a strategy about how we're going to distribute that
22:12:36 <docaedo> *or if not the foundation, maybe there's a list we can get from their user groups page...
22:13:05 <Patifa> ok... let's start creating the survey then
22:13:13 <docaedo> right - I did not see this as a one time thing though, I think it's more valuable if we try to get people to ask a few questions and share the answers regularly
22:13:25 <docaedo> (vs. doing an annual survey or something)
22:13:31 <Patifa> (changed the order in the etherpad)
22:13:57 <Patifa> I don't see it as a one time thing either
22:14:08 <docaedo> makes sense though to think about it carefully though, I'm glad you are.  Making sure we actually have a plan for getting the survey to people and a way to collect the answers (along with even details, etc.)
22:14:32 <docaedo> (I apologize for using "though" twice in that sentence, that's just terrible grammar)
22:14:57 <Patifa> thanks for apologizing
22:15:11 <Patifa> ;)
22:15:27 <docaedo> #action docaedo to work on improving his proper utilization of the words
22:15:39 <Patifa> So, 1st thing to define.. what do we want to find out?
22:16:03 <docaedo> yep, should we throw ideas up on etherpad, or just here?
22:16:18 <docaedo> I'd say:
22:16:25 <Patifa> I was thinking about starting a new etherpad just for that
22:16:34 <cbsterrett> +1
22:16:45 <docaedo> works for me
22:17:08 <Patifa> just a second...
22:17:30 <docaedo> FASTER!
22:17:51 <Patifa> loading...
22:17:53 <Patifa> loading...
22:18:14 <Patifa> #link https://etherpad.openstack.org/p/AppDevEnablement_DevSurvey
22:20:43 <Patifa> technologies ok
22:22:12 <docaedo> so technologies - would that be platforms and languages?  Or something else?
22:22:42 <cbsterrett> I was going to say sure
22:22:44 <cbsterrett> :)
22:22:54 <cbsterrett> I guess more technologies, PaaS layers, etc
22:23:00 <cbsterrett> and have languages separeate
22:23:41 <Patifa> why are we doing the survey in the 1st place... is it to define the type of content we want to make available in openstack.org/appdev?
22:24:30 <docaedo> For me the point of the survey is that I want to know what apps folks are developing, and how they're doing it (expecting they might not be developing "native" OpenStack apps on openstack)
22:24:56 <Patifa> ok.. what for?
22:24:59 <cbsterrett> I was thinking to investigate what we need to cover as a group as a whole, not just the web site
22:25:11 <docaedo> so if we learn most respondents at user groups and other events are using cloud foundry, or docker + swarm or something, it will be pretty useful w/r/t where to focus
22:25:31 <Patifa> so the goal is to help define the WG goals
22:25:55 <cbsterrett> I agree
22:25:59 <docaedo> I think so, for me yes
22:26:09 <Patifa> 3 yeseesesss
22:26:31 <Patifa> (grammar police can help me with plural)
22:28:05 <docaedo> more than two "yes" responses constitute a collective hell yes
22:28:23 <Patifa> ok... hell yes... got it
22:28:51 <Patifa> Goal: collect data from app dev about what and how they are developing to help shape App Dev Enablement WG goals.
22:29:21 <docaedo> +1
22:29:42 <cbsterrett> +1
22:30:54 <docaedo> I would say target audience is application developers - or do you mean something else?
22:30:59 <Patifa> is there a specific target audience? do we care what size company they work for.. ?
22:31:08 <Patifa> type of app?
22:31:14 <Patifa> I don't know...
22:31:17 <docaedo> oh I don't think we would want to limit it based on size
22:31:44 <cbsterrett> Can we say something like end user application developers or something to distinguish from our usual openstack services developers
22:31:45 <Patifa> do we want input from operators?
22:32:04 <docaedo> and for "type of app" I still think there's not really anyone developing "OpenStack" apps (in any appreciable numbers), but I'd like to be proven wrong on that, or learn at least what kind of apps are being developed and how/where
22:32:31 <docaedo> Operators could be a good source especially if they're operating a cloud used by developers
22:33:05 <Patifa> is it a different survey? operator and devs?
22:33:14 <cbsterrett> My fear is operators will give us openstack apps, but they will be reports and operator automation
22:33:24 <cbsterrett> nothing that anybody sees
22:35:44 <Patifa> I don't have an opinion...
22:35:49 <docaedo> true but if the operators are developing apps to do that it still counts - and in fact might be the best example of a native openstack app
22:37:51 <Patifa> so one survey, app dev and operators? same questions for all?
22:39:16 <docaedo> I think so - I also might be thinking different survey in general - my thinking was more like 3-4 questions you can ask a group, to spark a conversation, and try to catalog what people say
22:39:29 <docaedo> I was not thinking about a survey we mail out to a small group (or a big group)
22:39:34 <Patifa> more like a focus group then
22:39:47 <cbsterrett> Yeah but that requires moderators and note takers
22:39:54 <docaedo> so maybe worth clarifying whether that's the point of this since maybe I have a different view
22:40:08 <docaedo> I would say anyone hosting a user group can moderate and take notes
22:40:35 <docaedo> I would imagine asking these questions (or maybe just getting a show of hands to start off - see if it's worth asking any more questions)
22:40:41 <Patifa> focus groups are great... and produce rich data.. they are harder to replicate consistently
22:40:52 <docaedo> anyway, could see them being asked at the end of each meetup
22:41:04 <cbsterrett> and take longer to complete, but are more likely to get completed
22:41:05 <docaedo> focus groups seem like a *lot* of administrative effort though
22:41:36 <docaedo> vs this, which would be "come up with some questions, spam the user group organizers and beg them to ask questions and send the answers back each time they meet"
22:42:42 <cbsterrett> I think survey is easier, should we start there and see if we get any responses
22:43:35 <Patifa> we can work on both... we can have a script for a guided conversation in meetups and point ppl to a survey
22:44:13 <Patifa> for other events like hackathon or trainings the survey might be better - for a larger audience
22:44:57 <Patifa> (focus group is now guided conversation but we can call it aedo circles ;)
22:45:04 <docaedo> hah you want to make this a real thing :D  I was just thinking we'll agree on a few questions and be done (but I'm happy to help if you're going to make this much more thorough)
22:45:10 <cbsterrett> LOL
22:45:20 <docaedo> oh hell no, don't coin my name in that phrase!
22:45:22 <docaedo> :p
22:45:28 <Patifa> hahahahaha
22:47:08 <Patifa> I was thinking big, let's send this out everywhere!!! we can start small though
22:47:28 <Patifa> sorry - Though we can start small though though
22:48:07 <docaedo> hahahaha
22:50:12 <Patifa> 10 min
22:50:12 <docaedo> 10 minutes left!
22:50:19 <docaedo> haha dangit!
22:51:07 <docaedo> ok should one of us take an action to start a mailing list thread on this topic (survey), intro the goals and stuff, and share the etherpad link (plus probably a link to this meeting log for additional context) ?
22:51:44 <Patifa> I can do that.
22:52:04 <Patifa> #action Patifa start a mailing list thread on this topic (survey), intro the goals and stuff, and share the etherpad link (plus probably a link to this meeting log for additional context)
22:52:24 <Patifa> didn't work
22:52:31 <Patifa> #action: Patifa start a mailing list thread on this topic (survey), intro the goals and stuff, and share the etherpad link (plus probably a link to this meeting log for additional context)
22:52:46 <Patifa> I don't know how to do this.
22:52:54 <Patifa> But I'll take the action
22:53:14 <docaedo> It did work I think - it will just show up in the meeting minutes (thanks meetingbot!)
22:53:34 <Patifa> ok!
22:53:49 <docaedo> 7 minutes remaining
22:53:58 <docaedo> #topic Open discussion
22:54:14 <Patifa> do you want to take a stab at what are the steps for the guided conversation bit AKA Aedo circles?
22:54:34 <docaedo> haha sure I can work through the steps for the Aedo Circles
22:54:55 <Patifa> see.. it's catching already!
22:55:00 <cbsterrett> it is
22:55:13 <docaedo> so funny
22:55:45 <Patifa> I named UX design techniques before... but that story requires beer
22:56:07 <docaedo> agreed!
22:57:47 <Patifa> 3 min
22:57:51 <docaedo> well i think we are done?
22:58:15 <cbsterrett> yeah
22:58:24 <docaedo> success!
22:58:39 <docaedo> Thanks for coming folks, talk to you later, don't forget to action up your action items!
22:58:41 <docaedo> #endmeeting