22:00:33 <Patifa> #startmeeting app_ecosystem_wg
22:00:34 <openstack> Meeting started Mon Sep 26 22:00:33 2016 UTC and is due to finish in 60 minutes.  The chair is Patifa. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:37 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:00:45 <Patifa> Hello all
22:00:54 <Patifa> Agenda can be found on our etherpad
22:01:02 <Patifa> #link https://etherpad.openstack.org/p/2016_Sep_26_App_Ecosystem_Workgroup
22:01:18 <docaedo> hello!
22:01:27 <Patifa> let's get started!
22:01:29 <vhdiaz> hey Zuup!
22:01:34 <Patifa> #topic rollcall
22:01:40 <docaedo> o/
22:01:47 <calebb> o/
22:01:50 <csterret_> o/
22:02:46 <Patifa> dfflanders must have fallen asleep on top of his tea ;D
22:02:50 <dfflanders> que pasa way yo
22:03:08 <Patifa> #topic WG Chair
22:03:11 * dfflanders tea sleep mmmmmmm
22:03:27 <Patifa> First item of the day is voting for the new chair.
22:03:50 <Patifa> We have Chris Aedo and Maria Bracho as our candidates
22:04:01 <docaedo> chairs! I vote for both nominees, plus Patifa who has been crushing it at leadership and organization
22:04:48 <Patifa> I planned to open voting at the begining of this meeting and close it at the end... so we give folks that joined later time too.
22:05:08 <Patifa> Does that sound good?
22:05:25 <docaedo> works for me
22:05:30 <Patifa> Has anyone ever used voting on IRC... will this plan work?
22:05:58 <dfflanders> should work with meeting bot?
22:06:15 <docaedo> Should but I don't know the format (i.e. how to set it up so it tallies the votes for us)
22:06:18 * Patifa didn't test
22:06:30 <Patifa> #startvote Should we vote now? Chris Aedo, Maria Bracho
22:06:31 <openstack> Begin voting on: Should we vote now? Valid vote options are Chris, Aedo, Maria, Bracho.
22:06:31 <docaedo> but also we have the IRC log anyway, so we probably don't need to be overly formal with this
22:06:32 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
22:06:46 <Patifa> hahah.. that didn't work.. we have 4 candidates
22:06:46 <Patifa> hahah
22:06:57 <Patifa> #endvote
22:06:58 <openstack> Voted on "Should we vote now?" Results are
22:07:13 <docaedo> who are the four candidates?
22:07:26 <Patifa> #startvote Should we vote now? Chris, Maria
22:07:27 <openstack> Begin voting on: Should we vote now? Valid vote options are Chris, Maria.
22:07:29 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
22:07:43 <dfflanders> #vote both
22:07:44 <openstack> dfflanders: both is not a valid option. Valid options are Chris, Maria.
22:08:03 <dfflanders> #vote Chris, Maria
22:08:03 <openstack> dfflanders: Chris, Maria is not a valid option. Valid options are Chris, Maria.
22:08:08 <docaedo> also are we limiting the working group to two chairs only?  because I think we could handle having three chairs and still effectively be an awesome working group
22:08:15 <docaedo> #vote all of them
22:08:16 <openstack> docaedo: all of them is not a valid option. Valid options are Chris, Maria.
22:08:27 * docaedo just likes making meetingbot scold him
22:08:40 <vhdiaz> :)
22:08:44 <dfflanders> so the vote is in the open yes
22:08:47 <dfflanders> ?>
22:08:57 * dfflanders loves new bot toys :)
22:09:20 <Patifa> Do we want to do it some other way?
22:09:30 <Patifa> +1 on etherpad?
22:09:32 <dfflanders> Maybe we should discuss having three chairs?
22:09:37 <csterret_> maybe
22:10:02 <Patifa> That's is a nice idea.. do we have Maria here today?
22:10:14 <dfflanders> Is Maria on the chanel?
22:10:30 <dfflanders> Not sure she has done Upstream University training for getting IRC going...
22:11:30 <Patifa> Ok... so should I just close this vote and start one about 3 chairs?
22:11:55 <dfflanders> I think we should do the vote, for the sake of following the democratic process, however if docaedo is voted in, then we can always hold another meeting to add a third chair if valid...
22:12:08 <csterret_> #vote Chris
22:12:27 <Patifa> #showvote
22:12:28 <openstack> Chris (1): csterret_
22:12:34 <Patifa> it works
22:12:40 <docaedo> #vote chris
22:12:52 <leong> #vote chris
22:12:53 <Patifa> #vote chris
22:13:03 <docaedo> +1 for dfflanders plan (as always!)
22:13:09 <dfflanders> being a foundation staff i must abstain, as I loves you all.
22:13:55 <Patifa> ok... let's continue on and I'll remind you to continue voting later.. I'll close at 3:55
22:14:04 <calebb> #vote chris
22:14:04 <dfflanders> +1
22:14:15 <Patifa> #topic Barcelona - Time to plan
22:14:26 <Patifa> We only have 4 meetings until the summit and we need to start planning. I wanted to define the agenda items for the upcoming meetings to ensure we cover everything that needs to be planned before the summit.
22:14:27 <leong> i think 2 chairs are sufficient for a working group.. what's the rationale of having 3 chairs...
22:14:29 <dfflanders> aside calebb you going to be in Barcelona?
22:15:14 <dfflanders> leong, discussion at end of meeting during open agenda items?
22:15:32 <dfflanders> (after vote ends)
22:15:34 <docaedo> leong dfflanders agreed, let's discuss at the end if we have time
22:15:38 <leong> sure.. pls move ahead on the agenda..:)
22:15:40 <dfflanders> +1
22:15:48 <Patifa> back to Barcelona: Besides our WG Meeting and the BoF session, is there anything else that needs planning?
22:16:05 <calebb> dfflanders: yes
22:16:09 <dfflanders> I've got some additional social activities
22:16:38 <dfflanders> on the Monday night, during the booth crawl, hoping all App peoples will come hang out at the cloud app labs lounge
22:17:06 <dfflanders> email forthcoming via user-committee mailing list, many of you should have already been forewarned via email :)
22:17:08 <Patifa> Monday is my birthday.. ;) hint hint
22:17:25 <dfflanders> perfect!
22:17:37 <docaedo> Patifa: Monday at the summit?  I'll pack a cake!
22:17:55 <Patifa> docaedo yep!
22:18:14 <vhdiaz> yuju!!!
22:18:15 * dfflanders mmmmmmmm cake
22:18:26 <Patifa> But before cake we should start working on what we're doing there... I propose we use the IRC meetings to collect the topics and the call meetings to work on the details.
22:18:34 <dfflanders> +1
22:18:36 * docaedo ponders bigger suitcase, or hatbox for transatlantic flight with cake...
22:18:46 <docaedo> +1 on using IRC meetings
22:18:56 <docaedo> Is there an existing etherpad for planning as well?
22:18:58 <Patifa> That way we work on the BoF session this week and next.. and the WG meeting the following two weeks
22:19:01 <Patifa> sure!
22:19:16 <Patifa> #link https://etherpad.openstack.org/p/AppEcoSystem_WG_Barcelona_BoF
22:19:19 <dfflanders> +1 etherpad working agenda for both BoF and session.
22:19:45 <dfflanders> Also is there a pre meeting for chairs, i.e. when is everyone arriving, as having a breakfast meeting to finalise agenda is always good practice.
22:20:02 <dfflanders> breakfast meeting the weekend before? Sun or Mon?
22:20:06 <Patifa> great! I'm counting this as part of the WG meeting planning
22:20:14 <dfflanders> copy that
22:20:15 <Patifa> Mon for me
22:20:42 <vhdiaz> I am arriving monday afternoon
22:20:58 <Patifa> lets get started with BoF planning than
22:21:04 <Patifa> #topic Barcelona - BoF session
22:21:15 <Patifa> We’re approved! Wed 26 | 11:25am-12:05pm
22:21:19 <Patifa> #link https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/16211/app-ecosystem-work-group-bof-session
22:21:32 <Patifa> Please plan to attend! Follow the link and add to your agenda
22:21:53 <Patifa> And back to the planning etherpad
22:21:59 <Patifa> #link https://etherpad.openstack.org/p/AppEcoSystem_WG_Barcelona_BoF
22:22:26 <Patifa> On the etherpad we have a link for the prezo we used in Austin
22:22:50 <Patifa> and I pulled the topics and updated the list..
22:24:18 <Patifa> First thing I wanted to know is the format... does a presentation for who ever shows up sound good for everyone?
22:24:39 <vhdiaz> yes
22:24:53 <vhdiaz> mission, vision, things we do, etc
22:24:59 <dfflanders> The aim of the bof is to attract new members?
22:25:11 <Patifa> yep
22:25:26 <dfflanders> yes a pitch is a good idea then
22:25:26 <vhdiaz> we can speak hackathon :)
22:25:50 <dfflanders> though the BoF should include some clear expectations for membership participation
22:26:30 <dfflanders> biggest problem at Summits is having people come along who contribute to the meeting and then don't follow up by attending...
22:26:30 <Patifa> agree dfflanders
22:26:51 <Patifa> this is a topic for the WG meeting too, then
22:27:30 <dfflanders> we have so little time it needs to be made clear that the fishbowl setup is intentional with the most active members being closest to the centre of the room where the chairs are sitting.
22:28:22 <Patifa> at the WG meeting? what fishbowl setting?
22:28:55 <Patifa> are you jumping ahead and talking about the WG meeting?? :)
22:28:57 <docaedo> fishbowl is having chairs arranged in a semi-circle usually around a screen
22:29:14 <docaedo> supposed to encourage conversation, instead of making it a lecture setting
22:29:27 <dfflanders> +1
22:29:36 <vhdiaz> +1
22:29:59 <dfflanders> chairs should drive conversation (agenda), members should jump in where appropriate.
22:30:34 * Patifa confused
22:30:41 <dfflanders> hence pre-meeting by chairs to have a clear agenda (ways forward for next cycle) including objectives and outputs for Boston.
22:30:56 <Patifa> fishbowl for the WG meeting seems good for me
22:31:10 <Patifa> but we were talking BoF...
22:31:12 <dfflanders> https://en.wikipedia.org/wiki/Fishbowl_(conversation)
22:32:03 <dfflanders> duly noted re BoF planning first :)
22:32:41 <dfflanders> BoF = chairs pitching any new members to join, yes?
22:32:45 <Patifa> So.. topics for the BoF session in Barcelona...
22:32:59 <Patifa> dfflanders yep
22:33:53 <Patifa> what topics do we want on the pitch? I guess we can +1 the etherpad
22:33:55 <dfflanders> BoF = High level overview of the WG, its scope, remit and activities... + clear expectations for what kind of commitment is expected of members.
22:34:48 <dfflanders> what are some highlights from what this group has produced/achieved which we could highlight = pragmatics?
22:35:10 <dfflanders> SDKs... Hackthons... usability report...
22:35:36 <dfflanders> trainings...
22:36:01 <dfflanders> overviews and cohesion between different WGs <-- aspirational?
22:37:00 <Patifa> cohesion between WGs might be doable since our BoF is on Wed and the WGs meeting is on Tuesday
22:37:36 * Patifa added all suggestions to etherpad
22:37:44 <Patifa> Anything else?
22:38:46 <Patifa> Any volunteers to work on the presentation for next week?
22:38:58 <Patifa> So we can review it on the call meeting?
22:39:25 <Patifa> (I'd volunteer but I'm living on a recurring Monday for the past few weeks)
22:40:05 <Patifa> going once..
22:40:10 <docaedo> I would volunteer but I want to wait for the election results, so I can opt out if I lose ;)
22:40:25 <docaedo> kidding - I can volunteer
22:40:56 <Patifa> #action docaedo to work on BoF prezo for next week
22:41:07 <docaedo> #action docaedo to take first pass as creating presentation for Barcelon fishbowl session, by next weeks meeting
22:41:25 <docaedo> (hahaha)
22:41:27 <Patifa> there you go.. two actions for you ;)
22:41:37 <vhdiaz> haha
22:41:41 <dfflanders> suggestion: might be good to just use the wiki page on the AppEco to do most of the presenting from? <-- also a chance to clean up prior to proceedings.
22:42:00 <docaedo> +1 to that
22:42:03 <Patifa> +1
22:42:26 <Patifa> Next topic?
22:42:30 <dfflanders> +1
22:42:37 <Patifa> #topic Barcelona - OpenStack Academy - Cloud App Lounge
22:42:54 <Patifa> Flanders were you able to send out the recruiting form for volunteers
22:42:54 <Patifa> Anyone else wants to volunteer for “lab duty”?
22:43:16 <dfflanders> I've started sending out individual emails, two or three per day.
22:43:41 <Patifa> how's the response?
22:43:48 <dfflanders> Though yes, please re making the 'cloud app lab' lounge in the marketplace (expo hall) your home base to hang out and chat with likeminded app dev folk
22:44:02 <docaedo> I will definitely spend some time on lab duty, but I still have to figure out my schedule so don't know where I've got gaps
22:44:19 <dfflanders> it is good people are excited, everyone wants cloud apps, they just don't know what the skills are to get started...
22:45:15 <dfflanders> docaedo, no worries, that is where most people will be at, I just want to make sure n00bs can get help and meet someone from the community where possible #recruitment
22:45:44 <Patifa> Interesting. Anything you want us to help you with.. besides hanging around for my bday party?
22:46:09 <Patifa> (I'm good with having cake everynight)
22:46:13 <dfflanders> Anyone who wants to contribute a lab challenge is most welcome... though more on this via user-committee mailing list today.
22:46:42 <dfflanders> https://github.com/DFFlanders/cloud-app-labs
22:47:11 <dfflanders> Bruno and I are just working on one re basic heat templating with shade.
22:47:24 <Patifa> Great!
22:47:28 <dfflanders> cross datacentre cloud app self healing :)
22:47:36 * dfflanders I digress
22:47:37 <dfflanders> soz
22:47:53 <Patifa> #topic Barcelona - Dev Cheat Sheet - How to attract AppDevs to summit
22:48:02 <Patifa> moving on...
22:48:08 <docaedo> sounds magical though (that cross datacenter self healing cloud app)
22:48:48 <dfflanders> "cloud native" ;-)
22:49:47 <Patifa> dfflanders I talked to Patricia Dugan in Walmart and she wants to help with the SU article
22:49:56 <dfflanders> FTW!
22:50:55 <Patifa> But that is all that I was able to do last week... :(
22:51:03 <dfflanders> I've got an email in draft re 'cloud app social events' for the UC ML to get things going on that front as well.
22:51:34 <dfflanders> I've got an email in draft re 'cloud app social events' for the UC ML to get things going on that front as well.
22:52:12 <dfflanders> The key question for a cheatSheet/newsletter for Cloud App folk is where do they get their news from?
22:52:23 <dfflanders> Reddit, Register, Twitter...?
22:53:25 <dfflanders> If we put this CheatSheet out to try and attract any EU Cloud AppEng during the last couple of weeks build up to the summit, where should that post be syndicated to?
22:54:15 <Patifa> when are you sending the email?
22:54:31 <dfflanders> in addition it will naturally work as a nice way to know which planes the cloud app community will be roaming during on accross the summit's savanahs
22:54:42 <docaedo> What I've heard from all my dev friends is that they're language or platform specific (i.e. python, go, cloud foundry, etc.), I have not been able to turn up an analogous example of a community where it's something like "GCE Devs"
22:54:42 <dfflanders> planes=plains
22:54:44 <dfflanders> doh
22:54:48 <reed> news come from hacker news only :)
22:55:11 <reed> "if it wasn't on HN it wasn't worth it"
22:55:23 <dfflanders> noice
22:55:50 <Patifa> ok... 5 min reminder
22:55:51 <Patifa> #showvote
22:55:52 <openstack> Chris (5): leong, calebb, docaedo, csterret_, Patifa
22:55:59 <reed> that's where hipsters hang out
22:57:13 <Patifa> those who still need/want to vote the options are Chris and Maria.
22:57:13 <dfflanders> #action Flanders and Patricia to push forward conversation re CheatSheet on UC ML
22:57:17 <docaedo> reed: yeah true - would be interesting to see if it got positive traction (it being some announcement around OpenStack folks trying to attract developers)
22:57:48 <reed> ads on reddit work very well too
22:57:56 <dfflanders> +1
22:58:20 <Patifa> We're almost out of time..
22:58:36 <dfflanders> where else do you'll get your news?  chris, craig, vince?
22:58:41 <docaedo> goodness time does fly
22:58:42 <dfflanders> aok
22:58:43 <Patifa> I don't think we have time to move to the next topic
22:58:46 <reed> docaedo, some announcements may not get lots of tractions, but a solid, constant, coordinated push will work in the medium term
22:59:07 <Patifa> #endvote
22:59:07 <openstack> Voted on "Should we vote now?" Results are
22:59:08 <openstack> Chris (5): leong, calebb, docaedo, csterret_, Patifa
22:59:14 <docaedo> yeah we are out of time just when we were hitting an interesting subject for debate!
22:59:23 <dfflanders> always the case ;-)
22:59:30 * docaedo wins!
22:59:31 <Patifa> I know.. it's always the case
22:59:32 <reed> email works too :)
22:59:37 <Patifa> yay!
22:59:44 <dfflanders> congratulations docaedo
22:59:46 <dfflanders> !
22:59:48 <docaedo> woooo!
22:59:57 <leong> congrad docaeco!
23:00:03 <docaedo> as my first order of official business, I will suggest we end this meeting
23:00:09 <leong> +1
23:00:10 <Patifa> #endmeeting