22:04:14 <craigs> #startmeeting app_ecosystem_wg
22:04:15 <openstack> Meeting started Mon Aug 29 22:04:14 2016 UTC and is due to finish in 60 minutes.  The chair is craigs. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:04:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:04:18 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:04:29 <craigs> Agenda can be found on our etherpad
22:04:38 <Patifa> https://etherpad.openstack.org/p/2016_Aug_29_App_Ecosystem_Workgroup
22:04:50 <craigs> #chair Patifa
22:04:51 <openstack> Current chairs: Patifa craigs
22:04:53 <shamail> o/
22:04:55 <Patifa> #link Agenda https://etherpad.openstack.org/p/2016_Aug_29_App_Ecosystem_Workgroup
22:05:40 <craigs> #topic rollcall
22:05:47 <craigs> Craig S
22:05:55 <CarolBarrett> Here!
22:05:58 <shamail> here (only for the first 15 minutes unfortunately)
22:06:00 <Patifa> here!
22:06:31 <docaedo> here as well!
22:06:39 <craigs> OK, lets get started then, shamail have any topics you need to get to before you go?
22:06:44 <vhdiaz> zuuuup!
22:06:59 <shamail> Thanks, just a quick update on the ISV sub-group thread.
22:07:18 <craigs> OK, #topic ISV sub-group update
22:07:19 <dfflanders> Flanders here :)
22:07:27 <craigs> #topic ISV sub-group update
22:08:04 <shamail> I had an action item to send an email to the user committee about bringing the ISV team under App Ecosystem.  I did not do it last week due to the OpenStack events in NYC. I will send an email this week so we can get community feedback before asking for the topic in the next team meeting.
22:08:14 <shamail> I apologize for the delay.
22:08:30 <craigs> No problem
22:08:55 <craigs> #action shamail Send email to user comittee about bringing the ISV team under App Ecosystem
22:09:04 <craigs> #topic Next weeks meeting
22:09:06 <shamail> Thanks craigs, once we get feedback, I will contact Patifa and yourself to add the topic to an upcoming meeting.
22:09:17 <craigs> Next weeks meeting is labor day here in the US
22:09:36 <craigs> We have a doodle poll where you can choose other date/times that may work
22:09:43 <craigs> #link http://doodle.com/poll/vszm9zk3z56ayef9
22:10:16 <shamail> link please?
22:10:22 <shamail> :D
22:10:47 <craigs> Please fill out your options and we will send out an updated meeting date/time later in the week
22:11:03 <craigs> #topic Guadalajara App Hackathon
22:11:38 <dfflanders> many of us will be at the hackathon at that time, so apologies if the meeting does get rescheduled.
22:11:53 <craigs> Wow it's next week
22:11:57 <craigs> lost track of time
22:12:12 <Patifa> Caribbean does that to ppl
22:12:20 <craigs> LOL yep
22:12:21 <vhdiaz> \o/
22:12:24 * dfflanders so jelly
22:12:28 <shamail> Lol
22:12:41 <craigs> Any updates Victor or Marcela?
22:13:01 <dfflanders> I suspect they are busy as we speak getting ready ;-)
22:13:04 <Patifa> Here's the latest rev on the attendees survey: https://etherpad.openstack.org/p/GDCHackathon-research-survey
22:13:41 <Patifa> dfflanders I need the actual options for question 5
22:14:04 <Patifa> from the original survey used in the Taiwan hackathon?
22:14:18 * dfflanders looking at now...
22:15:19 <Patifa> great.. I also added a question about the org size. although I think most ppl are going to be independent workers - aka students
22:15:42 <Patifa> line 28
22:17:06 <vhdiaz> status: green
22:17:17 <vhdiaz> still pending to close the agenda and some details
22:17:26 <vhdiaz> but the event looks great so far
22:17:39 <craigs> excellent, anything else for the topic?
22:17:57 <Patifa> Also on line 61 - do we want to point to Piet's survey? I can take the action of asking him.
22:18:18 <vhdiaz> When are you arriving @flanders?
22:18:45 <craigs> I'm OK with pointing to Piets survey
22:18:57 <dfflanders> Patifa, yes closing the comms loop between you, Piet and Michael Jenkins a la #CloudAppHack-WG would be good, also timings for when the survey is going to take place is important via vicdiaz
22:19:01 <Patifa> The other issue is the mentors focus group. HEre's the last version of the script: #link https://etherpad.openstack.org/p/GDCHackathon-research-focusgroup-mentors
22:19:16 <Patifa> dfflanders we have a meeting scheduled this week :D
22:19:22 * docaedo has to step out, but promises to read backscroll and hopes all the action items don't get assigned to him while away :p
22:19:24 <dfflanders> FTW :)
22:19:28 <vhdiaz> pls invite me
22:19:32 <Patifa> sure!
22:19:58 <Patifa> #action Patifa to invite vhdiaz to Hackathon research meeting
22:20:10 <dfflanders> So there are three "information collection" points which will take place with participants?  Survey, panel and another survey?
22:20:11 <Patifa> For the mentors focus groups I
22:20:27 <Patifa> I'm worried about recruiting... and the moderation
22:20:41 <Patifa> vhdiaz is Danny confirmed?
22:20:45 <Patifa> to moderate?
22:22:00 <craigs> Victor?
22:22:49 <Patifa> I can take it offline with him.
22:23:04 <craigs> #action Patifa to followup with Victor and check on Danny availability
22:23:14 <craigs> #topic Barcelona
22:23:55 <craigs> Do we have the WG session or BoF confirmed yet?
22:24:10 <Patifa> https://etherpad.openstack.org/p/App_Ecosystem_Workgroup-Barcelona_sessions
22:24:32 <Patifa> #link https://etherpad.openstack.org/p/App_Ecosystem_Workgroup-Barcelona_sessions
22:24:34 <CarolBarrett> I haven't seen a call for these from the Foundation team yet - expect it any time now
22:25:33 <craigs> OK, good we can still try and get these scheduled then.
22:25:46 <dfflanders> eek not good that no application catalogue sessions are going ahead?
22:26:35 <dfflanders> we should get an action for docaedo to chat with the foundation about this as not having people aware of the app catalogue is a problem :/
22:27:14 <Patifa> I agree. how do we go about that?
22:28:03 <dfflanders> I'd post something on the user-committee mailing list in the first instance and perhaps the dev mailing list as well to see what people want the future of the app catalogue to be
22:28:43 <craigs> #action docaedo See Flanders messages about the App Catalog and the fact the talks did not get approved
22:28:52 <dfflanders> I know Chris is moving some of the features over to Glance project, so maybe it is being covered in one of those presentations or design summits?
22:30:01 <dfflanders> Aslo re vicdiaz and marcella presentation on the hackathon, I believe we can host them in the Foundation staff lounge so people can come and learn about how to apply to run a hackathon... more anon.
22:30:27 <dfflanders> I'm getting this setup as more hackathons cometh!
22:30:30 <craigs> Will there be a meeting for the hackathon WG?
22:31:10 <dfflanders> question for Michael Jenkins and Gonzalo as co-chairs of that WG.
22:31:36 <craigs> Michaels paper also did not get approved so he may not be attending
22:31:49 <Patifa> :(
22:32:08 <craigs> Anybody else attending, update your status on the etherpad so we can get an idea of how many App Eco people will be there
22:32:50 <craigs> Also what about the OpenStack Academy AppDev Lounge bullet?
22:33:41 <Patifa> dfflanders
22:34:07 <craigs> Are we going to do anything there?  If so we should setup a meeting to discuss it and get a better idea of what we are committing to
22:34:23 <dfflanders> Yes, details of the AppDev lounge / training space and self-paced labs area is still being confirmed.
22:34:35 <vhdiaz> pls let us know!
22:34:44 <dfflanders> There are shuffling space still, as soon as I know you will know.
22:34:52 <vhdiaz> excellent!
22:34:53 <Patifa> ok. Let me know when to bring this up on the agenda
22:35:02 <dfflanders> keep it weekly ;-)
22:35:07 <dfflanders> keeps me vigilant :)
22:35:13 <Patifa> deal
22:35:25 <vhdiaz> haha
22:35:47 <craigs> What about the App Dev Cheat Sheet
22:36:06 <craigs> I'm not sure what that is about (you would think I would have read the notes on a beach but I didn't)
22:36:53 <Patifa> The doodle is not getting a lot of traction - to define the outline
22:38:05 <craigs> Is this something we plan on delivering at Barcelona, and what format?
22:38:47 <Patifa> I'm the only reply so far. I'll keep working on an outline and sent it to the list to see if we get better responses
22:39:00 <craigs> If anybody wants to attend and help define it, please sign up on the doodle for a time you can meet
22:39:14 <craigs> #link https://etherpad.openstack.org/p/appdev-summit-cheat-sheet-barcelona
22:39:32 <craigs> #link http://doodle.com/poll/69uzxy2rsh2ryvh9
22:39:41 <dfflanders> I would think it could be an extended (special) agenda item for one of these meetings, as all of us need to know what is going on accross the summit re appdev
22:39:57 <dfflanders> irc and/or voice. /2p
22:40:45 <Patifa> sure
22:41:47 <craigs> The only other item under Barcelona is the pre-meeting but I think we can delay that until we find out who all is coming and when
22:41:59 <craigs> #topic AppDev User Study
22:42:19 <Patifa> uxdanielle any updates?
22:42:39 <dfflanders> when is the last one of these meetings before the summit?  Perhaps we could utilise it for some pre-planning?
22:43:13 <Patifa> October 17
22:43:28 <dfflanders> have an extended voice meeting to go through proposed agenda/workpackages, etc. - might be worth having this meeting with ISV and CloudAppHack WGs to try and circle the wagons?
22:43:31 <Patifa> Shoul we start sooner?
22:43:32 <dfflanders> ^^thinking out loud
22:43:47 <craigs> Sounds good, maybe 2 weeks before just in case
22:43:52 <Patifa> Yep.
22:43:55 <dfflanders> Perhaps circulate on the user-committee mailing list for discussion\
22:43:56 <dfflanders> ?
22:44:10 <Patifa> sounds like a plan
22:44:25 <dfflanders> I think we need to be more vocal on the mailing list and it will attract people back into the meetings.
22:44:54 <dfflanders> I've got a couple of emails in draft to the mailing list on this topic for all WGs so stay tuned ;-)
22:45:26 <craigs> Anything else for Barcelona, or move on to UX study
22:45:44 <dfflanders> timecheck: t-minus 15min
22:46:12 <Patifa> #action Patifa to schedule summit pre-planning - engage with ISV and CloudAppHack WG
22:46:28 <craigs> Last I heard on the AppDev study is they are still looking for one more participant
22:46:56 <Patifa> I have not heard from them in a while.
22:47:00 <craigs> #topic Firstapp
22:47:50 <craigs> I have not made any further progress on Heat firstapp, I am still mostly done, just have autoscaling to go, and then need to figure out how to publish it since a good part of the hardcoded body text in firstapp is SDK specific
22:48:35 <Patifa> is how to publish it is your real issue at the moment?
22:48:49 <Patifa> or rather, biggest issue
22:49:16 <dfflanders> have you had a chance to what other automation/orchestration dev think of your heat lesson?  Esp Ansible, Puppet, Salt people <-- might be good feedback and encourage them to do similar?
22:49:18 <craigs> It's a big issue, I haven't asked the docs group to see if they have any suggestions yet since I was still writing it, but I will do that this week
22:49:52 <craigs> No I haven't, if you have any contacts let me know
22:50:28 <Patifa> dfflanders any suggestions about where/how publish it?
22:50:29 <dfflanders> One of the fundamental questions I have (to be discussed anon) is if we don't need another usability study around AppDev and which orchestration/configuration language they would prefer...heat, ansible, salt, k8s, etc.
22:50:57 <dfflanders> Patifa, standard git commit approval process.
22:51:07 <craigs> I kind of agree, but we often get big pushback when we are looking at non-OpenStack components
22:51:47 <dfflanders> I hear you.
22:52:47 <craigs> The FirstApp doc has been structured differently, most of the text is hardcoded, and only the code blocks change between SDK's.  Heat really requires me to edit the hardcoded text in addition to code blocks. I also need to add an additional section to the firstapp doc
22:53:08 <craigs> So the changes are pretty significant
22:54:10 <Patifa> I agree we should get data arounf AppDev preferred orchestation/lenguage
22:54:41 <craigs> #action craigs Contact Docs group and find out how to publish the heat firstapp with all of the changes necessary
22:55:14 <dfflanders> timehcheck: t-minus 5min.
22:55:26 <Patifa> Might shed a light of what we want to focus on in the future.. and support the decision to look beyond openstack components
22:55:30 <craigs> Any Opens from anybody?
22:55:42 <craigs> #topic Opens
22:56:03 <dfflanders> I'll be incognito for a fortnight in build up to hackathon.
22:56:51 <Patifa> ok.
22:57:06 <craigs> If nothing else we can close a few minutes early
22:57:28 <craigs> Thanks all for attending
22:57:32 <craigs> #endmeeting