20:00:02 <krot_vaca_jul19> #startmeeting app_ecosystem_wg
20:00:03 <openstack> Meeting started Wed Jul  6 20:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is krot_vaca_jul19. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:08 <openstack> The meeting name has been set to 'app_ecosystem_wg'
20:00:15 <krot_vaca_jul19> Hello everyone, who made it?
20:00:21 <mbonell> hi :)
20:00:23 <uxdanielle> Hi there!
20:00:34 <krot_vaca_jul19> Woo, peoples!
20:00:39 <rockyg> o/
20:00:44 <krot_vaca_jul19> Many greetings from... uh... "Sunny" scotland.
20:00:57 <krot_vaca_jul19> (For very, very broad definitions of "Sunny")
20:01:08 <krot_vaca_jul19> Agenda:
20:01:10 <krot_vaca_jul19> #link https://etherpad.openstack.org/p/2016_July_6_App_Ecosystem_Workgroup
20:01:29 <krot_vaca_jul19> #topic Logistics
20:01:36 <craigs> HI
20:01:41 <krot_vaca_jul19> Looks like we're successfully holding this meeting, so item one is done.
20:01:55 <docaedo> o/
20:02:01 <krot_vaca_jul19> Does anyone konw if notmars is planning on joining us?
20:02:29 <calebb> o/
20:02:35 <Patifa> o/
20:02:36 <mbonell> not sure
20:03:03 <krot_vaca_jul19> Alright, we'll ask him later.
20:03:44 <krot_vaca_jul19> It looks like the "What is an app" discussion has died down, does anyone have any last words they'd like to get in before Patifa summarizes everything and comes up with a final draft?
20:04:37 <Patifa> flanders last email kinda summarizes the conversation. right?
20:04:43 <krot_vaca_jul19> It really does
20:06:04 <Patifa> lets just give it another week to see if anyone adds to it.
20:06:29 <krot_vaca_jul19> Patifa: Works for me. Frankly, I'd be happy to stick with flanders' summary.
20:06:41 <Patifa> Me too.. ;)
20:07:01 <mbonell> where will be it published? in our wiki?
20:07:08 <mbonell> What is an app - discussion
20:07:21 <krot_vaca_jul19> However, I'm not really ok pushing this out another week. The topic needs to be settled so we don't get distracted.
20:08:22 <krot_vaca_jul19> However, we haven't really clearly communicated what the deadlines are on that topic. So how about someone (volunteer?) sends out an email saying: "We're closing this discussion in a week, drafting a final, and submitting that for approval".
20:08:51 <Patifa> o/
20:08:54 <krot_vaca_jul19> mbonell: YEs, I expect it'll be on the wiki.
20:09:05 <mbonell> ok
20:09:18 <krot_vaca_jul19> We have a volunteer! Any major disagreements on this before we move on?
20:09:50 <krot_vaca_jul19> #action Patifa Send out email clearly communicating deadline and closure of "What is an app" discussion, and followup process for approval.
20:10:34 <krot_vaca_jul19> Ok, moving on.
20:10:46 <krot_vaca_jul19> #topic FirstApp: jclouds
20:10:48 <Patifa> Deadlin monday? Before the meeting/
20:10:50 <Patifa> ?
20:11:16 <craigs> I don't have an update on jclouds or .NET
20:11:21 <krot_vaca_jul19> Patifa: I think so- use the meeting to introduce it to the group, then send us with homework to review it.
20:11:36 <krot_vaca_jul19> craigs: Got it. Martin's going to be joining the converstaion next week, yes?
20:11:45 <craigs> I did hear on php-opencloud and Jamie says he cannot support it
20:11:54 <craigs> Yes Martin said that he would start attending
20:12:08 <krot_vaca_jul19> craigs: That's good to hear.
20:12:12 <krot_vaca_jul19> (On php
20:13:05 <krot_vaca_jul19> Alright, let's see if we can get an update from him next week.
20:13:16 <krot_vaca_jul19> #topic FirstApp: Shade
20:13:36 <krot_vaca_jul19> mbonell: Looks like you're working on the scaling-out portion now?
20:13:46 <mbonell> yep, scaling out section is WIP
20:14:17 <mbonell> my goal is to complete shade by the end of july
20:14:23 <krot_vaca_jul19> WOOHOO!
20:14:26 * krot_vaca_jul19 does a little dance
20:14:30 <mbonell> and then it will be ready for the go
20:14:35 <mbonell> no more drafts :p
20:14:48 <krot_vaca_jul19> :D
20:14:53 <krot_vaca_jul19> Excellent.
20:14:53 <docaedo> mbonell: that's great!
20:14:55 <calebb> what is left to be done for shade?
20:15:06 <mbonell> calebb: just validation, testing
20:15:15 <mbonell> minior bugs
20:16:01 <calebb> ahhh, ok, I saw you had a issue on shade's storyboard about the object metadata thing, that's fixed on master, but hasnt been in a shade release yet
20:16:07 <mbonell> some TODOs
20:16:22 <mbonell> yes, I was me :)
20:16:57 <krot_vaca_jul19> Sounds like you two have it well in hand.
20:17:04 <mbonell> ;)
20:17:13 <krot_vaca_jul19> ANything else before we move on?
20:17:14 <Patifa> \o/
20:17:22 <mbonell> nop, let's move on
20:17:23 <krot_vaca_jul19> #topic FirstApp: Fog
20:17:27 <krot_vaca_jul19> Sean? You here?
20:18:06 * krot_vaca_jul19 is guessing not.
20:18:27 <krot_vaca_jul19> Does anyone have an update form Sean?
20:18:36 <mbonell> nop
20:18:52 <craigs> nope
20:19:07 <krot_vaca_jul19> Ok.
20:19:24 <krot_vaca_jul19> #topic FirstApp: JavaScript
20:19:39 <krot_vaca_jul19> No update from me, mostly because I've been on vacation and wasn't able to attend the meeting this morning.
20:19:47 <krot_vaca_jul19> There's patches landing, I just have no idea what they are :)
20:20:33 <krot_vaca_jul19> Any questions?
20:21:01 <krot_vaca_jul19> Ok, moving on.
20:21:16 <krot_vaca_jul19> #topic FirstApp: PHP
20:21:40 <krot_vaca_jul19> Jamie has said that he can't support it. Does anyone else have th etime to do this?
20:22:24 * krot_vaca_jul19 listens to crickets.
20:22:29 <mbonell> hahaha
20:22:35 <krot_vaca_jul19> Ok, this brings up an interesting question.
20:22:54 <krot_vaca_jul19> At what point do we abandon something, and what does abandoning an effort look like?
20:23:18 <Patifa> that is an interesting question.
20:23:37 <craigs> Yeah don't know how
20:24:02 <docaedo> In this case I would say it's pretty clear there's little to no interest in continuing, but the effort would be "on hold" until a PHP developer steps forward to help
20:24:16 <craigs> Just update the spreadsheet as on hold
20:24:22 <krot_vaca_jul19> On hold? Or shall we remove it entirely?
20:25:40 <docaedo> is there a draft of the document in play anywhere?
20:26:11 <krot_vaca_jul19> #link https://review.openstack.org/#/c/224987/
20:26:18 <rockyg> I think I'd put in "needs a volunteer" rather than on hold
20:26:38 <docaedo> rockyg: that's better :)
20:27:28 <Patifa> paused - need a volunteer
20:27:37 <mbonell> yes
20:27:43 <craigs> https://bugs.launchpad.net/openstack-manuals/+bug/1449332
20:27:43 <openstack> Launchpad bug 1449332 in openstack-manuals "FirstApp: Add php-opencloud support" [Medium,Confirmed]
20:27:44 <Patifa> because all the other need volunteers..
20:28:20 <Patifa> even the ones that are not on hold
20:28:33 <krot_vaca_jul19> Righto, that works for me.
20:28:45 <krot_vaca_jul19> Everyone ok with "Paused - need a volunteer"?
20:28:53 <mbonell> +2
20:29:11 <rockyg> ++
20:29:13 <docaedo> maybe the foundation can sponsor an "doc bounty" and we offer some lovely gift to encourage more volunteers?
20:29:25 <krot_vaca_jul19> I like bounties :)
20:29:25 <mbonell> both links are in the spreadsheet?
20:29:58 <krot_vaca_jul19> I don't see the bug link in the spreadsheet
20:30:03 <krot_vaca_jul19> #link https://docs.google.com/spreadsheets/d/18Zj2JU0jR4hy8y1HxFl30gTEGeqgBjc6hqv0ZAByVYo/edit#gid=0
20:30:28 <craigs> yep should add it
20:30:29 <krot_vaca_jul19> Now it is.
20:30:39 <krot_vaca_jul19> Ok, moving on
20:30:44 <krot_vaca_jul19> #topic FirstApp: IOpenStack
20:30:49 <krot_vaca_jul19> notmars is not here!
20:31:27 <krot_vaca_jul19> Moving on.
20:31:39 <krot_vaca_jul19> #topic App Hackathon
20:32:31 <vhdiaz> o/
20:32:51 <vhdiaz> We have addressed the training schedule for October
20:33:05 <mbonell> Aug
20:33:12 <krot_vaca_jul19> Woot!
20:33:27 <vhdiaz> :P thinking ahead in the summit ...
20:33:27 <vhdiaz> Aug*
20:33:51 <vhdiaz> there are pending items to define with the foundation to have budget support for couple of the trainers...
20:34:09 <vhdiaz> Open: I need to consult @notmars about the cloud for the event
20:34:53 <vhdiaz> at this time We have not received confirmation from OSIC if they will sponsor the cloud...
20:35:03 <vhdiaz> so I am now chcking public cloud options...
20:35:11 <vhdiaz> We may need to pay for that :(
20:35:41 <krot_vaca_jul19> vhdiaz: Is there no free-developer-instances program out there we can piggyback on?
20:36:12 <vhdiaz> I don't think a free instance can support the main event
20:36:19 <krot_vaca_jul19> vhdiaz: Alternatively, http://trystack.org/
20:36:20 <vhdiaz> We are looking for free instances for the training...
20:36:36 <craigs> trystack is very limited in what it will give you for resources
20:36:47 <rockyg> trystack?
20:36:47 <vhdiaz> that is my point..
20:36:52 <mbonell> trystack is not an option
20:37:12 <vhdiaz> We will have 200 participants... my assumption is that We need a more robust solution
20:37:31 <rockyg> we should try for att.  They claim they have a solution;-)
20:38:11 <krot_vaca_jul19> This seems like a pretty big problem that needs to be addressed quickly.
20:38:55 <krot_vaca_jul19> I know I cannot rely on HPE for resources at this time, because politics.
20:38:56 <rockyg> yeah, but it would be great press for any Public Cloud Provider to host it....
20:39:13 <krot_vaca_jul19> rockyg: Does huawei have anything they can offer?
20:39:16 <vhdiaz> It will be a very public event
20:39:29 <rockyg> Our cloud is in China :(
20:39:36 <reed> vhdiaz, the question is 'how much public will it be'?
20:39:40 <rockyg> I'll check around, though.
20:39:46 <krot_vaca_jul19> rockyg: No cloud in that new research office in Belleveu?
20:39:50 <krot_vaca_jul19> *bellevue
20:40:03 <vhdiaz> This falls into the 'in kind cloud sponsorship" to public cloud providers...  who can bring many more of their customer clients... to these public clouds
20:40:17 <rockyg> Not yet.  Well, so far as I know.  I haven't even gotten 5 machines for a cloud here in Santa Clara R&D
20:40:34 <krot_vaca_jul19> vhdiaz: You mentioned reaching out to notmars and Internap?
20:40:48 <vhdiaz> yes
20:40:50 <rockyg> I *will* send an email to those who supposedly can decide, though.
20:40:56 <vhdiaz> OSIC and Internap
20:41:00 <krot_vaca_jul19> rockyg: Thank you! :D
20:41:03 <rockyg> Location is Guadalajara, right
20:41:08 <vhdiaz> was ideal, in order to bring 'multi-cloud' experience
20:41:10 <rockyg> ?
20:41:10 <krot_vaca_jul19> This really seems like it's what OSIC was made for.
20:41:13 <vhdiaz> yes
20:41:18 <mbonell> haha
20:41:39 <reed> vhdiaz, what's the communication plan of the event? is there a way it can be made quite international?
20:41:41 <rockyg> I'd ask what the connectivity is like to China, but......ahem
20:41:49 <vhdiaz> :s
20:42:09 <reed> what's OSIC?
20:42:19 <vhdiaz> the event is going to be in a big university
20:42:25 <krot_vaca_jul19> #link https://osic.org/
20:42:34 <vhdiaz> I cannot answer the question.. but We can test ahead
20:42:49 <vhdiaz> Open Stack Innovation Center
20:43:02 <rockyg> There is actually a publick cloud provider in Queretaro, MX
20:43:44 <docaedo> I thought OSIC was about testing deployments at scale, so users of OSIC just get dedicated metal and have to deploy their own OpenStack cloud on the nodes they get?
20:43:49 <krot_vaca_jul19> reed: Is DreamCompute an option?
20:43:53 <vhdiaz> that is exactly right,  that will be the next step <- contacing local providers... ask them if they want to participate, or pay them..
20:44:00 <krot_vaca_jul19> docaedo: There's an optino to have them install openstack for you?
20:44:23 <krot_vaca_jul19> 15 minute warning
20:44:23 <reed> krot_vaca_jul19, I am so swamped right now with things to do that I'm not sure it's worth the investment for me
20:44:29 * reed practice shamless honesty here
20:44:33 <krot_vaca_jul19> reed: Understood.
20:44:35 <docaedo> krot_vaca_jul19: oh nice! I did not know that (though some folks are coming to the OpenStack PDX meetup in a few weeks to tell us EVERYTHING about OSIC)
20:44:48 <krot_vaca_jul19> reed: Is there someone else at DreamHost that we can pester?
20:45:08 <krot_vaca_jul19> docaedo: Soooooo.... what you're saying is that you're oging to talk to OSIC people in PDX in a few weeks on vhdiaz's behalf? :D
20:45:22 <krot_vaca_jul19> reed: (Trying every angle ;) )
20:45:28 <vhdiaz> :p
20:45:45 <vhdiaz> That helps...
20:45:51 <rockyg> Also, Internap might be a good one to hit up.....
20:45:51 <docaedo> hahaha I can send an email even sooner than that
20:45:56 <vhdiaz> I am speaking to a few folks as well
20:46:06 <vhdiaz> Internap is key
20:46:17 <vhdiaz> that is why I need to speak to notmars
20:46:18 <krot_vaca_jul19> Ok then. vhdiaz- you've got plenty of contacts via this group already that you can take advantage of if Internap doesn't work out.
20:46:20 <reed> krot_vaca_jul19, I am the best person here, i can make the decision but the problem is that I am going to be also the one that needs to extract value from the effort :)
20:46:36 <reed> and if I don't have time to do the latter (get the value) the former makes no sense
20:46:58 <rockyg> so, my AI is to send an email after I get off this meeting.
20:47:24 <vhdiaz> thanks
20:47:34 <krot_vaca_jul19> rockyg: Thanks! Keep vhdiaz in the loop.
20:47:45 <rockyg> Will do.
20:48:17 <krot_vaca_jul19> Moving on.
20:48:29 <krot_vaca_jul19> #topic Barcelona
20:48:39 <rockyg> expected number of hackers - 200.  How many vm's of what size expected?
20:49:00 <krot_vaca_jul19> So, just a quick summary of last week: Flanders wrote up a big proposal to the foundation right before last week's meeting, and we as yet have no update on that.
20:49:17 <krot_vaca_jul19> He's also said that anything on a training track that he organizes is very likely not going ot be bound by the July 15th deadline, so we can relax on that.
20:49:30 <krot_vaca_jul19> I'll keep bringing this topic up in the agenda so we can keep abreast of what's going on.
20:50:09 <krot_vaca_jul19> Any questions before we move on?
20:50:11 <krot_vaca_jul19> 10 minute warning
20:50:40 <rockyg> I think we will again need to line up the cloud providers sooner rather than later for that
20:51:22 <krot_vaca_jul19> rockyg: True, but I expect that'll be a bit easier seeing as it's attached to the summit.
20:51:30 <krot_vaca_jul19> Also, we can make flanders do that :)
20:51:41 <krot_vaca_jul19> #topic Hosted IRC: The Lounge
20:51:49 <rockyg> ++
20:52:00 <docaedo> Hi!
20:52:16 <krot_vaca_jul19> Hi docaedo!
20:52:20 <docaedo> not much progress this last week - the next action is for me to try to write the auth component
20:52:22 * krot_vaca_jul19 provided docaedo with a summary of the auth things that we need to support.
20:52:47 <docaedo> I did dig in some, and saw the auth flow for thelounge based on an LDAP auth piece that's merging soon
20:53:10 <docaedo> it's not super complicated but I've never written anything in JS ;)
20:53:20 <docaedo> on action I have though:
20:53:41 <docaedo> #action Aedo to update "hosted IRC spec" to indicate authentication will be against openstack ID, with that code yet to be written
20:54:05 <krot_vaca_jul19> Excellent, thanks for the update. Any questions?
20:54:14 <docaedo> no, what you shared was useful, thanks
20:54:35 <krot_vaca_jul19> Alright!
20:54:36 <krot_vaca_jul19> #topic Open Discussion
20:54:39 <krot_vaca_jul19> uxdanielle needs note takers!
20:54:52 <rockyg> docaedo, you might check with the refstack folks.  They wrote a server that validates with OSID
20:55:01 <rockyg> Might be js
20:55:05 <uxdanielle> Yes! Interviews are happening (maybe as soon as tomorrow) and I just found out I'm not allowed to record the sessions ;)
20:55:18 <rockyg> ouch!
20:55:26 <docaedo> rockyg: I will, I know some of those fine people as we get our paystubs from the same person ;)
20:55:34 <docaedo> rockyg: thanks for the pointer
20:55:58 <mbonell> qq, are we going to have a BoF session for Barcelona?
20:56:01 <rockyg> np!
20:56:25 <rockyg> We should
20:56:31 <krot_vaca_jul19> mbonell: Let's! Do we need to submit a proposal?
20:56:36 <mbonell> yep
20:56:45 <krot_vaca_jul19> uxdanielle: You can't record them?
20:56:52 <Patifa> nope
20:57:05 <uxdanielle> Nope, would need consent, and that's complicated :P
20:57:13 <krot_vaca_jul19> Oh. Hrm.
20:57:17 <mbonell> :o
20:57:31 <krot_vaca_jul19> It always gest annoyting when the lawyers get involved.
20:57:31 <mbonell> patifa: for
20:57:33 <uxdanielle> So anyone is welcome to join and write down what is said/what they think is important. I believe Patricia will collect email addresses and I'll send any interested parties the meeting invite as they are scheduled (5 sessions)
20:57:39 <Patifa> so we need volunteers to take notes on the ehter pad
20:57:52 <krot_vaca_jul19> uxdanielle, Patifa: I am interested, however I am also time constrained.
20:58:17 <krot_vaca_jul19> mbonell: When does that proposal need to be submitted, by July 15th?
20:58:41 <Patifa> volunteers will have the chance to ask questions too, right uxdanielle
20:58:52 <uxdanielle> That is correct!
20:59:07 <Patifa> and/or add comments to the notes.
20:59:35 <krot_vaca_jul19> Ok, we're out of time. Outstanding discussion needs to go to the list.
20:59:36 <Patifa> all that is required is that who ever listens to the interview helps take notes
20:59:47 <krot_vaca_jul19> Patifa: Definitely send me an invite then.
20:59:50 <rockyg> for BoF, 7/15  But, it doesn
20:59:52 <rockyg> 't
20:59:57 <docaedo> (times up)
20:59:59 <krot_vaca_jul19> Thanks everyone!
20:59:59 <Patifa> ok
21:00:03 <rockyg> take much to write up the abstract for a BoF
21:00:04 <krot_vaca_jul19> #endmeeting