22:15:33 <craigs> #startmeeting App_ecosystem_wg
22:15:34 <openstack> Meeting started Mon Jun  6 22:15:33 2016 UTC and is due to finish in 60 minutes.  The chair is craigs. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:15:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:15:37 <openstack> The meeting name has been set to 'app_ecosystem_wg'
22:15:56 <leong> cool!
22:16:09 <krotscheck> Any questions?
22:16:17 <leong> craigs rollcall :-)
22:16:47 <krotscheck> o/
22:16:57 <craigs> #topic rollcall
22:17:04 <leong> 0/ :)
22:17:20 <craigs> craig o/
22:17:58 <craigs> who else is on for the App Ecosystem meeting?
22:18:57 <krotscheck> Just start tagging people as we go through topics, it'll get their attention.
22:19:18 <leong> yup
22:19:23 <leong> move on to next topic
22:20:06 <craigs> #topic First App Status
22:20:28 <craigs> Marcela did you get a chance to try the changes to the Shade version of First App
22:20:53 <mbonell> I'm still reviewing Caleb's path
22:20:56 <mbonell> patch
22:21:16 <mbonell> https://review.openstack.org/#/c/320709/
22:21:44 <craigs> OK, I am waiting to hear back from Martin Paulo on the jclouds version he said he would have time last week to work on it
22:22:32 <craigs> Isn't the fog one done?  Marcela were you going to do some testing on that one too?
22:22:44 <mbonell> for Fog I don't have updates from Sean
22:23:01 <mbonell> He's working on complete it
22:23:20 <mbonell> once he send a patch I'll review and test it
22:23:28 <craigs> OK
22:23:48 <craigs> Those are the ones that we have some commitment to complete
22:24:01 * krotscheck will look at the JS pieces.
22:24:08 <craigs> Anybody have anything else for FirstApp?
22:24:14 * docaedo waves hi just before hopping on an airplane :)
22:24:16 <leong> craigs, try to use #info #agree #action to keep track of decision
22:24:33 <craigs> I don't know what the state of the JS one is, let us know
22:24:33 <mbonell> krotscheck can help with JS :p
22:24:36 <krotscheck> I'll reach out to kenperkins at rackspace, he may be interested in buliding out the pkgcloud firstapp.
22:24:49 <krotscheck> (FYI: he's the person who started pkgcloud)
22:25:00 <craigs> ok
22:25:51 <craigs> #action krotscheck Contact Ken Perkins and see if he would be able to help build out the pkgcloud firstapp
22:26:27 <craigs> #topic Update on Hackathon Status
22:27:14 <craigs> Any update on the Hackathon Marcela?
22:27:33 <vhdiaz> that is me, Team is meeting reguarly on tuesdays, our focus is sponsorship recruitment and marketing campaign
22:28:24 <craigs> anything else for the hackathon?
22:28:35 <vhdiaz> krotscheck: do you think hpe in mexico/guadalajara might be interested in sponsorship opportunities ?
22:29:07 <mbonell> or cloud training/mentorship?
22:29:11 <krotscheck> vhdiaz: I'll ask, though it might take a bit while I dig through the green tape to figure out who's the correct contact person.
22:30:00 <vhdiaz> #action krotscheck will double check if HPE might be interested in sponsoring Guadalajara's hackathon
22:30:08 <vhdiaz> thanks!, thas is all
22:30:13 <craigs> OK
22:30:24 <krotscheck> vhdiaz: Fair warning, that's towards the end of our fiscal year, so all those moneys may already have been allocated.
22:30:30 <craigs> #topic Extend openstack app discussion
22:31:02 <craigs> This one still needs to be done, I will make another action item for myself
22:31:30 <craigs> #action craigs Need to expand the what is an openstack app question out to the mail lists
22:32:05 <craigs> #topic Brainstorm what training we are going to do for Barcelona Summit
22:32:27 <craigs> Victor do you know what the plans are for training in Barcelona?
22:32:34 <craigs> Are we doing a FirstApp session?
22:32:47 <craigs> or do you know if Bill is working on something?
22:33:05 <mbonell> we can do API/SDK training
22:33:17 <mbonell> based on challenges
22:33:42 <leong> i suppose flander also planning for the dojo training
22:34:03 <craigs> Yeah we need to ask him what's up, we haven't heard from him for a while
22:34:06 <vhdiaz> I will double check one more time, at this time I will say We own the training for Barcelona.. Bill will not participate one more time
22:34:20 <krotscheck> Good to know.
22:34:36 <vhdiaz> the trainers should come out of this wg
22:34:37 <craigs> #action vhdiaz Check with Flanders and see what he has planned for dojo training
22:34:39 <krotscheck> I don't suppose anyone here has experience with pedagogical patterns? ;)
22:35:12 <vhdiaz> We have some guidance
22:35:22 <vhdiaz> We can use some resources
22:36:03 <krotscheck> What does guidance/resources mean? Do you mean funding from the foundation, support via flanders, ...?
22:36:25 <notmars_> we do have a list of subject/challenge for the Guadalajara hackaton that could be interesting to look into
22:36:49 <vhdiaz> yes, that was 1 idea behind the hackathon.. connecting with the Dojos and provide training previous the hackathon as preparation
22:37:12 <vhdiaz> 1 of those pre-event activities could be converted into a training for Barcelona
22:37:33 <notmars_> https://docs.google.com/spreadsheets/d/1Tdqe13aTbh0GN5tWHIWBTDwqu4UY6EAjksY64KtnREg/edit?usp=sharing&pref=2&pli=1
22:37:58 <notmars_> not sure everybody has acces, if not, let me know, i'll forward
22:38:37 <craigs> who is notmars?
22:38:42 <mbonell> bruno
22:38:55 <craigs> LOL makes sense now
22:39:02 <mbonell> hahaha
22:39:04 <vhdiaz> LoL
22:39:09 <krotscheck> Hrm. Maybe a "contribute to openstack" intro to our infra things?
22:39:41 <leong> this wg is more focusing from "app developer" perspective
22:40:01 <mbonell> yep, contributors is other kind of developers
22:40:02 <krotscheck> I figured.
22:40:10 <vhdiaz> it should solve the challenge on how to write your first app
22:40:11 <krotscheck> Occasionally, however, you find a bug.
22:41:12 <craigs> I would expect our app developers to just submit the bugs
22:41:50 <craigs> Where did this training list come from?
22:42:17 <notmars_> the amazing Guadalajara hackaton group :)
22:42:26 <mbonell> \o/
22:42:28 <notmars_> kudo to mbonell :)
22:42:37 <krotscheck> That's pretty neat
22:43:58 <mbonell> the pre-trainings for the hackathon will be on Agu
22:44:02 <krotscheck> I assume all of these courses are Python-based, yes?
22:44:34 <mbonell> no
22:44:37 <notmars_> more mixed, the 'Openstack 101' is more non-programmatic at all
22:44:53 <notmars_> the cURL challenge is obviously...curl :P
22:44:57 <notmars_> ..
22:45:46 <craigs> Well if we are going to do a training session for Barcelona we have to submit a proposal soon, right?
22:46:05 <krotscheck> I believe so.
22:46:09 <notmars_> I'd say the sooner
22:46:28 <notmars_> question is probably : what do we want to start with ?
22:46:43 <leong> for training session, pls check with Flander/Foundation
22:47:12 <leong> and yes, definitely need to prepare asap
22:47:30 <craigs> Deadline to submit a talk is July 13
22:48:02 <krotscheck> For Barcelona, we could focus on Firstapp. Build FirstApp in python, build it in Java, build it in JavaSCript, etc.d
22:48:23 <notmars_> I like that option a lot
22:48:37 <craigs> Well be careful what we offer up, we only have it in one language at this point
22:48:49 <leong> training session might be "separated" from the normal talk submission
22:48:50 <notmars_> I have it in Objective-C
22:48:56 <krotscheck> craigs: Well, it'll light some fire underneath the contributors to get their apps working, no? ;)
22:48:59 <notmars_> I think krotscheck will have it soon in js
22:49:09 <notmars_> we have python now for sure
22:49:16 <krotscheck> And by "soon" you mean "barcelona", yes.
22:49:17 <mbonell> fog
22:49:23 <notmars_> a bit of Java and a bit of .NET
22:49:26 * krotscheck hopes he'll have reviewers.
22:49:26 <notmars_> and we're good no ?
22:49:59 <notmars_> krotscheck: you have already :) (me and my js-guys are waiting to be useful :P)
22:50:07 <craigs> victor has the AR to go talk to Flanders, is this what we want to propose?
22:50:08 <krotscheck> \o/
22:50:17 <krotscheck> notmars_: gerrit topic neverland
22:50:36 <krotscheck> I'm all for it.
22:50:43 <notmars_> krotscheck: yup, already bookmarked :) going through it tomorrow
22:50:52 <krotscheck> Woot
22:51:53 <notmars_> so let's the firstapp for Barcelona ?
22:51:58 <craigs> OK, Victor talk to Flanders and let him know this is our proposal
22:52:09 <notmars_> +1
22:52:16 <mbonell> ok
22:52:25 <krotscheck> If flanders says yes, we can determine who's responsible for each of the languages, and use that to focus our barcelona deliverables.
22:53:20 <notmars_> yup, assign a champion to each and check on them every regularly should be enough
22:53:35 <notmars_> (-every)
22:53:36 <craigs> #link Here is the current list of ownership https://docs.google.com/spreadsheets/d/18Zj2JU0jR4hy8y1HxFl30gTEGeqgBjc6hqv0ZAByVYo/edit?pref=2&pli=1#gid=0
22:55:17 <krotscheck> 5 minutes
22:55:58 <piet> Did we chat about the app developer recruitment survey?
22:56:11 <craigs> nope
22:56:28 <craigs> Are we done with Firstapp topic?
22:56:40 <mbonell> yes
22:56:41 <krotscheck> For now, yes.
22:56:44 <notmars_> yes
22:57:10 <krotscheck> piet: it doesn't look like it's on the agenda. Do you mind waiting a week and having it formally on the agenda?
22:57:21 <craigs> either is fine
22:57:23 <piet> Yep - no problem
22:57:24 <craigs> are you ready to talk now
22:57:28 <piet> It's live
22:57:47 <craigs> #topic App developer recruitment survey
22:57:53 <craigs> Can you share the link
22:57:53 <vhdiaz> I shared it to engineering teams in Mexico
22:57:57 <vhdiaz> and social networks
22:58:01 <craigs> great
22:58:03 <piet> The goal is to identify app devs that are interested in participating in user research for the community
22:58:32 <piet> So, it's really intended to be a resource for this group
22:58:53 <piet> However, we need to start distributing the survey to a huge number of people
22:58:56 <krotscheck> Is this something that can be added to a registration form on one of our training events?
22:59:05 <piet> Yep
22:59:07 <johncallaghan> Bye all, its been fun and I will miss you.
22:59:10 <krotscheck> i.e. "Sign up for training in barcelona, oh and do you mind if our UX team reaches out to you?"
22:59:33 <piet> krotscheck Yep
22:59:40 <johncallaghan> quit
22:59:45 <vhdiaz> By John! take care yourself
22:59:49 <piet> We have a list of 1200 devs at INtel who will get the survey
22:59:58 <vhdiaz> it was a pleasure co-charing wih you!
23:00:04 <notmars_> yup, be well John !
23:00:24 <piet> vhdiaz There were a few folks that responded to the survey
23:00:33 <craigs> Looks like we have run out of time
23:00:43 <piet> Let's pick-up next week
23:00:51 <krotscheck> Alright.
23:00:58 <craigs> Thanks all for joining
23:01:08 <mbonell> byee
23:01:28 <craigs> #endmeeting