17:00:19 <docaedo> #startmeeting app-catalog
17:00:22 <openstack> Meeting started Thu Apr  7 17:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:25 <openstack> The meeting name has been set to 'app_catalog'
17:00:32 <docaedo> #link https://wiki.openstack.org/wiki/Meetings/app-catalog Agenda
17:00:54 <docaedo> morning (or evening I guess!) kzaitsev_mb
17:01:39 <kzaitsev_mb> evening, indeed =)
17:02:28 <docaedo> Maybe just us today? Might as well follow the agenda for official record keeping :)
17:02:32 <docaedo> #topic Status updates
17:03:04 <markvan> o/
17:03:15 <docaedo> kzaitsev_mb: can you give a quick update on glare status? I have not checked in on the latest patches but sounds like runserver local works for glare testing?
17:03:24 <docaedo> welcome markvan !
17:03:43 <kfox1111> o/
17:04:14 <docaedo> hey kfox1111 - this is turning into a real meeting all of a sudden ;)
17:04:35 <kfox1111> :)
17:05:10 <kzaitsev_mb> docaedo: I've been away most of the prev week. As for the patches — kfox1111 updated them to work with run_tests and I've updated the angular ones to work on top of that
17:05:39 <kfox1111> awesome. :)
17:05:42 <docaedo> ah great - kfox1111 is there anything to note about testing glare with runserver or is it pretty obvious from the patch?
17:05:57 <kzaitsev_mb> unified them (more or less compliant with horizon's style-guide)
17:05:58 <kfox1111> it should work the same way its worked in the past.
17:06:14 <docaedo> awesome I will mess with it today
17:06:16 <kfox1111> it will just be slower since it has to import all the entries to sqlite.
17:06:43 <docaedo> sounds like we're in good shape to get to a point where we can demo this at the summit
17:07:02 <kzaitsev_mb> the one that's supposed to add assets to glare is still a WIP, but most of the code is already there, I hope to finish it off today/tomorrow.
17:07:20 <docaedo> excellent
17:07:27 <kzaitsev_mb> We still haven't started work on auth though
17:07:48 <docaedo> yeah I expect that one is going to be hairy
17:07:48 <kfox1111> yeah. that'll be a fair amount of effort to get right.
17:08:22 <docaedo> but getting all the right parts lined up first at least so it'll be easy to focus on the auth piece
17:09:04 <docaedo> Regarding AppCatalog OSC plugin
17:09:05 <kfox1111> yeah.
17:09:06 <docaedo> #link https://github.com/pvaneck/python-appcatalogclient
17:09:36 <docaedo> Still holding for repo creation but that should land shortly, then pvaneck can get that code in the official repo
17:09:45 <kfox1111> nice.
17:10:05 <docaedo> for the first pass/foundation I think it's great, does just what we'd want for v1 api and will be easy to build from
17:10:23 <docaedo> right now just does list and show, but pretty cool start
17:11:22 <kfox1111> +1. :)
17:11:24 <docaedo> #link http://paste.openstack.org/show/493378/
17:12:11 <docaedo> some rough edges on formatting a little bit, but nice base
17:12:28 <docaedo> #link http://paste.openstack.org/show/493379/
17:12:37 <kfox1111> oh...
17:12:49 <kfox1111> so, those are all components...
17:12:56 <kfox1111> I'd suggest we rework it to be:
17:13:08 <kfox1111> openstack catalog app list
17:13:12 <kfox1111> openstack catalog component list
17:14:28 <docaedo> that could make sense though I figured we'd be narrowing down by type - but lots of time to tweak and adjust anyway
17:14:41 <kzaitsev_mb> docaedo: those formatting issues can be worked around I believe. At least I believe my outreachy mentee managed to find a workaround =)
17:14:55 <kfox1111> yeah. but I think our users will fall naturally into those two camps.
17:15:04 <kfox1111> further filtering can be done in either case.
17:15:38 <kfox1111> when I just want to launch an app, I really don't want to see all the little bits.
17:16:45 <kfox1111> should be pretty easy to kergigger around though.
17:17:17 <docaedo> agreed - I'm hoping we'll get a conversation going *somewhere* about what an OpenStack App looks like some day
17:17:41 <kfox1111> +1. maybe we can talk more about it at the summit this time around.
17:18:10 <docaedo> yep - more on that in our next topic ;)
17:18:12 <kzaitsev_mb> aren't those what the summits are for =)
17:18:36 <docaedo> markvan: any updates on the testing stuff? Need feedback/help on anything?
17:19:59 <markvan> after a few chats with the horizon folks, seems like there might a slight change in direction for int testing framework, but will have some discussions at the summit to clarify
17:20:45 <markvan> basically how to best go foward with something that makes it easy for new angular code
17:21:10 <docaedo> cool - I'm going to ask for time with the horizon team to talk about app catalog UI and horizon with them (maybe a portion of one of their sessions)
17:21:18 <kfox1111> yeah. I've got some discussions with them on that too.
17:21:21 <kfox1111> +1.
17:21:26 <kfox1111> on a related note,
17:21:30 <kfox1111> https://review.openstack.org/#/c/300275/
17:21:44 <kfox1111> a stab at moving the horizon plugin over to share app-catalog-common.
17:21:59 <docaedo> oh yeah that counts as an update :)
17:22:00 <kfox1111> found one hitch that I'm working around, but horizon never considered a plugin would need aditional xstatic deps.
17:22:22 <kfox1111> so a non hackish solution should be discussed with them.
17:22:53 <kfox1111> also, we'd like to share some of their angular widgets on our webiste. so being able to pull them out more easily and have both parties depend on them would be nice to talk about too.
17:24:02 <docaedo> yeah that would be a good conversation to have. I'm (as always) reluctant to tie the web site too closely to horizon project directly but when it solves more problems than it creates I'm in
17:24:29 <kfox1111> yeah. we wouldn't be useing all of horizon. just using some of the stuff they already created/support.
17:24:43 <kfox1111> so we don't have to write a clone ourselves.
17:25:00 <kfox1111> their magic search angular plugin and smart table stuff make things much easier.
17:25:20 <docaedo> yep, I think I follow and agree there
17:25:36 <kfox1111> right now, I just copy'ed the raw files in.
17:25:49 <kfox1111> it would be nice to have that be an external dep so bugs get fixed automatically.
17:25:50 <kzaitsev_mb> we just need to make them to publish it as some sort of xstatic package, right?
17:25:55 <kfox1111> right.
17:25:57 <docaedo> #action docaedo to ask Horizon team for some work session time at summit
17:26:49 <docaedo> I think the part that scares me is that they won't be considering the app catalog website when making changes, so we need to be very deliberate with the web site
17:27:31 * docaedo notes we've already moved on to the next topic, so...
17:27:36 <kzaitsev_mb> yeah, but if they publish it as some sort of package — we would be able to depend on specific package version
17:27:40 <docaedo> #topic Summit workroom session topics
17:27:47 <kfox1111> yeah.
17:27:52 <docaedo> #link https://etherpad.openstack.org/p/app-catalog-newton-summit
17:29:12 <docaedo> Please everybody take a look at that etherpad and throw some stuff up there today.
17:29:36 <docaedo> I want to update the summit schedule with some descriptions by end of the week
17:30:08 <kzaitsev_mb> I've looked at the schedule — And I have a murano meeting, that conflicts with 1st app-catalogs one
17:30:35 <docaedo> ah that's a bummer
17:30:45 <kzaitsev_mb> docaedo: yep, I believe ttx mentioned, that end of next week is the dedaline for those, but always better to have it early
17:30:48 <docaedo> the fishbowl session?
17:31:19 <docaedo> yeah I want to get the details up ASAP because people are already going through the schedule and figuring out where they're going to spend their time.
17:31:29 <docaedo> Having basically empty entries is not going to attract anyone :)
17:32:20 <kzaitsev_mb> gotta dig up a schedule table. it was there in one of the letters
17:33:27 <kfox1111> hmm...
17:33:59 <kfox1111> openstack cli has 'catalog' bound to the keystone catalog. :/
17:34:22 <kfox1111> thats really unfortunate.
17:35:31 <kfox1111> shoudl we talk about the naming collision again at the summit?
17:36:29 <docaedo> I think appcatalog is ok - considering all the history around use of catalog with respect to keystone, that seems like a pointless battle
17:37:00 <kfox1111> yeah, no I'm not arguing we try and get them to rename.
17:37:13 <kfox1111> I'm saying the term 'catalog' itself is really overloaded and painful. :/
17:37:30 <kfox1111> should we rename ourselves 'app store' or some other, less contended word?
17:38:19 <kfox1111> grimoire or something? (I would have to hate to spell that though... :)
17:38:23 <docaedo> I don't know, just publicizing the use of "openstack appcatalog list glance" or "appcatalog search Ubuntu" does not feel ambiguous to me
17:38:36 <kfox1111> no, I'm talking a higher level.
17:38:45 <kfox1111> I get questions all the time,
17:38:49 <kfox1111> your talking about murano, right?
17:39:14 <kzaitsev_mb> kfox1111: saw your discussions about all the 'naming hell' we're in. Seems like we'll have a chance to talk that one once more on summit
17:39:16 <kfox1111> this is just yet another little case of using a term way too much.
17:39:31 <kfox1111> yeah, that.
17:40:35 <kfox1111> I added a thing in the etherpad.
17:40:39 <docaedo> well yeah, I don't think anyone benefits by us picking a name that obfuscates what we're doing but I would gladly discuss/debate as well
17:41:38 <docaedo> (I'm partial to Application Index, but that doesn't sound really classy :) )
17:42:12 <kfox1111> time for a thesaurus. :)
17:42:36 <kzaitsev_mb> naming things is haaard =(
17:42:50 <kfox1111> yeah. :/
17:43:02 <docaedo> I think we have enough for the work sessions anyway, so I can add details to the schedule and we can always adjust later
17:43:20 <docaedo> #action docaedo to update summit schedule with work room session topics
17:43:36 <kfox1111> "registry"?
17:43:48 <kfox1111> the openstack registry, the openstack app registry, etc?
17:43:59 <docaedo> not bad
17:44:01 <markvan> openstack "warehouse" list glance  ;)
17:44:01 <kfox1111> no need to figure it out today...
17:44:14 <kfox1111> hmm... warehouse is good too...
17:44:14 <docaedo> I'll bring some darts, we'll write them all on a board and see which one wins :D
17:44:44 <kfox1111> k. added those 2 to the etherpad too.
17:45:32 <docaedo> #topic Open discussion
17:45:57 <docaedo> the floor is open :)
17:46:56 <kfox1111> "exchange" maybe...
17:46:58 <kzaitsev_mb> docaedo: yeah, I have a murano work session at the same time as the app-catalog fishbowl, so I'll probably miss at least the first part of it. I'll try to pick the topics so that I'll be able to get to the 2d half of the fishbowl =)
17:47:12 <kfox1111> go to the openstack exchange and download...
17:47:38 <docaedo> kzaitsev_mb: cool, appreciate the scheduling gets really tough, appreciate whatever you can make
17:52:13 <docaedo> Anything else?
17:52:43 <docaedo> Thanks for coming, looking forward to seeing you all in a few weeks in Austin!
17:53:16 <docaedo> #endmeeting