17:00:34 <docaedo> #startmeeting app-catalog
17:00:35 <openstack> Meeting started Thu Feb 25 17:00:34 2016 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'app_catalog'
17:00:47 <kfox1111> o/
17:01:00 <kzaitsev_mb> o/
17:01:03 <docaedo> hello kfox1111!
17:01:10 <docaedo> and kzaitsev_mb :)
17:01:12 <kfox1111> hey.
17:01:34 <docaedo> courtesy ping markvan
17:01:56 * docaedo can't find he usual courtesy-ping list all of a sudden:/
17:02:04 <markvan> yo
17:02:12 <docaedo> hey hey
17:02:19 <docaedo> #topic Status updates
17:02:52 <docaedo> Let's start with kzaitsev_mb today? Any notable updates on the glare work?
17:03:33 <kzaitsev_mb> docaedo: well, I've setup a staging server on Mirantis cloud VM, seems to work fine for me, but
17:03:44 <kzaitsev_mb> but I still do not have a public IP to share with you guys
17:04:18 <kzaitsev_mb> I've been promised to have it this week though, so I'm going to ping the guys in charge for it
17:04:26 <docaedo> Great thanks :)
17:04:52 <kzaitsev_mb> The script for importing assets from v1 is also almost ready (I think it only lacks a couple of fields)
17:05:13 <kzaitsev_mb> ddovbii promised to update it by tomorrow evening
17:05:15 <docaedo> I'm hoping next week to take a much closer look at the required fields and such, and give more useful feedback
17:05:41 <docaedo> but I did at least have a good experience in my own test environment
17:05:58 <kzaitsev_mb> so I hope, that I'll be able to share you an IP to the server, that serves both v1 and v2 (or at least something we can call v2 +))
17:07:23 <kzaitsev_mb> my next step would be to add patches, that would make UI (both dashboard and site) fetch data from glare
17:07:24 <docaedo> Nice - we'll have time for more debate/discussion (maybe topic for next week?) but I want to make sure we're clear on the transition, especially minimal requirements for switching to v2
17:08:04 <docaedo> for that, for v1, it should be transparent, no changes required to anything other than what serves the v1 endpoint
17:08:35 <docaedo> for v2 it would I think need to include authentication, and that's where things start to get markedly different (and at that point we can drop assets.yaml for adding new assets)
17:08:55 <kfox1111> kzaitsev_mb: for now, probably should just switch the pythong v1 api to pull from glare.
17:09:23 <kfox1111> then no changes to the ui/plugin are needed.
17:09:49 <kfox1111> we still need to merge the code for the website and plugin, and I just haven't had time to finish that work. it will be much easer at that point to point the code at v2 since it will be common to all.
17:10:13 <docaedo> I'll add "glare transition review" as the topic for next week so we can plan to have enough time for the conversation
17:10:31 <kfox1111> I'm hoping mid March my time will free up. I have a major deliverable finished at that point.
17:10:34 <docaedo> #action add "glare transition review" to next weeks agenda
17:11:36 <kzaitsev_mb> kfox1111: sounds fair. I'll keep you guys updated on any work I do and would ping around as soon as I have something to review/something to play with
17:11:39 <docaedo> in short though, thanks a ton kzaitsev_mb (and ativelkov) for getting glare to a point where we can poke and play with it :)
17:11:53 <kfox1111> +1
17:12:14 <docaedo> markvan: do you have any updates on the work to add integration tests?
17:12:30 <docaedo> (and any calls to action/help from any of us too of course!)
17:12:59 <markvan> hi, I have the basic testing patches done https://review.openstack.org/#/c/276438/  and https://review.openstack.org/#/c/276440/
17:13:25 <markvan> I have done testing with devstack locally and I think these are ready to go in now.  Then we can build out other tests from there.
17:13:48 <kfox1111> nice. :)
17:14:08 <markvan> Since there's a bunch of python code, I also created patches for adding linting: https://review.openstack.org/#/c/283201/ and https://review.openstack.org/#/c/283202/
17:14:26 <docaedo> that's awesome, thanks a ton!
17:14:42 <markvan> just contains python updates as their are quite a few js updates to...made that non-voting for now
17:15:18 <kzaitsev_mb> markvan: does it install latest horizon?
17:15:54 <kzaitsev_mb> markvan: oh yes, I see it's in test-requirements
17:15:56 <markvan> yes, it just a full devstack from master with horizon and catalog plugin
17:16:14 <markvan> oh, you meant the horizon source, yup, still tied to that.
17:17:01 <markvan> I have started on the next testcases for images and templates, to test a basic flow
17:18:01 <markvan> And I'm also working on my templates for LBaaSv2 which is about to land in heat (hopefully)
17:18:35 <kzaitsev_mb> we can probably later add a murano-integration gate, that would also install murano through devstack plugin. and have similar tests for import =)
17:18:39 <docaedo> markvan: if I start a blueprint, would you mind adding your planned steps in work items?
17:18:55 <kfox1111> nice. :)
17:19:00 * docaedo tries to keep things looking official now and then ;)
17:19:11 <markvan> kzaitsev_mb: yup, that would be fairly easy after this intitial patch
17:19:18 <markvan> docaedo: no
17:19:21 <markvan> docaedo: np
17:19:24 <markvan> :)
17:19:26 <docaedo> haha
17:19:44 <docaedo> #action docaedo to create "add tests" blueprint for markvan's many work items
17:20:13 <docaedo> Any other status updates? kfox1111 how's your cloud coming?
17:20:37 <kfox1111> got a round of switching out nics coming soon. bad silicon. :/
17:20:44 <docaedo> ugh!
17:20:59 <kfox1111> but there is light at the end of the tunnel.
17:21:17 <docaedo> that's good to hear at least
17:22:08 <kfox1111> then the next step I want to do is swithc the horizon plugin to app-catalog-common.
17:22:08 <docaedo> moving on then
17:22:12 <docaedo> #topic Space considerations for Austin summit (docaedo)
17:22:32 <kfox1111> then finish up the website ui work to do app-catalog-common too.
17:22:46 <kfox1111> then it should be easy to add new types. will only have to do it in app-catalog-common.
17:23:31 <docaedo> kfox1111: ah yes - that'll be great .. I guess I should have added on the previous topic, next week I'm going to poke at updating the "recently added" section to actually use the dates that are now tied to assets
17:23:54 <kfox1111> nice. :)
17:24:27 <kfox1111> we may need a default icon for things without icons for that task.
17:25:02 <docaedo> kfox1111: agreed, will find something "openstack" that works for generic case
17:25:28 <docaedo> #action docaedo to remember to get some generic icon for assets that don't include their own
17:25:51 <docaedo> So the foundation is working on planning for Austin summit
17:26:07 <docaedo> Every project gets a few of three different types of rooms/space:
17:26:19 <docaedo> * Fishbowl slots (Wed-Thu)
17:26:22 <docaedo> Our traditional largish rooms organized in fishbowl style, with advertised session content on the summit schedule for increased external participation. Ideal for when wider feedback is essential.
17:26:25 <docaedo> * Workroom slots (Tue-Thu)
17:26:28 <docaedo> Smaller rooms organized in boardroom style, with topic buried in the session description, in an effort to limit attendance and not overcrowd the room. Ideal to get work done and prioritize work in small teams.
17:26:33 <docaedo> * Contributors meetup (Fri)
17:26:36 <docaedo> Half-day session(s) on the Friday to get into the Newton action while decisions and plans are still hot, or to finish discussions started during the week, whatever works for you.
17:26:45 <docaedo> In Tokyo we had one fishbowl and one workroom slot
17:27:04 <docaedo> In Austin I would propose we request a fishbowl again, and two workroom slots.
17:27:32 <docaedo> I don't think we're big enough to need a contributors meetup, not to mention most of our concerns are cross-project anyway, so we're more likely to be in other sessions quite a lot
17:27:36 <docaedo> Thoughts?
17:28:16 <kfox1111> sounds good to me.
17:28:27 <markvan> +1
17:28:53 <kzaitsev_mb> Would we have enough topics to discuss for 1fb + 2wr? =)
17:29:12 <kzaitsev_mb> or should we ask for more to get less (=
17:29:28 <docaedo> I think two work rooms would be good considering we'll have some pure API-related stuff, plus the horizon/ui stuff
17:30:21 <docaedo> I'll break it up more clearly, but I can certainly see two hours worth of topics, ideally bringing in more people than the usual (which is the four of us :) )
17:31:00 <kfox1111> it would be good to discuss with the horizon folks some things for sure.
17:31:47 <docaedo> kzaitsev_mb: as for asking for more, we'll get this as it's a fairly minimal request, and I think what we're trying to accomplish is still pretty dear to the hearts of the foundation and TC :)
17:32:33 <docaedo> kfox1111: yes, we'll have to make sure we're finding time to work with horizon people too
17:32:52 <docaedo> which maybe means for a topic like that, it gets shared between us and them
17:33:08 <kzaitsev_mb> sounds fair, 1 big room for more people/announcements/etc, 2 small rooms for more on-topic discussions.
17:33:18 <docaedo> kzaitsev_mb: that's exactly it
17:33:42 <kzaitsev_mb> now I remember that I felt, that I needed 1 more Workroom slots back in Tokio
17:34:13 <docaedo> haha yep - though when I remember tokyo, I just remember feeling like I was half a step behind for a whole week :/  Austin is going to be a whole lot better
17:35:23 <docaedo> OK moving on :)
17:35:25 <docaedo> #topic Open discussion
17:35:54 <docaedo> I don't have any topics for open discussion this week, but I'll yield the floor to anyone else
17:36:56 <markvan> nothing from me
17:38:35 <docaedo> kfox1111 or kzaitsev_mb ?
17:39:38 <kzaitsev_mb> don't think I have anything
17:39:52 <kfox1111> nothing new here.
17:40:37 <docaedo> alrighty then!  thanks so much for coming to the meeting, and as always, thanks a ton for all the work you're doing - talk to you later on!
17:40:46 <docaedo> #endmeeting