17:05:22 <docaedo> #startmeeting app-catalog
17:05:23 <openstack> Meeting started Thu Oct  1 17:05:22 2015 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:26 <openstack> The meeting name has been set to 'app_catalog'
17:05:45 <docaedo> #topic rollcall
17:05:47 <docaedo> o/
17:05:58 <kfox1111> o/
17:06:30 <docaedo> courtesy ping for j^2 and kzaitsev_mb
17:06:38 <j^2> :D
17:06:58 <kzaitsev_mb> pong
17:07:05 <docaedo> #topic Updates
17:07:26 <docaedo> kfox1111: if you wouldn't mind re-stating what you said moments ago (for the OFFICIAL RECORD of course)
17:07:56 <kfox1111> k.
17:08:07 <kfox1111> whats the status of https on apps.openstack.org?
17:08:31 <docaedo> My understanding is the cert was purchased yesterday
17:08:42 <kfox1111> awesome. :)
17:08:44 <docaedo> I'll ping fungi after the meeting to confirm
17:08:45 <j^2> nice!
17:08:55 <kfox1111> so, almost there.
17:09:00 <docaedo> then once it's purchased, he'll put it in their hiera and merge the patch
17:09:00 <fungi> docaedo: i'll be around
17:09:28 <fungi> docaedo: oh, i pinged you last night in #openstack-infra with the hiera key names i used for those
17:09:40 <docaedo> fungi: nice thanks! haha, a celebrity appearance in our app-catalog meeting!
17:09:45 <fungi> they're all ready to get included in the global site manifest now
17:09:53 * fungi is _everywhere_
17:09:56 <docaedo> fungi: ah sorry, I missed that - great, I'll catch up with you then on infra
17:10:09 <fungi> sounds good
17:10:46 <kfox1111> k. next up is the status of the app-catalog-ui.
17:10:58 <kfox1111> I've got one more patch I want to put in, then we can do a 1.0.0b1
17:11:11 <docaedo> excellent!
17:11:13 <kfox1111> Hopefully I can get to it tomorrow or this weekend.
17:11:32 <kfox1111> docaedo: can you draft up a release anouncement or figure out how to do those?
17:11:59 <docaedo> #action docaedo to learn about how we are supposed to do a release
17:12:08 <docaedo> yep, will do that
17:12:10 <kfox1111> cool. thanks.
17:12:28 <kzaitsev_mb> there were a couple of emails this month, that denoted how to make release notes =)
17:12:35 <kzaitsev_mb> I've marked them as "toread" =)
17:12:42 <kzaitsev_mb> but haven't, I guess =(
17:12:45 <kfox1111> nice.
17:13:19 <j^2> docaedo: releases are pretty straight forward
17:13:20 <kfox1111> third item, any more reviewers for the django/flask prototype?
17:13:21 <docaedo> kzaitsev_mb: haha, I'll look for the threads, and fall back on my usual mode of pestering the infra channel for the details
17:13:34 <j^2> there’s great docs on the wiki
17:13:58 <docaedo> j^2: cool thanks, yeah you've been through that already too, glad to hear it's pretty straight forward
17:14:10 <j^2> yep, it’s my world ;)
17:14:43 <docaedo> kfox1111: can you share the link for that patch again?
17:14:52 <j^2> oh yeah i do have a question for the room; and i thought here would be a good forum, when i can ask please ping me
17:15:26 <kfox1111> ok. just a sec...
17:15:46 <kfox1111> https://review.openstack.org/#/c/227856/
17:16:17 <docaedo> #link https://review.openstack.org/#/c/227856/
17:16:20 <kfox1111> j^2: will do. one other item to discuss.
17:16:25 <j^2> kk
17:16:37 <kzaitsev_mb> docaedo: http://lists.openstack.org/pipermail/openstack-dev/2015-August/071189.html this thread I guess. not sure if it applies.
17:17:10 <kfox1111> last one I've got, the summit. we really really need to get murano, glance, and the app-catalog teams in a room and chat. :)
17:17:29 <j^2> oh ha!
17:17:33 <j^2> that’s what i was going to ask
17:17:37 <kfox1111> :)
17:17:38 <docaedo> kzaitsev_mb: thanks - yep I read that thread. Not sure it's directly applicable to what we're doing right this moment (for a very first release) but a few points in there need to be remembered
17:17:55 <j^2> kfox1111: at the operators meetup, people looked at me like i was crazy talking about the apps project
17:18:00 <kfox1111> sorry to steal your tunder.
17:18:13 <docaedo> oh yeah! thank you for reminding me! I was going to talk about that
17:18:16 <j^2> so as a “pseudo”member of this project, we need to do some marketing
17:18:26 <kfox1111> yeah.
17:18:30 <docaedo> Meant to chat on the regular channel about proposing a cross-project topic: http://odsreg.openstack.org/
17:18:30 <j^2> i want y’all to succeed, and i want to help how i can
17:18:52 <kfox1111> goes back to that converstaion about is openstack an os or not. We have a lot of explaining there I think. :/
17:18:54 <j^2> woah, I’ve never seen that site before
17:18:54 <docaedo> and we will have rooms for one fishbowl session and one working session
17:19:09 <kfox1111> I'm hoping once we have a release of the app-catalog ui, and we have it in a few distro's, it will start selling itself.
17:19:37 <j^2> kfox1111: that’s…ambitious, i think the idea of just cornering people is better then nothing
17:20:10 <j^2> i’m having to do this with chef so…selfishly any practices i can have “selling” internal OS projects is a + to me
17:20:41 <kfox1111> yeah.
17:21:12 <docaedo> I think the key will be getting Horizon team to adopt it (after we have packages that make it dead easy to implement)
17:21:23 <j^2> but yeah making it an official “cross-project” is actually probably the best way. just hope you get selected to be one of the later ones so you can sell it over the [beers|drinks|sake|lunch table]
17:21:24 <kfox1111> I'm kind of hoping its like the other app stores on phones. It wasn't obvious it was a great idea, until it was there right on the phone,
17:21:36 <docaedo> because the UI piece is super lightweight and low impact, but brings a ton of value to any deployment
17:21:38 <j^2> from what i understand, horizon is…scatter brained
17:21:41 <kfox1111> then it became demanded by everyone.
17:22:11 <j^2> i’m going mobile, but i have irc cloud on my phone, slow responses but i’ll keep up
17:22:25 <kfox1111> kk.
17:22:39 <kfox1111> docaedo: still think that's a bad idea.
17:23:01 <kfox1111> thats like requiring the google app store to be shipped and non upgradable outside of an android release.
17:23:04 <docaedo> the OpenStack Foundation is also very interested in promoting the catalog
17:23:40 <docaedo> kfox1111: that's true
17:23:58 <kfox1111> since the catalog relies on external functionality, being able to upgrade it on release cycles different then horizon's is helpful.
17:24:12 <kfox1111> I think the real solution is to ensure all the major openstack distro's support it.
17:24:34 <kfox1111> rdo, ubuntu, debian, suse, fuel, etc.
17:25:04 <kfox1111> if its just a yum install or a click on this extra box (hopefully even defaulted on), then its not really any harder to install then horizon.
17:25:17 <docaedo> I can agree on that front, though the distros lag behind the release
17:25:31 <kfox1111> or a debian suggests dep in the horizon package.
17:26:03 <kfox1111> yeah, thats usually becuase upstreams break compability with older stuff. :/
17:26:22 <kfox1111> I'm hoping we keep compatabily with newer plugins with older horizons for at least a couple of years.
17:26:27 <docaedo> though I agree the key is making the package super super easy, like you're saying - but the trick is to have a package that keeps up with updates in the catalog
17:26:59 <kfox1111> yeah. I've been toying around with having the plugin be a shell, and calling out to apps.openstack.org to fetch the javascript engine.
17:27:13 <kfox1111> but really unsure if that will make the distro folks sick.
17:27:16 <kfox1111> I suspect it will.
17:27:27 <docaedo> hahaha yeah that's likely
17:27:58 <kzaitsev_mb> Also I was thinkign, that horizon guys do not want to include new dashboards in horizon itself and were going to exclude some of the existing
17:28:07 <kzaitsev_mb> not really sure if that's true though
17:28:20 <kzaitsev_mb> just what some of my colleagues are often speaking about
17:28:21 <kfox1111> yeah, I heard that. with as plugable as it is in liberty+, its a resonable thing now.
17:29:00 <j^2> +1
17:29:06 <docaedo> I think kfox1111 is right about not pushing for it to be default include, I do agree with that - but the plugin works great and is really simple
17:29:51 <kzaitsev_mb> also inclusion into horizon repo would probably mean that changes would go slower. And it might be more a matter of packaging then =)
17:30:04 <kfox1111> yeah.
17:30:16 <kzaitsev_mb> and there it might be a part of some meta-package and thus be a semi-default install )
17:30:17 <kfox1111> maybe in a few years once we have v3+ and its all settled down, it may make sense then.
17:30:34 <docaedo> correct, I guess I didn't really mean "include it directly in horizon" :) I was just thinking about making it so easy to include in a cloud.
17:30:51 <kfox1111> yeah, it fuel it could just be a defaulted on checkbox in the cloud deployment. in packstack, just a defaulted on feature. etc.
17:30:54 <docaedo> which means rpm/deb, plus working with *someone* from the chef side to get that included as an easy option...
17:31:05 <kfox1111> ah. yeah.
17:31:14 <docaedo> (and same goes for that other config management platform some people use ;) )
17:31:30 <kfox1111> the chef/ansible/kolla/etc side of things too.
17:31:52 <kfox1111> maybe we need to spend some time at the summit talking to the various deployment projects too.
17:31:55 <kfox1111> tripleo..
17:32:32 <kfox1111> I'm close on an rdo package.
17:32:33 <docaedo> yeah I was about to say I don't think anyone uses that for anything other than testing, but seems redhat included it in their latest foreman/staypuft thing
17:32:42 <kfox1111> so that would help with kolla too.
17:32:58 <docaedo> but it's pretty easy to write a fuel plugin once it's packaged, so that one won't be too hard
17:32:59 <kfox1111> rdomanager's based on tripleo.
17:33:07 <kfox1111> they are pushing it as a packstack replacement.
17:33:24 <kfox1111> I think, once they integrate with kolla, tripleo's going to be suddenlyl very interesting...
17:34:07 <docaedo> I still think it's too much for just deploying your base images (but I do like bifrost, which makes sense to me)
17:34:33 <kfox1111> I think it makes sense if you try and make bare metal available to users too.
17:34:38 <docaedo> do agree though that kolla stuff is looking really interesting and has promise - but luckily, doesn't matter too much to us
17:34:50 <kfox1111> that way, you can shrink your hypervisor pool, and then users can use the evacuated bare meta.
17:34:57 <kfox1111> anyway, way off on a tangent.
17:35:06 <docaedo> I mean - completely agree with getting the deployers onboard
17:35:26 <docaedo> but the route there is packages, and tooling (chef, puppet, ansible, kolla)
17:35:33 <kfox1111> right.
17:35:57 <kfox1111> kzaitsev_mb: do you do anything with fuel or just murano?
17:36:25 <kfox1111> cause I think fuel packages are somewhat different then rdo ones?
17:36:56 <kzaitsev_mb> nah, mostly murano.
17:37:04 <kfox1111> ok.
17:37:10 <kfox1111> docaedo: how about you?
17:37:11 <docaedo> fuel deploys on fedora or ubuntu, so just uses whatever packages are available (more or less)
17:37:25 <docaedo> I might know more about fuel than I want to :D
17:37:32 <kfox1111> last I looked, mirantis was actually providing all the rpms.
17:37:37 <kzaitsev_mb> although I think, that you're right, about the fact that those are different
17:37:46 <kfox1111> (centos 6) and rdo is only supporting centos 7.
17:38:18 <docaedo> they build a lot but the majority comes from upstream AFAIK - but another tangent ;)
17:38:31 <kzaitsev_mb> kfox1111: docaedo: yep, I thought that fuel uses it's own packaged or re-packaged packages. Have to ask around to verify that though
17:38:39 <kfox1111> I didn't think there was an upstream rpm set of packages yet.
17:38:54 <kfox1111> kzaitsev_mb: Thanks.
17:39:11 <kfox1111> I'm guessing we can adapt the rdo one I wrote with minimal effort, but I don't know for sure.
17:39:30 <kfox1111> rpms can look the same on the surface, but are very different under the hood sometimes.
17:39:42 <kfox1111> (for example, if they move everythign to /opt)
17:39:42 <docaedo> Dmitry wrote a good blog post about what's proprietary in fuel that would help
17:40:26 <kfox1111> If  Iremember correctly, fuel packages had qa'ed patches in them, and were licensed by mirantis to companies.
17:40:29 <kfox1111> per seat.
17:40:31 <docaedo> but for our purposes, the plugin for fuel would basically be a wrapper for a shell script that deploys the UI with knowledge of the internals (like fetching variables from nailgun or whatever)
17:41:37 <kfox1111> no, I'd expect the plugin to simply yum install the extra package, and most of the work woudl be in packaging up the plugin into a fuel-horizon compatable rpm.
17:42:08 <kfox1111> I don't think fuel uses venvs or things like that?
17:42:35 <docaedo> yes that's what I mean really - last time I looked at the plugin builder, we would essentially want to just write a puppet manifest that installs the package
17:42:46 <kfox1111> ah.
17:42:53 <kfox1111> yeah.
17:43:09 <docaedo> No venvs as of the march/april (last time I was paying much attention to fuel stuff)
17:43:14 <kfox1111> probably can kill two birds there, fuel and puppet-app-catalog-ui? :)
17:43:40 <docaedo> BUT Mirantis is excited about the catalog, and I am pretty sure they would want the catalog to be first class citizen in environments deployed by Fuel.
17:43:55 <docaedo> I'm all for killing all the birds :)
17:44:07 <kfox1111> hehe
17:44:10 <docaedo> but first, we need a release, and then a package :)
17:44:42 <kfox1111> +1. but, packages. :)
17:45:00 * docaedo needs to scare up some more coffee as soon as this meeting is over
17:45:06 <kfox1111> I think the debian/ubuntu one's going to be very important too.
17:45:13 <kfox1111> just don't have time for it. :/
17:45:33 <kfox1111> I'm shocked on the amount of reviewership rdo needs to get a package in.
17:45:37 <docaedo> I still have it on my todo, promise I'll take a first pass at it in the next few days
17:45:47 <kfox1111> I'm thinking debian/ubuntu probably does as well. :/
17:45:53 <kfox1111> cool. thanks.
17:45:57 <docaedo> np
17:47:07 <kfox1111> kind of lost track of the summit megameeting converstion.
17:47:18 <docaedo> haha yeah
17:47:24 <kfox1111> do we have something schedualed or an action item to get something schedualed?
17:47:53 <docaedo> #link http://odsreg.openstack.org/
17:48:34 <docaedo> #action docaedo to propose a cross-project meeting based on words that will come from a shared etherpad
17:48:49 <kfox1111> k.
17:48:52 <docaedo> #action docaedo to make the etherpad and share link on #openstack-app-catalog
17:49:55 <docaedo> I'll do that right after I rectify my coffee situation :)
17:51:10 <docaedo> ok anybody have anything else?
17:51:13 <kfox1111> cool. thanks. :)
17:51:23 <kfox1111> no, I think I used up my talking token today. ;)
17:51:28 <docaedo> haha
17:52:08 <docaedo> ok thanks as always everyone! glad we ended up having a meeting today and covering some good stuff
17:52:41 <docaedo> Talk to you on #openstack-app-catalog !
17:52:44 <docaedo> #endmeeting