17:00:30 <docaedo> #startmeeting app-catalog
17:00:34 <openstack> Meeting started Thu Sep 17 17:00:30 2015 UTC and is due to finish in 60 minutes.  The chair is docaedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'app_catalog'
17:00:50 <docaedo> #topic rollcall
17:01:00 <kfox1111> o/
17:01:05 <docaedo> o/
17:01:20 <kzaitsev_mb> o/
17:01:37 <docaedo> the usual suspects :)
17:01:40 <pkoros> o/
17:02:07 <docaedo> #topic Status updates (docaedo)
17:02:11 <pkoros> first timer!
17:02:17 <docaedo> pkoros: welcome!
17:02:18 <kfox1111> welcome. :)
17:03:16 <docaedo> one update, looks like I'm the official PTL now, which means .. not too much :) don't expect things to change too much
17:03:27 <kfox1111> yay! :)
17:03:49 <docaedo> but I will be cleaning up the group membership, which I'll announce on the ML. We have a bunch of cores that haven't touched the app catalog in many months
17:04:01 <docaedo> also need to get kfox1111  and myself added to release
17:04:25 <docaedo> and if kzaitsev_mb is not a core, he should be (again, will be handled on the mailing list for proper exposure
17:04:47 <kzaitsev_mb> I believe I'm not =) would be honored )
17:04:52 <kfox1111> status update for the horizon plugin. Have a prototype package for rdo working. in the process, found a bug. apps.openstack.org needs https support if the horizon is https.
17:05:01 <kfox1111> docaedo: +1 for kzaitsev_mb
17:05:30 <docaedo> kfox1111: yep, thanks for logging a bug, I'll get that sorted out in the next few days
17:05:52 <docaedo> #action docaedo to get SSL cert for app catalog website
17:06:17 <kfox1111> np. I also have to fix the bug on the plugin side so that it just requests the same protocol as its running, rather then just http://
17:06:28 <docaedo> good idea
17:06:56 <docaedo> the only other update of sorts I have is that I'm planning to work on adding a few heat templates in the next few days
17:07:11 <docaedo> anyone else with status updates before we move on?
17:07:48 <docaedo> #topic Discuss "new site plans" etherpad (docaedo)
17:07:55 <docaedo> #link https://etherpad.openstack.org/p/app-catalog-v2-backend
17:08:20 <kfox1111> oh. on that topic, we probably need another repo. an app-catalog-common or something like that.
17:08:36 <docaedo> After spending some time this week playing with flask and looking through it, seems like that's going to be the best choice for a framework.
17:08:38 <kfox1111> so we can put javascript/images that can be shared between apps-catalog-ui and apps.openstack.org
17:08:47 <docaedo> It's being used by keystone and a few other projects as well
17:09:42 <docaedo> kfox1111: what if we just put the shared bits in the app-catalog repo? Trying to make sure we don't start making things too complicated here :)
17:09:45 <kfox1111> k. we'll use flask, and reevaluate only if it just doesn't work well. since so many projects are using it, I wouldn't expect it to be a problem.
17:10:23 <kzaitsev_mb> +1 for flask, should be pretty straightforward )
17:10:28 <kfox1111> I can see app-catalog storing a lot of server related bits in it, that shouldn't be installed if all your doing is install the horizon plugin.
17:11:03 <docaedo> ah yeah, that makes sense
17:12:18 <kfox1111> I think app-catalog-common will end up being just some of the angular js files and some icons. Then the server/plugin will import it and add specific to that package's js/images to it.
17:12:34 <kfox1111> should be a very light repo.
17:13:10 <docaedo> sounds like that would work...
17:14:47 <kfox1111> could you put in the request for it?
17:15:05 <docaedo> I think the next step on this topic will be to make a version of the app catalog basically as-is, except served by flask (with the JSON bit built and served at the same API endpoint, except this time built dynamically by flask)
17:15:17 <docaedo> and yes, I can put in a request for the repo
17:15:21 <kfox1111> +1
17:15:38 <docaedo> #action docaedo to request a new repo for common elements shared between app-catalog and ui
17:15:59 <docaedo> so .. volunteers for that flask thing? Or shall I take it?
17:16:02 <kfox1111> One of the first features I'd like to see after that is something that keeps track of when entries were commited.
17:16:22 <kfox1111> the flask endpoint can join that date in with the contensts of assets.yaml,
17:16:36 <kfox1111> and we can tweak the website to have a dynamically kept up to date "recently added" section.
17:16:47 <docaedo> kfox1111: +1 on that, once we have the base, it'll be easy to start adding small things (though we need to think about a redesign as well, and I'm definitely not a designer...)
17:17:04 <kfox1111> k.
17:17:28 <kfox1111> yeah, I was thinking my next thing would be to move some of the generic stuff from app-catalog-ui into common,
17:17:34 <docaedo> kfox1111: I like that idea, and was along the lines of what I was thinking. That'll be a relatively easy thing to add
17:17:37 <kfox1111> and then we can source it in the site.
17:18:02 <docaedo> good plan
17:18:16 <kfox1111> we could then basically make the site look just like the horizon plugin if we wanted.
17:18:43 <kfox1111> with install links changed to pop up the dialogs that exist on the website today.
17:19:02 <kfox1111> that would make it easier to add new asset types in the futre.
17:19:13 <docaedo> yeah, sounds like a good plan
17:19:15 <kfox1111> we would just tweak the code in -common.
17:19:37 <docaedo> I think this is going to come together nicely!
17:19:55 <kfox1111> yup. :)
17:20:02 <kzaitsev_mb> so you basically want to allow theaming?
17:20:26 <docaedo> kzaitsev_mb: theming in horizon? Or as a concept for the web site?
17:20:53 <kzaitsev_mb> I might be reading it wrong
17:21:39 <kzaitsev_mb> yep, nevermind =)
17:21:46 <kfox1111> kzaitsev_mb: I'm suggesting, rather then have two different code bases, one for the site, and one for the horizon plugin, we try and share as much of the common code as we can, so that adding new features can be implemented once rather then twice.
17:22:16 <kzaitsev_mb> aha, got that. was a little confused by the "make it look like horizon" part
17:22:26 <kfox1111> so, like when we add stars/likes, we just do it in -common.
17:22:34 <kfox1111> ah. sry.
17:22:54 <docaedo> OK I think that's a lot covered on the new website front, and feels like we're on the same page. I have some work to do now! moving on?
17:23:09 <kfox1111> yup. k.
17:23:19 <docaedo> #topic Open discussion
17:23:50 <docaedo> pkoros: did you have anything you wanted to discuss? Or just joining to learn more about what we're up to?
17:24:23 <docaedo> and of course, anyone else, feel free to speak up if there's anything you wanted to discuss
17:25:56 <docaedo> I didn't have anything to discuss, so unless someone else speaks up in the next minute or two I think we'll be done
17:26:41 <pkoros> just joining to learn more..
17:27:04 <docaedo> pkoros: cool - be sure to join us on #openstack-app-catalog, that's where all the REAL action is ;)
17:27:34 <pkoros> ok
17:28:09 <docaedo> guess we're done, thanks everyone - I'll enumerate the next few things I'll be doing and (probably) put things up in blueprints
17:28:31 <docaedo> #endmeeting