16:00:00 <cdent> #startmeeting api-wg
16:00:01 <openstack> Meeting started Thu Jul 27 16:00:00 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'api_wg'
16:00:17 <edleafe> \o
16:00:20 <cdent> #chair edleafe elmiko
16:00:21 <openstack> Warning: Nick not in channel: elmiko
16:00:22 <openstack> Current chairs: cdent edleafe elmiko
16:00:43 <dtantsur> o/
16:00:54 <cdent> edleafe: you willing to run the show today, I’m flagging from my cold and not got a ton of attention
16:01:02 <elmiko> o/
16:01:21 <edleafe> sure - just finishing up something else
16:01:30 <cdent>16:02:07 <edleafe> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:02:16 <edleafe> small group today
16:02:23 <edleafe> (as usual :)
16:03:21 <edleafe> #topic previous meeting action items
16:03:23 <edleafe> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/
16:03:40 <edleafe> #undo
16:03:40 <openstack> Removing item from minutes: #link http://eavesdrop.openstack.org/meetings/api_wg/2017/
16:03:46 <edleafe> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-07-20-16.00.html
16:03:58 <edleafe> (more precise)
16:04:22 <edleafe> Only one there is: elmiko investigate moving the wiki guided review document into gerrit, somehow
16:04:29 <elmiko> yup
16:04:32 <elmiko> 1sec
16:04:39 <edleafe> #link https://review.openstack.org/487847
16:04:46 <edleafe> elmiko: ^^
16:04:59 <elmiko> thanks, beat me to it =)
16:05:20 <cdent> good stuff there
16:05:24 * edleafe had it open already
16:05:50 <elmiko> to cdent's point in the comments, my hope is that a good example review will clear up confusions about what to expect in the conrete
16:05:54 <elmiko> *concrete
16:06:55 <edleafe> elmiko: I understood that to mean that we don't want to give the impression that a group will come in,
16:06:59 <elmiko> also, on the point of guided reviews. i have some approval to travel for the ptg, but i will most likely have to limit myself to 1 or 2 days
16:07:07 <edleafe> and we will announce a clear solution to their problems
16:07:13 <elmiko> ahh, right
16:07:42 <edleafe> So maybe we need to add 'facilitate discussion' to set expectations
16:07:58 <elmiko> i like that
16:08:13 <edleafe> And this doc is just an idea base for what we'd like to send out, right?
16:08:27 <elmiko> i think so, just a starting point
16:08:59 <elmiko> we can continue to hack on it, and then i hope it would live as a document in that page to help teams figure out how to approach the wg for help
16:09:06 <edleafe> How about we refine that so that it has the text of what we will eventually send out to PTLs?
16:09:18 <elmiko> +1
16:09:46 <edleafe> Part of it is long-lived, but it's also a way to work out specifics for what we'd like to do in Denver
16:09:56 <elmiko> totally agree
16:10:37 * cdent nods
16:10:52 <elmiko> so, i'll take an action to revise for next week
16:11:19 <elmiko> #action elmiko revise guided review process pr to incorporate managed expectations for participants
16:11:23 <elmiko> sound good?
16:11:32 <edleafe> yup
16:11:34 <cdent> yup
16:11:41 <elmiko> cool
16:11:54 <edleafe> moving on
16:11:55 <edleafe> #topic open mic and new biz
16:12:05 <elmiko> question about the ptg
16:12:09 <edleafe> sure
16:12:25 <elmiko> do we know if we'll have a single day session or two days? (it was unclear to me from the spreadsheet)
16:12:41 <cdent> two, last I checked
16:12:49 <cdent> do you have a link to the spreadsheet?
16:12:56 <elmiko> ok, so the green shading was the marker then
16:12:58 <edleafe> I don't
16:13:01 <elmiko> yeah, 1sec
16:13:43 <elmiko> #link https://docs.google.com/spreadsheets/d/1xmOdT6uZ5XqViActr5sBOaz_mEgjKSCY7NEWcAEcT-A/edit#gid=397241312
16:14:06 <cdent> yeah, green is "scheduled"
16:14:13 <cdent> xl room
16:14:28 <elmiko> cool, i'm gonna make my plans around those days then. with luck, i'll get final approval =)
16:14:30 <edleafe> Ooooh - living large!
16:14:37 <elmiko> living _extra_ large!
16:14:44 <edleafe> :)
16:15:50 <edleafe> Anyone else have anything to discuss?
16:15:57 <elmiko> that's all i had
16:16:19 <cdent> no sirs
16:16:40 <edleafe> #topic guidelines
16:16:50 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:17:17 <edleafe> Besides elmiko's doc, there is the typo fix from efried
16:17:20 <cdent> I added a new one, sort of fixing a bug
16:17:29 <cdent> #link https://review.openstack.org/#/c/487504/
16:17:51 <edleafe> oops - missed that one
16:18:05 <edleafe> Monty's are moribund
16:18:33 <edleafe> So is Sean's, although efried just added some comments to that
16:19:47 <edleafe> What do we want to do (if anything) about the merge conflict for the version stuff?
16:19:53 <cdent> does efried’s count as a typo fix and thus okay to fast merge
16:20:16 <elmiko> is that this one?
16:20:17 <elmiko> #link https://review.openstack.org/#/c/478638/
16:20:20 <cdent> I think there’s enough other desired changes on the version stuff that we can let it sit until mordred returns from worl travels
16:20:31 <cdent> yes elmiko
16:21:09 <elmiko> that one looks ok to me
16:21:21 <edleafe> is efried's dependent on the other patches?
16:21:28 <edleafe> or the other way around?
16:21:55 <mordred> heya!. yes
16:21:57 * elmiko looks
16:22:01 <cdent> it had been, but he changed earlier today
16:22:06 <mordred> I believe we'll be able to make progres on the version patch again by next week
16:22:27 <elmiko> mordred: cool!
16:22:29 <edleafe> mordred: no, drop everything you're doing and FIX IT NOW!!!!!
16:22:33 <elmiko> lol
16:22:33 <mordred> fwiw, all of the things in it have now landed in keystoneauth and been released - so we've got a great reference case for verifying it now
16:22:34 <edleafe> :-P
16:22:47 <elmiko> good to hear
16:23:02 <mordred> (and I think cmurphy and efried now have all the context in the world so can give excellent reviews)
16:23:13 <edleafe> mordred: awesome news
16:23:31 <mordred> also - it's not QUITE on topic - but in case y'all missed it, the os-service-types lib has a 1.0 release out :)
16:23:35 <mordred> so that's a thing now
16:23:44 <edleafe> woo hoo
16:23:55 <mordred> I'm more than happy to add any of you who are interested to the core team on that one
16:24:39 <edleafe> Not a heavy workload, I'd assume?
16:24:59 <mordred> it does not currently fetch from https://service-types.openstack.org directly as we ran into some intersection between the cachecontrol and requests-mock libs -so while we have working code for that, it's currently not testable :)
16:25:10 <mordred> edleafe: nope. the lib should basically almost never change
16:25:18 <mordred> except for landing remote-fetching support
16:25:26 <elmiko> nice to hear about the levels of standardization happening, very encouraging
16:25:27 <mordred> but that's not urgent and we can do it next cycle
16:25:32 <edleafe> Not a lot of work? Sign me up!!
16:25:37 <elmiko> haha
16:25:56 <mordred> elmiko: yah. it's honestly super exciting. getting this stuff into nova - and I think ironic is looking at a use-the-catalog patch too
16:26:18 <elmiko> very cool
16:26:24 <elmiko> long time coming, for sure
16:26:27 <dtantsur> we will be looking, I think, yes
16:27:50 <edleafe> Anything else to add about guidelines?
16:28:23 <edleafe> #topic bug review
16:28:24 <edleafe> #link https://bugs.launchpad.net/openstack-api-wg
16:28:31 <edleafe> Nothing new in that list
16:28:55 <cdent> I did a bug!
16:28:58 <cdent> I’m so proud of myself
16:29:25 <elmiko> +1
16:29:27 * edleafe hands cdent a cookie
16:29:31 <elmiko> i'm proud of you as well
16:29:33 <cdent> nom nom
16:29:56 <edleafe> #topic weekly newsletter
16:29:58 <edleafe> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:30:05 <edleafe> Any takers?
16:30:10 * cdent hides
16:30:31 <elmiko> i can do it
16:30:41 * edleafe can still see cdent
16:30:44 <elmiko> LOL
16:30:46 <edleafe> thanks elmiko
16:31:06 * cdent hides more er er
16:31:22 <edleafe> So... are we done?
16:31:46 <cdent> looks that way, unless dtantsur has something exciting?
16:31:53 <dtantsur> nope
16:32:02 <edleafe> OK - thanks everyone!
16:32:04 <edleafe> #endmeeting