16:00:45 <elmiko> #startmeeting api-wg
16:00:46 <openstack> Meeting started Thu Jul 20 16:00:45 2017 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:50 <openstack> The meeting name has been set to 'api_wg'
16:00:56 <elmiko> #chair edleafe
16:00:58 <openstack> Current chairs: edleafe elmiko
16:01:16 <dtantsur> o/
16:01:17 <edleafe> \o
16:01:20 <elmiko> hi
16:01:28 <elmiko> #chair cdent
16:01:28 <openstack> Current chairs: cdent edleafe elmiko
16:01:29 <edleafe> #chair cdent
16:01:30 <openstack> Current chairs: cdent edleafe elmiko
16:01:33 <edleafe> jinx!
16:01:36 <elmiko> hehe =)
16:01:41 <cdent> my communism was getting tested over in openstack-tc
16:01:43 <elmiko> i owe you some beverage i suppose
16:01:52 <elmiko> wow, sounds interesting
16:02:19 <edleafe> I don't want to know
16:02:21 <elmiko> just a head's up before we start, i have a hard stop at quarter till the hour
16:02:54 <cdent> my efforts to model openstack problems as a conflict between labor and rentiers doesn’t quite work
16:03:03 <elmiko> haha
16:03:07 <elmiko> sounds hilarious though
16:03:12 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:03:20 <elmiko> #topic previous meeting action items
16:03:29 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/
16:03:56 <elmiko> ok, so we were all supposed to chew on the idea of the ptg review stuff
16:04:13 <elmiko> and due to a stray ":" cdent's action item for me never got committed XD
16:04:21 <elmiko> but, i created a thing anyways
16:04:39 <elmiko> #link https://wiki.openstack.org/wiki/API_Working_Group/Guided_Review_Process
16:04:51 <elmiko> my hope was to get the ball rolling and just throw out a few ideas
16:05:11 * cdent reads
16:05:32 * edleafe reads too
16:06:27 <edleafe> So it sounds like a wider-ranged approach than what I had in mind
16:06:29 <edleafe> "Pick a general area of your API to focus on"
16:06:42 <elmiko> well, that was just my first stab
16:06:49 <dtantsur> mmm, interesting. I suspect Ironic could use a review or two
16:06:59 <edleafe> I was thinking more like "pick an API that is causing controversy among team members"
16:07:21 <elmiko> my hope is that interested parties will look at their api, figure out some questions they have about api-wg guidelines, and then start a review
16:07:25 <edleafe> The general approach would be excellent for new APIs, though
16:07:39 <elmiko> edleafe: i agree with the "pick an API..." approach
16:08:21 <cdent> it is certainly _far_ easier to do a review when there is a known conflict or question
16:08:27 <elmiko> yeah, i tried to hint that teams should pick something a little more specific, but maybe that wasn't clear enough
16:08:36 <cdent> having people rock up and say “do you like our api” is hard to get any leverage
16:08:42 <elmiko> totally
16:09:20 <elmiko> so, maybe #1 should say "pick a specific part of your API" instead?
16:09:20 <edleafe> "No, your API sucks. Next!"
16:09:23 <elmiko> LOL
16:09:24 <dtantsur> lol
16:09:40 <elmiko> edleafe: come on, cdent would be way more tactful than that!
16:09:41 <dtantsur> reserve a slot or two for us, we have a few long-standing problems
16:10:08 <elmiko> dtantsur: you're first in line apparently =)
16:10:16 <dtantsur> good :)
16:10:36 <elmiko> bear in mind, this is just a proposal at this point
16:10:45 <dtantsur> sure, sure :)
16:10:55 <cdent> Could we say “priority will be given to those applicants who are trying to make a choice between two or more options…” <blah blah bsomething mumble>
16:11:52 <cdent> or “if you come to us with some choices, it will be like so much easier…”
16:11:55 <elmiko> i will certinaly go back and make it more clear that teams with specific requests will be given priority over general "is it gud?" questions
16:12:08 <edleafe> Oooh... I like it! Makes it sound like there will be a line down the hallway waiting to get in
16:12:14 <elmiko> right
16:12:40 <elmiko> makes no sense to spend an entire session look at one entire api when we could answer several smaller questions in the same time
16:12:43 <cdent> r i gud? u r gud.
16:12:50 <elmiko> exactly
16:13:17 <cdent> they’re good apis lmeeeko
16:13:24 <elmiko> would it be easier to review and collaborate on this document if i try to make it a review in gerrit to the specs repo or something?
16:13:25 <dtantsur> LOL
16:13:49 <cdent> yeah, elmiko, we can make it a sort of guideline itself
16:13:49 <dtantsur> ++ for a review for anything
16:13:54 <elmiko> indeed, they are... /me pats on head gently
16:14:05 <elmiko> ok
16:14:08 <edleafe> no, not a guideline - those get permanently published
16:14:19 <edleafe> just a note of some sort
16:14:23 <elmiko> yeah
16:14:34 <elmiko> like one of the extra docs we have on the specs repo
16:15:02 <elmiko> hmm
16:15:17 <elmiko> i thought about this while writing it, that wiki is terrible for collaborating with review
16:15:26 <elmiko> but i wanted to get something started
16:15:44 <cdent> I was thinking that permanently published is a good thing: as in “this is a thing we do at ptgs”
16:15:58 <cdent> when ptgs stop or we stop going to ptgs, then the guideline can be marked dead
16:16:28 <elmiko> so, how about this:
16:16:48 <elmiko> #action elmiko investigate moving the wiki guided review document into gerrit, somehow
16:16:56 <cdent> yes
16:17:06 <elmiko> ack
16:18:03 <edleafe> kewl
16:18:11 <elmiko> ok, then, any more on this topic?
16:18:36 <elmiko> #topic open mic and new biz
16:18:49 <elmiko> nothing on the agenda, any new biz to bring up?
16:19:02 <edleafe> not from me
16:19:15 <cdent> nor me, this phase of the cycle is very project oriented
16:19:32 <elmiko> cool
16:19:33 <elmiko> #topic guidelines
16:19:40 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:19:50 <elmiko> was there any movement since last meeting?
16:20:09 <elmiko> looks like we're still waiting
16:20:14 <edleafe> I admit to not having spent much time on any of those
16:20:27 <elmiko> likewise, i used up my time last week writing the doc =(
16:21:00 <cdent> I looked a couple days ago, and the main thing is mordred’s stuff and he’s actively implementing some of it in ksa at the moment, so productively distracted
16:21:26 <elmiko> got it
16:21:47 <elmiko> ok, so for now we're kinda in a holding pattern unless we get some new work
16:22:13 <cdent> yes
16:22:23 <elmiko> #topic bug review
16:22:36 <elmiko> i'm guessing same story here, albeit with different main characters ;)
16:23:05 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg
16:23:50 <elmiko> at some point, maybe we should do a bug triage or something just to make sure all these are still relevant
16:24:18 <elmiko> possibly plan a meeting to be a bug triage meeting and just spend the hour going through the list?
16:24:21 <cdent> that’s a good idea, but I don’t reckon there’s that much of a rush. the last time we did a bug run was to create most of them based on the todo’s in the existing guidelines
16:24:37 <elmiko> ok, i'm good with that too
16:24:56 <edleafe> Yeah, I keep thinking I should grab a TODO every now and then
16:24:57 <cdent> part of the current malaise is that edleafe and I are too wrapped up in placement related stuff
16:25:02 <edleafe> Then other work gets in the way
16:25:13 <elmiko> i feel ya, work... feh.
16:25:44 <elmiko> i'm more or less completely enmeshed in kubernetes and spark stuff
16:26:19 <elmiko> ok, moving along
16:26:20 <elmiko> #topic weekly newsletter
16:26:26 <cdent> there will be some surfacing in a week or two? (Im unsure when feature freeze is)
16:26:30 <elmiko> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:26:34 <elmiko> cool
16:26:36 <cdent> I guess it is probably my turn?
16:26:46 <elmiko> that would be grand, thank you sir
16:26:52 <edleafe> yes, thank you
16:27:02 <cdent> will ping for a proof
16:27:29 <elmiko> i will try to read it, but i'm doing another meeting after this for like 2 hours
16:27:47 <elmiko> anything else to bring up?
16:27:55 <elmiko> everyone having a good thursday so far?
16:28:01 <cdent> nothing else to bring
16:28:06 <cdent> relatively good thursday
16:28:08 <cdent> many bugs found
16:28:10 <elmiko> nice =)
16:28:14 * edleafe pulls out empty pockets
16:28:17 <elmiko> haha
16:28:36 * elmiko gives edleafe a quarter for a cup of coffee
16:28:46 <elmiko> ok, thanks everybody!
16:28:50 <elmiko> #endmeeting