16:00:03 <cdent> #startmeeting api_wg
16:00:06 <openstack> Meeting started Thu Apr 13 16:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <openstack> The meeting name has been set to 'api_wg'
16:00:14 <elmiko> heyo/
16:00:23 <edleafe> \o
16:00:30 <cdent> #chair cdent elmiko edleafe
16:00:30 <openstack> Current chairs: cdent edleafe elmiko
16:00:44 <cdent> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:00:48 * dtantsur lurks as he's in 2 more meetings
16:00:57 <elmiko> oof
16:01:14 <cdent> #link last meeting notes http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-04-06-16.00.html
16:01:23 <cdent> #topic old biz
16:01:33 <cdent> elmiko to continue thinking about how to discuss and formulate what we do
16:01:46 <cdent> that appears to be on the agenda for the opens, so that's a good start
16:01:53 <cdent> elmiko and cdent to decide (with input from everyone) about how to do summit
16:01:53 <elmiko> score!
16:02:00 * cdent looks at elmiko and shrinks
16:02:05 <elmiko> i did think about it too, but that's more difficult to capture
16:02:14 <elmiko> without maybe a blog post /me looks at edleafe
16:02:17 <cdent> I don't reckon I did anything in that regard
16:02:32 <elmiko> for me it kinda breaks down into a couple issues
16:02:35 <edleafe> me neither
16:02:46 <elmiko> 1. staying true to the original intent
16:02:52 <elmiko> 2. growing the group
16:03:10 <edleafe> 3. free bagels
16:03:10 <elmiko> if we stick 1, then there is a clear end-line for the group
16:03:17 <elmiko> oh wait, i vote #3
16:03:24 <elmiko> can we add that to our mission?
16:03:58 <edleafe> elmiko: Not unless we also add lox and cream cheese
16:04:15 <cdent> we have bagels here every week (real ones from new york), did you not know?
16:04:23 <elmiko> edleafe: you are so talking my language
16:04:33 * elmiko wants bagels
16:05:02 <cdent> I guess it is safe to say
16:05:07 * edleafe gets serious again
16:05:07 <cdent> #topic new biz and opens
16:05:11 <elmiko> anyways, bagel talk aside, i think the best way to discuss if we should grow or not, or expand the mission is probably best left for a face-to-face
16:05:29 <edleafe> We need to define the "original intent" clearly enough that it attracts new blood
16:05:33 <elmiko> or emails or something, it's a big topic to unpack
16:05:36 <elmiko> for me at least
16:05:54 <elmiko> edleafe: yeah, i'm not sure that's possible if it's just "guidelines"
16:06:14 <elmiko> otoh, keeping it the way it is gives the group a finite mission. which can also be desirable
16:06:20 <cdent> we could follow the time honoured tradition of pushing a review of the mission and chatting in gerrit but I'm not sure that would capture the full breadth and depth of things
16:06:47 <elmiko> yeah, i don't think it would
16:06:53 <edleafe> Let's have a meeting about that, but we might first need a pre-meeting to refine the topic
16:06:58 <cdent> for me the thing that start this was the assertion that guidelines were both the activity and the goal
16:07:09 <cdent> edleafe: please speak with my pa to set that up
16:07:13 <elmiko> lol
16:07:33 <edleafe> The guidelines are the means to reach the goal, which is a better API experience for consumers of OpenStack
16:08:20 <elmiko> that's a good way to put it
16:09:28 <cdent> after the amount of time and effort put into the interoperability guideline and the amount of questions it opened, I'm less concerned about any finite lifetime than I used to be. There's loads left to do.
16:10:07 <edleafe> Now we have to worry about *our* finite lifetimes
16:10:10 <elmiko> i guess what i'm driving at with that is the notion that the guidelines could eventually be mostly done
16:10:13 <cdent> 'xactly
16:10:14 <elmiko> haha
16:10:46 <cdent> elmiko: yeah, I no longer really think the guidelines are that close to done, and even if they were, going back to the oldest one and starting over again is a useful activity
16:10:50 <elmiko> like, i can envision a situation where we have most cases covered for openstack and *have* improved the api experience for consumers
16:10:59 <elmiko> cdent: fair
16:11:17 <cdent> on that front: we rarely talk to consumers, so until we do, we don't really know that much with any confidence
16:11:50 <elmiko> maybe there is a possibility for growth, community outreach to our "customers" as it were
16:12:05 <elmiko> although, is there another wg that does that?
16:12:34 <cdent> some people have recommended that we speak more and more often with the interop wg and product wg (and probaby others)
16:13:44 <edleafe> That sounds like a forum thing
16:13:44 <elmiko> i think that makes good sense when we consider the idea of improving the api for consumers
16:13:52 <cdent> yes and yes
16:14:15 <elmiko> but, it also makes me wonder what is our tool for improving the experience when we acknowledge that the guidelines are opt-in?
16:14:30 * elmiko still wants to avoid becoming the api police
16:15:21 <elmiko> i guess the tags will be helpful in this regard
16:15:51 <cdent> to some extent
16:16:26 <cdent> but if you put on this api-police hat, we might make progress more quickly
16:16:33 * cdent gives elmiko a very nice hat
16:16:49 * edleafe wants a spiffy uniform to go with it
16:17:06 <cdent> https://www.youtube.com/watch?v=hn1VxaMEjRU
16:17:32 <elmiko> LOL
16:18:08 <edleafe> https://www.youtube.com/watch?v=kHVI5fAzWq0
16:18:14 <cdent> So, perhaps the next step on this topic is for elmiko and I to speak to whomever is willing to chat while at forum, and get a feel for the lay of the land.
16:18:25 <elmiko> cdent: i'm good with that
16:18:39 <cdent> #action elmiko and cdent prepare to chat about the future at forum
16:19:30 <elmiko> edleafe: oh man, that link
16:19:30 <cdent> okay
16:20:00 <cdent> any other new biz or open discussion? anyone else here besides elmiko, edleafe and lurking dtantsur ?
16:21:01 <cdent> #topic guidelines
16:21:10 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:22:05 <cdent> #link pagination https://review.openstack.org/#/c/446716/
16:22:23 <cdent> that currently has only one +1 so I guess it is difficult to call it ready
16:22:26 * cdent quickly reviews it
16:22:39 <edleafe> Yeah, I was gonna ask you guys to review that soon
16:22:55 <elmiko> ack, i'll take a look now
16:24:41 <cdent> #link interoperability https://review.openstack.org/#/c/421846/
16:24:59 <cdent> only has one +1 as well, but has been through so many rounds now...
16:25:09 <cdent> dtantsur: did my cleanups satsify you enough?
16:25:26 <dtantsur> cdent, did not have a chance to check, sorry :(
16:25:31 <cdent> #link correct method for http tags https://review.openstack.org/#/c/451536/
16:25:32 <dtantsur> ETOOMANYTHINGSTODO
16:25:32 <edleafe> I think that those rounds of butting heads has at least aired a lot of the important views on this
16:25:43 <cdent> that one looks definitely ready to freeze, so I will
16:25:58 * dtantsur will try to quickly check today before going on PTO
16:26:06 <elmiko> i love this addition, "These definitions assume that client code is written to follow the
16:26:09 <elmiko> standards of HTTP."
16:26:54 <cdent> thanks dtantsur
16:27:00 <edleafe> elmiko: yeah, that's just crazy talk
16:27:05 <elmiko> haha, right
16:35:31 <cdent> were you still thinking about doing the other guideline spawned from the interoperatbility, edleafe ?
16:35:34 <cdent> elmiko: long road
16:36:02 <edleafe> cdent: yeah, I could
16:36:11 <edleafe> I'm about to leave for a long weekend though
16:36:19 <cdent> i don't think there's any rush is there?
16:36:27 <edleafe> So as with the functional tests, remind me next week
16:36:36 <edleafe> The rush is my increasingly fleeting memory
16:36:37 <cdent> ya
16:36:45 <dtantsur> functional tests?
16:36:45 <cdent> #topic bug review
16:36:53 <cdent> dtantsur: nova resource tracker stuff
16:37:05 <cdent> #link https://bugs.launchpad.net/openstack-api-wg
16:37:09 <dtantsur> ah ok
16:37:22 <cdent> no new bugs
16:37:41 <cdent> dtantsur: because edleafe is getting on a bit in age, he needs help from others to remember things for him
16:37:53 <cdent> unfortunately he's chosen me and I think I'm pretty much as old as he is
16:38:01 <elmiko> ouch, savage!
16:38:15 <cdent> edleafe: maybe we should get dtantsur to remember?
16:38:23 <elmiko> could we add biting sarcasm to the mission statement?
16:38:24 <cdent> he's already said he's not got enough to do
16:38:24 <edleafe> Hey, cdent, get off my lawn!
16:38:26 <dtantsur> WUT?
16:38:29 * dtantsur hides
16:38:46 <elmiko> i feel like we could produce copious quantities
16:39:09 <cdent> possible because of all that aforementioned trust
16:39:15 <elmiko> haha, true dat
16:39:21 <cdent> #topic weekly newsletter
16:39:30 <dtantsur> api-wg: sarcasm as a service \o/
16:39:31 <cdent> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:39:35 <elmiko> i can take it this week
16:39:43 <cdent> elmiko: woot
16:39:54 <cdent> dtantsur: saas is perfect
16:40:00 <elmiko> lol
16:40:12 <elmiko> can we get the logo designers to invite a "snarkhog" ?
16:40:22 <elmiko> s/invite/invent/
16:40:26 <edleafe> People would pay to have SaaS *un*installed
16:40:31 <elmiko> LOL
16:40:39 <elmiko> oh man, i know what business i need to be in
16:41:15 <dtantsur> lol
16:41:29 <elmiko> cdent: just to be clear, we are feezing pagination and interop?
16:41:39 <elmiko> freezing.. sigh, /me needs the long weekend
16:41:40 <cdent> and https://review.openstack.org/#/c/451536/
16:41:55 <elmiko> thanks
16:42:55 <cdent> next week I have an internal meeting that overlaps this one, so while I'll be here, somebody else probably ought to run it
16:43:41 <elmiko> ok, i should be able to run it
16:43:50 <cdent> hurrah
16:44:56 * cdent moves some links around on newsletter
16:47:22 <cdent> oh, question about future linkage on the newsletter. when we link in a published guideline do you think we should link to the review or the actually published thing at specs.openstack.org?
16:48:12 <edleafe> cdent: if it's the published one, then the s.o.o one would be best
16:48:22 <cdent>16:48:32 <cdent> I don't think we've done that in the past, but I agree we should.
16:48:32 <elmiko> agreed
16:48:38 <edleafe> a review can always be superseded
16:48:43 <elmiko> tell me how that paragraph looks
16:49:03 <cdent> #agreed when publishing links to published guidelines use specs.openstack.org
16:49:17 <elmiko> cdent: thanks for fixing the freeze links
16:50:09 <cdent> paragraph looks good to me
16:51:00 <elmiko> if edleafe has no objections, i'll ship it
16:51:09 <edleafe> None from me
16:51:43 <cdent> yeah, ship it
16:51:50 <elmiko> cool, thanks!
16:52:15 <cdent> no, thank you
16:53:02 <cdent> anyone else have anything they'd like to say or report? or shall we call it a day?
16:53:12 <elmiko> nothing from me
16:53:30 * edleafe fades to black
16:53:50 <cdent> thank you and goodnight
16:53:51 <cdent> #endmeeting