16:00:10 <edleafe> #startmeeting api-wg
16:00:11 <openstack> Meeting started Thu Jan 26 16:00:10 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:14 <openstack> The meeting name has been set to 'api_wg'
16:00:16 <cdent> o/
16:00:25 <etoews> o/
16:00:31 <edleafe> #chair cdent elmiko etoews edleafe
16:00:32 <openstack> Warning: Nick not in channel: elmiko
16:00:33 <openstack> Current chairs: cdent edleafe elmiko etoews
16:00:46 <cdent> I'm present, but also on a voice call, so may experience latency
16:00:53 <edleafe> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:13 <edleafe> #topic previous meeting action items
16:01:17 <edleafe> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/
16:01:29 <edleafe> No action items from last week
16:01:41 <edleafe> #topic open mic and new biz
16:01:51 <edleafe> Updating stability/compatibility guidelines: https://review.openstack.org/#/c/421846/ and http://lists.openstack.org/pipermail/openstack-dev/2017-January/110384.html
16:02:15 <cdent> my efforrts to engage the commonweal are not progessing as I hoped :(
16:02:30 <edleafe> #link https://review.openstack.org/#/c/421846/
16:02:32 <edleafe> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/110384.html
16:03:07 <edleafe> I keep meaning to comment on them, but I keep getting distracted by the FF pressures
16:03:15 <etoews> the usual suspects showed up :)
16:03:21 <etoews> edleafe: FF?
16:03:26 <etoews> fantastic four?
16:03:33 <edleafe> etoews: sorry - Feature Freeze
16:03:57 <edleafe> etoews: I would prefer the Fantastic Four!
16:04:06 <cdent> especially human torch
16:05:26 <edleafe> cdent: you had the note in the agenda: "What about projects that don't use microversions or version boundaries of any kind."
16:05:51 <cdent> that seems to be one of the sticking points in the current discussion
16:06:22 <edleafe> Can we just add "if not, you're hosed"
16:06:29 <etoews> pretty much
16:06:41 <etoews> versioning software. terrible idea.
16:07:28 <cdent> the issue there is that some people want the stability concept to apply globally but it's hard to do without some versioning, unless you never change
16:07:33 <cdent> but since some projects don't microversion they struggle (e.g. glance)
16:07:50 <cdent> on the flip side, because some projects microversion, they change all the freaking time
16:08:04 <cdent> which runs rather contrary to the concept of real stability
16:08:20 <cdent> instead that's backwards support capability, which is not really the same thing
16:08:27 <cdent> but is perhaps what people really mean
16:08:40 <stevelle> stability for whom becomes the question
16:08:50 <edleafe> "We won't break old clients"
16:09:09 <edleafe> ...except if your client doesn't understand how to request a microversion
16:09:16 <etoews> backwards support i definitely at the top of most people's minds
16:09:18 <cdent> stevelle: you're a good example of someone who ought to jump into that thread :)
16:09:35 <etoews> s/i/is/
16:10:11 <edleafe> cdent: Your other note was "Anything formal for PTG?"
16:10:13 <edleafe> #link https://etherpad.openstack.org/p/ptg-architecture-workgroup
16:11:05 <cdent> yeah, so it turns out thanks to the good graces of the foundation, I will be at the PTG. I think there's plenty of cross project stuff we can probably horn in on (like the service catalog stuff scottda wants to get rolling) but I wondered if we needed or wanted to have an official schmooze
16:11:06 <edleafe> We'll see if there is any interest for that
16:11:32 <edleafe> "that" being the architecture wg topic
16:11:43 <scottda> hi
16:11:47 * scottda is late
16:11:49 <edleafe> heyo
16:12:57 <etoews> i won't be at the ptg but something formal might be helpful to drive some of the more contentious guidelines forward
16:13:45 <etoews> hell, just pick exactly one contentious guideline and attempt to drive resolution/consensus
16:13:57 <cdent> capabilities will probably come up
16:14:15 <edleafe> that certainly meets the definition of 'contentious'
16:14:33 <cdent> 'xactly
16:14:44 <etoews> that, pagination, or change guidelines are all good candidates
16:14:51 <cdent> yes
16:15:05 * etoews stops offering opinions on an event he won't be attending
16:15:25 <edleafe> etoews: no worries; we'll just assign everything we decide on to you
16:15:36 <cdent> I think it will be interesting to see how the the unconference style of orchestrating the whole week is going to work out
16:15:47 <cdent> it all seems a bit chaotic, but that's perhaps good
16:15:53 <edleafe> So the API WG doesn't have a formal space assigned
16:16:19 <edleafe> Do we a) horn in on another group, or b) ask ttx for our own space (if available)
16:16:57 <cdent> i'm not sure I can commit to be in any particular space at any particular time
16:17:15 <edleafe> sort of amorphous?
16:17:27 <cdent> i have taken on the form of an amoeba
16:18:04 <edleafe> Looks-wise, it's gotta be an improvement
16:18:05 <edleafe> :)
16:18:16 <cdent> duh amn
16:19:33 <edleafe> ok, so we'll just kinda join the architecture wg? Maybe send them a note? Or mention it at their next meeting?
16:19:49 <cdent> i'll be at their next meeting, so yeah, I'll do that
16:20:09 <cdent> #action cdent schmooze with arch-wg for ptg party time
16:20:15 <edleafe> That's today at 4pm CST
16:20:22 <edleafe> Kinda late for you?
16:21:19 <cdent> I started late today. I start late on tuesday and thursday to hang with those cool west coast kids
16:22:02 <edleafe> gotcha
16:22:12 <edleafe> I'll try to make it too, but no promises
16:22:32 <edleafe> My daughter gets out of school at different times every day
16:23:54 <edleafe> anyway, let's move on
16:24:04 <edleafe> #topic guidelines
16:24:04 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:24:07 <edleafe> What's ready to freeze? Or what's not, what's missing?
16:24:10 <edleafe> What's ready to merge?
16:24:26 <cdent> nothing
16:24:34 <cdent> cuz nothing is frozen
16:24:48 <edleafe> For freeze, I think these are ready
16:24:51 <edleafe> - Clarify the status values in versions
16:24:51 <edleafe> - Add guideline for invalid query parameters
16:24:51 <edleafe> - Add guidelines on usage of state vs. status
16:25:02 <edleafe> no objections there
16:25:11 <cdent> yeah, that sounds right
16:25:24 <edleafe> There is still some back-and-forth on 'Add guidelines for boolean names'
16:25:25 <cdent> who wants to do the freezing (and notifying) honors?
16:25:42 <edleafe> not me, since I'm not sure of the process
16:25:54 <cdent> a) I'll do it, b) remind me to tell you at some point
16:26:17 <edleafe> #action edleafe to remind cdent to show him how to freeze + notify
16:26:35 <etoews> edleafe: here's the process http://specs.openstack.org/openstack/api-wg/process.html
16:26:42 <etoews> i think that's mostly up-to-date
16:26:45 <edleafe> If others can weigh in on the boolean naming, that would be awesome
16:27:10 <edleafe> Monty's preference sounds odd to me, but apparently it works for them
16:27:21 <edleafe> I'd like others' input
16:27:51 <edleafe> etoews: thanks for the link
16:28:11 <etoews> lemme look at the boolean guideline. i'm a bit behind on reviews. :(
16:28:58 <edleafe> the pagination and capability discovery patches could also use some input/discussion
16:30:29 <cdent> I think those will likely stay a bit stalled through FF time
16:30:37 <cdent> probably get a reboot at PTG?
16:30:59 <edleafe> they would be good to discuss, although pagination is pretty close
16:31:28 <edleafe> IAC, please add your comments to the reviews
16:31:32 <edleafe> Let's move on
16:31:33 <edleafe> #topic bug review
16:31:35 <edleafe> #link https://bugs.launchpad.net/openstack-api-wg
16:31:57 <cdent> nada new?
16:32:13 <edleafe> Nothing jumps out at me
16:32:44 <edleafe> Reminder to anyone who wants to start to contribute: these bugs are a great place to start!
16:33:01 <edleafe> Most are just tracking missing parts of guidelines
16:33:45 <edleafe> #topic weekly newsletter
16:33:46 <edleafe> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:33:55 <edleafe> cdent: you up for that one?
16:34:21 <cdent> yup sure, but will be a bit slow
16:34:46 <cdent> will ping when I need some proofreading
16:34:48 <edleafe> I don't think that time is of the essence here
16:35:07 <edleafe> So... anything else from anybody?
16:35:28 <edleafe> Or do we let cdent get down to just one meeting at a time?
16:35:34 <etoews> nope. i'm +1 on the boolean guideline.
16:35:48 <cdent> it's lonely on this other meeting, you guys are _much_ more fun
16:36:18 <edleafe> cdent: Glad we could entertain you
16:36:23 <edleafe> #endmeeting