15:59:41 <cdent> #startmeeting api wg
15:59:42 <openstack> Meeting started Thu Jun 16 15:59:41 2016 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:45 <openstack> The meeting name has been set to 'api_wg'
15:59:51 <cdent> #chair etoews
15:59:52 <openstack> Current chairs: cdent etoews
16:00:00 <etoews> well hello
16:00:06 <edleafe> \o
16:00:09 <cdent> good afternoon
16:00:24 <aimeeu> 0/
16:00:26 <edleafe> good UGT morning!
16:00:28 <cdent> #link agenda: https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:13 <cdent> no action items from last meeting
16:01:18 <etoews> :)
16:01:28 <cdent> and I think we should do the newletter near the end so next is
16:01:46 <cdent> #topic address all of the TODOs in the guidelines (turn them into bugs?)
16:02:00 <mfedosin> o/
16:02:27 <cdent> I suspect I made that entry, which was effectively: let's agree to do that. Do we agree?
16:02:55 <edleafe> bugs would certainly be easier to track
16:03:43 <cdent> #agreed make todos in guidelines into bugs for easier tracking and stigmergy
16:03:53 <etoews> grep -R TODO * | wc -l == 18
16:05:06 <etoews> so how do we do that?
16:05:08 <cdent> etoews: if you paste that grep into an etherpad, we can divide the list up into the number of people here and do it right now
16:05:14 <etoews> ++
16:05:20 <cdent> as in make stubby buglets
16:05:31 * edleafe learned a new word: stigmergy
16:06:02 <etoews> #link https://etherpad.openstack.org/p/api-wg-todos-to-bugs
16:06:03 <cdent> edleafe: that's probably one of my favorite concepts when it comes to remote collaboration
16:06:50 <cdent> There are at least three of us. Anyone else want to take a chunk of those, or shall we split by three?
16:07:27 <cdent> i've taken a chunk
16:07:33 <edleafe> threesies is fine
16:08:34 <edleafe> one bug per TODO or one per file?
16:10:00 <cdent> per todo
16:10:00 <cdent> granularity is nice
16:10:03 <etoews> per todo
16:10:06 <cdent> https://bugs.launchpad.net/openstack-api-wg
16:10:33 <etoews> and i'm going to link back to http://git.openstack.org/cgit/openstack/api-wg/
16:10:35 <etoews> in the bug
16:11:56 <etoews> hmmmm...how do i get git.o.o to ref a certain commit
16:12:32 <etoews> so when we remove the TODOs the back links are still valid
16:13:03 * cdent has never been able to figure cgit, so always ends up back at github :(
16:13:44 <etoews> me too :(
16:13:51 <etoews> i'm okay with back links to github
16:14:58 <etoews> yep. i'm using github links.
16:15:45 <etoews> cdent: edleafe: shall we tag these with "todo" so we know where they came from?
16:15:54 <etoews> tag all of these that is
16:16:22 <cdent> makes sense
16:16:27 <edleafe> yeah, sounds sane
16:16:35 <etoews> here's my first crack at it https://bugs.launchpad.net/openstack-api-wg/+bug/1593305
16:16:35 <openstack> Launchpad bug 1593305 in openstack-api-wg "HEAD is weird in a bunch of our wsgi frameworks" [Undecided,New]
16:20:21 <etoews> ha! already done this one. https://bugs.launchpad.net/openstack-api-wg/+bug/1593308
16:20:21 <openstack> Launchpad bug 1593308 in openstack-api-wg "The recommended way of transmitting error/fault information back to the user" [Undecided,New]
16:20:32 <etoews> filed bug because pedantic
16:23:30 <etoews> no, i need to report a new bug
16:23:47 <edleafe> I did me one too! https://bugs.launchpad.net/openstack-api-wg/+bug/1593312
16:23:47 <openstack> Launchpad bug 1593312 in openstack-api-wg "compatibility.rst is missing the Guidance section" [Undecided,New]
16:24:36 * etoews copies everything cdent is doing in https://etherpad.openstack.org/p/api-wg-todos-to-bugs
16:25:11 <cdent> ?
16:25:17 * edleafe is doing the same
16:26:26 <etoews> cdent: the strike through and link to bug
16:26:32 <cdent> ah
16:27:00 <cdent> I only have time to do that because I'm not being as luxurious as you with links back github, just referencing the guideline filename
16:27:22 <etoews> i'm all about link luxury
16:27:37 <etoews> i'm done with my set
16:27:42 * edleafe is also copying etoews links format
16:27:50 <edleafe> I'm lagging
16:27:54 <etoews> going to remove the TODO from the files.
16:28:05 <edleafe> why remove?
16:28:27 <etoews> why keep?
16:29:08 <etoews> i'd rather not have 2 things tracking the work
16:29:12 <edleafe> Because it's easier to find when editing?
16:29:35 <cdent> todo is now an official tag
16:30:04 <etoews> they also clutter the guidelines/code
16:30:19 <etoews> cdent: any feels on removing the TODOs or not?
16:30:45 <cdent> I think removing them will introduces process noise because they'll have to wend their way through gerrit
16:31:09 <cdent> and leaving them in place in the published version helps people to know that we are aware that there is stuff still to do
16:31:11 <etoews> i commit to remove them isn't too noisy
16:31:17 <etoews> 1 commit...
16:31:39 <cdent> if it were code I'd say yes, for sure, but since it is narrative I think it is useful, here comes that word again, stigmergy
16:31:53 <cdent> but I'm not super concerned either direction
16:32:42 <etoews> this also speaks to the next topic. "get out of draft mode"
16:33:11 <cdent> true
16:33:32 <etoews> a) is that even something we want?
16:34:04 <etoews> currently "draft" is pretty much meaningless to me
16:34:17 <etoews> i don't think it carries any meaning for openstack-land either
16:34:22 <cdent> the main question I have on that is that here http://specs.openstack.org/openstack/api-wg/ it sounds like this is just for giggles and has no meaning
16:34:33 <cdent> I'd be fine with just removing that note
16:34:37 <etoews> let's do it
16:34:46 * cdent does it
16:35:08 <etoews> cdent: does having 18 TODOs in the guidelines affect our decision to remove it?
16:35:19 <cdent> I don't think it should
16:35:27 <cdent> because was want to think of the guidelines as a live thing
16:35:33 <etoews> yep
16:35:42 <cdent> my concern with that header was that it seemed like we weren't even born yet
16:35:43 <edleafe> just as having 18 todo bugs doesn't affect it :)
16:36:13 <etoews> alrighty. we'll keep the TODOs and remove the "draft mode".
16:37:31 <etoews> this is good fodder for the newsletter. we should definitely do the newsletter in the later half of the meeting. but first...
16:37:50 <etoews> aimeeu: mfedosin: welcome to the api wg meeting. :)
16:38:05 <mfedosin> etoews: hi!
16:38:06 <etoews> was there something you care to discuss in particular?
16:38:15 <mfedosin> nothing special
16:38:32 <mfedosin> but I wanted to say that the spec is updated
16:38:35 <etoews> just checking in after the glare review?
16:38:42 <etoews> gotcha
16:38:49 <mfedosin> and we simplified glare api dramatically
16:38:58 <mfedosin> https://review.openstack.org/#/c/283136/10/specs/newton/glare-api.rst@906
16:38:59 <etoews> always good to hear!
16:39:09 <mfedosin> thanks cdent :)
16:39:13 <cdent> mfedosin: excellent work tuning that stuff up
16:39:32 <cdent> #link https://review.openstack.org/330687 Get rid of the DRAFT warning at the top of guidelines
16:41:40 <etoews> mfedosin: i just noticed the /versions
16:41:50 <etoews> have you looked at https://review.openstack.org/#/c/254895/1/guidelines/versioning.rst ?
16:42:22 <mfedosin> but how user will know what versions are supported?
16:42:23 <cdent> edleafe: would you like some assistance with the rest of your chunk of todos or are you good?
16:42:49 <cdent> goes to look at /versions
16:43:04 <etoews> mfedosin: that's the point of that guideline
16:43:29 <etoews> Each service should advertise the API versions exposed by the service and the endpoint from where that service can be accessed. The purpose of this document is to standardize the format for these responses.
16:43:44 <etoews> which is your intention behind /versions right?
16:44:12 <mfedosin> etoews: return a list of available api versions I think
16:44:58 <cdent> mfedosin: ah, yeah, so what you are proposing at /versions could be at / and following the guideline at http://specs.openstack.org/openstack/api-wg/guidelines/microversion_specification.html#version-discovery
16:45:25 <edleafe> cdent: I'm good. On the last ones
16:45:42 <cdent> etoews: looks like we might have a bit of an overlap between versioning.rst and the microversion spec ?
16:45:59 <etoews> just saw that. they're in conflict.
16:46:03 <etoews> :(
16:46:23 <mfedosin> cdent: so, we can return version just by GET / request?
16:46:57 <etoews> i think the nature of the conflict is microversions expose their versions one way, everything else does something a little differently.
16:47:28 <cdent> mfedosin: sort of, but see what etoews just said
16:48:02 <etoews> cdent: mfedosin: i'd say glare should stick to http://specs.openstack.org/openstack/api-wg/guidelines/microversion_specification.html#version-discovery since it's doing microversions
16:48:38 <etoews> my bad for confusing things but at least we uncovered the conflict.
16:48:41 <mfedosin> etoews: ok, it was done for bringing compatibility with Glance
16:48:59 <etoews> that matters too :)
16:49:01 <cdent> etoews: make a bug?
16:49:12 <mfedosin> I'll update the spec in a minute
16:49:25 <cdent> or should we (you! :) ) just comment on the versioning guideline since it is not merged yet?
16:49:53 <etoews> cdent: ya. a comment is more appropriate. i'll do it now.
16:50:02 <etoews> cdent: do you want to start on the newsletter?
16:50:21 <cdent> yeah, I've got the etherpad up, will start on it
16:50:25 <etoews> ++
16:51:02 <edleafe> cdent: done
16:52:23 <Dinesh_> Hi all,
16:53:54 <Dinesh_> Could you please give your suggestions on this: https://review.openstack.org/#/c/315964/
16:55:11 <cdent> Hi Dinesh_
16:55:21 <etoews> commented on https://review.openstack.org/#/c/254895/1
16:55:52 <cdent> Dinesh_: Is there a disagreement on it?
16:56:44 <edleafe> cdent: partial disagreement
16:56:59 <edleafe> basically, strict status checking
16:57:45 <edleafe> IOW, if you pass an invalid status (which nothign could match), should you get a 200 with an empty list, or a 400
16:57:58 <cdent> etoews: we started to discuss this last week, but did we decide about abandoning old tired reviews that are not getting attention?
16:58:18 <cdent> edleafe: ah.
16:59:23 <etoews> cdent: i don't recall a decision...
16:59:40 <cdent> I want to put a friendly threat of some kind in the newsletter
16:59:41 <etoews> or the discussion for that matter :P
17:00:06 <etoews> heh. sure. why not.
17:00:13 <etoews> time!
17:00:26 <etoews> #endmeeting