#openstack-meeting-3: api wg

Meeting started by etoews at 16:00:58 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 16:01:57)

  1. previous meeting action items (etoews, 16:02:28)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-03-10-16.00.html (etoews, 16:02:35)

  2. Tackling TODOs in existing guidelines (etoews, 16:04:01)
    1. ACTION: start tracking todos and other planning style issues for wg in launchpad openstack-api-site (cdent, 16:15:14)
    2. ACTION: cdent to create openstack-api-wg launchpad (cdent, 16:17:45)

  3. Doc: RST plus parameters YAML files as substitute for Compute API not fitting Swagger/OpenAPI (etoews, 16:18:17)
    1. https://review.openstack.org/#/c/294078/ (etoews, 16:18:26)
    2. https://etherpad.openstack.org/p/api-site-in-rst (sdague, 16:19:04)
    3. https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:wip_api_docs (sdague, 16:24:16)
    4. https://github.com/openstack/keystone-specs/tree/master/api (elmiko, 16:28:19)

  4. Do a cross project session? (etoews, 16:35:28)
    1. https://etherpad.openstack.org/p/newton-cross-project-sessions (etoews, 16:35:35)
    2. https://etherpad.openstack.org/p/austin-api-wg-session-plans (cdent, 16:40:16)

  5. Etags and the lost update problem (etoews, 16:45:25)
    1. https://www.w3.org/1999/04/Editing/ (cdent, 16:46:43)
    2. ACTION: cdent starts an etag guideline (cdent, 16:56:18)
    3. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z is not loading for me (etoews, 16:58:39)


Meeting ended at 16:59:30 UTC (full logs).

Action items

  1. start tracking todos and other planning style issues for wg in launchpad openstack-api-site
  2. cdent to create openstack-api-wg launchpad
  3. cdent starts an etag guideline


Action items, by person

  1. cdent
    1. cdent to create openstack-api-wg launchpad
    2. cdent starts an etag guideline
  2. openstack
    1. start tracking todos and other planning style issues for wg in launchpad openstack-api-site
    2. cdent to create openstack-api-wg launchpad


People present (lines said)

  1. elmiko (84)
  2. etoews (68)
  3. sdague (58)
  4. cdent (56)
  5. annegentle (47)
  6. dstanek (4)
  7. stevelle (3)
  8. openstack (3)
  9. dims (1)


Generated by MeetBot 0.1.4.