#openstack-meeting-3: api wg

Meeting started by elmiko at 16:00:17 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (elmiko, 16:00:36)

  1. previous meeting action items (elmiko, 16:01:54)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2016/api_wg.2016-02-11-16.00.html (cdent, 16:03:42)
    2. https://review.openstack.org/#/c/280381/ (cdent, 16:04:49)
    3. http://lists.openstack.org/pipermail/openstack-dev/2016-February/087086.html (cdent, 16:05:28)

  2. service type vs. project name for use in headers (elmiko, 16:06:55)
    1. http://lists.openstack.org/pipermail/openstack-dev/2016-January/085145.html (elmiko, 16:07:13)
    2. http://eavesdrop.openstack.org/meetings/tc/2016/tc.2016-02-02-20.01.log.html#l-263 (elmiko, 16:07:20)
    3. api-wg has agreed that service type is the preferred usage (elmiko, 16:08:06)

  3. taking on the service type registry (elmiko, 16:08:21)
    1. https://etherpad.openstack.org/p/service-registry-format (cdent, 16:10:49)
    2. http://git.openstack.org/cgit/openstack/service-types-authority/tree/ (cdent, 16:13:24)
    3. ACTION: : cdent to clarify if people want the radical change to microversion headers (cdent, 16:23:58)
    4. ACTION: cdent get a position from ironic and manilla projects on modernization of microversion headers (cdent, 16:26:30)

  4. header values (elmiko, 16:30:14)
    1. ACTION: cdent guideline giving best practices for header right side values (cdent, 16:33:48)

  5. the trouble with names (elmiko, 16:34:22)
  6. cache invalidation (elmiko, 16:35:27)
  7. Glance-Glare (Artifacts) (elmiko, 16:36:09)
    1. https://review.openstack.org/#/c/283136/ (nikhil, 16:36:47)
    2. http://developer.openstack.org/api-ref-image-v2.html (mfedosin, 16:41:27)

  8. guidelines for freeze (elmiko, 16:55:07)
    1. https://review.openstack.org/#/c/243429/ (elmiko, 16:55:57)
    2. https://review.openstack.org/#/c/243414/ (elmiko, 16:56:04)


Meeting ended at 16:59:23 UTC (full logs).

Action items

  1. : cdent to clarify if people want the radical change to microversion headers
  2. cdent get a position from ironic and manilla projects on modernization of microversion headers
  3. cdent guideline giving best practices for header right side values


Action items, by person

  1. cdent
    1. : cdent to clarify if people want the radical change to microversion headers
    2. cdent get a position from ironic and manilla projects on modernization of microversion headers
    3. cdent guideline giving best practices for header right side values


People present (lines said)

  1. elmiko (151)
  2. cdent (71)
  3. nikhil (32)
  4. mfedosin (28)
  5. sdague (17)
  6. openstack (7)
  7. stevelle (2)


Generated by MeetBot 0.1.4.