00:01:02 <elmiko> #startmeeting api wg
00:01:03 <openstack> Meeting started Thu Jun 25 00:01:02 2015 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:01:06 <openstack> The meeting name has been set to 'api_wg'
00:01:15 <elmiko> anyone here?
00:02:45 <ryansb> \o
00:02:57 <ryansb> if it's just us, we can skip this week
00:03:06 <elmiko> yea
00:03:16 <elmiko> i do appreciate the re-review on the 5xx stuff, thank you =)
00:06:10 <ryansb> np, anything else dying for review?
00:06:21 <ryansb> I think I hit all the frozen ones.
00:06:23 <elmiko> hmm
00:06:37 <elmiko> i'm really curious to hear what people think about the 1xx advice, if we need it or not.
00:06:51 <elmiko> i had an extended conversation with notmyname and lifeless about it
00:07:15 <elmiko> and basically our advice is, use it if you need to, but be sure you read the rfc and the wsgi docs.
00:07:25 <elmiko> which kinda does seem like non-advice. i dunno
00:07:53 <elmiko> i think i could re-write the guidance, but i could use some.... guidance ;)
00:08:28 <lifeless> is it something we see people making mistakes on?
00:08:33 <ryansb> Yeah, I'd probably say it's not necessary guidance
00:08:33 <lifeless> HTTP is HUGE
00:08:42 <lifeless> writing a shadow RFC is going to consume you :)
00:08:44 <ryansb> since afaik nobody has asked about it
00:08:49 <ryansb> lifeless: lol
00:08:59 <lifeless> I wrote up a spreadsheet once
00:09:02 <elmiko> it was added in the spirit of completeness, so that we had something for each category of response
00:09:11 <lifeless> of all the MUST, MUST NOT, etc etc etc in HTTP/1.1
00:09:17 <elmiko> and?
00:09:22 <lifeless> hundreds of rows
00:09:27 <elmiko> lol ouch
00:10:17 <ryansb> o.O
00:10:30 <elmiko> my question for the group is, is it worth it to add a small paragraph or two describing that mostly the 1xx series doesn't need to be used manually, but that 100 should get special attention and to be carefule when using it (paraphrase)?
00:11:02 <lifeless> I think it got lost when the squid-cache server had a crash
00:11:41 <ryansb> fair, but no more than 2.
00:12:37 <elmiko> "two paragraphs only Mr. Vasily" ;)
00:12:46 <ryansb> lol
00:13:04 <lifeless> ahhhttp://web.archive.org/web/20041204194210/http://devel.squid-cache.org/squidhttp1.1.htm
00:13:07 <lifeless> http://web.archive.org/web/20041204194210/http://devel.squid-cache.org/squidhttp1.1.htm
00:13:17 <ryansb> gotta make sure we don't alert the americans. :)
00:13:27 <elmiko> hehe
00:13:38 <lifeless> so just under 500 distinct requirement
00:13:50 <elmiko> lifeless: impressive
00:13:55 <ryansb> lifeless: goodness...
00:14:00 <lifeless> yeah
00:14:11 <lifeless> so- I think we should provide advice on things people get wrong
00:14:13 <lifeless> not on the spec
00:14:22 <lifeless> cause - bottomless pit of despair
00:14:30 <lifeless> we've had 0 occurences of this being wrong :)
00:15:01 <lifeless> sigmavirus24: oh yeah - you'll likely find ^^^ entertaining, speaking of RFC-heads :)
00:15:16 <elmiko> so, 1 for yes, 1 for no... ಠ_ಠ
00:15:24 <sigmavirus24> oh right
00:15:29 <sigmavirus24> Forgot about this meeting
00:15:29 <sigmavirus24> sorry
00:15:33 <elmiko> np
00:16:39 <ryansb> sigmavirus24: break the tie!
00:16:51 * sigmavirus24 is reading the scrollback
00:16:56 * sigmavirus24 wonders where miguelgrinberg and stevelle are
00:18:06 <sigmavirus24> Yeah I was worried we were reiterating in shorter, less clear (to some) language what the HTTP specs say
00:18:45 <sigmavirus24> I'm not sure how much of HTTP the protocol we need to cover. Error codes make sense, but I'm not certain we need guidance for every class
00:18:56 <sigmavirus24> I doubt anyone is misusing 301/302/307/308 for redirects
00:19:17 <sigmavirus24> And I doubt their misusing permanent redirects otherwise requests would have already been yelled at on the openstack-dev mailing list again
00:19:31 <elmiko> ok, fair. i'll abandon the 1xx review
00:19:45 <sigmavirus24> Sorry for all that hassle elmiko
00:20:06 * sigmavirus24 goes back to hacking on cryptography
00:20:08 <elmiko> no problem, i learned a ton about 100-continue thatnks in no small part to lifeless
00:20:44 <elmiko> the only other question i had for the group, was about moving this guideline into freeze
00:20:48 <elmiko> #link https://review.openstack.org/#/c/180094
00:20:59 <elmiko> any thoughts? (seems like we have good approval so far)
00:21:32 <ryansb> +1, freeze it
00:22:13 <sigmavirus24> F-f-f-f-f-f-freeze it
00:22:22 <elmiko> hehe, ok. will do
00:22:42 <elmiko> #action elmiko to freeze and notify about https://review.openstack.org/#/c/180094
00:23:22 <elmiko> well, if no one else has a topic i suppose we can close this out and take back the 35 minutes left =)
00:24:04 <sigmavirus24> woot
00:24:10 <sigmavirus24> more time to run cryptography's tests =P
00:24:15 <sigmavirus24> all 140k+ of them
00:24:15 <elmiko> lol
00:24:20 <elmiko> thanks everybody!
00:24:24 <ryansb> lucky you
00:24:26 <elmiko> #endmeeting