16:00:31 <annegentle> #startmeeting api wg
16:00:32 <openstack> Meeting started Thu Apr 23 16:00:31 2015 UTC and is due to finish in 60 minutes.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:37 <openstack> The meeting name has been set to 'api_wg'
16:00:44 <annegentle> etoews: do you want to run the agenda for half?
16:00:47 <etoews> o/
16:00:51 <etoews> sure
16:00:57 <annegentle> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:00 <stevelle> o/
16:01:04 <miguelgrinberg> hello
16:01:44 <annegentle> hi
16:02:00 <etoews> #topic previous meeting action items
16:02:13 <etoews> #link http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-04-16-00.00.html
16:02:48 <etoews> oh. it was just me.
16:02:52 <edleafe> o/
16:03:00 <etoews> i managed to get to those 2 things.
16:03:18 <etoews> #topic cross-project meeting
16:03:28 <etoews> Cross-Project meeting log #link http://eavesdrop.openstack.org/meetings/crossproject/2015/crossproject.2015-04-21-21.02.log.html
16:03:45 <etoews> i attended the cross-project (cp) the other day
16:03:50 <etoews> meeting that is
16:04:16 <etoews> just searching for ways to get more viz and more traction for the api wg.
16:04:33 <etoews> i think step 1 will simply be attending that meeting regularly
16:04:49 <sigmavirus24_awa> sorry that I'm late
16:04:52 <elmiko> etoews: +1
16:05:01 <etoews> i'll bring up any guidelines we have that are ready for final review
16:05:27 <annegentle> etoews: I think that's a great place
16:05:32 <etoews> we can't wait on the API CPLs forever so i proposed we give them a week for final review and then merge
16:05:42 <annegentle> etoews: +1
16:05:47 <etoews> everyone seemed agreeable
16:06:04 <etoews> we do need to be sensitive for the time in the release cycle
16:06:24 <etoews> CPLs are a lot busier around release and summit time
16:06:46 <annegentle> right
16:07:15 <etoews> in conjunction with that i'll send out an email to -dev and -operators to highlight the guidelines ready for review.
16:07:19 <sigmavirus24_awa> should we perhaps (going forward) have a freeze on acceptance during this period to make it easier on CPLs?
16:07:37 <elmiko> nice idea
16:08:04 <etoews> sigmavirus24_awa: what exactly do you mean by freeze on acceptance?
16:08:27 <annegentle> "look now or forever hold your peace"?
16:08:30 <sigmavirus24_awa> In other words, we would signal that we think it's done in some way, but wait to merge the actual guideline
16:08:34 <annegentle> or is it "hold your piece"
16:08:52 <sigmavirus24_awa> annegentle: I honestly don't know
16:09:11 <sigmavirus24_awa> etoews: perhaps 2 +2's where one of them also -1's the Workflow
16:09:37 <dtroyer> if there has been a long discussion it might be nice to summarize, sometimes the lengthy comments don't get read, especially if they're in the patchsets
16:09:51 <annegentle> dtroyer: good point
16:10:31 <etoews> i think the email to -dev and -operators is the signal. along with mentioning them in the cp meeting.
16:10:31 <annegentle> dtroyer: sort of like what sdague did when summarizing discussion at the ops midcycle for nova (or was it Russel?) Anyway, summarizing for audience.
16:11:47 <edleafe> annegentle: 'peace'
16:11:56 <annegentle> edleafe: thanks :) been in Tejas too long
16:11:57 <etoews> sigmavirus24_awa: is this explicit -1 freeze on acceptance done in other projects?
16:12:05 <edleafe> annegentle: saying the latter might get you in trouble :)
16:12:23 <sigmavirus24_awa> etoews: to a degree, yes
16:12:27 <sigmavirus24_awa> etoews: with specs and with code
16:12:43 <annegentle> etoews: I've seen it with specs
16:13:11 <etoews> okay. let's give it a try.
16:13:16 <elmiko> sahara has had -2 freezes at times, depending on the release state
16:15:08 <etoews> #action etoews freeze the 3 current guidelines up for final review
16:15:30 <etoews> #topic APIChangeGuidelines wiki page
16:15:41 <etoews> #link https://wiki.openstack.org/wiki/APIChangeGuidelines
16:16:10 <etoews> this wiki page came up in a discussion on -dev
16:16:25 <etoews> it caused a bit of confusion
16:16:33 <elmiko> looks like it needs some love
16:16:46 <etoews> i think it just need to be migrated into our repo
16:16:57 <miguelgrinberg> +1, should be a guideline
16:17:02 <etoews> as a series of patches
16:17:25 <annegentle> etoews: sure, it can be
16:17:34 <annegentle> that's from TC work a few years back
16:17:46 <etoews> ah. good to know.
16:18:12 <annegentle> something beyond "gentleman's agreement" was the goal (hate to use gender specific lang but that's my recollection)
16:18:27 <etoews> "human's agreement"
16:18:50 <edleafe> "gentlehuman's agreement"
16:18:54 <etoews> anybody up for tackling moving those guidelines into the repo?
16:18:59 <annegentle> etoews: heh. Well, it was approved, so it's the guidelines, so seems fine to move in the wg repo
16:19:05 <etoews> "gentleanne's agreement"
16:19:08 <edleafe> annegentle: +1
16:19:09 <elmiko> lol
16:19:12 <annegentle> what was the confusion on list? any recap?
16:19:20 <etoews> 1 sec.
16:19:21 <annegentle> :)
16:19:45 <elmiko> so, just to be clear. these should be written up as guidelines according to the repo and then submitted as reviews?
16:20:00 <annegentle> elmiko: I think so, but want to know what the controversy/confusion was
16:20:44 <etoews> #link http://lists.openstack.org/pipermail/openstack-dev/2015-April/062050.html
16:20:53 <etoews> no controvery, minor confusion
16:21:09 <elmiko> do we then change the wiki page to point towards the repo?
16:21:20 <annegentle> elmiko: yep sure can
16:21:21 <sigmavirus24_awa> elmiko: I would think so
16:21:27 <elmiko> k
16:22:03 <etoews> in the email, ian wells basically describes the api wg repo but doesn't know it already exists.
16:22:13 <annegentle> got it
16:23:09 <annegentle> so, if I recall right, the API WG repo will contain guidelines, then we present to TC, then eventually we may publish to governance.openstack.org, which will then take care of the "advertise that page a little more widely" concern
16:23:12 <annegentle> is that right
16:23:18 <annegentle> er, that's a question :)
16:23:40 <edleafe> annegentle: Try adding the '?' character  :)
16:23:57 <etoews> i did not even know governance.openstack.org existed :|
16:24:06 <annegentle> :) I want slack-style up arrow edit
16:24:08 <elmiko> i thought we were trying to back off of TC being a gate for the guidelines, with exceptions for controversial changes?
16:24:10 <etoews> but yes, something like that.
16:24:14 <annegentle> etoews: yeah it's not super well advertised
16:24:24 <annegentle> elmiko: not sure, that's why I'm asking.
16:24:30 <elmiko> ah, cool.
16:24:39 <annegentle> (and I'm the TC, so... wanting to clarify)
16:24:41 <elmiko> would be awesome to have these on governance.os.o
16:24:56 <annegentle> I think of it as the TC needed a working group to dive into details.
16:25:03 <etoews> elmiko: see #5 of http://specs.openstack.org/openstack/api-wg/process.html
16:25:23 <elmiko> etoews: ack, thanks
16:25:38 <annegentle> right, there we go
16:25:49 <dtroyer> this doesn't seem to me like the sort of thing that should go in governance
16:25:58 <etoews> they'll be official guidelines.
16:26:12 <elmiko> dtroyer: is governance more about the foundation?
16:26:42 <dtroyer> no, but it's also not about specific technical implementation details
16:26:42 <annegentle> dtroyer: what else would be a pointer for reviews? I think of it as a reference guide. (can't think of another subdomain that fits)
16:27:12 <dtroyer> I could see a pointer from governance out to the various working group docs to lend the 'this is good' label
16:28:18 <annegentle> dtroyer: pointer to specs.openstack.org would work
16:28:36 <annegentle> I think so anyway
16:28:43 <elmiko> dtroyer: that makes sense
16:28:45 <dtroyer> that sounds good
16:29:12 <annegentle> ok good. I can update the wiki page with that intention
16:29:27 <annegentle> er. process.html is not a wiki page :)
16:29:37 <etoews> i think we can firm that up down the road a bit.
16:29:46 <etoews> back to the topic
16:29:47 <annegentle> elmiko: yep
16:29:53 <annegentle> er, etoews: yep
16:30:13 <etoews> how do we go about moving https://wiki.openstack.org/wiki/APIChangeGuidelines to the repo?
16:30:32 <annegentle> elmiko: you up for it? I can't until at least May
16:30:53 <elmiko> sure, i can take a stab at it
16:31:05 <annegentle> elmiko: I do have some history/familiarity so I'm happy to help
16:31:16 <elmiko> annegentle: awesome, expect questions =)
16:31:22 <annegentle> elmiko: cool, thanks
16:31:25 <etoews> it doesn't necessarily have to be a 1 person effort
16:31:38 <etoews> yep. reach out for help as necessary elmiko. thanks!
16:32:02 <elmiko> maybe a change to test the new template.. /shameless-plug
16:32:06 <etoews> #action elmiko to investigate moving https://wiki.openstack.org/wiki/APIChangeGuidelines to the api wg repo
16:32:06 <elmiko> *chance
16:32:10 <etoews> yes
16:32:44 <etoews> 1 sec.
16:33:40 <etoews> the template just merged. nice work elmiko!
16:33:45 <annegentle> :)
16:33:47 <elmiko> \o/
16:34:20 <etoews> #topic API WG at the Summit
16:34:48 <etoews> so there are a bunch of time slots at the summit out there for working groups
16:35:26 <etoews> considering the summit schedule #link https://docs.google.com/spreadsheets/d/1VsFdRYGbX5eCde81XDV7TrPBfEC7cgtOFikruYmqbPY/edit#gid=569963128
16:36:01 <etoews> would late wed afternoon or early thurs morning work for people?
16:37:00 <annegentle> slight preference for late wed. afternoon
16:37:09 <elmiko> same for me
16:38:37 <etoews> sigmavirus24_awa dtroyer stevelle miguelgrinberg edleafe ^
16:38:57 <miguelgrinberg> I'm good for both
16:39:01 <sigmavirus24_awa> I'm okay with whatever. I am bad at figuring out what sessions I'll be going to
16:39:08 * cdent sighs
16:39:09 <sigmavirus24_awa> I don't think that conflicts with glance sessions fo rme though
16:39:11 <cdent> calendar fail
16:39:11 <dtroyer> either for me
16:39:22 <stevelle> etoews: I don't see a conflict
16:40:06 <miguelgrinberg> the rooms look all taken on Wed and Thurs though.  How does this work?
16:40:20 <etoews> these are different rooms
16:40:32 <sigmavirus24_awa> etoews: are these rooms just the lawn outside the center?
16:40:36 <etoews> opened up for working groups
16:40:42 <sigmavirus24_awa> are you tricking us into going outside?
16:40:48 <annegentle> heh
16:40:52 <etoews> maybe if it's a nice day :)
16:41:05 <annegentle> "rooms" scarequotes
16:41:59 <edleafe> I have potential conflicts all over (nova), so everything's a crap shoot
16:42:00 <etoews> okay. i'll book us in for wed afternoon and maybe sometime on thurs too in case we feel we need it.
16:42:14 <stevelle> session agenda features picking dandelions and rolling in grass I hope
16:42:22 <annegentle> sweet
16:42:34 <etoews> steamroller!
16:43:05 <etoews> there's also the official Cross-project track session
16:43:07 <dtroyer> actually, we're on the water…fishing poles anyone?
16:43:11 <etoews> sessions
16:43:19 <etoews> #link https://docs.google.com/forms/d/1LJZxdxE8P2F0WoULZEsRCXeqZP_VgH5nWUdZlbcA68M/viewform?c=0&w=1
16:43:35 <etoews> should we also submit an official cp track session?
16:43:48 <etoews> basically just for more viz?
16:44:04 <annegentle> etoews: there's one for Service Catalog now
16:44:30 <annegentle> #link https://docs.google.com/spreadsheets/d/1vCTZBJKCMZ2xBhglnuK3ciKo3E8UMFo5S5lmIAYMCSE/edit#gid=827503418
16:44:38 <annegentle> that's the list of already-proposed ^^
16:44:43 <etoews> row 18
16:45:12 <annegentle> I believe there are 17 slots, 19 proposed
16:45:13 <etoews> i see sdague would like us to drive
16:45:32 <annegentle> I told him I would at the TC meeting Tuesday.
16:45:40 <etoews> +1 annegentle
16:45:55 <annegentle> I was supposed to edit it, but you know, privileges.
16:46:20 <etoews> alright. well maybe i'll throw an official cp session out there.
16:46:37 <annegentle> I think it would be good to do a "state of the WG" session
16:46:47 <etoews> good idea
16:47:04 <etoews> i'll do that
16:47:09 <annegentle> cool thanks etoews
16:47:21 <etoews> #action propose a state of the api wg cp session
16:47:54 <etoews> i've only got a few min left
16:48:05 <etoews> did we want to talk about meeting times?
16:48:19 <etoews> the thread on -dev kinda went nowhere.
16:48:48 <miguelgrinberg> what are the new proposed times? I don't remember
16:48:54 <etoews> just leave it as is and have a poorly attended meeting every other week?
16:49:23 <elmiko> i'll keep showing up for the late meeting, even if it's only a couple of us ;)
16:49:25 <etoews> we couldn't come up with a good time that satisfied all timezones (of course)
16:49:54 <dtroyer> is the Thurs 00:00 meeting a good time for anyone other than US Pacific?
16:50:01 <etoews> cdent: what timezone are you?
16:50:10 <etoews> dtroyer: probably not
16:50:22 <cdent> BST
16:50:27 <dtroyer> persoanly, I could do later, but right at dinnertime (US Central) is hard
16:50:49 <sigmavirus24> ==dtroyer
16:51:04 <elmiko> the tough issue was getting something that is reasonable for the asia contingent, but it's also tough to gauge how big that group is :/
16:51:30 <cdent> there's not been a lot of feedback from the ml
16:51:36 <etoews> right
16:51:37 <elmiko> =(
16:51:43 <dtroyer> we have some experience with an existing slot, I was wondering how inconvenient that one was for them
16:51:44 <edleafe> thurs evening is never good for me
16:51:51 <edleafe> other nights would be much better
16:52:08 <dtroyer> edleafe:  this is wed evening in US
16:52:32 <annegentle> I can never make the evening ones...
16:52:52 <etoews> i'd prefer a very early meeting (cdt) to an evening meeting if that worked for other timezones
16:53:05 <annegentle> me too
16:53:18 <stevelle> a very early meeting CDT will exclude US Pacific
16:53:29 <miguelgrinberg> etoews: that leaves west coast out
16:53:32 <etoews> ah. i gotta go. can someone bump the ml thread on this?
16:53:48 <elmiko> etoews: i'll give it a kick ;)
16:53:57 <etoews> oh right. very early west coast then if possible.
16:54:01 <etoews> bye!
16:54:08 <etoews> thx elmiko!
16:54:08 <annegentle> bye etoews!
16:55:09 <annegentle> ok what's next on the agenda
16:55:44 <annegentle> Hm, Swift?
16:55:52 <annegentle> #topic Swift
16:55:58 <annegentle> What's that about, anyone have more context?
16:56:00 <notmyname> hi
16:56:03 <annegentle> hi notmyname
16:56:07 * notmyname saw "swift"
16:56:14 <annegentle> have more context to offer? It's on our agenda
16:56:23 <sigmavirus24> notmyname: so if I say "swift" elsewhere, I can summon you that easily? =P
16:56:28 <elmiko> lol
16:56:29 <notmyname> pretty much ;-)
16:56:40 <dtroyer> say it three times and see what happens!
16:56:50 <annegentle> I've seen it. it works :)
16:57:18 <sigmavirus24> dtroyer: do I need to be looking into a mirror?
16:57:22 <annegentle> heh
16:57:33 <annegentle> Are there any guidelines in review that notmyname could take a look at?
16:57:51 <annegentle> Or is it the classic "data apis are data apis" discussion?
16:58:03 <annegentle> Or the iOS language?
16:58:05 <annegentle> I kid, I kid
16:58:15 <notmyname> or that singer person
16:58:26 <annegentle> "shake it off"
16:58:52 <annegentle> Ok, two minutes
16:58:54 <notmyname> or Students With an Interest in the Future of Technology (which is what the #swift channel on IRC is for)
16:58:59 <annegentle> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:59:01 <annegentle> ha
16:59:19 <annegentle> Those are the reviews in progress, and Everett sent the deadline to CPLs on the mailing list.
16:59:35 <annegentle> for guidelines
16:59:41 <annegentle> then for APIImpact
16:59:43 <annegentle> #link https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z
17:00:19 <annegentle> I just triaged about 25 docimpact bugs today, some with apiimpact, but all _should_ have had apiimpact.
17:00:20 <elmiko> annegentle: usually we try to spend a little time for folks to bring up reviews from that list. probably not time now though
17:00:24 <annegentle> yeah
17:00:34 <annegentle> Well that's our hour, so the links are in the minutes now.
17:00:39 <annegentle> #endmeeting