#openstack-meeting-3: api wg

Meeting started by etoews at 00:00:21 UTC (full logs).

Meeting summary

  1. agenda (etoews, 00:01:43)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 00:01:49)

  2. previous meeting action items (etoews, 00:04:04)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2014/api_wg.2014-12-04-16.01.html (etoews, 00:04:19)

  3. APIImpact (etoews, 00:11:16)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (etoews, 00:11:29)
    2. https://review.openstack.org/#/c/136760/ (etoews, 00:11:49)
    3. ACTION: miguelgrinberg to comment on https://review.openstack.org/#/c/136253/ to point out that metadata works better as its own resource, just like for cinder snapshots http://developer.openstack.org/api-ref-blockstorage-v2.html#snapshots-v2 (etoews, 00:40:33)
    4. ACTION: miguelgrinberg to write up an initial guideline to review for metadata to be consistent across openstack (etoews, 00:43:36)

  4. guidelines (etoews, 00:43:53)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (etoews, 00:44:00)
    2. ACTION: ycombinator to restrict scope of https://review.openstack.org/#/c/133660/ to collections only (ycombinator_, 00:46:29)
    3. https://review.openstack.org/#/c/137490/ might need a few more eyes (elmiko, 00:50:59)
    4. https://review.openstack.org/#/c/130825/ looks mergable. (etoews, 00:51:49)
    5. https://review.openstack.org/#/admin/projects/openstack/api-wg,access (etoews, 00:52:29)
    6. https://review.openstack.org/#/admin/groups/468,members (etoews, 00:52:42)
    7. ACTION: etoews ping jay to review the queue https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z and merge what meets the criteria. (etoews, 00:54:01)

  5. open topics (etoews, 00:54:23)
    1. https://github.com/elmiko/sahara-doc (elmiko, 00:57:35)
    2. https://pypi.python.org/pypi/wadl2swagger/0.0.2 (ycombinator_, 00:58:52)


Meeting ended at 01:01:01 UTC (full logs).

Action items

  1. miguelgrinberg to comment on https://review.openstack.org/#/c/136253/ to point out that metadata works better as its own resource, just like for cinder snapshots http://developer.openstack.org/api-ref-blockstorage-v2.html#snapshots-v2
  2. miguelgrinberg to write up an initial guideline to review for metadata to be consistent across openstack
  3. ycombinator to restrict scope of https://review.openstack.org/#/c/133660/ to collections only
  4. etoews ping jay to review the queue https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z and merge what meets the criteria.


Action items, by person

  1. etoews
    1. etoews ping jay to review the queue https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z and merge what meets the criteria.
  2. miguelgrinberg
    1. miguelgrinberg to comment on https://review.openstack.org/#/c/136253/ to point out that metadata works better as its own resource, just like for cinder snapshots http://developer.openstack.org/api-ref-blockstorage-v2.html#snapshots-v2
    2. miguelgrinberg to write up an initial guideline to review for metadata to be consistent across openstack
  3. openstack
    1. miguelgrinberg to comment on https://review.openstack.org/#/c/136253/ to point out that metadata works better as its own resource, just like for cinder snapshots http://developer.openstack.org/api-ref-blockstorage-v2.html#snapshots-v2
    2. miguelgrinberg to write up an initial guideline to review for metadata to be consistent across openstack
    3. ycombinator to restrict scope of https://review.openstack.org/#/c/133660/ to collections only
    4. etoews ping jay to review the queue https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z and merge what meets the criteria.


People present (lines said)

  1. etoews (91)
  2. miguelgrinberg (55)
  3. elmiko (38)
  4. ycombinator_ (30)
  5. rosmaita (12)
  6. ryansb (10)
  7. dtroyer (4)
  8. openstack (3)
  9. stevelle (2)
  10. eliqiao (1)


Generated by MeetBot 0.1.4.