16:00:54 <dtantsur> #startmeeting api-sig
16:00:56 <openstack> Meeting started Thu Jan  9 16:00:54 2020 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:01 <openstack> The meeting name has been set to 'api_sig'
16:01:01 <dtantsur> #chair sshnaidm elmiko
16:01:02 <openstack> Current chairs: dtantsur elmiko sshnaidm
16:01:04 <sshnaidm> yay
16:01:14 <sshnaidm> happy holidays everyone
16:01:25 <sshnaidm> welcome back to 2020 meetings..
16:01:31 <dtantsur> what, work again??
16:01:42 <dtantsur> I'm sorry, I already worked last year..
16:01:43 <sshnaidm> dtantsur, no, to talk :)
16:01:43 <elmiko> hehe, ++ dtantsur
16:02:02 <sshnaidm> #link https://etherpad.openstack.org/p/openstack-ansible-modules
16:02:07 <sshnaidm> our agenda ^^
16:02:26 <sshnaidm> #topic Need to decide finally about the strategy
16:02:32 <sshnaidm> oops
16:02:40 <sshnaidm> didn't mean it
16:02:46 <dtantsur> there is always #undo
16:02:58 <sshnaidm> #undo topic
16:02:59 <openstack> Removing item from minutes: #topic Need to decide finally about the strategy
16:03:14 <sshnaidm> it's too complicated
16:03:30 <sshnaidm> we talked and sent mails about how we need to move modules
16:03:39 <sshnaidm> I just want to be sure we're all on the same page
16:04:17 <sshnaidm> I think we stopped on moving modules to ansible SIG repo, linking with new names in Ansible repo
16:04:42 <sshnaidm> and redesigning if need with kind deprecation notices
16:04:49 <gtema> right
16:04:51 <sshnaidm> is it correct ^
16:05:13 <sshnaidm> any comments, objections ?
16:05:52 <sshnaidm> ok, let's move on
16:06:07 <sshnaidm> about freezing current modules in Ansible github repo
16:06:42 <sshnaidm> I notices we still have patches merging:  https://github.com/ansible/ansible/commits/devel/lib/ansible/modules/cloud/openstack
16:07:17 <sshnaidm> so, do we have a good way to make sure we really freeze them after a moving?
16:07:35 <sshnaidm> and we move them next week when gundalow is back from PTO
16:07:39 <gtema> drop permissions of cloudnull
16:07:42 <sshnaidm> mordred, stephenfin ^^
16:07:58 <sshnaidm> gtema, :)
16:08:05 <gtema> he was approving lots of PRs
16:08:23 <sshnaidm> I'll talk with cloudnull
16:08:36 <sshnaidm> but I think we need to send something to Ansible core team
16:08:41 <sshnaidm> like make it official
16:09:12 <gtema> yeah, perhaps a good idea
16:09:13 <dtantsur> yep
16:09:15 <sshnaidm> and kindly to ask to ignore patches or make their bot to print a message there
16:09:28 <sshnaidm> like "from now please use gerrit in .. blabla"
16:10:06 <sshnaidm> #action sshnaidm to send message to Ansible core team about freezing OS modules
16:10:16 <mnaser> (sorry, i am in and out but following along)
16:10:33 <sshnaidm> mnaser, sure
16:10:42 <sshnaidm> ok, let's move on if no objections
16:10:47 <sshnaidm> Should we move modules with keeping history?
16:10:59 <Shrews> i think you'll probably need some process (and an actual collection) in place before they'll actually freeze them (if they even do)
16:11:02 <gtema> nope - ansible github is history
16:11:16 <mordred> yeah- I think moving with history is too much work at this point
16:11:25 <sshnaidm> Shrews, we will do it after a move I think
16:11:54 <sshnaidm> I think dtantsur had some experience with keeping history, was is complicated ?
16:12:04 <openstackgerrit> Dmitry Tantsur proposed openstack/os-client-config master: Add a release note for Python 2 support removal  https://review.opendev.org/701761
16:12:09 <yoctozepto> hi (just listening today)
16:12:10 <dtantsur> splitting a subtree in git is not hard
16:12:23 <dtantsur> but submitting all the resulting patches to gerrit is going to kill our infra
16:12:36 <sshnaidm> dtantsur, ack
16:12:38 <dtantsur> so somebody will have to (force-)push them to gerrit
16:12:46 <dtantsur> that's what we did for ironic-tempest-plugin in the end
16:12:54 <dtantsur> (actually, we also merged two git trees from two repos, that was fun)
16:13:05 <mordred> if someone wants do to the subtree split, I can do the gerrit goo
16:13:42 <sshnaidm> any volunteers? ^
16:14:05 <dtantsur> c'mon, it's fun!
16:14:17 <gtema> not me. I do not see any benefit
16:14:31 <sshnaidm> if no volunteers - not keeping history then
16:14:33 * dtantsur assumes gtema has something to hide in `git blame` :D
16:14:44 <dtantsur> sshnaidm: I can do it if people find it useful
16:14:55 <dtantsur> but I don't insist if nobody does
16:15:06 <dtantsur> time for a poll? :)
16:15:08 <sshnaidm> I think it might be useful, but not deal-breaker
16:15:14 <gtema> dtantsur - actually only very few fixes were really landed, so - nope ;-)
16:15:14 * dtantsur hasn't used the poll functionality in a while
16:15:27 <sshnaidm> dtantsur, does it have a poll?
16:15:37 <dtantsur> #poll Should we keep the git history of the moved modules? Yes, No
16:15:50 <dtantsur> given that it doesn't react, I might have done something wrong
16:16:02 <dtantsur> #startpoll Should we keep the git history of the moved modules? Yes, No
16:16:47 <sshnaidm> Yes, No
16:16:50 <sshnaidm> all right, let's make it simple.. no keeping history
16:16:57 <gtema> +1
16:17:12 <sshnaidm> we have things to do beside that..
16:17:27 <sshnaidm> let's move on
16:17:38 <sshnaidm> next question - python 2/3 compatibility
16:17:49 <sshnaidm> Ansible supports from 2.6(?), but Openstack is moving to 3 completely. Should we stick to Ansible and support from 2.6/2.7?
16:18:00 * dtantsur finally remembered it was #startvote
16:18:18 <dtantsur> if openstacksdk drops python 2, we cannot support it
16:18:23 <sshnaidm> dtantsur, we can use it for this topic ^ )
16:18:30 <dtantsur> haha, let's try
16:18:44 <dtantsur> #startvote Should we let Python 2 live? Yes, No, OMG
16:18:45 <openstack> Begin voting on: Should we let Python 2 live? Valid vote options are Yes, No, OMG.
16:18:46 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
16:18:54 <sshnaidm> OMG
16:19:01 <sshnaidm> #vote OMG
16:19:09 <dtantsur> #vote No
16:19:41 <gtema> #vote hehe
16:19:41 <openstack> gtema: hehe is not a valid option. Valid options are Yes, No, OMG.
16:19:42 <sshnaidm> interesting, what gundalow thinks about it, but we'll know that only next week
16:19:45 <dtantsur> To elaborate on my vote: we're planning something forward-looking, and Python 2 is dead today
16:19:48 <gtema> # vote no
16:19:53 <gtema> #vote no
16:20:18 <dtantsur> anyone else wants to play with the vote functionality? :)
16:20:42 <gtema> #vote again - no
16:20:43 <openstack> gtema: again - no is not a valid option. Valid options are Yes, No, OMG.
16:20:47 <sshnaidm> gtema, dtantsur made it case sensitive :o
16:20:56 <dtantsur> it's not case sensitive, but it requires a valid option
16:21:03 <gtema> doesn't looke like that
16:21:08 <dtantsur> #endvote
16:21:09 <openstack> Voted on "Should we let Python 2 live?" Results are
16:21:10 <openstack> OMG (1): sshnaidm
16:21:11 <gtema> simly "no" was accepted
16:21:12 <openstack> No (2): gtema, dtantsur
16:21:16 <dtantsur> as you see ^^
16:21:19 <sshnaidm> ah, worked
16:21:52 <sshnaidm> ok, I hope Ansible people won't be mad we break their 2.7 support..
16:22:02 <mordred> sorry - juggling two meetings - #vote no :)
16:22:14 <gtema> too late
16:22:27 <sshnaidm> too late, we decided no :)
16:22:30 <mordred> looks like there were no yes votes anyway :)
16:22:31 <dtantsur> #agreed Unless gundalow objects next week, we won't keep Python 2 support
16:22:36 <mordred> \o/
16:22:42 <sshnaidm> mordred, you just want to join the winning part!
16:22:44 <mordred> I mean - sdk isn't keeping python 2 support anyway
16:22:56 <mordred> so, you know, don't know that these modules have much choice :)
16:23:01 <dtantsur> :D
16:23:03 <gtema> yeah, but so far we haven't stripped it off
16:23:09 <mordred> this is true
16:23:14 <mordred> we *have* removed testing
16:23:35 <gtema> yes, that's true. But I explicitely was not starting to drop "six"
16:23:38 <gtema> hehe
16:23:39 <dtantsur> not tested == broken
16:23:52 <sshnaidm> very true ^
16:24:18 <gtema> you forgot "if" in a comparison
16:24:26 <sshnaidm> ok, I think we finished all topics from agenda, and now - open discussions
16:24:29 <dtantsur> it's a boolean expression
16:24:52 <gtema> then it should be a single "="
16:25:11 <sshnaidm> gtema, in boolean?
16:25:14 <dtantsur> gtema: I'm thinking in python :)
16:25:41 <gtema> open discussion - what is with jobs for proper testing and releasing?
16:26:07 <sshnaidm> gtema, good question
16:26:47 <sshnaidm> I configured a job that doesn't test anything for now
16:26:48 <sshnaidm> https://review.opendev.org/#/c/698085/
16:26:50 <dtantsur> on opendev writing jobs should be easier
16:27:09 <sshnaidm> it's a job that always was running in ansible patches
16:27:24 <gtema> everything is easy until you start doing that
16:27:32 <sshnaidm> so I'll configure it to run on current repo and it will be a start
16:28:06 <sshnaidm> we can run some tripleo jobs as well
16:28:12 <gtema> should we move func tests from SDK here, or link to SDK?
16:28:33 <dtantsur> I have a feeling that the new repo is a better place for tests
16:28:46 <gtema> and basically those SDK func tests must install collection first
16:28:54 <gtema> me too
16:29:03 <gtema> (not this "me too")
16:29:16 <sshnaidm> gtema, and apply a patch I suppose..
16:29:30 <gtema> well, you can install collection from local
16:29:50 <sshnaidm> gtema, yeah, I think you make a tarball and then install it, iirc
16:29:53 <gtema> so it's basically just "ansible-galaxy collection build && ansible-galaxy collection install"
16:29:59 <gtema> exactly
16:30:00 <sshnaidm> yep
16:30:40 <dtantsur> zuul applies patches for you
16:30:43 <sshnaidm> well, I think it will be more clear when we move it finally
16:31:06 <sshnaidm> I'm not familiar with SDK jobs
16:31:18 <sshnaidm> but do we have there something
16:31:26 <sshnaidm> that can be helpful for modules as well?
16:31:35 <gtema> there are tests for modules
16:31:56 <sshnaidm> I suppose we need installed Openstack to run modules that change it
16:32:05 <sshnaidm> devstack, tripleo, whatever
16:32:06 <gtema> https://opendev.org/openstack/openstacksdk/src/branch/master/openstack/tests/ansible
16:32:10 <mordred> yah - there is a module function test job that runs against devstack
16:32:24 <mordred> I totally agree, those should move into the collection repo once we've got it
16:32:35 <mordred> and we can still also trigger it from sdk for cross-testing
16:32:46 <gtema> sure
16:33:04 <mordred> essentially, it runs devstack and then runs the module tests against the api endpoint from the devstack
16:33:10 <mordred> it's not COMPREHENSIVE
16:33:16 <mordred> but it's a solid starting place
16:34:17 <sshnaidm> as I see there are test actions, but not verifications..?  like in https://opendev.org/openstack/openstacksdk/src/branch/master/openstack/tests/ansible/roles/keystone_domain/tasks/main.yml
16:34:29 <dtantsur> ironic coverage can be provided by bifrost
16:34:33 <gtema> right
16:34:55 <mordred> sshnaidm: well, the verifications are a little implicit for now
16:35:25 <mordred> that update isn't going to work if the create didn't, etc ... but we can *definitely* improve these and make them better
16:35:29 <mordred> and should
16:35:46 <mordred> it's been harder to improve that with the modules in ansible/ansible and the tests in openstacksdk
16:36:09 <sshnaidm> yeah, maybe using molecule will be helpful too
16:36:34 <mordred> yah - maybe so - I hear you know something about that :)
16:36:34 <sshnaidm> for testing on various platforms for example
16:36:43 <gtema> not definitely - you want to mess with devstack and molecule?
16:36:50 <sshnaidm> mordred, yeah, we use it heavily now
16:37:11 <sshnaidm> devstack is providing openstack cloud
16:37:28 <sshnaidm> but all tests can be wrapped in molecule
16:38:11 <sshnaidm> for last triple module I just used keystone container for testing
16:38:30 <sshnaidm> and running os_keystone_* tasks with it
16:38:42 <sshnaidm> not even whole openstack
16:38:59 <sshnaidm> the same tried with ironic dev container
16:39:30 <mordred> cool
16:40:07 <mordred> like - my brain doesn't necessarily know how that all hangs together, but I could imagine seeing some patches would bea . good learning experience all around
16:40:07 <sshnaidm> OK, I think we agreed to design a good testing for modules after a move
16:40:14 <mordred> ++
16:40:55 <sshnaidm> anything else in your minds?
16:41:35 <sshnaidm> OK, I think we're good for today
16:41:44 <sshnaidm> and welcome back everyone
16:41:51 <mordred> happy new year!
16:42:01 <sshnaidm> +1
16:42:09 <sshnaidm> #endmeeting