16:00:01 <cdent> #startmeeting api sig
16:00:01 <openstack> Meeting started Thu Sep 20 16:00:01 2018 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:04 <openstack> The meeting name has been set to 'api_sig'
16:00:14 <elmiko> o/
16:00:16 <cdent> #chair cdent elmiko edleafe dtantsur
16:00:17 <cdent> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:00:18 <cdent> #topic previous meeting action items
16:00:18 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:23 <edleafe> \o
16:00:59 <cdent> #link last meetings mintues http://eavesdrop.openstack.org/meetings/api_sig/2018/api_sig.2018-09-06-16.00.html
16:01:27 <dtantsur> o/
16:01:56 <cdent> it's been a long time since the last in-irc meeting
16:01:58 <elmiko> how was ptg?
16:02:04 <cdent> so not much in the way of action items
16:02:05 <elmiko> haha
16:02:07 <cdent> so yeah ptg
16:02:10 <edleafe> Lonely without you!
16:02:13 <elmiko> =(
16:02:19 <elmiko> i missed you all as well
16:02:43 <cdent> both ed and I made some ptg reports that include api-sig bits:
16:02:55 <cdent> #link cdent ptg report https://anticdent.org/drafts/openstack-stein-ptg.html
16:02:57 <edleafe> Didn't we assign the task of merging MOnty's stuff to dtantsur ?
16:03:09 <dtantsur> and I did update the looooong patch
16:03:19 <cdent> #link edleafe ptg report https://blog.leafe.com/stein-ptg-recap/
16:03:21 <elmiko> yeah, i've been re-reading the review, but it's a lot
16:03:32 <dtantsur> yeah, now you have to read it, poor souls
16:03:36 <elmiko> ++ cdent and edleafe for writing up reports =)
16:04:16 <edleafe> elmiko: it helps me justify IBM paying for me to go :)
16:04:53 <elmiko> ++
16:05:33 <elmiko> wow, this linked tweet from Alex Xu just sounds horrible =(
16:05:37 <cdent> I guess the main event at the monday session was people re-joining the healthcheck effort
16:05:45 <elmiko> ooh, nice!
16:05:49 <cdent> elmiko: oh yeah, my post is full of joy
16:06:39 <cdent> it's not clear how much of the healthcheck enthusiasm will expand beyond the boundaries of the ptg
16:06:43 <elmiko> it's just a shame to hear someone say how they don't want to attend another ptg but have to for work, i always found the community events to be a joyous part of openstack for me
16:06:59 <cdent> keep reading!
16:07:01 <elmiko> ack
16:07:06 <elmiko> X2
16:07:17 <cdent> #topic new biz/opens
16:07:25 <cdent> #link https://etherpad.openstack.org/p/api-sig-stein-ptg
16:07:35 <cdent> we've already started talking about that. anything else to add
16:07:38 <elmiko> i think the healthcheck idea is really nice, but yeah tough if no one has the time to work on it
16:08:19 <elmiko> did you actually get to talk about microversions?
16:08:29 <cdent> not that I recall
16:08:51 <elmiko> saw it on the agenda and just wondered out of sick curiosity XD
16:09:13 <edleafe> not a single microversion was discussed
16:09:17 <elmiko> ++
16:09:32 <elmiko> also cool to see the action about the IETF HTTP protocols
16:09:55 <cdent> we didn't talk about that much, other than to say it is a useful additional resource
16:10:10 <elmiko> yeah
16:10:18 <elmiko> it seemed pretty uncontroversial
16:10:44 <elmiko> looks like some great discussions, were there a lot of people who stopped by?
16:11:23 <edleafe> It was much thinner attendance than in the past
16:11:36 <elmiko> i like the comment on L50 as well, that sounds like a good call to action for the sig
16:11:38 <cdent> overall the entire prtg was thin
16:11:44 <elmiko> gotcha
16:11:45 <cdent> but our room especially so
16:12:19 <edleafe> The healthcheck discussions did pick it up a bit
16:12:29 <elmiko> seems like it from the notes
16:12:50 <cdent> the stuff on L50 was a theme that I heard a few times during the week. overall openstack needs to be better about shouting about the coolness
16:13:03 <elmiko> makes sense
16:13:04 <elmiko> brb
16:13:54 <edleafe> Trouble is, APIs just aren't that sexy or cool
16:13:59 <elmiko> right
16:14:17 <dtantsur> yeah
16:14:17 <elmiko> unless we overhaul everything to use grpc! XD
16:14:26 <dtantsur> and something about edge
16:16:09 <cdent> don't forget the far edge
16:17:01 <elmiko> or the fog edge!
16:17:36 <dtantsur> yeah, I only learned about far edge today
16:17:42 <elmiko> are there any big actions that we need to take as a group coming out of the ptg?
16:18:24 <cdent> not that I could tell, but I have a sort of related thing
16:18:34 <elmiko> cool
16:18:42 <edleafe> I guess I should write up a thing about the DELETE concepts
16:19:04 <edleafe> #action edleafe to write a guideline on API fault tolerance
16:19:04 <elmiko> i was gonna ask about that, it sounds like an interesting topic (fault tolerance)
16:19:26 <edleafe> I want to finish the book first :)
16:19:34 <elmiko> ack =)
16:19:38 * edleafe forgot to pack it for the flight
16:19:42 <elmiko> doh!
16:20:10 <cdent> PTG was a bit of a come to jesus moment for me with regard to the extent of my too-thinly-spread attention, so I'm considering stepping back from (but not leaving entirely) the SIG and I'd either like your blessing or to be convinced I should not
16:20:33 <elmiko> oh wow, that's a big one
16:21:09 <edleafe> I think that this is a good time, as we really don't have very much on our plate
16:21:24 <cdent> yeah, that's kind of what I was thinking too
16:21:37 <elmiko> well, our work is pretty low bandwidth, but if you feel it's negatively impacting your time with other stuff then i certainly encourage you to make the decision that puts you working on the stuff you want to
16:22:00 * dtantsur wanted to say the same ^^^
16:22:02 <edleafe> s/want/have
16:22:07 <edleafe> :-P
16:22:11 <cdent> it's more in terms of the mental gesture: "it's okay to set this aside"
16:22:12 <elmiko> fair ;)
16:22:39 <elmiko> cdent: it is okay to set this aside =)
16:22:41 <edleafe> cdent: totally ok
16:22:48 <cdent> cool, thanks
16:23:09 * cdent has a bit of a good will hunting moment
16:23:20 <elmiko> hehe =)
16:23:21 <edleafe> Now we'll have someone to gossip about!
16:23:26 <elmiko> LOL
16:24:08 <cdent> yay! gossip!
16:24:23 <dtantsur> huzzah!
16:24:40 <cdent> next topic: do we need forum space in berlin?
16:24:50 <cdent> i got a mail about that, not sure if others did
16:24:55 <elmiko> i saw it too
16:25:04 <elmiko> i doubt i will be in berlin
16:25:11 <edleafe> Right now, no. If the healthcheck or GraphQL projects take off suddenly, then perhaps
16:25:18 <elmiko> ++
16:25:37 <dtantsur> I can lead any sessions if needed
16:25:49 <elmiko> cool, that's good to know
16:26:15 <edleafe> Yeah, I'm still 50-50 on whether I can go
16:26:20 <dtantsur> if I catch mordred, we may end up finishing The Catalog Discovery Book
16:26:22 <elmiko> maybe at the least we would have a brief update session if dtantsur wanted to give it
16:26:35 <dtantsur> elmiko: have we done anything? :D
16:27:17 <cdent> aye, there's the rub
16:27:32 <elmiko> yeah...
16:27:43 * dtantsur imagines: Hi all, I'm from API-SIG. cdent is too busy, edleafe is huzzah! elmiko and I are just slackers. Bye!
16:27:45 <elmiko> well, this naturally kinda makes me wonder about the sig and our future
16:27:50 <edleafe> I'm not a fan of "let's have a space because we can"
16:28:00 <elmiko> edleafe: totally agree
16:28:17 <cdent> elmiko: it's not really a consolation but many/most sigs are wondering the same thing
16:28:38 <elmiko> i'm just kinda wondering if there is some signal we put up that we are migrating to maintenance mode
16:28:42 <elmiko> ?
16:28:52 <dtantsur> I wonder if something like "Ops feedback on OpenStack API design" can fly
16:28:54 <cdent> that's a good question
16:28:57 <dtantsur> indeed
16:28:58 <edleafe> elmiko: I don't think that's necessary
16:29:16 <elmiko> edleafe: ok
16:29:25 <edleafe> We still need to be available for things that come up, even if we aren't churning out new guidelines
16:29:32 <elmiko> definitely
16:29:43 <elmiko> and i think our biggest impact of late has been facilitating others
16:29:49 <dtantsur> just a reminder: finishing the discovery guidelines will probably occupy us for a cycle more
16:30:07 <elmiko> but like, should we consider migrating our meetings to like an open office hours type of thing?
16:30:33 <edleafe> So how about this: let's keep this weekly meeting, but more as a simple check-in with each other. If there isn't anything to do, then end it quickly, and no need for a newsletter
16:30:56 <elmiko> that sounds reasonable to me
16:31:02 <edleafe> If some event does demand attention, we can revert to the format we've been using for a while
16:31:07 <dtantsur> I'm definitely in favor of it, esp. since the meeting starts at 6pm
16:31:20 <edleafe> I really don't like newsletters that say "We didn't do crap"
16:31:22 <elmiko> of course it is also an opportunity for folks to reach out to us as well, but that hasn't happened during meeting hours in a while
16:31:33 <elmiko> edleafe: ++
16:31:51 <dtantsur> I wonder if we should have something in Berlin, even if only to highlight that we exist
16:32:07 <edleafe> elmiko: well that's why we should keep this regular meeting, in case someone does want to reach out
16:32:20 <elmiko> edleafe: right, that was kinda my point about office hours
16:32:48 <elmiko> dtantsur: i think if you are willing to host something, i am not opposed to that. do they birds of feather meetups at the forums?
16:32:57 <elmiko> *do they have*
16:33:00 <edleafe> elmiko: hmmm, then maybe that will be the way to go. Office hours in -sdks
16:33:02 <cdent> I think we've been operating on a premise somewhere in the realm of "if we build it they will come" but we may need to adjust to "if there's a problem they will come" (not just here, but in general)
16:33:08 <dtantsur> I'm surprisingly ignorant to the Forum format
16:33:23 <dtantsur> the fact that I haven't been to a single one before may contribute
16:33:24 <edleafe> cdent: zactly
16:33:25 <cdent> it's not just you dtantsur . it keeps moving around
16:33:32 <elmiko> cdent: yeah, i think those days of using drawing a crowd are probably past us
16:33:45 <edleafe> RIP Microversion Controversy
16:33:51 <dtantsur> \o/
16:33:52 <elmiko> hahaha
16:35:40 <elmiko> so, i'm ok with keeping this meeting time as a touch point, but i would also be ok with announcing some sort of office hours in -sdks as a replacement
16:36:25 * cdent has no preference
16:36:25 <edleafe> We could make two office hours, so that dtantsur doesn't have to miss dinner
16:36:25 <elmiko> maybe give an indication of deprecation before we yank this location/time though
16:36:26 <dtantsur> a good thing about office hours is that you can have them in different time zones
16:36:31 <elmiko> edleafe: ++
16:36:32 <dtantsur> edleafe: exactly :)
16:36:46 <elmiko> it would also help with the asia times
16:37:36 <edleafe> OK, so how does this sound: we have one more meeting next week, where we will set office hours. We announce that in today's newsletter, and anyone who cares can provide input, either on the ML or at that meeting
16:37:44 <mordred> what about those of us who don't have an office though?
16:37:59 <elmiko> edleafe: i'm good with that
16:38:01 <cdent> mordred: you've used up all your attendance tokens
16:38:18 <elmiko> mordred: where we're going, we don't need offices.... XD
16:38:32 <cdent> elmiko's was better
16:38:44 <elmiko> also, i thought you were calling it quits for today after your previous triumph in -sdks?
16:38:46 <edleafe> mordred: I'm more concerned with those of us who don't have hours
16:38:53 <elmiko> LOL
16:39:10 <dtantsur> :D
16:39:42 <mordred> edleafe: hours and offices are both overrated
16:39:52 <mordred> elmiko: :)
16:40:49 <cdent> ed's plan sounds good, should we move on?
16:40:54 <elmiko> ++
16:40:59 <cdent> #topic guidelines
16:41:05 <cdent> dtantsur did some stuff
16:41:12 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:41:28 <cdent> i have not attended to me "design advice" thing
16:41:31 <dtantsur> or rather messed with mordred's stuff
16:41:59 * mordred is TOTALLY enjoying reviewing that
16:42:10 <elmiko> i'm still reading dtantsur's update, but things have heated up locally for me so i am slow
16:43:22 <cdent> so nothing to freeze or anything along those lines, correct?
16:43:38 <dtantsur> yup
16:43:41 <cdent> #topic bug review
16:43:41 <cdent> #link https://storyboard.openstack.org/#!/project/1039
16:43:52 <cdent> nothing new
16:44:23 <cdent> #topic weekly newsletter
16:44:23 <cdent> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:45:00 <edleafe> I guess I can do it
16:45:05 <elmiko> i have a meeting right after this one, but i can take it if no one else has time
16:45:12 <elmiko> thanks edleafe =)
16:45:18 <dtantsur> edleafe++
16:45:24 <cdent> huzzah to edleafe
16:45:44 * edleafe loves his huzzahs
16:45:48 <elmiko> also huzzah to cdent for many many great contributions to the sig and openstack =)
16:45:56 <dtantsur> huzzah!
16:46:01 <cdent> I'm not leaving, just fading, but thanks
16:46:14 <elmiko> i know, but still, i feel it's worth mentioning
16:46:53 <cdent>16:46:57 <edleafe> I should write something like that and make it sound like a eulogy
16:47:05 <elmiko> hhahaha
16:47:09 * cdent is full of dread
16:48:24 <cdent> anything else or shall we call it? if we follow the plan, next week will be the last official meeting for a while. I'll bring virtual booze.
16:48:35 <elmiko> nothing else from me
16:48:49 <elmiko> i will be at a conference next week, but i will do my best to make the meeting
16:48:59 <edleafe> I'm good to go
16:49:03 <elmiko> even if i have to use the web interface from my phone!
16:49:06 <cdent> rad
16:49:08 <cdent> thanks
16:49:12 <cdent> #endmeeting