16:00:42 <cdent> #startmeeting api-sig
16:00:43 <openstack> Meeting started Thu Aug 30 16:00:42 2018 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:46 <openstack> The meeting name has been set to 'api_sig'
16:00:52 <cdent> #chairs edleafe dtantsur
16:00:57 <cdent> or rather
16:01:03 <cdent> #chair edleafe dtantsur
16:01:04 <openstack> Current chairs: cdent dtantsur edleafe
16:01:07 <dtantsur> o/
16:01:15 <edleafe> \o
16:01:15 <cdent> #link agenda https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:26 <cdent> #topic old biz
16:01:42 <cdent> #link old minutes http://eavesdrop.openstack.org/meetings/api_sig/2018/api_sig.2018-08-23-16.00.html
16:01:52 <cdent> no action items
16:02:17 <edleafe> Yay! We didn't not do the things we didn't have to do!
16:02:20 <cdent> and the newletter indicates that not a lot happened
16:02:35 <cdent> so any additional reflections?
16:02:55 <edleafe> not from me
16:03:01 <cdent> #topic new biz
16:03:18 <cdent> looks like I (nor anyone else) udpated the agenda
16:04:37 <cdent> so it looks like there's no new biz
16:05:09 <cdent> one idle thing I did want to mention, because it's come up in conversations I've had outside the upstream openstack conversation, is whether, from a philosophical standpoint
16:05:17 <edleafe> There was a post tot he ML about Open API 3.0
16:05:20 <cdent> k8s CRD are awesome or the devils work
16:05:44 <edleafe> Like most tech, they can be both
16:05:59 <edleafe> Anything that is powerful can also be dangerous
16:06:53 <cdent> yeah, pretty much
16:07:18 <cdent> presumably they are antithetical to the "our" work, because they break interop, by definition
16:07:37 <edleafe> They're like metaclasses in python: if you don't understand 'em, you don't need 'em
16:07:45 <cdent> (unless you are one of those people who think that capabilities discover is an appropriate way to route around such things)
16:07:59 * dtantsur is out of context here
16:08:19 <cdent> #link CRD: https://kubernetes.io/docs/concepts/extend-kubernetes/api-extension/custom-resources/
16:08:39 <edleafe> Interop is not necesary unless you have a set of standard things
16:09:01 <edleafe> OpenStack has discrete services. k8s doesn't
16:09:23 <edleafe> well, theyt do, but it isn't intended to be everything
16:09:32 <cdent> and therein lies the rub
16:09:54 <cdent> company x can present the k8s-in-a-cloud solution, with some CRDs that will now not work with company u
16:10:27 <cdent> some insiders are saying "it had to be done to help 'create a market' but it is going to be chaos'
16:10:28 <dtantsur> ah, so extensions
16:10:32 <cdent> effectively
16:10:49 <edleafe> yep
16:11:35 <cdent> so, for that standpoint they are an interesting compare and contrast I guess, and I suppose that's why I bring them up (besides just wanting to fill the dark void which is life)
16:12:36 <edleafe> Speaking of dark voids...
16:12:39 <edleafe> http://lists.openstack.org/pipermail/openstack-dev/2018-August/133960.html
16:12:55 <cdent> #link open api 3.0 http://lists.openstack.org/pipermail/openstack-dev/2018-August/133960.html
16:13:14 <cdent> something I guess we need to track but I've not yet teased out the "ask" in that tread
16:13:47 <edleafe> I read the ask as "we need cheerleaders"
16:14:24 <cdent> that makes everyone look to the right
16:15:39 <cdent> is there anything to do?
16:15:54 <cdent> by which I mean: any actions to put in the minutes?
16:16:18 <edleafe> No, no actions. I'm mjust keeping an eye on it
16:17:22 <cdent> #action edleafe keeping an eye on that open api 3.0 stuff
16:17:28 <cdent> huzzah
16:18:36 <cdent> anything else on the radar. dtantsur ?
16:18:42 <dtantsur> nope
16:20:17 <cdent> okay then, next topic
16:20:19 <cdent> #topic guidelines
16:20:20 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:20:22 * edleafe and cdent are stuck in a -placement brouhaha
16:21:22 <dtantsur> huzzahaha
16:21:38 <cdent> nothing new in guidelines as far as I can see?
16:22:01 <edleafe> dtantsur: :)
16:22:32 <cdent> I'm not going to be able to get back to the design guideline until after some of this placement stuff clears, as my mind is not right
16:22:44 <cdent> everything else is old
16:23:38 <cdent> however, it looks like some approved things can be moved around to get them to merge
16:23:49 <dtantsur> we need to keep going with the version discovery stuff
16:24:00 <dtantsur> we realized that ironic is doing it wrong, but we don't have a merged definition of "right"
16:24:18 <dtantsur> see https://storyboard.openstack.org/#!/story/2003567
16:24:56 <cdent> ah, yeah
16:25:27 <cdent> #action cdent reorder some of his pending guidelines which somehow have bad dependencies
16:26:46 <cdent> mordred: you still want to care and feed https://review.openstack.org/#/c/459710/ or should someone adopt it (and its peers)?
16:27:45 <cdent> #action reinvigorate version discovery and consumption guidelines
16:28:09 <cdent> anything else on guidelines?
16:29:17 <cdent> #topic bug review
16:29:18 <cdent> #link https://storyboard.openstack.org/#!/project/1039
16:29:38 <cdent> nothing new, no activity that I can see
16:30:06 <edleafe> me neither
16:30:13 <dtantsur> we're perfect \o/
16:30:37 <cdent> heh
16:30:55 <cdent> zen master says the way to be perfect is to be irrelevant
16:31:22 <edleafe> Guess I'm perfect then
16:31:33 <cdent> huzzah
16:31:36 <cdent> #topic weekly newsletter
16:31:37 <cdent> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:31:45 <cdent> anybody aching?
16:32:54 <cdent> I guess it's been a while since I did it, so I'll make something terse and cold
16:33:04 <edleafe> yeah, not a lot to report
16:33:35 <cdent> I'll ping when I need a read
16:34:13 <cdent> anybody have anything or are we done? Next week come prepared with your ptg planning head on please, so we can have a nice pleasant first day at the ptg, full of flowers and unicors and such.
16:34:14 <edleafe> I'll pong
16:34:44 <edleafe> No unicorns.
16:35:00 <edleafe> I don't want to be distracted by farting rainbows
16:35:09 <dtantsur> lol
16:35:23 * cdent looks forward to whiteboards
16:35:39 <cdent> thanks for your participation and attendance
16:35:45 <cdent> #endmeeting