16:00:01 <cdent> #startmeeting api-sig
16:00:02 <openstack> Meeting started Thu Mar 22 16:00:01 2018 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'api_sig'
16:00:09 <cdent> who is here today?
16:00:10 <elmiko> nice timing
16:00:16 <elmiko> you were on the button
16:00:17 <cdent> #chairs edleafe elmiko dtantsur
16:00:20 <dtantsur> o/
16:00:36 <cdent> #chair edleafe elmiko dtantsur
16:00:37 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:47 <edleafe> \o
16:01:13 <cdent> #link agenda https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:37 <cdent> #topic old biz
16:01:40 <cdent> #link last meeting http://eavesdrop.openstack.org/meetings/api_sig/2018/api_sig.2018-03-15-16.00.html
16:02:26 <cdent> actions were everyone to read http guidelines, edleafe split them up, which seems a good start
16:02:44 <cdent> other action was elmiko to check if https://review.openstack.org/#/c/444892/ is relevant
16:03:20 <elmiko> my bad, i got caught up on the os-api-ref stuff and used all my bandwidth
16:03:42 <elmiko> on the upside, i am making good progress and hopefully will have some useful input about it next time
16:04:03 <elmiko> i need to re-add the action for reviewing the microservice stuff, unless dtantsur got a chance to look at it?
16:05:14 <elmiko> #action elmiko review https://review.openstack.org/#/c/444892/ for relevance
16:05:59 <cdent> cool (sorry for delay had to answer door)
16:06:29 * edleafe is also splitting attention
16:06:34 <cdent> we can talk api-ref stuff in new biz
16:06:39 <cdent> and other old biz?
16:06:51 <cdent> #topic new biz and open mic
16:06:52 <dtantsur> elmiko: not yet
16:07:35 <elmiko> so, yeah, i've been working through the api-ref stuff
16:07:55 <elmiko> i am not quite at the point where i could add any meaningful patches to mugsie's work, but i am getting close
16:08:12 <elmiko> my question at this point though is what our output from this should be
16:08:15 <elmiko> ?
16:08:37 <cdent> which "our" do you mean? sig, guideline producers,  you and gilles, something else?
16:08:38 <elmiko> it seems like a nice way to capture our api schemas, but i'd like a little more time to understand it thoroughly and play with it
16:08:46 <elmiko> sorry, the sig's
16:09:23 <elmiko> like should we evaluate and try to get projects to do this, or just help with the coding to get it through the reviews and whatnot, or maybe something else?
16:09:46 <elmiko> the first 2 seem reasonable to me, assuming the ref continues to hold water
16:11:54 <dtantsur> is it about generating schemas?
16:12:02 * dtantsur is not sure what exactly api-ref means here
16:12:15 <dtantsur> if so, we need at least decide what to do with microversions
16:12:24 <elmiko> right
16:12:31 <dtantsur> I do not find the "just generate 60 schemas" answer satisfying tbh
16:12:35 <elmiko> at the minimum the api-ref is already being used to generate docs
16:12:45 <dtantsur> ok, "just generate 60 docs" :)
16:13:01 <dtantsur> we probably need to be able to express microversions as some kind of "delta" between versions
16:13:01 <elmiko> the next step is mugsie's patch which will help to create a solid output format that can be ingested by other tools
16:13:26 <elmiko> yeah, i've been thinking about the microvesion issue, but i'd like to continue my evaluation before reporting my ideas
16:14:13 <dtantsur> ack
16:14:34 <dtantsur> I just don't see it useful without solving this issue. but maybe not as action #1
16:14:59 <elmiko> agreed, microversions are high on the list for requirements
16:15:31 <elmiko> i /think/ there might be a way to utilize openapi as well, but like i said, i would like a little more time to fully form my idea
16:18:04 <cdent> The reason that api-ref was mooted as the starting point is because there's sufficient belief that a shared api docs format is valuable that it has made considerable penetration
16:18:18 <cdent> people don't have to do a second thing
16:19:10 <elmiko> ack
16:19:28 <elmiko> i mean, it does work and produces nice documentation output
16:19:50 <cdent> and the reason api-ref got the format it did is because Sean D for a buzz of energy
16:19:54 <elmiko> i'm trying to come at this from the perspective that Gilles (and presumably others) want, which is a machine readable format to build off of
16:20:09 <elmiko> sdague++
16:20:58 <elmiko> i'm happy to keep hacking on this to see if we can improve the state of the art by helping mugsie, i just wanted to see if there was more we should be doing or if there is a different expected outcome
16:21:39 <cdent> I don't think we we are (or should be) the arbiters of expected outcomes
16:22:11 <elmiko> i guess, is there relevance to the sig then considering Gilles asks?
16:22:52 <cdent> of course there is relevance: it's about api stuff, that's what the sig is for, a place for people do talk and do api stuff
16:23:06 * edleafe was just typing the same response
16:23:10 <edleafe> near-jinx
16:23:11 <elmiko> ack on that
16:23:17 <elmiko> i meant more from the help out perspective
16:23:27 <cdent> elmiko: you're helping move things along so is a good thing
16:23:35 <elmiko> ok, cool
16:24:23 <elmiko> this framing and reference is helpful for me, thanks
16:24:46 <cdent> anything else on that topic?
16:24:57 <elmiko> i think i'm good
16:25:07 <cdent> any other new biz?
16:25:12 <edleafe> none from me
16:25:18 <elmiko> nothing here
16:25:32 <dtantsur> nope
16:26:33 <cdent> #topic guidelines
16:26:33 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:26:47 <cdent> some action here of late
16:27:13 <cdent> #link errors fixups https://review.openstack.org/#/c/554921/
16:27:14 <cdent> is new
16:27:30 <cdent> #link sdk and microversion https://review.openstack.org/#/c/532814/
16:27:37 <cdent> is probably ready for wider review?
16:27:56 <edleafe> agree
16:28:21 <cdent> you want the honors edleafe ?
16:28:33 <edleafe> why not?
16:28:40 <dtantsur> let the storm begin :D
16:28:49 <cdent> #link split up http stuff https://review.openstack.org/#/c/554234/
16:28:59 <elmiko> i will review again this afternoon
16:29:12 <cdent> is new and probably needs quick more eyes but ought to be pretty straightforward to freeze
16:29:46 <edleafe> there's nothing new there except for the overview page wording
16:30:04 <cdent> thus the "quick"
16:30:34 <edleafe> yeah, just pointing out in case that wasn't clear
16:32:10 <cdent> anything else to say about guidelines?
16:32:26 <cdent> #action edleafe freeze microversion in sdks
16:33:28 <cdent> #topic bug review
16:33:29 <cdent> #link https://bugs.launchpad.net/openstack-api-wg/+bugs?orderby=-id&start=0
16:33:30 <cdent> #link https://bugs.launchpad.net/openstack-api-sig/+bugs?orderby=-id&start=0
16:33:49 <cdent> one new bug
16:33:54 <cdent> #link errors service type: https://bugs.launchpad.net/openstack-api-wg/+bug/1756464
16:33:55 <openstack> Launchpad bug 1756464 in openstack-api-sig "Errors guidelines reference service name, should be type" [Undecided,New]
16:34:00 <cdent> but it's already fixed in
16:34:19 <cdent> #link errors service type fix https://review.openstack.org/#/c/554921/
16:34:44 <elmiko> yay us
16:36:18 <cdent> anything else on bugs?
16:36:41 <elmiko> nothing from me
16:36:56 <dtantsur> nope
16:37:00 <cdent> elmiko: if you haven't read the bug night be worth doing so before the +1. I present why some might disagree (but they are wrong ;) )
16:37:17 <cdent> #topic open mic again
16:37:24 <cdent> in case anything else?
16:37:44 <elmiko> cdent: ack, i looked at the bug, but i will re-look
16:37:53 <elmiko> your change seems reasonable on first glance to me
16:38:35 <cdent> #topic weekly newsletter
16:38:35 <cdent> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:38:36 <cdent> who wants it?
16:39:27 * edleafe pushes up elmiko's hand
16:39:31 <elmiko> haha
16:39:33 <elmiko> i can take it
16:39:52 <elmiko> if only in acknowledgement of a fine joke by edleafe
16:40:12 * edleafe now realizes how to manipulate elmiko
16:40:38 <dtantsur> hehe
16:40:49 <cdent> remarkable
16:41:04 <elmiko> lol
16:41:24 <elmiko> what are you cambridge analytica?
16:41:31 <edleafe> heh
16:41:39 <edleafe> they're mere pikers
16:41:44 <elmiko> LOL
16:41:51 <cdent> excellent use of the term pikers
16:42:14 <cdent> I think that should be our signal to conclude. elmiko, ping as required and thank you
16:42:19 <cdent> and thanks to everyone else
16:42:22 <elmiko> ack, thanks
16:42:25 <cdent> any final words?
16:42:37 <elmiko> shablagoooo
16:42:52 <edleafe> "Don't shoot!"
16:43:00 * elmiko chuckles
16:43:02 <dtantsur> :D
16:43:28 <cdent> smh
16:43:33 <cdent> #endmeeting