15:59:44 <elmiko> #startmeeting api sig
15:59:45 <openstack> Meeting started Thu Jan 11 15:59:44 2018 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:59:48 <openstack> The meeting name has been set to 'api_sig'
15:59:53 <elmiko> oooh 16 seconds early
16:00:11 <elmiko> #chair cdent elmiko edleafe dtantsur
16:00:12 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:19 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:00:27 <cdent> o/
16:00:35 <elmiko> #topic previous meeting action items
16:00:36 * edleafe comes out of hiding
16:00:57 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_sig/2018/
16:01:32 <cdent> I did the writing for the annual report and was told "it's pefect!"
16:01:35 <cdent> so I guess that went well
16:01:43 <elmiko> \o/
16:01:50 <elmiko> cdent++
16:02:22 <edleafe> huzzah!
16:02:33 <dtantsur> :)
16:02:36 <elmiko> #topic open mic and ongoing or new biz
16:02:37 <cdent> except that the quoted person spelt perfect perfectly
16:02:53 <elmiko> perfectly!
16:03:18 <elmiko> ok, so i see a topic of how do we encourage change without becoming the api police
16:03:22 <elmiko> any thoughts?
16:03:46 <cdent> related to that, monty has proposed a couple of openstack-wide goals related to api stuff, including the recent pagination stuff
16:04:05 <cdent> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:04:08 <cdent> ooopes
16:04:11 <cdent> #uncod
16:04:14 <cdent> #undo
16:04:15 <openstack> Removing item from minutes: #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:04:17 * cdent is standing
16:04:19 <dtantsur> a starting guide and a template for new projects?
16:04:22 <cdent> #link https://review.openstack.org/#/c/532627/
16:04:26 <dtantsur> and openstack-wide goals indeed
16:04:30 * edleafe thinks cdent is wobbling
16:05:13 <cdent> dtantsur: by template do you mean stub code or something less specific?
16:05:30 <dtantsur> cdent: similar to cookiecutter
16:05:44 <elmiko> dtantsur: well, some of this was in relation to how we encourage projects to use the pagination rfc stuff, like should we open bugs or ?
16:05:48 <dtantsur> something, preparing the python code and one CRUD resource with eerything set up
16:05:58 <dtantsur> major versions, microversions, discovery...
16:06:13 <cdent> dtantsur: I'd be pretty leary of code, but a cookbook on what the code can do would be useful
16:06:18 <elmiko> ooh, are you talking about a project template?
16:06:19 <cdent> leery
16:06:32 * dtantsur opens google translate
16:06:47 <elmiko> cookbook ++, we went around the code template idea once before and it wasn't generally deemed worth it
16:06:52 <elmiko> too many options, too many variables
16:07:15 <cdent> and too many opinions
16:07:30 <elmiko> ++
16:07:35 <dtantsur> actually, we may want to get into the business of chosing the recommended framework for new projects
16:07:45 <dtantsur> and making sure it has enough libs for common stuff
16:07:47 <edleafe> only cdent's opinion counts, thoguh
16:07:49 <edleafe> though
16:07:53 <elmiko> agreed
16:08:10 <edleafe> dtantsur: how do you mean?
16:08:27 <edleafe> dtantsur: what would be an example?
16:08:51 <dtantsur> edleafe: e.g. "use Flask; use <this library> for Restful API, <this middleware> for microversions, plug keystonemiddleware this way"
16:09:38 <edleafe> dtantsur: that sounds more like the stuff that the (now defunct) Architecture WG was focusing on
16:10:03 <dtantsur> to me it sounds like something we could help with, even though it does grow our missing a tiny bit
16:10:35 <cdent> edleafe: perhaps api-wg would not address such things, but the api-sig might
16:10:35 <dtantsur> otherwise we have a lof of recommendations, but no practical help in implementing them..
16:10:53 <dtantsur> it can mean some understandable resistance
16:10:57 <dtantsur> s/mean/meet/ WUT?
16:11:01 <cdent> such advice would be something other than "guidance"
16:11:43 <elmiko> yeah
16:13:07 <cdent> there's nothing new on api-schema is there?
16:13:18 <elmiko> i had always thought that adding some code projects would help drive some traffic to the sig(ex. wg), but it never seemed to gain much traction
16:14:04 <elmiko> cdent: i don't think so, but i also don't know for sure
16:14:22 <cdent> I think I just left it on the agenda as a reminder
16:14:36 <elmiko> so, do we have anything to record about encouragin projects to adopt the guidelines for things like pagination?
16:15:04 <elmiko> last time we talked about opening bugs on projects that might need it, is this something we would pursue?
16:15:20 <cdent> do you all agree that it is okay for them to sometimes be an openstack-wide goal?
16:15:33 <cdent> or is that too stick-ish?
16:15:46 <dtantsur> sometimes - yes
16:15:47 <edleafe> elmiko: there's always this: https://goo.gl/images/KkRL2o
16:15:49 <elmiko> man, that seems so heacy
16:15:52 <elmiko> heavy*
16:16:08 <elmiko> edleafe: LOL, not quite my style but yeah
16:16:50 <edleafe> cdent: aren't goals supposed to be complete-able in one cycle?
16:17:02 <elmiko> cdent: my question to that would be, if we say something is an openstack-wide goal (eg pagination either in headers or body), then how do we get buy-in from the community for our pronouncements?
16:17:23 <cdent> edleafe: yeah, thus why the pagination thing is just one thing
16:17:48 <cdent> elmiko: the goal has to be approved by the tc and the tc won't approve it if there isn't perceived buy in
16:17:57 <cdent> and if there isn't a champion to drive it
16:18:01 <elmiko> and would we need a separate process for declaring something a goal like that?
16:18:09 <edleafe> cdent: yeah, that's what I thought
16:18:33 <cdent> elmiko: we don't really do the declaring (unless we feel like it) see
16:18:37 <elmiko> so, i'm ok with the openstack-wide goal if we have a higher body to help us (ie the tc)
16:18:46 <cdent> #link https://governance.openstack.org/tc/goals/index.html
16:18:57 <edleafe> So saying "adding/correcting pagination links" is doable, but "conforming to the API guidelines" would not be
16:19:39 <elmiko> i had not seen that page, given that i am ok with going forward on the goals
16:19:39 <cdent> ?
16:19:56 <cdent> we miss you in openstack elmiko
16:20:09 <elmiko> <3 i miss y'all too =)
16:21:25 <elmiko> ok, so for this week is it fair to say that we agree the sig will works towards identifying pieces of the guidelines with high impact that should be promoted to openstack-wide goals?
16:21:55 <cdent> there's only two goal (usually) per cycle, so this is not a solution, simply a tool
16:22:04 <elmiko> ah, gotcha
16:22:05 <cdent> but it would be safe to say that we seem okay to use the tool
16:22:21 <elmiko> still though, getting pagination fixed across the ecosystem in a single cycle would be a big accomplishment
16:22:32 <cdent> yes
16:22:47 <elmiko> ok then, moving along
16:22:54 <elmiko> anyone wanna talk about health check apis?
16:22:57 <elmiko> #link https://etherpad.openstack.org/p/self-healing-rocky-forum
16:23:04 <elmiko> #link https://etherpad.openstack.org/p/sydney-cloud-native-partii
16:23:19 <elmiko> (i'm not sure who added this)
16:23:47 <dtantsur> I'm not sure from these links what we should talk about right now
16:24:05 <elmiko> ack
16:24:14 <cdent> sorry, that was me.
16:24:19 <elmiko> i wasn't sure if we had an advocate in attendence
16:24:51 <cdent> there's work in progress to establish health check tools (things that make it easy to kill contiainers when not healthy)
16:25:24 <cdent> the api-sig has been invited to help define the api for the for that, so that the implementation is consistent across services
16:25:29 <cdent> things like the same well known url
16:25:34 <cdent> there's an oslo-spec in progress
16:25:49 <cdent> #link https://review.openstack.org/#/c/531456/
16:26:01 <cdent> i think it is suffering from internet over-engineering task force
16:26:05 <cdent> but lays out some of the goals
16:27:09 * elmiko chuckles
16:27:18 <elmiko> i had not heard ioetf XD
16:27:27 <dtantsur> heh
16:27:42 <dtantsur> I'd say this document should first appear in api-sig indeed
16:27:59 <cdent> the oslo-spec is mostly about the backend
16:28:55 <cdent> but as the api-sig, we're under no obligation to only attend to documents in our domain, being active on that spec is desired and invited
16:29:34 <edleafe> seems like there could be two parallel efforts: the oslo one to implement, and the api-sig to review and create the guidelines as needed
16:29:55 <elmiko> edleafe++
16:30:23 * cdent nods
16:30:44 <dtantsur> yeah.. thought I'd still prefer the api-sig one to show up first
16:31:00 <cdent> too late? :)
16:31:05 <dtantsur> there are interesting things from our perspective that seem missing: like how to manage microversions?
16:31:08 <edleafe> heh
16:31:24 <dtantsur> is it going to have separate microversions? the same as project? none?
16:32:34 <cdent> that, too, sounds like ioetf
16:32:44 <cdent> this thing should answer yes, no, and maybe maybe
16:32:46 <edleafe> I guess I would have to know more of the health check mechanisms to consider the need for versioning
16:33:18 <cdent> reading the specs and the etherpads will help to illuminate some of the thinking, especially the comments on the spec will identify some of the different ideas
16:33:28 * dtantsur puts on his review list
16:33:31 <cdent> there are some preconceptions which could probably be adjusted usefully
16:34:27 <elmiko> aside from the guidance about which libs to use and code stuff, i think this would really be nice to land as a guideline
16:34:36 <elmiko> *assuming* that a concensus can be achieved
16:35:07 * elmiko is skimming over the review
16:35:14 * cdent nods
16:37:33 <elmiko> i realize we might not be as quick to react as the folks driving that review though, so i'm curious if there is a way for us to signal this intention to those folks and get their advice
16:37:49 <edleafe> comment on the review?
16:37:52 <cdent> just say so on the review
16:38:03 <elmiko> that sounds way too reasonable
16:38:30 <elmiko> #action elmiko add thoughts to health check review about becoming an api-sig guideline
16:38:32 <edleafe> ok, then show up at their homes and bang on their doors
16:38:35 <elmiko> sound good?
16:38:38 <elmiko> LOL
16:38:51 * edleafe likes being unreasonable
16:38:57 <elmiko> ++
16:39:27 <cdent> take that gun from earlier
16:39:28 <dtantsur> hehe
16:39:37 <elmiko> cdent: fair enough lol
16:40:10 <elmiko> moving on...
16:40:12 <elmiko> #topic guidelines
16:40:19 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,
16:40:25 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:40:38 <elmiko> there was that addition from mordred, anything else?
16:40:40 <dtantsur> #link https://review.openstack.org/#/c/532814/ :)
16:40:56 <elmiko> ooh!
16:41:07 <cdent> dtantsur's new thing is vera nice
16:41:31 <cdent> If dtantsur likes https://review.openstack.org/#/c/531914/ we should probably freeze it?
16:41:42 <elmiko> agreed
16:41:58 <dtantsur> cdent: I haven't checked it yet, but you can freeze it. I will let you know if I really object :)
16:42:21 <edleafe> freeze it, baby!
16:42:41 <elmiko> frozen
16:43:05 <elmiko> ok, and we need to do some reviews on dtantsur's
16:43:09 <elmiko> well, i do at least
16:43:28 <edleafe> yeah, I need to review, too
16:43:54 <dtantsur> MOAR REVIEWS \o/
16:43:59 <elmiko> \o/
16:44:02 <elmiko> #topic bug review
16:44:09 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg
16:44:15 <elmiko> #link https://bugs.launchpad.net/openstack-api-sig
16:44:23 <elmiko> anything new here?
16:44:47 <cdent> no sir
16:45:17 <elmiko> #topic weekly newsletter
16:45:21 <elmiko> volunteers?
16:45:38 <cdent> it's been a while since I have, so... me?
16:45:52 <elmiko> i'm cool with that, i have a preso after this meeting anyways
16:45:55 <cdent> I'll go sit somewhere, so I can actually type
16:46:00 * edleafe pats cdent on the back
16:46:06 <elmiko> for completeness
16:46:06 <cdent> I know, right?
16:46:07 <elmiko> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:46:25 <elmiko> alrighty then, any last comments?
16:46:35 <cdent> I'll ping when I have something to review
16:46:44 <elmiko> ++
16:46:57 <elmiko> ok, we get back 14 minutes. thanks all! =)
16:47:03 <elmiko> #endmeeting