16:00:43 <cdent> #startmeeting api-sig
16:00:44 <openstack> Meeting started Thu Oct  5 16:00:43 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:48 <openstack> The meeting name has been set to 'api_sig'
16:00:52 <cdent> #chair elmiko edleafe dtantsur
16:00:56 <dtantsur> o/
16:00:59 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:01:02 * dtantsur is a chair now wow
16:01:04 <elmiko> o/
16:01:08 <cdent> Welcome to this week’s meeting
16:01:16 * cdent is an anarchist, everyone whould be chair
16:01:20 <dtantsur> lol
16:01:20 <elmiko> +1
16:01:31 * edleafe is split-brained with a work call
16:01:32 <dtantsur> speaking of me, sorry for the long absence. I was changing countries of living :)
16:01:43 <elmiko> interesting...
16:01:55 <cdent> which country of living do you have now dtantsur ?
16:02:07 <dtantsur> cdent: Germany (Berlin)
16:02:15 <elmiko> ooh, nice, <3 Berlin
16:03:31 <cdent> Berlin++
16:04:10 <cdent> So the meeting
16:04:17 <cdent> #link agenda https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:04:22 <cdent> #topic old biz
16:04:44 <cdent> I had an action: cdent to check with flanders about sdk-related stuff
16:04:54 <cdent> edleafe had an action: edleafe explore the boundaries of expression
16:05:11 <cdent> With regard to sdk related things the main action there was to create a forum session:
16:05:34 <cdent> http://forumtopics.openstack.org/cfp/details/52
16:05:54 <cdent> #link forum proposal: http://forumtopics.openstack.org/cfp/details/52
16:06:19 <cdent> apparently I don’t get emailed when people comment, so I wasn’t aware of those comments
16:06:32 <cdent> #action cdent to follow up on form proposal comments
16:06:32 <elmiko> that stinks =(
16:06:35 <cdent> #undo
16:06:36 <openstack> Removing item from minutes: #action cdent to follow up on form proposal comments
16:06:44 <cdent> #action cdent to follow up on forum proposal comments
16:06:46 <elmiko> it looked reasonable to me, i just added a suggestion
16:07:32 <cdent> maybe in terms of expression what edleafe did was:
16:07:37 <dtantsur> "Dealing with and understanding microversions" will probably occupy the whole time..
16:07:58 <cdent> #link rename to sig changes: https://review.openstack.org/#/c/508242/
16:08:55 <cdent> #topic new biz
16:09:01 <elmiko> dtantsur: probably...
16:09:03 <cdent> nothing on the agenda
16:09:09 <cdent> any new topics people have to bring up?
16:09:22 <elmiko> nothing from me, been busy and i'll be traveling again soon
16:09:33 <dtantsur> I tried reading mordred's stuff, got stuck in the middle of the 1st patch
16:10:05 <dtantsur> there is something I'd argue is not correct, and something that is just confusing to me
16:10:39 <cdent> I think it’s probably the case that given the passage of time that’s fairly wip
16:10:44 <mordred> uhoh
16:10:55 <cdent> the pieces that were above it (but have merged) adapted somewhat along the way
16:10:59 <mordred> oh - sorry - as soon as v3 rollout madness has waned, I will fix that doc - VERY sorry for the delay on that
16:11:19 <dtantsur> mordred: no problem, we haven't been reviewed it without having such a serious excuse :)
16:11:23 <cdent> “v3 rollout madness” is the _best_ ride at the local fair
16:11:29 <mordred> :)
16:11:32 <elmiko> lol
16:11:57 <mordred> dtantsur: I assume you're talking about https://review.openstack.org/#/c/459405/ of course, yeah?
16:12:19 <dtantsur> yep
16:12:25 <mordred> dtantsur: for the most part (with one exception) that has all now been implemented in keystoneauth - and yes, there are things in the doc that turned out to be wrong
16:12:56 <mordred> so in a week or two I'll grab efried and get him to help me verify that the docs and reality match :)
16:13:47 <dtantsur> I think one of my comments may be against what you coded in keystoneauth, but let's see
16:13:49 <cdent> #action mordred (post v3 rollout madness) fixup https://review.openstack.org/#/c/459405/
16:13:51 <mordred> dtantsur: and yes - just scanning your comments, difference between major and microversion was one of the things that came up in the ksa impl work that definitely needs to be fixed in that spec
16:13:57 <elmiko> mordred: ++
16:14:02 <dtantsur> yeah
16:14:22 <dtantsur> and I don't like asking for ranges vs asking for a list of specific versions. but we can continue on the spec.
16:15:51 <cdent> any other new business from any one?
16:16:31 <cdent> I had a bit of an idea, which was that it might be nice to have a kind of short summary of the guidelines, the creation of which might help find (and fix) flaws in the long form documents
16:16:46 <cdent> sort of like a cheat sheet
16:16:51 <elmiko> that sounds nice
16:17:30 <elmiko> imo, this makes me remember an idea we kicked around in the past about making a visual cheat sheet
16:17:44 <elmiko> like have an http request with parts of it annotated to link through to guidelines
16:17:45 <dtantsur> I'm not sure I really get it
16:17:48 <dtantsur> ah
16:18:21 <elmiko> regardless of implementation, i think having a quick reference is nice
16:18:39 <dtantsur> I'd welcome anything that simplifies starting with our stuff
16:18:55 <dtantsur> I remember, when I joined, there was no easy entry point
16:18:55 <elmiko> ++
16:19:03 <cdent> given how copious our free time is, I’m not sure how it will get off the ground
16:19:13 <cdent> but I was thinking of it as a good respite from other things (for me)
16:19:34 <cdent> so if we agree it is a good idea, some subset of “we” can have a noodle on it
16:19:39 <elmiko> agreed, maybe something to kick around in a spec or etherpad, to start with?
16:19:52 <elmiko> just collect ideas and start getting a picture of what might work
16:20:40 <cdent> yup
16:21:22 <elmiko> sounds good to me
16:21:35 <cdent> #action cdent (and others) start thinking about a api guidelines cheat sheet
16:21:52 <cdent> shall we move on?
16:21:59 <elmiko> ++
16:22:01 <cdent> #topic guidelines
16:22:06 <cdent> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:22:21 <cdent> we’ve already mentioned the two active things there
16:22:39 <elmiko> what about https://review.openstack.org/#/c/508242/
16:22:52 <elmiko> i need to review it, but do we need anything there?
16:22:57 <cdent> that’s one of the ones that was mentioned
16:23:06 <cdent> it has a blip identified by dtantsur that ought to be fixed
16:23:16 * edleafe is off his call and reading back
16:23:16 <dtantsur> yeah, just wanted to bring it :)
16:23:44 <elmiko> ack
16:25:21 <elmiko> i think dtantsur makes a good point, i'm good with `Audience:: Information Technology`
16:27:34 <cdent> so we can probalby merge that one next week
16:27:45 <cdent> #topic bug review
16:27:52 <cdent> #link https://bugs.launchpad.net/openstack-api-wg
16:28:03 <cdent> nothing new
16:28:13 <cdent> any bugs that ought to exist but don’t?
16:28:32 <elmiko> nothing from me
16:28:50 <cdent> #topic weekly newsletter
16:28:54 <cdent> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:28:58 <mordred> dtantsur: replied to your comments - thanks!
16:29:00 <cdent> any takers?
16:29:07 <dtantsur> np
16:29:26 <elmiko> i can take it cdent
16:29:33 <cdent> elmiko: you are a star
16:30:19 <cdent> With that we can probably call it a day. The last thing I’d ask for is if you haven’t commented on the forum thing yet, and have thoughts, please do
16:30:36 <cdent> #link forum thing http://forumtopics.openstack.org/cfp/details/52
16:30:48 <cdent> last words?
16:30:48 <elmiko> ++
16:30:58 <elmiko> i'll ping in -sdks when the newsletter is good =)
16:30:59 <edleafe> none from me
16:31:10 * edleafe feels like he's outside looking in today
16:31:18 * dtantsur is good
16:31:23 * elmiko opens door for edleafe
16:32:01 * dtantsur wants to go our, but we have a hurricane here
16:32:04 <dtantsur> s/our/out/
16:32:35 <elmiko> yikes!
16:32:38 <edleafe> In Berlin?
16:32:44 <dtantsur> yep
16:33:05 <dtantsur> https://www.thelocal.de/20171005/storm-xavier-brings-train-services-in-much-of-north-germany-to-a-stop
16:33:35 <cdent> that’s rather unusual
16:33:53 <dtantsur> Winter is coming!
16:34:04 <elmiko> haha
16:34:11 <cdent> I better end the meeting then so we can get some dragons or something
16:34:14 <cdent> #endmeeting