18:00:59 <adam_g> #startmeeting akanda
18:01:00 <openstack> Meeting started Mon Sep 21 18:00:59 2015 UTC and is due to finish in 60 minutes.  The chair is adam_g. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:04 <openstack> The meeting name has been set to 'akanda'
18:01:07 <adam_g> heyo
18:01:15 <elo> Hello
18:01:16 <sarob> o/
18:02:08 <adam_g> #topic outstanding actions from last meeting
18:02:50 <adam_g> im not seeing anything listed on the agenda. we did that PTL thing last week, sarob is there anything that needs doing in infra/elsewhere to finalize me as the current PTL?
18:03:02 <sarob> not yet
18:03:10 <sarob> the govenance patch
18:03:13 <adam_g> sarob, what are the next steps if anything?
18:03:24 <sarob> i have the patch ready to push the update
18:03:50 <adam_g> #action sarob to push governance patch finalizing PTL change
18:03:53 <sarob> im expecting an update on the trademark thing
18:03:55 <sarob> very soon
18:04:12 <adam_g> k
18:04:12 <sarob> i can push the ptl change now
18:04:28 <adam_g> nice
18:04:29 <sarob> it just wont merge until the trademark thing is worked out
18:04:43 <sarob> which should be any day now
18:04:56 <adam_g> ok well ill carry the action under your name till then
18:05:19 <adam_g> #topic mitaka planning + F2F meetup planning
18:05:50 <adam_g> sarob, what are the final dates for the PDX get together?
18:05:58 <adam_g> and have we got a location we can publicize?
18:06:40 <sarob> this coming monday and tuesday
18:06:46 <sarob> 27-28th of september
18:06:53 <adam_g> okay cool
18:07:09 <stanchan> hi all
18:07:12 <davidlenwell> o/ sorry
18:07:19 <sarob> whats the etherpad url?
18:07:26 <adam_g> i imagine we'll probably spend those days finishing up any remaining liberty work and trying to get it all merged
18:07:26 <sarob> stanchan: heya
18:07:50 <sarob> for the mitaka design planning
18:07:59 <adam_g> https://etherpad.openstack.org/p/akanda-mitaka-planning is the etherpad we started for our tokyo planning but its honest. TBH i think we're all a bit burdened with pre-release crunch and we will probably have an easier time braindumping there once liberty is behind us
18:08:03 <adam_g> #link https://etherpad.openstack.org/p/akanda-mitaka-planning
18:08:35 <adam_g> #action lets all start brainstorming ideas for mitaka topics to tackle in tokyo @ https://etherpad.openstack.org/p/akanda-mitaka-planning
18:08:38 <sarob> adam_g: yeah, i want to overload it with our f2f agenda
18:09:30 <adam_g> #info Portland akanda meetup happening sept 27+28th in portland OR, exact location TBD this week
18:09:47 <adam_g> #topic critical bugs
18:09:49 <sarob> i have the exactly location
18:09:54 <adam_g> sarob, o rly?
18:10:05 <adam_g> do share
18:12:11 <sarob> 2124 Southeast Ankeny Street, Portland, OR 97214
18:12:35 <adam_g> sarob, there an office name or something?
18:12:39 <stanchan> sarob: I ran through the akanda devstack install... it errored out.  Trying to figure out if it's something with my environment.
18:12:47 <sarob> its where i am staying in PDX
18:13:11 <adam_g> sarob, huh? where is the meetup happening
18:13:31 <sarob> the f2f for akanda
18:13:45 <sarob> which is us
18:13:56 <sarob> its a house
18:13:58 <davidlenwell> adam_g:  we're renting a house for our group we are going to hold the face to face at that house.. cuz.. why not
18:14:09 <sarob> with a large table and wifi
18:14:16 <adam_g> oh, interesting
18:14:31 <adam_g> anyway..
18:14:34 <adam_g> #topic critical bugs
18:14:39 <adam_g> https://bugs.launchpad.net/akanda/+milestone/liberty-rc1
18:14:47 <adam_g> #link https://bugs.launchpad.net/akanda/+milestone/liberty-rc1
18:15:06 <adam_g> i feel like markmcclain was hitting https://bugs.launchpad.net/akanda/+bug/1482389 as well last week and hopefully he's got some more insight into a fix
18:15:08 <openstack> Launchpad bug 1482389 in akanda "demo tenant instance connectivity issues /w devstack " [High,New]
18:15:19 <adam_g> if he wasn't absent right now i'd assign it to him
18:15:55 <adam_g> thats the only bug we have targetted to RC1 that hasn't had any progress
18:16:11 <adam_g> the others are either landed or in review, any help getting the proposed patches landed would be appreciated
18:16:55 <adam_g> anyone have any other bugs that need immediate attention before RC1?
18:17:42 <adam_g> ok
18:17:46 <adam_g> #topic progress on liberty rc1 blueprints
18:18:06 <adam_g> #link https://launchpad.net/akanda/+milestone/liberty-rc1
18:18:19 <adam_g> https://blueprints.launchpad.net/akanda/+spec/appliance-provisioning-driver
18:18:52 <adam_g> so the driver work is progressing into its final iteratinos now i hope
18:19:08 <adam_g> we've got a functional driver framework in review and im in the process of building the initial LBAAS driver on top of that
18:20:00 <adam_g> https://blueprints.launchpad.net/akanda/+spec/lbaas-v2-support looks like it overlaps with that blueprint. can we ditch this one in favor of tracking everything in the appliance-provisioning-driver BP?
18:20:15 <adam_g> or were you intentionally separating them, sarob  ?
18:20:34 <sarob> not intentionally
18:20:48 <sarob> but my assumption early on
18:21:02 <sarob> was that the ability to support a router driver
18:21:10 <sarob> appliance
18:21:28 <adam_g> ok i guess ill keep them separate for now and update the later lbaas patches to point to the second one later today
18:21:30 <sarob> was separate than lbaas nginix driver
18:21:39 <adam_g> https://blueprints.launchpad.net/akanda/+spec/nodepool-support
18:21:52 <sarob> it was titled as lbaasv2 though
18:22:09 <adam_g> i made good progress on this last week but swithced focus late in the week to help get the lbaas driver stuff closer, i will hopefully have time to pick it up again and finish it later this week
18:22:26 <adam_g> https://blueprints.launchpad.net/akanda/+spec/liberty-doc-updates
18:22:31 <adam_g> sarob, anything to update on docs front?
18:23:04 <sarob> im adding multi-node to install
18:23:14 <sarob> then its ready to merge
18:23:32 <adam_g> i think part of the liberty doc updates should include sections on new user-facing features like pez and the active/active rug HA.. assuming those land this cycle
18:23:49 <adam_g> probably the driver stuff too, in the developer section
18:24:13 <sarob> adam_g: sure
18:24:20 <adam_g> https://blueprints.launchpad.net/akanda/+spec/rug-scaling
18:24:29 <sarob> adam_g: i can patch that into the what is akanda section
18:24:34 <adam_g> this stuff has been languishing in review for some time now
18:24:37 <sarob> pez and such
18:25:01 <adam_g> it totally conflicts with the driver work thats still in progress, which is unfortunate. i guess we should focus on landing that and then i'll doa  rebase of the rug-scaling once it has
18:25:42 <adam_g> #topic liberty release
18:26:01 <adam_g> last month we had agreed in a meeting that we'd be cutting our RC1 this week
18:26:09 <adam_g> at least, IIRC
18:26:25 <adam_g> TBH it doesnt seem like thats going to happen
18:26:45 <adam_g> i propose we bump it till next week and hope we can flush through the rest of our work between now and then, taking advantage of F2F time on mon+tues
18:27:14 <sarob> sounds good to me
18:27:16 <adam_g> in tokyo i'd like to formalize our release planning, come with a schedule and stick to it for mitaka
18:28:05 <adam_g> any objections to delaying RC1 till oct 1?
18:28:51 <adam_g> ...
18:29:00 <adam_g> the crickets say no
18:29:01 <davidlenwell> no objections
18:29:14 <adam_g> #info liberty rc1 pushed back to thurs oct 1
18:29:27 <adam_g> #topic open discussion
18:29:36 <adam_g> anyone have anything else they'd like to bring up?
18:29:55 <adam_g> ryanpetrello was trying to get something landed to stable/kilo but it looks like theres a requirements jam going on there. i'll be looking into that today
18:30:19 <sarob> adam_g: release planning, yes
18:31:05 <adam_g> ok unless anyone has anything else, we can call it
18:31:28 <sarob> i have nothing else
18:31:56 <adam_g> right on cya guys later
18:32:06 <adam_g> stanchan, if you need help with devstack running please follow up in #akanda
18:32:07 <adam_g> #endmeeting