18:01:43 <sarob> #startmeeting akanda
18:01:44 <openstack> Meeting started Mon Aug  3 18:01:43 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:48 <openstack> The meeting name has been set to 'akanda'
18:01:54 <adam_g> o/
18:01:58 <markmcclain> o/
18:02:03 <puranamr> o/
18:02:39 <sarob> agenda
18:02:45 <sarob> #link https://wiki.openstack.org/wiki/Meetings/akanda
18:03:20 <davidlenwell> o/
18:03:37 <sarob> there are no follow up actions from previous meeting
18:03:47 <sarob> so lets move to
18:03:53 <sarob> #topic critical bugs
18:04:32 <sarob> #link https://bugs.launchpad.net/akanda/+bug/1470673
18:04:32 <openstack> Launchpad bug 1470673 in akanda "pbr version numbering doesn't match semantic versioning" [Critical,In progress] - Assigned to Sean Roberts (sarob)
18:04:33 <uvirtbot> Launchpad bug 1470673 in akanda "pbr version numbering doesn't match semantic versioning" [Critical,In progress]
18:04:34 <uvirtbot> Launchpad bug 1470673 in akanda "pbr version numbering doesn't match semantic versioning" [Critical,In progress] https://launchpad.net/bugs/1470673
18:04:53 <sarob> we stuck with the 2015.2.x numbering
18:05:11 <adam_g> so there are two unrelated bugs that are blocking the setup.cfg versioning changes from merging
18:05:25 <sarob> until we could come to a decision on on 7.0.0 or 2.0.0
18:05:28 <adam_g> one is an API change in the newer mock
18:05:31 <sarob> adam_g: true
18:05:43 <adam_g> addressed by https://review.openstack.org/#/c/207697/ (squashed with the versioning change)
18:06:00 <adam_g> the other is more critical and is in upstream neutron change that changed the way extensions register
18:06:06 <adam_g> https://launchpad.net/bugs/1480418
18:06:06 <openstack> Launchpad bug 1480418 in akanda "gate-functional-dsvm-akanda failing, q-svc doesnt load dhrouterstatus extension" [Critical,In progress] - Assigned to Adam Gandelman (gandelman-a)
18:06:06 <uvirtbot> Launchpad bug 1480418 in akanda "gate-functional-dsvm-akanda failing, q-svc doesnt load dhrouterstatus extension" [Critical,In progress]
18:06:07 <uvirtbot> Launchpad bug 1480418 in akanda "gate-functional-dsvm-akanda failing, q-svc doesnt load dhrouterstatus extension" [Critical,In progress] https://launchpad.net/bugs/1480418
18:06:23 <adam_g> the latter actualyl blocks version change to akanda-neutron and akanda-appliance
18:06:29 <adam_g> addressed by https://review.openstack.org/#/c/208052/
18:06:33 <adam_g> needs a +W and we swhould be good
18:06:54 <markmcclain> adam_g: I
18:06:56 <sarob> do i hear a merge!
18:07:01 <markmcclain> adam_g: I'll review it
18:07:12 <adam_g> markmcclain, cool.
18:07:13 <sarob> cool
18:07:36 <adam_g> markmcclain, is this a neutron bug? seems like a bad thing to break for out of tree extensions like ourselves
18:07:52 <markmcclain> at some point in time, we'll need to revisit how we're integrating with quota's
18:08:17 <markmcclain> authzbase is fork from folsom and there's better ways to do it now
18:08:44 <adam_g> ah
18:10:00 <sarob> we have merge
18:10:03 <sarob> well start
18:10:05 <sarob> of gate
18:10:22 <adam_g> okay
18:10:27 <adam_g> so that should get pending stuff into master
18:10:34 <sarob> i believe the rest have merged
18:10:35 <markmcclain> cool
18:10:47 <adam_g> after the 2015.2 changes go through what is the plan?
18:10:54 <sarob> shall we revisit 7 verses 2
18:11:03 <adam_g> sarob, are yo ugoing to tag the b2 and then we make the switch to a semver?
18:11:04 <sarob> verses 2015.2
18:11:21 <sarob> that is my current plan,
18:11:56 <adam_g> 7.0.0 is fine by me for alignment /w neutron.
18:12:03 <sarob> adam_g: does that sound correct?
18:12:10 <sarob> i have 7
18:12:14 <sarob> do i have another
18:12:25 <markmcclain> 7 is the current version number
18:13:02 <sarob> markmcclain: for neutron
18:13:59 <sarob> markmcclain: i believe you are in favor of 7 version numbering for akanda as well
18:14:08 <sarob> as is I
18:14:22 <sarob> in favor of 7 rather than 2015.2 or 2
18:15:05 <sarob> anyone else?
18:15:06 <markmcclain> we either need to be 7 or 2
18:15:25 <sarob> markmcclain: do you have a preference for either?
18:15:40 <adam_g> sarob, before you tag anything lets look through open reviews and bugs. see if we can get some stuff merged into the less active repos  to make sure we dont re-tag HEAD in a repo that hasn't moved.
18:16:13 <markmcclain> I'm open what ever everyone else is wants to do
18:16:16 <markmcclain> adam_g: good idea
18:16:22 <sarob> adam_g: sure
18:16:35 <sarob> horizon is pretty cool
18:16:57 <sarob> unless you think we should create a dummy patch to move head
18:17:14 <adam_g> sarob, im sure i can find something that needs to be fixed :)
18:17:22 <markmcclain> haha
18:17:25 <sarob> adam_g: right on
18:17:36 <adam_g> anyway..
18:17:39 <adam_g> 7.0.0 good?
18:17:56 <sarob> adam_g: 7 is my choice, matching neutron
18:18:03 <adam_g> fine by me
18:18:17 <sarob> i think that is a quorum
18:18:50 <sarob> so i will hold off this week with new ml2 tags
18:19:04 <davidlenwell> no objections
18:19:20 <sarob> looking for head to be moved off 2015.2.0b1 tag
18:19:39 <markmcclain> ml2 tag?  milestone tag?
18:19:52 <sarob> yup
18:20:01 <sarob> i meant lm2
18:20:12 <sarob> funky typing
18:20:23 <sarob> liberty milestone 2
18:20:40 <sarob> lm2 will be 2015.2.0b2
18:20:56 <sarob> lm3 will be 7.0.0b3 matching neutron
18:21:31 <sarob> #action sarob lm2 tag 2015.2.0b2
18:21:47 <sarob> #action sarob lm3 tag 7.0.0b3
18:22:13 <sarob> other crtiical bug
18:22:16 <sarob> #link https://bugs.launchpad.net/akanda/+bug/1477381
18:22:16 <openstack> Launchpad bug 1477381 in akanda "rug-ctl browse fails with no route to host" [Critical,In progress]
18:22:28 <uvirtbot> Launchpad bug 1477381 in akanda "rug-ctl browse fails with no route to host" [Critical,In progress]
18:22:29 <uvirtbot> Launchpad bug 1477381 in akanda "rug-ctl browse fails with no route to host" [Critical,In progress] https://launchpad.net/bugs/1477381
18:22:37 <davidlenwell> first off that is't the right error message
18:22:53 <davidlenwell> what it is actually complaining about is that no host option was specified
18:23:13 <davidlenwell> which is actually a failure of importing the config in that context
18:23:16 <adam_g> the fix @ https://review.openstack.org/#/c/204748/ should merge after the other stuff mentioned above flushes through
18:23:20 <davidlenwell> which adam pushed a fix for last week
18:23:29 <sarob> looks like it already merged
18:23:31 <markmcclain> ok.. I'm going up update the title
18:23:37 <sarob> just the bug didnt get updated
18:24:35 <adam_g> that one is basically fixed-committed pending the gate unblocking
18:24:37 <adam_g> NEXT
18:24:54 <sarob> right
18:25:07 <sarob> #topic progress liberty milestone 2
18:25:42 <sarob> #link https://launchpad.net/akanda/+milestone/liberty-2
18:25:57 <sarob> looks like we are going to slip
18:26:13 <sarob> if lm2 is going to tag within a week or so
18:26:41 * adam_g is going through updating bug status
18:26:52 <sarob> shall i push all the bp to lm3 minus octavia and vpnaas
18:27:22 <sarob> adam_g: holding for a minute so you can catch up
18:27:32 <adam_g> also
18:27:36 <adam_g> im going to merge Rug Scaling and Rug HA
18:27:57 <adam_g> oh nvm
18:28:08 <markmcclain> yeah anything that didn't make milestone-2 should be bumped
18:28:54 <sarob> davidlenwell: hows the driver spec coming
18:29:13 <davidlenwell> will push today regardless of how I feel about it
18:29:23 <sarob> davidlenwell: sounds good
18:30:12 <sarob> any other reviews of pending specs?
18:31:12 <adam_g> i fixed up the bug list for the milestone
18:31:20 <sarob> adam_g: thanks!
18:31:21 <adam_g> there are two bugs that have no assignee
18:31:25 <adam_g> https://bugs.launchpad.net/bugs/1473771
18:31:25 <openstack> Launchpad bug 1473771 in akanda "building the appliance instructions are out of date" [High,New]
18:31:26 <uvirtbot> Launchpad bug 1473771 in akanda "building the appliance instructions are out of date" [High,New]
18:31:27 <uvirtbot> Launchpad bug 1473771 in akanda "building the appliance instructions are out of date" [High,New] https://launchpad.net/bugs/1473771
18:31:29 <adam_g> https://bugs.launchpad.net/bugs/1462098
18:31:29 <openstack> Launchpad bug 1462098 in akanda "No logging in the appliance" [Medium,New]
18:31:30 <uvirtbot> Launchpad bug 1462098 in akanda "No logging in the appliance" [Medium,New]
18:31:31 <uvirtbot> Launchpad bug 1462098 in akanda "No logging in the appliance" [Medium,New] https://launchpad.net/bugs/1462098
18:31:42 <adam_g> IMO if we dont have anyone assigned and working on them now we should untarget them
18:31:53 <adam_g> unless someone wants to volunteer to work on them now
18:32:13 <adam_g> the build instructions seems like low hanging fruit
18:32:15 <markmcclain> adam_g: thanks for updating
18:32:39 <markmcclain> adam_g: yeah if they're unassigned makes sense to remove the target unless critcial
18:32:48 <adam_g> actually looking over the docs it looks like they may have been updated already
18:33:21 <adam_g> ah cool
18:33:24 <adam_g> it is fixed already
18:33:45 <markmcclain> best kind of bugs
18:34:01 <adam_g> :)
18:34:34 <sarob> i think i fixed that one right after i logged it
18:34:52 <markmcclain> we also start using tags a bit more
18:35:18 <adam_g> https://bugs.launchpad.net/bugs/1462098 is the only remaining one
18:35:18 <uvirtbot> Launchpad bug 1462098 in akanda "No logging in the appliance" [Medium,New]
18:35:18 <openstack> Launchpad bug 1462098 in akanda "No logging in the appliance" [Medium,New]
18:35:20 <uvirtbot> Launchpad bug 1462098 in akanda "No logging in the appliance" [Medium,New] https://launchpad.net/bugs/1462098
18:35:32 <adam_g> im in favor of untargetting it especially since we dont have a good story around appliance logging atm
18:35:41 <sarob> sounds good
18:35:52 <adam_g> we could probably tackle that as part of a larger blueprint around appliance logging
18:36:02 <adam_g> (later on)
18:36:04 <markmcclain> agreed
18:36:32 <adam_g> ok cool
18:37:27 <sarob> any other discussion on lm2 bp?
18:38:00 <sarob> #action sarob to push unfinished lm2 bp to lm3
18:38:07 <sarob> #topic any other business
18:38:34 <adam_g> our stable branches are borked atm
18:38:38 <adam_g> on another gate blocker
18:38:55 <adam_g> but it should be fixed by a new release of python-neutronclient
18:39:06 <adam_g> which mestery_afk said he'd be getting out early this week
18:39:26 <markmcclain> I'll follow up with him
18:39:42 <adam_g> once thats out our stable/juno pathces should be good to merge and flush through... and then our open review queue should hopefully start to shrink and show a lot less RED
18:40:04 <sarob> adam_g: yea!
18:41:45 <sarob> davidlenwell, puranamr, and sarob are running another agile training session this thursday
18:41:58 <sarob> #link http://www.meetup.com/openstack/events/223611752/
18:42:38 <sarob> we have slightly modified our plan from last time
18:42:58 <sarob> so the three of us should spend a some time this week reviewing
18:43:06 <sarob> i send out an invite
18:43:14 <puranamr> sarob: sure
18:44:11 <sarob> anything else
18:44:14 <sarob> ..
18:44:15 <sarob> .
18:45:10 <sarob> okey dokey
18:45:22 <sarob> then i give back 15 minutes to y'all
18:45:59 <sarob> #endmeeting