18:02:10 <sarob> #startmeeting akanda
18:02:11 <openstack> Meeting started Mon Jul 13 18:02:10 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:02:15 <openstack> The meeting name has been set to 'akanda'
18:02:18 <sarob> morning
18:02:23 <sarob> roll call
18:02:24 <davidlenwell> o/
18:02:28 <puranamr> morning o/
18:02:47 <sarob> agenda is pretty simple
18:03:10 <sarob> outstanding patches, semver agreement, and driver update
18:03:17 <sarob> first semver
18:03:27 <sarob> #topic semver change
18:04:00 <sarob> i have few outstanding patches to mod the package version to 7.0.0
18:04:14 <sarob> 2015.x versioning is done
18:04:25 <sarob> neutron has moved to 7.0.0
18:04:33 <sarob> nova has moved 12.0.0.0
18:04:46 <sarob> the question is
18:05:05 <sarob> does akanda move in step with neutron and its subprojects to 7.0.0
18:05:30 <sarob> or 2.0.0 since this is the second public release we are working on
18:05:42 <sarob> i like following neutron
18:05:47 <davidlenwell> I personally don't feel like we should concern ourselves too much with what number scheme we use as long as we stay consistant.
18:05:48 <sarob> what you all say?
18:06:07 <sarob> davidlenwell: consistent is important
18:06:18 <sarob> puranamr: your thoughts?
18:06:27 <davidlenwell> So with that in mind I am going to suggest that we stick to what we've already started with.
18:07:06 <puranamr> sarob: we may need to clarify as to why it was moved from 1.0 to 7.0, for late joiners
18:07:18 <puranamr> could confuse too
18:07:22 <sarob> davidlenwell: you mean with 2015.x?
18:07:35 <sarob> puranamr: we are currently at 2015.x version
18:07:37 <davidlenwell> 2015.2.0.x.x.x.x
18:07:40 <davidlenwell> or whatever it is
18:08:04 <sarob> davidlenwell: so you would rather not join the semver movement
18:08:28 <davidlenwell> I think its confusing to jump from version 2015.1.x to 7.x
18:08:34 <davidlenwell> we don't have 7 releases
18:08:44 <sarob> davidlenwell: true
18:08:50 <puranamr> yes that is what my thinking also is
18:09:07 <sarob> davidlenwell: are we not closely tied with neutron
18:09:12 <markmcclain> sorry... appt ran long.. reading scrollback
18:09:19 <sarob> markmcclain: np
18:09:28 <davidlenwell> of course we are .. but that doesn't mean our version numbers have to coralate
18:09:53 <sarob> markmcclain: we are discussion the proposed semver changes
18:10:00 <sarob> discussing that is
18:10:00 <markmcclain> ah right
18:10:51 <markmcclain> davidlenwell: I take it you want us to have our own velocity in terms of version numbering?
18:10:58 <davidlenwell> yes
18:11:05 <davidlenwell> thats how software versioning works
18:11:22 <davidlenwell> we can map out compatibility
18:11:29 <davidlenwell> it will never be a one to one mapping
18:12:18 <markmcclain> yeah... I think the biggest challenge currently is expressing how we map to main servers since they're not releasing yet
18:13:16 <davidlenwell> but I don't think hopping around in our versioning naming convention is a wise choice.. it will lead to us having to do a lot more explination than is needed
18:13:42 <davidlenwell> that is my humble opinion.. and I think we have bigger fish to fry at the moment than a numbering convention
18:13:54 <sarob> davidlenwell: so sticking with current version is your perf
18:14:01 <davidlenwell> yes
18:14:01 <puranamr> 1+
18:14:48 <markmcclain> well the rest of OpenStack is jumping to X.0.0  5 < X < 11
18:15:04 <markmcclain> as is we have to explain that this is our 1.0 release
18:15:15 <markmcclain> I'd be ok making our code match that version
18:16:54 <sarob> markmcclain: so that would be 2.0.0 ?
18:17:13 <sarob> markmcclain: for this current cycle
18:17:18 <markmcclain> or even 1.1
18:17:25 <sarob> markmcclain: right
18:17:37 <davidlenwell> 1.1 is more accurate
18:18:20 <sarob> davidlenwell: im fine with that
18:19:13 <sarob> davidlenwell: so are we leaning towards updating versioning based on our own schedule sooner
18:19:31 <davidlenwell> I think so?
18:19:44 <sarob> we had discussed earlier about sticking with the community schedule for liberty
18:20:40 <sarob> if we start doing minor and major releases over the summer, then we are breaking with that
18:20:50 <davidlenwell> schedule and version number are two different topics
18:21:22 <markmcclain> +1
18:21:27 <sarob> davidlenwell: so when the driver code is released
18:21:44 <sarob> and ml2 arrives
18:22:03 <davidlenwell> those are pretty major changes.. large delta .. so it might bump it to 2
18:22:05 <sarob> we go 1.2 at ml2 or when the driver code is landed
18:22:16 <sarob> my point
18:23:29 <davidlenwell> We early on discussed a release train model
18:23:42 <sarob> more importantly how the distros work with our versioning
18:23:56 <davidlenwell> so that version numbers are tied to specific dates .. and what makes it in makes it in
18:24:05 <davidlenwell> and the train leaves on time
18:24:09 <davidlenwell> no matter what
18:24:18 <sarob> davidlenwell: i still like that model
18:24:47 <davidlenwell> it has positive and negitive impacts on dev cycles
18:24:48 <sarob> right now im stuck with the semver or not to semver
18:25:48 <markmcclain> tooling for semver is better
18:25:56 <davidlenwell> well I think we've spent a lot of time talking about it .. and I honestly don't think its all that important
18:26:23 <sarob> i have these patches out
18:26:24 <sarob> https://review.openstack.org/#/c/197787/
18:26:31 <sarob> on moving to 7.0.0
18:27:19 <davidlenwell> lets use the review to discuss it ..
18:27:30 <sarob> good plan
18:27:42 <davidlenwell> I'll review and leave my thoughts
18:27:53 <sarob> cool
18:28:22 <sarob> #topic driver code
18:28:34 <sarob> https://review.openstack.org/#/c/195814/
18:28:41 <sarob> #link https://review.openstack.org/#/c/195814/
18:28:49 <davidlenwell> driver code has been on hold while we do the last mile on the dreamhost migration
18:29:07 <sarob> understood
18:29:23 <sarob> any thoughts on it for the log?
18:29:33 <davidlenwell> I'd like to get back to it
18:29:44 <davidlenwell> let the record state ;)
18:29:53 <sarob> davidlenwell: :)
18:30:30 <markmcclain> haha
18:31:09 <sarob> davidlenwell: i assume you need some review of the current patch
18:31:14 <davidlenwell> no..
18:31:27 <davidlenwell> that patch is a serious work in progress.. it would be a waste of time to review it
18:31:57 <davidlenwell> I pushed it up because I needed to switch context and needed to be able to cleaning get my local dir back to that state later
18:32:16 <sarob> davidlenwell: right
18:32:39 <sarob> adam_g: is out for a least a week or two more
18:32:56 <davidlenwell> as he should be
18:33:03 <sarob> #info adam_g has a new baby girl and is out on leave for a few weeks
18:33:12 <sarob> davidlenwell: yup
18:33:36 <sarob> #topic current patches
18:33:55 <sarob> other than adam_g and the driver code
18:34:05 <sarob> there is ryanpetrello patch
18:34:24 <sarob> https://review.openstack.org/#/c/201220/
18:34:34 <markmcclain> right... he was fixing some bad mocks
18:34:41 <ryanpetrello> I'm not sure if ^ tests pass yet
18:34:50 <ryanpetrello> they don't pass on osx and I was too lazy to spin up Linux
18:34:59 <ryanpetrello> but the failing ones on osx looked OS-related
18:35:17 <markmcclain> yeah.. there's one test that fails unless run on Linux
18:37:10 <davidlenwell> lgtm.. I'll check it out and run the tests today
18:37:15 <sarob> davidlenwell: thx
18:37:24 <sarob> #topic any other business
18:38:24 <sarob> #action team review on semver to 7.0.0, 2.0, or 1.2 on patch https://review.openstack.org/#/c/197787/
18:38:59 <sarob> if no other business
18:39:07 <sarob> i call this
18:39:15 <markmcclain> nothing from me
18:39:26 <sarob> davidlenwell, ryanpetrello, puranamr?
18:39:41 <puranamr> nothing from my side too
18:39:42 <davidlenwell> negatory
18:39:43 <ryanpetrello> nothing on my end
18:39:47 <sarob> roger roger
18:39:53 <sarob> cheers everyone
18:40:05 <sarob> #endmeeting