13:59:30 <sthussey> #startmeeting Airship Meeting 2018-11-06
13:59:31 <openstack> Meeting started Tue Nov  6 13:59:30 2018 UTC and is due to finish in 60 minutes.  The chair is sthussey. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:34 <openstack> The meeting name has been set to 'airship_meeting_2018_11_06'
13:59:50 <mattmceuen> GM! o/
14:00:29 <sthussey> Good morning everyone, markburnett is unavailable this morning so I'm typing the commands for meetbot
14:00:52 <sthussey> Our agenda is up at https://etherpad.openstack.org/p/airship-meeting-2018-11-06
14:01:38 <sthussey> I'll give everyone a few minutes to add any topics they'd like and then we'll get started
14:01:50 <aaronsheffield> \o
14:04:19 <b-str> Hello
14:05:56 <sthussey> Okay, it is 5 after so let's get started
14:06:16 <sthussey> #topic Announcement - Airship at the Berlin Summit
14:06:29 <mattmceuen> One thing to add here on top of last week in prep for the summit
14:07:06 <mattmceuen> We have a handful of airship-related forum topics - I have put up the beginnings of etherpads to start prepping for those
14:07:12 <sthussey> So just a few links in the agenda with opportunities to learn about or contribute to Airship at the Summit
14:07:31 <mattmceuen> They are not well fleshed out yet but wanted to have something to share this am
14:07:35 <mattmceuen> https://etherpad.openstack.org/p/BER-container-security
14:07:35 <mattmceuen> https://etherpad.openstack.org/p/BER-airship-qa
14:07:35 <mattmceuen> https://etherpad.openstack.org/p/BER-airship-bare-metal
14:08:14 <sthussey> I believe the Airship core team will have 4 representatives at the summit presenting in some capacity
14:08:18 <mattmceuen> For cross-project lessons learned around containerized security, Airship for QA use, and Airship bare metal provisioning discussion
14:08:57 <mattmceuen> Feedback / help grooming those appreciated!  Share with folks who might be interested as well.
14:08:59 <mattmceuen> Thx!
14:09:33 <sthussey> We'll move on as mattmceuen has provided a forum for feedback and questions
14:09:49 <sthussey> #topic OB - Airship-in-a-bottle (AIAB) status
14:10:24 <sthussey> Last week during the meeting, the tip of master for AIAB wasn't working. I don't know if anyone has an update on that?
14:11:00 <mattmceuen> A fix was put in - I don't think I heard positive / negative confirmation of whether that resolved things, but may have missed it?
14:11:03 <b-str> I've not stood up an instance since before I was vacationing last week - when I left, One issue was resolved, but more remained - I didn't see any changes fly by to fix any more of it.
14:11:24 <mattmceuen> Are there bugs in storyboard or any such for the remaining issues?
14:11:41 <b-str> not that I created, so I don't know.
14:12:01 <b-str> but one issue was with the move of Promenade to use PBR - this seems to have introduced a problem.
14:12:02 <mattmceuen> Where's the best info live, in the mailing list?
14:12:16 <b-str> I think in the line above your question.
14:12:39 <sthussey> There is a CI gate that attempts to run AIAB
14:13:01 <sthussey> however, it is silent as there is currently no capacity to publish logs without being on a private network
14:13:16 <sthussey> so we can internally look there for the latest status
14:13:22 <b-str> need to get that solidified. I had to move on to some other work yesterday, so I've not gotten back at AIAB just yet. Sounds like this is my plan for today - I'll start creating bugs for issues I find and can't fix immediately.
14:13:42 <mattmceuen> thank you b-str please tag me on those, I'll try to help too
14:13:55 <mattmceuen> need to get that in good shape before berlin
14:14:00 <b-str> yep
14:14:06 <mattmceuen> not that it's good to be broke the rest of the time either :)
14:14:10 <sthussey> #action b-str will be working to flush out the last issues for AIAB
14:14:43 <sthussey> the other end is future plans for said demo
14:14:43 <b-str> Mind you I'll be focusing on the script version, not the multinode gates version for the time being.
14:15:03 <sthussey> okay
14:15:10 <mattmceuen> it's the script version that's run by the gate, right?
14:15:22 <mattmceuen> (the broken job I mean)
14:15:27 <b-str> It's the one pointed to by our webpage
14:15:32 <sthussey> there has been some discussion about consolidating the airship-in-a-bottle demo with airship-treasuremap
14:15:49 <b-str> that has an item in storyboard.
14:16:29 <b-str> https://storyboard.openstack.org/#!/story/2003778
14:16:43 <sthussey> looks like there is also a bug on storyboard for general failure
14:16:48 <mattmceuen> Hey, so we've started tagging stable, worthy treasuremap integrations: https://github.com/openstack/airship-treasuremap/releases
14:16:54 <mattmceuen> as releases
14:17:19 <mattmceuen> Maybe a good practice would be, post TM-refactoring, to point AiaB to the most recent globals from that
14:17:48 <b-str> https://github.com/openstack/airship-treasuremap/releases
14:17:54 <sthussey> if that is target state, then we need a stable branch as well as tags
14:18:14 <sthussey> otherwise someone has to continually update AIAB config to point at a new tag
14:18:28 <b-str> that storyboard item above needs more love and attention... I put it out as a stake in the ground.
14:18:46 <b-str> Please provide feedback, direction, etc... to help move that forward.
14:19:04 <mattmceuen> I guess my point sthussey was that, inasmuch as aiab is a "demo", would make sense to demo one of the more formal release tags
14:19:05 <b-str> I think it would make sense to have decisions like ^^^^ be part of that story.
14:19:26 <mattmceuen> ++
14:20:11 <b-str> In general, I think we all want the same thing - predictable, recent, and repeatable AIAB.
14:20:58 <mattmceuen> I think an item for next week
14:21:11 <mattmceuen> would be to get a little more detail on the release process planned by kaspars
14:21:12 <sthussey> okay, so an opportunity for someone to review both airship-in-a-bottle and airship-treasuremap and then provide some enhancement to the storyboard item b-str linked above
14:21:42 <mattmceuen> my impression was that these releases would be "periodic", read monthly(?) but that would be a very different animal from e.g. nightly tags
14:22:08 <mattmceuen> anyone interested in taking that on?
14:22:14 <sthussey> not sure. as far as I know it was unilateral, so kaspars would need to provide that information.
14:22:54 <mattmceuen> sorry, I meant taking on the opportunity you mentioned sthussey:
14:22:54 <mattmceuen> " an opportunity for someone to review both airship-in-a-bottle and airship-treasuremap and then provide some enhancement to the storyboard item b-str linked above"
14:23:54 <mattmceuen> I want to help with that but will be out for a couple weeks after this week, so maybe someone looking to get experience in manifest engineering / QA realm might be interested in taking point
14:24:17 <mattmceuen> But we can take that offline / bring up in chat later too
14:24:25 <sthussey> Okay
14:24:46 <sthussey> #action Work on enhancing storyboard 2003778
14:24:54 <sthussey> Any other comments on AIAB?
14:25:02 <mattmceuen> not from me
14:25:23 <sthussey> Moving on then
14:25:26 <sthussey> #topic OB - Ironic support as a node driver in Drydock
14:25:53 <sthussey> Just wanted to bring this back as there is an outstanding spec linked in the agenda
14:26:09 <sthussey> Anyone interested in this functionality should provide feedback there
14:26:31 <sthussey> Anything else?
14:26:39 <b-str> Has this been reviewed on the Thursday meeting ?
14:26:51 <b-str> I've missed too many of those
14:26:59 <sthussey> I don't know, I don't attend
14:27:17 <b-str> Maybe we can see if this is ready for Rodolfo to cover there.
14:27:26 <b-str> and maybe spur some conversation
14:27:29 <sthussey> I'm not sure we can make that meeting a gate for work
14:27:41 <b-str> probably not... just an idea
14:27:43 <sthussey> but certainly can be broached in that forum if there is interest
14:28:18 <mattmceuen> agree, there's good discussion around specs in rodolfo's call, would be a good place to cover
14:28:33 <mattmceuen> also, in the forum mentioned above for folks at the summit next week
14:28:35 <sthussey> but until then, anyone interested should provide feedback via Gerrit in the spec
14:29:07 <sthussey> Anything else?
14:29:54 <sthussey> Moving on to new business
14:30:10 <sthussey> #topic NB - Best forums for support
14:30:52 <b-str> Question on this ... I see this is about what channel to use, but is there any discussion about expectations and levels of support? Or is that a completely different discussion?
14:31:01 <sthussey> So dealing in reality, Airship is something mostly maintained by folks at AT&T at this point.
14:31:11 <sthussey> Well, I think it all is entangled
14:31:56 <sthussey> My point in putting it on here is that community support requests are not always going to be prioritized such that they are responded to quickly
14:32:35 <roman_g> Hi.
14:32:52 <roman_g> Who would reply to te e-mail's we've got today morning?
14:32:52 <b-str> I think I agree with the channels for support as listed though - might want to call out the subreddit since that's kinda new
14:33:09 <b-str> like as an announcement
14:33:18 <sthussey> So IRC may not be the best forum for these types of request because synchronous communication becomes painful between timezone differences and folks only having capacity to respond occasionally.
14:33:38 <sthussey> Well, I wanted to bring this to a discussion in terms of what is the best forum
14:33:46 <b-str> ah
14:33:51 <sthussey> Some of the cores have recently received direct emails asking for support
14:34:10 <sthussey> this is not the best way, and IMO, not an appropriate way
14:34:29 <roman_g> I would aslo try to note somewhere that logs should be posted to some pastebin, and not directly to the e-mail/irc/subreddit
14:34:30 <mattmceuen> yeah, keeping those in the open will 1) increase odds of getting help 2) increase odds of other folks benefitting from the help
14:34:33 <roman_g> *also
14:34:43 <mattmceuen> good thought roman
14:34:46 <sthussey> As I mentioned, IRC has issues with the challenges of synchronous communication
14:35:07 <b-str> I kinda like the subreddit for its persistence and threading and searchability. IRC can do some of that (digests), but seems a lot more transient.
14:35:18 <sthussey> though IRC is certainly appropriate, just may not yield success
14:35:33 <sthussey> I also think the subreddit is a pretty nice forum
14:35:51 <openstackgerrit> Felipe Monteiro proposed openstack/airship-deckhand master: docs: Add use cases for each of the mutation operations  https://review.openstack.org/615892
14:35:56 <sthussey> but at this point it exists basically to squat on the name until the OSF decides how to handle 2nd tier social media
14:36:14 <sthussey> If we want to make it active, how best to achieve that?
14:36:27 <roman_g> At the moment we don't really check tickets created in the storyboard (I would say it's not very apropriate tool for bug reports, it's more for the software project development management). I would suggest to remove mentioning of the storyboard from docs.
14:36:30 <openstackgerrit> Felipe Monteiro proposed openstack/airship-deckhand master: docs: Add use cases for each of the mutation operations  https://review.openstack.org/615892
14:36:49 <sthussey> Maybe updates on airshipit.org about how to request assistance?
14:36:51 <mattmceuen> roman_g I'd rather do a better job at responding personally
14:37:01 <mattmceuen> it's a good tool if we use it well
14:37:24 <sthussey> Include what roman_g stated about sharing logs
14:37:34 <sthussey> I've added storyboard to the forum list
14:37:42 <openstackgerrit> Felipe Monteiro proposed openstack/airship-deckhand master: docs: Add use cases for each of the mutation operations  https://review.openstack.org/615892
14:37:48 <roman_g> mattmceuen: me too, but in fact we don't respond often there.
14:37:52 <sthussey> At some point, you've spread attention too thin to make any of those forums as efficient as they could be
14:38:18 <mattmceuen> hey roman_g, what emails were you referring to - I didn't see any from the ML this morning?  Did I miss them?
14:38:37 <mattmceuen> sthussey: yes that is a challenge
14:39:08 <sthussey> I would prefer to pick one forums and make it the preferred forum for support requests
14:39:19 <sthussey> And then provide some guidance about that on airshipit.org
14:39:49 <sthussey> Including what content to include (logs, versions, commands run, etc...) and how best to include it (pastebin, etc...)
14:40:18 <sthussey> No need to decide anything today as attendance is sparse, but something to consider
14:40:31 <mattmceuen> I think that's a great idea
14:40:37 <mattmceuen> that page is the front door
14:40:57 <mattmceuen> so "how to best seek assistance" is a good thing to have front and center
14:41:02 <roman_g> sthussey: https://pastebin.ubuntu.com/ and http://paste.openstack.org/ are free, ads-free, and Ubuntu-one allows nearly unlimited number of lines (in comparison to the most popular Pastebin.com)
14:41:30 <sthussey> Also it appears to be accessible from AT&T's corporate network
14:41:44 <mattmceuen> lol
14:43:22 <sthussey> I've updated the agenda w/ this idea. We can review next week and possibly decide a path forward.
14:43:27 <mattmceuen> ++
14:43:29 <mattmceuen> oh wait
14:43:37 <mattmceuen> next week is the summit - two weeks?
14:43:56 <sthussey> Okay, we'll review next week and target a decision for two weeks
14:44:10 <mattmceuen> Sadly I'll be on vacation in 2 weeks, but... wait that's not sad at all
14:44:14 <portdirect> im a big fan of modernpaste: https://paste.fedoraproject.org/
14:44:17 <mardim> Does anyone have the etherpad link for the topics of the meeting?
14:44:28 <sthussey> https://etherpad.openstack.org/p/airship-meeting-2018-11-06
14:44:33 <mardim> thanks!!
14:44:55 <sthussey> @mattmceuen if you add any additional thoughts in the agenda for today, they'll be carried forward
14:45:09 <mattmceuen> awesome, thx sthussey
14:45:23 <sthussey> any other comments on support forums?
14:46:14 <sthussey> Okay, moving to the last topic
14:46:30 <mattmceuen> that is some high tech paste portdirect!  Also accessible from behind my corporate proxy, neat.
14:46:40 <sthussey> #topic Review Requests
14:47:06 <mattmceuen> ah I added this one
14:47:10 <sthussey> I'm not going to paste them here, you can refer to the agenda
14:47:32 <mattmceuen> Just combined a few of the requests into one place along with one other -- the spyglass spec, it needs some review
14:47:54 <mattmceuen> If anyone has other things they're pining for review on, please add it to the agenda!
14:48:04 <sthussey> Personal opinion is that outside of specs, I'm not sure this is a good forum for review requests
14:48:23 <sthussey> But doesn't hurt to include them in the agenda
14:48:57 <sthussey> Okay then, I think that wraps it up
14:49:28 <b-str> thanks!
14:49:32 <sthussey> Next meeting will likely be light attendance as it overlaps the summit. We'll table any decisions that come up next week
14:49:51 <roman_g> Thank you for the meeting.
14:49:53 <sthussey> thanks everyone
14:49:56 <sthussey> #endmeeting