14:00:08 <dwalt> #startmeeting Airship
14:00:09 <openstack> Meeting started Tue Feb 19 14:00:08 2019 UTC and is due to finish in 60 minutes.  The chair is dwalt. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:10 <dwalt> #topic rollcall
14:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <openstack> The meeting name has been set to 'airship'
14:00:21 <dwalt> Hey everyone! I am hosting today's meeting since mattmceuen has a conflict.
14:00:33 <dwalt> Here is today's agenda: https://etherpad.openstack.org/p/airship-meeting-2019-02-19
14:00:35 <nishant_> Good Morning everyone !
14:00:53 <dwalt> Please add any topics you would like to discuss as everyone joins. We'll get started in a few minutes.
14:01:56 <aaronsheffield> o/
14:02:18 <georgk> hi
14:02:28 <hogepodge> hi
14:02:37 <evrardjp> o/
14:03:00 <seaneagan> o/
14:03:40 <dwalt> It looks like the dust has settled on the etherpad, let's get started
14:03:44 <dwalt> #topic New Airskiff storyboard items
14:04:06 <dwalt> Some new items have recently been added to the Treasuremap storyboard
14:04:12 <dwalt> #link https://storyboard.openstack.org/#!/project/openstack/airship-treasuremap
14:04:36 <dwalt> Several are geared towards Airskiff
14:05:10 <dwalt> One of the things I have been doing is marking those that seem like good "starting" issues with the label "low-hanging fruit"
14:06:16 <dwalt> Of course, anyone can work on them! But these items are a more easily digestible in size
14:06:43 <dwalt> roman_g: I see you added some items here. Would you like to discuss those?
14:08:40 <dwalt> I think Roman may still be AFK. Anyway, we'd like to open storyboard up a bit more to anyone else who has items they would like to add
14:09:25 <dwalt> Airskiff seemed like a natural starting place for this, since several new contributors are using this to ramp-up on the project
14:09:52 <dwalt> So please feel free to do so or claim any of the new items!
14:10:25 <nishant_> sure dwalt ! That sounds good.
14:10:57 <dwalt> Anything else on the new storyboard items or storyboard in general?
14:11:47 * roman_g is back
14:12:00 <roman_g> Any way to select and see tags easily in th storyboard?
14:12:04 <dwalt> hey roman_g!
14:12:17 <roman_g> "low-hanging fruit"'s
14:12:52 <roman_g> Let me know if you find a way.
14:13:02 <dwalt> I think you have to either click on a storyboard item to view tags or filter by them
14:13:12 <dwalt> Does anyone know of a better way?
14:13:46 <roman_g> All right. Will ask you for a screenshot.
14:13:56 <roman_g> Next topic.
14:14:22 <dwalt> Sure, I will update later with a query to use
14:14:24 <dwalt> #topic New meeting hours
14:14:56 <dwalt> So this idea was bounced around last week. mattmceuen proposed a new meeting time of two hours later
14:15:26 <dwalt> We've been keeping a vote on this on the meeting agenda. Is anyone opposed?
14:15:38 <roman_g> Submit a patch to the repo with new proposed meeting time, and add +1/-1 there.
14:15:39 <dwalt> Or have any other suggestions for a new meeting time
14:15:56 <dwalt> roman_g: that's a great idea. What is the proper repo to do that?
14:16:02 <roman_g> We have folks from Korea, which would be against the change.
14:16:37 <dwalt> That's a good point, I don't think they are represented here today
14:16:43 <roman_g> dwalt: openstack-infra/irc-meetings
14:17:10 <dwalt> #action propose new meeting time to openstack-infra/irc-meetings
14:17:14 <dwalt> thanks roman_g
14:17:26 <roman_g> SK-Telekom
14:17:41 <dwalt> Does anyone have any suggestions for a more inclusive time?
14:18:05 <roman_g> No way. It's already early for US-based team.
14:18:18 <roman_g> Like 6-7 or 8am
14:18:49 <dwalt> agreed. It seems to be easier in the summer when much of the U.S. is on Daylight savings time
14:19:10 <roman_g> Other countries also have DST
14:19:21 <hogepodge> I like this tool for comparing times.
14:20:00 <hogepodge> No time will be perfect, which is why I think it's important to push important decisions to places like the mailing list, which knows no time zones.
14:20:02 <hogepodge> https://www.worldtimebuddy.com
14:20:40 <dwalt> That's helpful, thanks hogepodge
14:21:28 <dwalt> I believe we have hosted votes over the mailing list before to promote core reviewers. I'll sync-up with mattmceuen about using the mailing list thread for this proposal
14:21:40 <roman_g> #action propose new meeting time in airship-discuss mailing list
14:21:53 <dwalt> thanks roman_g. Any other thoughts before we move on?
14:22:14 <dwalt> #topic ReadTheDocs
14:22:29 <dwalt> roman_g: I believe this is yours!
14:22:38 <roman_g> Yes. Should now be fixed.
14:23:05 <roman_g> There was a pull request to the RTD folks, which has been merged a few hours ago.
14:23:17 * b-str So something changed in RTD?
14:23:35 <roman_g> Waiting for Zuul to run this job again to see the results: http://zuul.openstack.org/builds?job_name=trigger-readthedocs-webhook
14:23:46 * sthussey You don't need to emote your questions.
14:24:11 <roman_g> b-str: RTD started to require CSRF token in December, all RTD jobst started to fail that time.
14:24:11 <b-str> Sorry, bad control-enter behavior due to another chat application
14:24:27 <b-str> Ok, thanks!
14:24:33 <dwalt> Glad to hear that, thanks for the update, roman_g
14:24:49 <roman_g> =)
14:25:02 <dwalt> I suppose this means we will need to manually re-trigger all documentation jobs once we confirm it works?
14:25:20 <roman_g> No. I have re-triggered all docs an hour ago.
14:25:41 <dwalt> Fantastic!
14:25:49 <roman_g> Found 1 new failing docs build
14:25:55 <b-str> I think that is a strange explanation for why Deckhand's docs were failing on a dependency, but if it works, I'll take it.
14:26:02 <roman_g> Divingbell is failing
14:26:25 <roman_g> Deckhand is failing since October, patch is pending review
14:26:41 <dwalt> Do you have a link to that patch, roman_g?
14:26:49 <b-str> oh, this is separate from the Deckhand issue. got it.
14:26:54 <roman_g> https://review.openstack.org/635357 - openstack/airship-deckhand - Embed UML generated diagrams into docs, fix docs build
14:27:17 <sthussey> Rumour has it that RTD now supports UML
14:27:23 <roman_g> I did not submit a patch for the Divingbell yet. https://storyboard.openstack.org/#!/story/2005046 Divingbell docs builds failure
14:27:28 <sthussey> So we should look at refactoring the build to utilize that
14:27:45 <roman_g> sthussey: yes, it is. integrated into my patch here https://review.openstack.org/635357 - openstack/airship-deckhand - Embed UML generated diagrams into docs, fix docs build
14:28:11 <sthussey> Ah, nice
14:28:45 <dwalt> That's great roman_g, thanks for taking the initiative on that
14:29:19 <dwalt> If anyone has the capacity, there is a storyboard item to fix the Divingbell documentation
14:29:21 <dwalt> #link https://storyboard.openstack.org/#!/story/2005046
14:29:51 <dwalt> Any other additional comments on this topic?
14:30:12 <roman_g> no
14:30:32 <dwalt> Cool. Moving on!
14:30:35 <dwalt> #topic Stories published on storyboard for Airship-* projects
14:30:45 <roman_g> Full list has been sent to Matt by roman_g
14:30:53 <roman_g> What do we do with those stories?
14:31:17 <dwalt> roman_g: is this list of stories on the ML or elsewhere?
14:31:23 <roman_g> Really, we need to find a way to work on them and close.
14:31:30 <roman_g> In corporate mail.
14:31:46 <roman_g> It's a copy-paste of all stories we have in storyboard.
14:32:08 <dwalt> I know some of these items have not been visited in a long time, so some may now be invalid
14:32:37 <dwalt> I imagine especially so in AIAB
14:32:49 <roman_g> Would we may be distribute them between us and work on them? Ask if help is still needed, or may be submit a patch or give a recommendation?
14:33:51 <dwalt> I think that's a good first step; comment on the items and see if they're still valid
14:34:15 <dwalt> Maybe once we do that, we could work to develop a proper labeling system?
14:34:36 <dwalt> I am not too familiar with how other OpenStack projects are using storyboard today
14:35:35 <roman_g> #action roman_g to ask if issue is still valid in Storyboard, make an announcement in mailing list
14:36:01 <dwalt> I am also happy to help with that effort, roman_g
14:36:02 <roman_g> How long to wait until people reply?
14:36:18 <roman_g> Say, wait for 2 weeks and close as "invalid"?
14:36:31 <dwalt> That's a good question. Two weeks seems reasonable to me
14:36:48 <roman_g> sthussey, b-str - what you think?
14:37:04 <roman_g> hogepodge
14:37:36 <sthussey> Probably should live in the governance work
14:38:25 <roman_g> Agree. Would be good to have it defined there.
14:38:28 <sthussey> I doubt this is the correct forum at this point until we outline the governance model
14:38:42 <hogepodge> other communities mark as stale as long as 30-90 days, but it largely depends on the size and activity of your community.
14:39:12 <b-str> I think there is some question too about if the items in storyboard are "tasks" or "roadmap" (probably both), they probably have different lifecycles.
14:39:15 <hogepodge> If you start with two you can adjust from there. I don't have any strong thoughts on it right now
14:39:33 <roman_g> Then I will just re-visit all stories and ask if it's still valid.
14:39:42 <roman_g> there are mostly bugs.
14:39:54 <roman_g> not roadmaps and tasks
14:40:04 <dwalt> that's a good point, b-str. A lot of these are questions on errors I assume have been fixed by now
14:40:26 <b-str> Right - bugs, support requests, enhancement requests, outlines of features, etc... it's a lot of things.
14:40:40 <dwalt> Maybe we can avoid closing them for now and just check up on their status
14:41:02 <b-str> the point is well taken though, needs some TLC.
14:41:07 <roman_g> Sure. Will not close, just will ask if it's still valid.
14:42:22 <dwalt> Sounds like a plan! Any other thoughts on this one before roundtable?
14:43:05 <dwalt> #topic roundtable
14:43:53 <dwalt> Any other items/thoughts that didn't make it into the meeting agenda?
14:44:11 <sthussey> I didn't have the link to the agenda, but for next meeting I'd like folks to consider what onboarding environment seems the most valuable
14:44:23 <roman_g> https://etherpad.openstack.org/p/airship-meeting-2019-02-19
14:44:26 <sthussey> Currently there is too much maintenance overhead
14:45:06 <sthussey> So IMO we need to cut down the number of 'out of the box' things Airship proves
14:45:29 <roman_g> sthussey: like what, from we have today?
14:45:32 <sthussey> Airskiff, Airship-in-a-bottle local VM, Airship-in-a-bottle multi-VM, treasuremap
14:45:48 <sthussey> I don't see enough value maintaining all of them
14:46:49 <sthussey> So a thing to consider and discuss next meeting
14:46:57 <roman_g> I agree.
14:47:32 <dwalt> That's a good thought, sthussey. I know there have been some grumblings of consolidating more of these items in treasuremap
14:47:57 <dwalt> I will make sure this gets added to the agenda for the next meeting. Thanks for bringing this up
14:48:51 <dwalt> #action add item to next meeting agenda to discuss onboarding environments
14:49:43 <dwalt> I realize now I skipped over the requests for review :p. I'll post those in a second, sorry folks
14:49:53 <dwalt> anything else beforehand?
14:50:25 <roman_g> No.
14:50:30 <dwalt> #topic Requests for review
14:50:37 <roman_g> I've added item to the next meeting agenda
14:50:45 <dwalt> Some patches from roman_g
14:50:50 <dwalt> https://review.openstack.org/635357 - openstack/airship-deckhand - Embed UML generated diagrams into docs, fix docs build
14:50:50 <dwalt> https://review.openstack.org/635507 - openstack/airship-treasuremap - Add cache for results of requests to quay.io in Updater tool (gate fails, but issue is not related to the patch)
14:50:50 <dwalt> https://review.openstack.org/636324 - openstack/airship-in-a-bottle - Fix: docs formatting
14:50:50 <dwalt> https://review.openstack.org/632457 - openstack/airship-in-a-bottle - Fix: publish MAAS dashboard
14:51:07 <dwalt> Any extra eyes on these would be much appreciated!
14:51:42 <roman_g> https://review.openstack.org/#/c/635357/ - Zuul -2 on gates. Will look at it.
14:52:21 <dwalt> roman_g: ah, perhaps another dependency issue
14:52:35 <dwalt> That's it for the agenda, everyone. Any other parting thoughts?
14:53:27 <roman_g> Any specs in process?
14:53:47 <b-str> Thanks for running the meeting today @dwalt
14:53:54 <dwalt> I believe we still have the ansible and ironic ones roman_g
14:54:03 <dwalt> my pleasure b-str!
14:54:15 <roman_g> Torpedo is pending
14:54:29 <sthussey> https://review.openstack.org/#/q/projects:openstack/airship-specs+status:open
14:54:39 <nishant_> I have a spec for Divingbell Ansible Framework- https://review.openstack.org/#/c/628221/
14:54:49 <roman_g> The spec for minimirror - is it implemented and can be moved to Implemented?
14:54:56 <nishant_> Would like to see some more feeedback. Thanks.
14:55:09 <dwalt> Sure thing, nishant_
14:55:28 <sthussey> Likely should be removed
14:55:36 <sthussey> As minimirror is not an Airship solution
14:55:52 <dwalt> roman_g: agree with sthussey. It was realized as a part of OpenStack-Helm-addons
14:56:16 <dwalt> I can take care of updating that
14:56:20 <roman_g> OK.
14:56:25 <dwalt> #action resolve mini-mirror spec
14:57:32 <dwalt> I think that's it. Thanks for coming, everyone. Have a great day!
14:57:41 <dwalt> #endmeeting