14:00:45 <mark-burnett> #startmeeting airship
14:00:46 <openstack> Meeting started Tue Aug 21 14:00:45 2018 UTC and is due to finish in 60 minutes.  The chair is mark-burnett. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:50 <openstack> The meeting name has been set to 'airship'
14:01:02 <mark-burnett> Hi all, today's etherpad is at: https://etherpad.openstack.org/p/airship-meeting-2018-08-21
14:01:18 <sthussey> hello
14:01:20 <mattmceuen> GM!
14:01:47 <aaronsheffield> o/
14:01:48 <mark-burnett> I just got back to the real world Sunday, so I didn't plan much of an agenda.  Just a few cleanup items
14:02:07 <seaneagan> o/
14:02:19 <mattmceuen> welcome back mark-burnett, we missed you :D hope your vacation was great
14:02:26 <mark-burnett> Naturally feel free to add items if you have any discussion points.
14:02:30 <mark-burnett> Great, but tiring :)
14:02:46 <mark-burnett> Ok, let's dive into some of the cleanup items
14:02:56 <mark-burnett> #topic PTG agenda
14:03:09 <mark-burnett> The PTG agenda etherpad is https://etherpad.openstack.org/p/AirshipPTG4
14:03:15 <mark-burnett> I just want to remind people to capture ideas there
14:03:29 <mark-burnett> Maybe next week we can take our first stab at organizing it
14:04:20 <mark-burnett> #topic Meeting re-schedule
14:04:22 <hogepodge> hi
14:04:24 <mark-burnett> Hi
14:05:01 <mattmceuen> gm hogepodge
14:05:33 <mark-burnett> I will send an email later today to the list about re-scheduling - I just added it to the agenda to make sure it didn't get lost
14:05:47 <mark-burnett> #action mark-burnett push the ball forward on meeting reschedule via mailing list
14:06:02 <mark-burnett> #topic Core policy
14:06:12 <mark-burnett> Moving through these quickly, as they're really just cleanup
14:06:31 <openstackgerrit> Kaspars Skels proposed openstack/airship-treasuremap master: Fixes for airship undercloud manifests  https://review.openstack.org/592679
14:06:34 <mark-burnett> This is one seems pretty similar to me - I get the sense that people would prefer to work entirely through the mailing list for this, which is fine by me.
14:06:41 <b-str> question.
14:06:56 <b-str> What is a reasonable # of cores for airship.
14:07:13 <b-str> I know "it depends"
14:07:48 <b-str> but... given the number of components and diversity of the responsibilities of those components, is there any wisdom around this number?
14:07:48 <mattmceuen> Probably "more than a normal project" since it's a bunch of projects
14:08:17 <mattmceuen> hogepodge is there a rule of thumb you'd share from different projects' team sizes, is there a sweet spot?
14:08:31 <mattmceuen> w.r.t. specifically to core reviewers
14:08:49 <sthussey> Seems to me the main driver is code churn. A large project mostly dormant probably doesn't need many reviewers
14:08:57 <mark-burnett> I am not sure.  I think size could be a consideration when adding/removing someone, but I would be surprised if we start pushing any boundaries on what's reasonable anytime soon.
14:08:58 <sthussey> And Airship has plenty of code churn.
14:09:23 <sthussey> I think we just continue to add folks that seem like a good fit
14:09:37 <sthussey> Doubling the current count would not be a stretch at all
14:09:54 <mark-burnett> Agreed with that sthussey
14:10:00 <mattmceuen> Right now we have one big cross-functional team
14:10:22 <mattmceuen> I believe it's been floated that eventually we might consider partitioning that.  Thoughts?
14:10:57 <mark-burnett> Sounds premature to me, but maybe you have something specific in mind?
14:11:05 <sthussey> None of the components to me are best-in-class for what they do
14:11:07 <mattmceuen> also agree with sthussey to grow organically, and that includes deferring some decisions like the above to the last responsible moment ;-)
14:11:10 <b-str> given logical planning of the desired outcome I could support a reasonable split
14:11:15 <sthussey> The only value proposition is the synergy of using them togather
14:11:28 <sthussey> together*
14:11:31 <mark-burnett> Yeah, none of the components is really stand-alone today, though that's the goal
14:11:35 <mark-burnett> Probably Drydock is the closest
14:11:58 <mattmceuen> I don't have a strong opinion right now about whether it will eventually make sense to partition the team, but
14:12:03 <hogepodge> I don’t have a good rule
14:12:08 <mattmceuen> The thought was based less on "stand alone-ness"
14:12:14 <mattmceuen> and more on "domain expertise"
14:12:33 <mattmceuen> since conerns have been raised along the lines of "it's hard to be a core reviewer of *everything*"
14:12:44 <mark-burnett> That would make the platform less cohesive probably, which is really the main value prop, as sthussey mentioned
14:13:03 <sthussey> I think it is fine to have reviewers that focus on pieces
14:13:16 <sthussey> I think a core should have a high degree of familiarity with the entire platform
14:13:26 <sthussey> Something being hard doesn't make it wrong
14:13:27 <hogepodge> Typically core is granted to active contributors who have pushed code and reviewed it, and has shown good judgment
14:13:53 <b-str> Ok, sounds like we need to think about this problem more.  Maybe come up with some proposals or a roadmap of where we want to take this short/mid/long term
14:14:38 <hogepodge> #link https://docs.openstack.org/openstack-ansible/latest/contributor/core-reviewers.html official guidelines for OpenStack
14:14:41 <sthussey> And I'm happy to nominate folks that have shown familiarity with a piece and the judgment to withhold approvals on the other pieces
14:15:14 <sthussey> But I'd hope that second piece is a matter of climbing the learning curve, not a permanent state
14:15:18 <mark-burnett> Yeah, certainly someone does not need to have contributed to every project to become a core, but familiarity will help keep things working together.
14:15:28 <hogepodge> (that's for osa, but it's generally applicable)
14:15:32 <mark-burnett> Which again, is where the value is today
14:15:38 <mattmceuen> Agree - and I think either way that's a good place to start mark-burnett
14:16:03 <mattmceuen> and adjust as time goes on if and only if valuable
14:17:59 <mark-burnett> Ok, do we feel the need to write a short-term core policy down right away?  Or are we comfortable being a bit more fluid and operate in the mailing list as an open discussion?
14:18:58 <hogepodge> I’d see it as part of developing governance for the project
14:19:01 <b-str> I'm fine with deferring a policy, but not plannig.
14:19:06 <b-str> planning
14:19:15 <mattmceuen> I hadn't seen the OSA core responsibilities -- they add a lot of detail on top of the general openstack guidelines: https://docs.openstack.org/infra/manual/core.html
14:19:47 <b-str> I would expect any expanded policy is driven by need
14:20:02 <b-str> and not just because someone else has one.
14:20:10 <mark-burnett> Yeah, probably the PTG would be a good place to discuss this further even.  Is that what you had in mind hogepodge?
14:20:17 <portdirect> The osa augments should be adopted generally for openstack hodgepodge, jus saying ;)
14:20:19 <hogepodge> Yeah
14:20:50 <mark-burnett> Ok, I've added a note to the PTG agenda for that
14:20:57 <mattmceuen> +1
14:21:00 <mark-burnett> Any other thoughts before we move on?
14:21:04 <b-str> cool, sounds like we can expect some great info after the PTG!
14:22:37 <mark-burnett> #topic Treasuremap
14:22:49 <mark-burnett> So the treasuremap repo is created
14:22:51 <mark-burnett> #link https://review.openstack.org/#/q/project:openstack/airship-treasuremap+status:open
14:23:18 <mark-burnett> The intent is for it to be home to a complete set of viable configuration
14:23:49 <mark-burnett> This is really just an announcement :)
14:23:58 <mark-burnett> #topic Weekly design meetings
14:24:04 <mattmceuen> 1min
14:24:27 <mattmceuen> Kaspars has been working on getting the manifests prepped
14:24:41 <mattmceuen> Review would be much appreciated so we can get them happy and merged!
14:24:52 <mattmceuen> There are also a couple WIP PS from that link
14:25:28 <mattmceuen> One for the pipeline that will run against the manifests daily and integrate them with the latest airship & OSH charts -- that one is 100% wip but just FYI
14:26:05 <mattmceuen> The other WIP is some further edits to the manifests.  Kaspars says that the undercloud parts in that PS are coming along nicely and are good for review if anyone is so inclined; otherwise can wait till the whole thing is de-wip'd
14:26:16 <mattmceuen> But definitely the core manifests - would be great to get that PS merged soon
14:26:25 <mattmceuen> that's all from me - thx mark-burnett
14:26:29 <mark-burnett> ok
14:26:47 <mark-burnett> I know I haven't been able to review at all, but I know the other cores spend quite a lot of time reviewing
14:26:54 <sthussey> Just merge it
14:26:59 <sthussey> It is a net add with no production impact
14:27:59 <mark-burnett> Ok, so onto the weekly design meeting discussion
14:28:08 <mark-burnett> The announcement is here
14:28:10 <mark-burnett> #link http://lists.airshipit.org/pipermail/airship-announce/2018-August/000001.html
14:29:07 <mark-burnett> Please feel welcome to join.  We have had these discussion internally at AT&T and are trying to move them into the community.
14:30:09 <mark-burnett> Any other thoughts?
14:30:12 <mattmceuen> ++
14:30:24 <mattmceuen> New ideas will be awesome and welcome :)
14:30:32 <hogepodge> We’ll be sure to promote it on the foundation side
14:30:43 <mark-burnett> Awesome, thanks
14:31:08 <mark-burnett> Ok, that's it for old business
14:31:16 <mark-burnett> And I don't see anything new added
14:31:24 <mark-burnett> #topic Roundtable
14:31:30 <mark-burnett> Any other roundtable topics before we close?
14:31:45 <hogepodge> Reminder about the sync meeting this Thursday
14:31:50 <mark-burnett> Oh, nice point
14:32:37 <hogepodge> 8:30 PT, 10:30 CT
14:32:51 <mark-burnett> Here's the thread for reference: http://lists.airshipit.org/pipermail/airship-discuss/2018-August/000053.html
14:33:05 <mark-burnett> Any other thoughts?
14:33:23 <hogepodge> We’ll be workshopping the one page overview and possibly 101 slide deck
14:33:42 <mattmceuen> looking forward to it hogepodge
14:34:45 <mark-burnett> Alright, thanks for coming all.
14:34:47 <mark-burnett> #endmeeting