16:01:24 <jasondotstar> #startmeeting #openstack-salt
16:01:25 <openstack> Meeting started Tue Feb  2 16:01:24 2016 UTC and is due to finish in 60 minutes.  The chair is jasondotstar. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:30 <openstack> The meeting name has been set to '_openstack_salt'
16:01:37 <jasondotstar> #topic Roll Call
16:01:39 <jasondotstar> o/
16:01:49 <cznewt> o/
16:02:13 <jasondotstar> hi cznewt :-)
16:02:15 <jasondotstar> GM
16:02:42 <jasondotstar> another 60secs
16:02:45 <cznewt> hello salters
16:02:51 <jasondotstar> to see who else joins us :-)
16:03:00 <jasondotstar> salters unite!
16:03:34 <jasondotstar> ok....
16:03:44 <jasondotstar> #topic Introduction
16:03:59 <jasondotstar> this is the second irc meeting for the openstack-salt team
16:04:10 <jasondotstar> If you're interested in contributing to the discussion, please join #openstack-salt
16:04:24 <jasondotstar> Meetings are Weekly on Tuesdays at 1600UTC  <-now
16:04:41 <jasondotstar> #link http://eavesdrop.openstack.org/#OpenStack_Salt_Team_Meeting
16:04:50 <jasondotstar> #link     https://wiki.openstack.org/wiki/Meetings/openstack-salt
16:05:11 <jasondotstar> #topic Review past action items
16:05:32 <jasondotstar> first order of business:
16:05:34 <jasondotstar> cznewt to finish out the chapter on local dev environment (i.e vagrant)
16:05:57 <cznewt> yes, the documentation is now up-to-date, how to provision vagrant
16:05:58 <jasondotstar> so I think this is completed
16:06:10 <jasondotstar> thanks cznewt - I'll try this out
16:06:24 <cznewt> single node deployment, meaning 1 config, 1 control 1 compute node
16:06:34 <jasondotstar> do you have that link handy to post here?
16:07:12 * jasondotstar looks
16:07:32 <jasondotstar> #link http://openstack-salt.tcpcloud.eu/develop/quickstart-vagrant.html
16:07:42 <jasondotstar> any other comments on this?
16:07:42 <cznewt> Until the official documentation is built use the preceding link
16:07:54 <cznewt> thanks, jasondotstar
16:07:57 <jasondotstar> +1
16:08:18 <cznewt> this is ok, well discuss heat in next topic
16:08:25 <jasondotstar> cool..
16:08:34 <jasondotstar> next: cznewt to report on the completion of the core set of salt formulas
16:09:15 <cznewt> the core formulas have been reviewed and all required parts are there
16:09:17 <jasondotstar> any news here?
16:09:28 <cznewt> we've added tests
16:09:35 <jasondotstar> nice
16:09:50 <cznewt> for the code style and metadata validity
16:10:03 <jasondotstar> +1
16:10:08 <cznewt> we've cought several errors by this mechanism already
16:10:20 <jasondotstar> one question about the last topic
16:10:24 <jasondotstar> i just thought about
16:10:30 <jasondotstar> for the AIO deployment
16:10:50 <jasondotstar> would it be beneficial to have a aio script to run all the tasks required?
16:11:00 <jasondotstar> the puppet guys do something similar
16:11:12 <jasondotstar> ah...
16:11:18 <cznewt> the question is the other needed formulas are to be included in the openstack as well
16:11:25 <jasondotstar> i see you have something there already for booting up the salt formulas...
16:11:27 <genunix> You mean something like Salt orchestrate? Or Fabric in eg. opencontrail case?
16:11:32 <jasondotstar> salt master i mean
16:11:54 <cznewt> yes there's a script to bootstrap salt-master from packages or git
16:12:22 <cznewt> and for AIO deploy it's just matter of highstating the nodes
16:12:29 <jasondotstar> gotcha.
16:12:41 <genunix> jasondotstar: basically this - https://github.com/tcpcloud/heat-templates/blob/master/templates/salt_single_public.hot#L120
16:13:09 <cznewt> yes
16:13:15 <jasondotstar> i haven't looked at the details of this script but
16:13:27 <cznewt> I've cleaned that up a little but basically that's it
16:13:35 <jasondotstar> there's a modular way that the puppet guys do it
16:13:42 <jasondotstar> you can add remove modules at will.
16:14:01 <jasondotstar> im wondering if that's implemented here for the salt states...
16:14:11 <jasondotstar> forgive me if it's there, and i just haven't seen it yet.
16:14:22 <cznewt> you mean librarian?
16:14:34 <jasondotstar> well
16:14:39 <cznewt> dependencies among modules?
16:14:44 <cznewt> versions and so on
16:14:50 <jasondotstar> yes
16:15:04 <jasondotstar> they've got the Puppetfile
16:15:10 <jasondotstar> with the list of modules in it
16:15:14 <cznewt> we had to do this for the testing purpose
16:15:21 <jasondotstar> tagged with version numbers and such.
16:15:23 <jasondotstar> ok
16:15:27 <genunix> jasondotstar: there are nothing like puppetfiles in salt, but we have done this for testing dependencies - https://github.com/openstack/salt-formula-heat/blob/master/metadata.yml
16:15:34 <jasondotstar> ok
16:15:35 <jasondotstar> gotcha.
16:15:39 <cznewt> define the dependencies, but it is not official
16:15:55 <genunix> jasondotstar: anyway we prefer deployment using debian packages which can handle these things
16:15:56 <jasondotstar> i see.
16:16:06 <jasondotstar> makes sense
16:16:07 <jasondotstar> ok
16:16:17 <cznewt> but we could propose something like that to the salt community
16:16:37 <cznewt> if there's demand
16:17:06 <jasondotstar> #agreed Perhaps proposing a dependency tool to the salt community is a good idea based on demand
16:17:11 <cznewt> also that's another topic to adress: how to contribute to salt community as well
16:17:22 <jasondotstar> cznewt: go for it
16:17:42 <jasondotstar> #topic Contributing to the Salt communit
16:17:46 <jasondotstar> #topic Contributing to the Salt community
16:18:01 <jasondotstar> i've yet to do that.... thoughts?
16:18:25 <cznewt> the testing mechanisms for salt formulas
16:18:37 <cznewt> the formula dependencies
16:19:13 <cznewt> these are the things that might be valuable to salt community as well
16:19:31 <genunix> we should discuss with salt community some standarized way to do this and possibly help with implementation
16:19:44 <genunix> maybe the same for debian packaging of formulas which we have already done
16:19:53 <jasondotstar> +1
16:20:28 <cznewt> the salt-linters out in the wild are outdated and need to be cleaned.
16:21:14 <jasondotstar> so upstream from us might be work in the salt project itself
16:21:45 <jasondotstar> and where it makes sense we should push those items up there.
16:21:46 <cznewt> yes i think so
16:21:49 <genunix> #agreed work with salt community - agree on standard for versioning and satisfying formula dependencies (aka Puppetfile) and for packaging
16:22:10 <jasondotstar> very well.
16:22:17 <jasondotstar> any other thoughts on this?
16:22:48 <cznewt> i think this is aggreed
16:22:49 <jasondotstar> if not, we'll move on.
16:23:02 <jasondotstar> cznewt: sounds good.
16:23:18 <jasondotstar> #topic Today's Agenda
16:23:46 <jasondotstar> ok, first: setup core/release teams:
16:24:03 <jasondotstar> cznewt, genuing, pupapaik, Jay_Clark, majklkcz anyone else?
16:24:12 <cznewt> genunix
16:24:16 <jasondotstar> +1
16:24:40 <genunix> +1
16:24:47 <cznewt> now nothing block the team creation?
16:25:00 <jasondotstar> that was my next question
16:25:10 <jasondotstar> we need to go back to -infra and make sure you are added, cznewt
16:25:14 <jasondotstar> if we haven't already
16:25:47 <cznewt> yes, I'll after the meeting
16:26:02 <jasondotstar> good deal.
16:26:19 <jasondotstar> next: development guideline
16:26:45 <jasondotstar> proposal - repositories imported under github.com/openstack
16:26:57 <cznewt> the repositories are under the openstack  nameespace now
16:27:28 <jasondotstar> cznewt: ok. how do we keep the github project(s) and the openstack project(s) in sync?
16:27:47 <cznewt> and in the openstack git, is the infromation here correct?
16:27:51 <cznewt> #link http://openstack-salt.tcpcloud.eu/develop/extending-contribute.html
16:28:17 <cznewt> github - the tcpcloud namespace - the repos will be removed
16:28:24 <genunix> jasondotstar: our repos in tcpcloud namespace will be removed so there's no need for sync
16:28:41 <jasondotstar> +1
16:28:52 <genunix> the question is about building packages
16:28:56 <cznewt> as they are being added to the openstack
16:29:07 <genunix> it's currently done in our Jenkins and uploaded to our PPA
16:29:18 <genunix> but I would like to do this in openstack way
16:29:19 <jasondotstar> that has to be moved over
16:29:20 <jasondotstar> right
16:29:32 <genunix> so these packages may reach ubuntu cloud and debian once
16:29:49 <genunix> but I don't know how it works for openstack packages so this is probably action item to me
16:30:19 <genunix> also maybe do some cleanup on packaging, specify dependencies for some formulas, etc.
16:30:39 <jasondotstar> #action genunix to research how to openstack packaging works
16:31:54 <cznewt> The integration setup of the launchpad needs to be checkedd
16:32:45 <jasondotstar> agreed
16:32:47 <cznewt> I think the openstack access is not well configured there
16:33:00 <jasondotstar> I can take a look at that one
16:33:24 <jasondotstar> #action jasondotstar to look at the integration of launchpad with our repos
16:33:52 <cznewt> jasondotstar: can we go over the complete process of contributing together? I'd like to evangelise further, but i want to certain that i do it right
16:34:02 <jasondotstar> of course
16:34:26 <jasondotstar> the contributor guidelines
16:34:59 <jasondotstar> let's take a quick at that
16:35:05 <jasondotstar> see if there is any feedback
16:35:34 <jasondotstar> #link http://openstack-salt.tcpcloud.eu/develop/extending-contribute.html
16:35:38 <jasondotstar> (again)
16:36:56 <cznewt> yes, I'll do it after the meeting to see how it works from both sides
16:37:31 <cznewt> I'd like to
16:37:51 <jasondotstar> +1
16:38:08 <cznewt> get the heat stack for development of salt stack tested
16:38:14 <cznewt> and ready
16:38:28 <jasondotstar> +1
16:38:44 <cznewt> we provide labs for openstack-salt creating to the customers so we can do it to the community as well
16:39:18 <cznewt> jasondotstar: there'a account for you ready already and it will be open for openstack-salt team members
16:39:28 <jasondotstar> nice
16:40:12 <cznewt> yes, the full scale HA deployment lab takes about 20 cores and 60gb of ram
16:40:26 <cznewt> it's out of scope of vagrant testing :)
16:40:31 <jasondotstar> hehehe
16:40:34 <jasondotstar> i think so
16:40:43 <jasondotstar> unless you've got an entire LAB
16:40:50 <jasondotstar> however, that might be a point to discuss
16:41:03 <jasondotstar> perhaps we can get talk to -infra about a dev environment
16:41:10 <jasondotstar> or have someone sponsor some resources
16:41:24 <jasondotstar> so that we can fully test HA
16:41:42 <cznewt> yes, this is for further discussion
16:42:12 <cznewt> it would be nice to get more sponsors
16:42:14 <cznewt> +1
16:42:21 <jasondotstar> #agreed Further research is needed on how we acquire resources for HA testing
16:42:51 <jasondotstar> I can ask around
16:43:15 <jasondotstar> my company *might* have something we can leverage, but don't quote me on that :-)
16:43:47 <jasondotstar> I've known rackspace to sponsor some lab space IIRC
16:43:48 <cznewt> Super, the openstack environments are preferrable
16:43:57 <jasondotstar> +1
16:44:25 <jasondotstar> #action jasondotstar to look into dev environment sponsorship
16:45:00 <jasondotstar> other items on collaborative efforts.....?
16:45:01 <cznewt> #action newt test the aio/ha openstack-salt heat setup
16:45:27 <cznewt> just the salt community involvement
16:45:33 <jasondotstar> +1
16:45:48 <cznewt> it has been already put into action, I think
16:45:53 <jasondotstar> good deal
16:46:15 <jasondotstar> we touched on this, but are we good on building formula packages under openstack?
16:46:31 <jasondotstar> RHEL needs love
16:46:34 <jasondotstar> yes?
16:47:11 <cznewt> we are good for debian, and the packages are not very complicated, just copying around
16:47:55 <cznewt> so i think we can provide rhel packages as well in short time
16:48:02 <jasondotstar> cool.
16:48:47 <jasondotstar> oh.... the contributor license
16:49:15 <jasondotstar> Apache License, Version 2.0
16:49:31 <jasondotstar> is that the license we're using?
16:50:15 <jasondotstar> are there comments about that?
16:50:37 <cznewt> the formulas use the apache2 all of them
16:50:55 <cznewt> and what about the contributor's license, which one applies
16:51:47 <jasondotstar> #link https://review.openstack.org/static/cla.html
16:52:23 <cznewt> yes, thank you
16:52:31 <jasondotstar> i think mainly this means that the code you contribute is originated by you
16:52:40 <jasondotstar> once you offer it
16:52:48 <jasondotstar> it goes under the apache license at that point
16:52:51 <jasondotstar> IIUC
16:53:26 <jasondotstar> i can't take closed-source code from IBM, and offer it as a patch
16:53:28 <jasondotstar> for example.
16:53:48 <cznewt> yes i get it even better now :)
16:53:59 <jasondotstar> so both kinda come into play
16:55:18 <jasondotstar> "I offer MY (and I mean MY code - as stated in the Contributor license) code to this project, which is then protected by the Apache License"
16:55:42 <jasondotstar> something to that affect
16:56:02 <jasondotstar> ok we've got 5 mins left
16:56:06 <jasondotstar> #topic Open Discussion
16:57:00 <jasondotstar> no additional comments from me. we've got a few things to look int.
16:57:04 <cznewt> well i'm out of topics, I'll be here to help you with the install
16:57:05 <jasondotstar> s/int./into.
16:57:19 <cznewt> which ones?
16:57:30 <jasondotstar> just the action items
16:57:50 <jasondotstar> im saying nothing else besides what we've already talked about :-)
16:58:03 <jasondotstar> oh... summit
16:58:09 <jasondotstar> you guys going?
16:58:38 <cznewt> yes, most probably
16:58:46 <jasondotstar> yep, I'll be there
16:58:57 <jasondotstar> we can talk more about that later
16:59:09 <cznewt> yes, looking forward to summit :)
16:59:22 <jasondotstar> cool. if nothing else, i think we can close
16:59:23 <cznewt> let's continue on #openstack-salt
16:59:27 <jasondotstar> thx guys
16:59:38 <cznewt> thx all
16:59:39 <jasondotstar> until next week
17:00:00 <jasondotstar> #endmeeting