20:00:26 <xgerman> #startmeeting(Octavia)
20:00:27 <openstack> Meeting started Wed Apr  1 20:00:26 2015 UTC and is due to finish in 60 minutes.  The chair is xgerman. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:31 <openstack> The meeting name has been set to '_octavia_'
20:00:35 <xgerman> #chair blogan
20:00:35 <openstack> Current chairs: blogan xgerman
20:00:42 <johnsom> o/
20:00:49 <bharath> o/
20:00:51 <ajmiller> o/
20:00:55 <Aish> o/
20:01:07 <mwang2> o/
20:01:34 <jamiem> o/
20:02:27 <dougwig> o/
20:02:33 <TrevorV_> o/
20:02:37 <johnsom> Is everyone else at the tow yard?
20:02:52 <rm_you> o/
20:02:59 <xgerman> cool
20:03:42 <ptoohill> o/
20:03:43 <xgerman> Agenda: https://wiki.openstack.org/wiki/Octavia/Weekly_Meeting_Agenda#Meeting_2015-04-01
20:04:17 <xgerman> I missed the Neutron meeting... dougwig any announcments?
20:04:48 <dougwig> it was all about not merging code for a bit, which doesn't apply to us, and a few holy wars.
20:05:03 <xgerman> ok, neat
20:05:22 <xgerman> HP approved our travel: so ajmiller, johnsom + I will be in Vancouver
20:05:42 <dougwig> great
20:06:04 <johnsom> Alex and Susanne as well
20:06:04 <xgerman> yeah, we need some great UDP loadbalancing session ;-)
20:06:27 <xgerman> #topic Brief progress reports
20:06:29 <dougwig> what cool devices is HP giving away this year?
20:06:46 <xgerman> marketing will figure that out ;-)
20:07:11 <johnsom> I hope it isn't the flashlight with bottle opener inside.  That was an odd one
20:08:19 <johnsom> Controller worker has been all about rebase and cleaning up the unit tests.
20:08:32 <xgerman> I rebased the Agent API Rest thing
20:08:40 <ajmiller> I have been working on the devstack plugin for octavia.  Will be posting another patch soon that creates screen windows, etc.  It can't actually do anything until we have workers that run merged, but its a start.
20:08:56 <johnsom> I hope to have the member and health monitor methods this week.  Then I will come back through and update for the database changes
20:09:48 <mwang2> we merged 2 patches, one is health manager , the other is the config drive
20:10:10 <xgerman> yeah!
20:10:38 <xgerman> we are still trying to wrap our  head around blogan's neywork driver; need to figure out if it runs against our cloud...
20:11:13 <xgerman> and I saw a new incarnation of the ssh driver, too :-)
20:11:14 <johnsom> Yeah, I want to look at the update patchset and see if the section I had questions about were updated.
20:11:29 <xgerman> ok, let's move on
20:11:36 <TrevorV_> Wait
20:11:42 <xgerman> ok
20:11:44 <TrevorV_> What do you mean new incarcation?  You mean patch-set?
20:11:47 <xgerman> yep
20:12:02 <TrevorV_> yeah, I made a few changes, but some I don't think are required in ssh_driver
20:12:06 <TrevorV_> Maybe as its own review
20:12:22 <xgerman> ok, cool
20:12:34 <xgerman> #topic How should a Octavia dev/test environment look like - 2
20:12:40 <xgerman> ajmiller started
20:12:55 <xgerman> basically the Octavia things will run straight on the devstack
20:13:27 <xgerman> ajmiller will explain it more ;-)
20:13:32 <xgerman> it's what trove does
20:14:37 <ajmiller> I just pushed a review that adds octavia devstack support.  All it does right now is start bash shells where there will eventually be workers, but it starts the screens.
20:15:03 <xgerman> should make demoing more awesome ;-)
20:15:03 <ajmiller> There will be one screen session for each worker process (queue consumer, health monitor, houskeeping manager)
20:16:01 <ajmiller> Just need to add the appropriate "enable_plugin" and "enable_service" entries to localrc.
20:16:28 <ajmiller> The review is
20:16:32 <ajmiller> #link https://review.openstack.org/#/c/167796/
20:16:47 <xgerman> ok, so comment there if the model isn't right...
20:16:52 <ajmiller> Please add questions or comments to gerrit.
20:17:30 <johnsom> Excellent!
20:17:45 <ptoohill> Awesome stuff guys!
20:17:59 <ptoohill> getting close
20:18:23 <xgerman> #topic Should Octavia use tempest or Rally for integration tests?
20:18:46 <dougwig> isn't rally for load testing?
20:18:58 <xgerman> I think it can do integration testing as well
20:18:59 <TrevorV_> Openstack says Tempest.
20:19:10 <ptoohill> yea, im a bit confused by this topic. i may have missed this conversation
20:19:32 <xgerman> there was no conversation... I just put it on the agenda as a question/esploration
20:19:35 <rm_you> yeah i thought tempest was a given
20:19:37 <ptoohill> Whats wrong with tempest?
20:19:44 <rm_you> ptoohill: is that a loaded question? :P
20:19:50 <ptoohill> :P
20:19:53 <rm_you> but yeah, no experience with rally, so couldn't say
20:20:05 <rm_you> but i thought tempest was essentially required in Openstack
20:20:19 <TrevorV_> At least one test rm_you :)
20:20:27 <rm_you> lol
20:20:39 <ptoohill> Was there any specific reasoning some wanted to use Rally over Tempest?
20:21:22 <xgerman> Rally has a better UI...
20:21:38 <ptoohill> oh, ive never used tempest ui
20:21:46 <dougwig> either one has a UI?
20:21:46 <xgerman> they don;t have one ;-)
20:21:48 <dougwig> huh.
20:21:53 <xgerman> Rally does
20:21:53 <ptoohill> lol
20:21:54 <dougwig> ha.
20:22:13 <ptoohill> interesting
20:22:27 <dougwig> the tempest UI is gerrit.
20:22:34 <ptoohill> but if openstack req is for tempest is Rally really a consideration?
20:22:48 <johnsom> Probably not
20:23:25 <dougwig> i don't think openstack requires tempest, just unit, api, functional, and integration testing.
20:23:33 <ptoohill> ah
20:23:34 <TrevorV_> I wouldn't want to incorporate Rally if we still had to use tempest.  Sounds like work duplication
20:24:13 <ptoohill> if we were using them for different things/reasons i would be ok with having both. But if one can do everything we need and theres no specific requirement for which we use
20:24:22 <johnsom> I liked that Rally gives timing information
20:24:41 <johnsom> Not if the tempest stuff does or not
20:24:44 <rm_you> hmm, i really thought tempest was required... though let me see if i can actually find that documented anywhere, and if not, then... whelp
20:25:02 <ptoohill> I would hate to run into new bugs/issues with a less used tool though.
20:25:08 <dougwig> they're busy making tempest not central, so i can't imagine it's required.
20:25:27 <xgerman> yeah, I think we can pick whatever we like most
20:25:59 <xgerman> but I also don't really have a strong opinion one way or the other -- just wanted us to start a conversation...
20:26:21 <xgerman> (and I like shiny things ;-)
20:26:48 <rm_you> lol checked https://wiki.openstack.org/wiki/Testing#Automated_Integration_Tests
20:26:54 <rm_you> and it is literally just a link to tempest
20:26:58 <ptoohill> i like shiny things that we dont have to fight with
20:27:01 <TrevorV_> xgerman I don't think enough of us have information about Rally to make that assessment
20:27:02 <mwang2> when you try to create or delete users through rally, it gives you something like this
20:27:04 <mwang2> Total durations
20:27:04 <rm_you> was hoping for more guidance <_<
20:27:04 <mwang2> Action 	Min (sec) 	Avg (sec) 	Max (sec) 	90 percentile 	95 percentile 	Success 	Count
20:27:04 <mwang2> keystone.create_user 	0.256 	0.382 	0.554 	0.456 	0.494 	100.0% 	100
20:27:04 <mwang2> keystone.delete_user 	0.2 	0.3 	0.404 	0.379 	0.394 	100.0% 	100
20:27:04 <mwang2> total 	0.491 	0.682 	0.92 	0.795 	0.82 	100.0% 	100
20:27:29 <ptoohill> certainly useful
20:27:38 <rm_you> xgerman: TrevorV_ +1, we need a bit to check it out before we can really discuss merits
20:27:39 <dougwig> makes sense, since it came into life as a way to do benchmarking.
20:28:19 <xgerman> rm_you, ptoohill: that's fine we are still a few weeks off from actually writing tests
20:29:19 <xgerman> #action smart up on Rally vs. tempest
20:30:09 <xgerman> #topic Open Discussion
20:30:36 <xgerman> I liked to talk about the config file sections for amphora driver
20:30:38 <TrevorV_> I have a small topic
20:30:49 <TrevorV_> Yeah ha ha ha xgerman that's what I was going to say ha ha
20:31:02 <xgerman> ok
20:31:04 <TrevorV_> blogan we could use your input for this as well :D
20:31:17 <xgerman> well, there are two issues:
20:31:28 <xgerman> 1) We shouldn't name it amphora ;-)
20:31:41 <xgerman> 2) Should haproxy drivers share the same config
20:31:45 <xgerman> section
20:32:25 <ptoohill> would we be running multiple drivers at the same time?
20:32:28 <ptoohill> for #2
20:32:40 <xgerman> no, we decided one driver per control plane
20:32:43 <ptoohill> If so, then we need a way to seperate them i think
20:32:47 <ptoohill> then, why not?
20:33:26 <xgerman> yeah, I wanted to keep the layout, etc. mostly the same and just have the transport (ssh/rest) be the variant
20:33:42 <xgerman> (layout-disk layout on the amp)
20:33:54 <ptoohill> ah, i see
20:34:29 <xgerman> yeah, I can see if we start an nginx driver that there will be a different section
20:34:31 <ptoohill> like sub sections of sorts?
20:34:35 <xgerman> like nginx-amphora
20:35:04 <TrevorV_> ptoohill xgerman blogan had a problem with all one section
20:35:12 <xgerman> yeyep
20:35:12 <TrevorV_> He said it looked bad in documentation
20:35:42 <TrevorV_> I told him I thought just one section was most appropriate because any given running env would just leave out fields it doesn't need.
20:35:46 <TrevorV_> He said "it looks bad"
20:35:47 <TrevorV_> So idk
20:35:53 <TrevorV_> Since he's not here to defend himself, ha ha
20:36:05 <xgerman> we can always vote :-)
20:36:19 <ptoohill> im sorta on the same page with you TrevorV
20:36:38 <ptoohill> when you document for the driver, it would be docuemted in that section right?
20:37:09 <ptoohill> yea, we may want to wait for blogan to examplain, im not sure what the problem is
20:37:14 <xgerman> well, I am not opposed to have different sections if we have differend backends, e.g. nginx, haproxy, a10
20:37:17 <ptoohill> explain*
20:37:24 <xgerman> but I don't think we need two haproxy sections
20:38:12 <xgerman> dougwig, you likely run one a10 section?
20:38:23 <ptoohill> as long as we can document things clear i dont really have a problem with however this is done
20:38:28 <dougwig> yep
20:39:34 <xgerman> #action xherman reach out to blogan to reach consensus
20:39:50 <xgerman> usually we are on the same page anyway (even without knowing it:-)
20:39:53 <TrevorV_> Yeah, get on that xherman
20:39:55 <TrevorV_> Pffff
20:40:04 <ptoohill> :)
20:40:07 <ptoohill> new guy
20:40:12 <TrevorV_> Best new guy
20:41:14 <johnsom> yeah, we hired pee-wee herman but he is hiding from the paparazzi
20:41:22 <ptoohill> lol
20:41:34 <TrevorV_> Anything else for OD?
20:41:37 <rm_you> yeah i think it can be handled in documentation
20:41:52 <rm_you> similar stuff is done elsewhere
20:42:12 <xgerman> yep
20:42:30 <xgerman> breaking news: OpenStack to be rewritten in Golang ;-)
20:42:38 <rm_you> hehe
20:43:04 <TrevorV_> Pff xgerman not fallin for it.
20:44:32 <xgerman> #endmeeting