#openstack-meeting: #gluon

Meeting started by bh526r_ at 18:00:18 UTC (full logs).

Meeting summary

  1. Roll Call (bh526r_, 18:00:41)
    1. Bin Hu (bh526r_, 18:00:48)
    2. Georg Kunz (georgk, 18:02:06)

  2. Admin Update (bh526r_, 18:03:28)
    1. We just finished OPNFV NetReady meeting (bh526r_, 18:03:44)
    2. Our lab was deployed with Fuel OpenStack Newton, ODL and Gluon Ocata (bh526r_, 18:04:10)
    3. Basic verification was done (bh526r_, 18:04:23)
    4. Next step is to deploy Shim Layer on SDN-C specific VMs (bh526r_, 18:04:45)
    5. And make Contrail work (Mechanism Driver) with Fuel OpenStack (bh526r_, 18:05:15)
    6. At an offline conversation, Huawei intended to set up a 2nd lab in Santa Clara (bh526r_, 18:06:38)
    7. They will start to work on the lab setup (bh526r_, 18:06:59)

  3. PoC Planning for OpenStack Summit and OPNFV Summit (bh526r_, 18:07:26)
    1. JinLi (jinli, 18:12:14)
    2. Logistics wise, in OpenStack Summit, we may not have our dedicated booth (bh526r_, 18:13:10)
    3. Bin is in talk with OPNFV regarding the possibility to share OPNFV booth there (bh526r_, 18:13:47)
    4. OPNFV is discussing it (marketing, admin, event team), and see what are the options, e.g. OpenSource Day booth etc. (bh526r_, 18:14:44)
    5. Bin will share more information once he knows more from OPNFV (bh526r_, 18:15:11)
    6. For OPNFV Summit, Bin will submit PoC proposal to secure an AT&T Booth as we did for OPNFV Summit in Berlin (bh526r_, 18:16:15)
    7. In terms of PoC scope, there are several options (bh526r_, 18:16:44)
    8. E.g. SFC among controllers. But it appears to be too aggressive to implement within short time frame (bh526r_, 18:17:19)
    9. It is more confident to focus on the core value of Gluon and Proton (bh526r_, 18:17:47)
    10. So the demo scope could include: (bh526r_, 18:19:05)
    11. (1) 3 YAMLs and Protons/APIs: L3VPN, SFC and P2P. We will write 3 YAMLs for L3VPN, SFC and P2P service models respectively. Then use Particle Generator to generate 3 Protons / 3 sets of APIs respectively. (bh526r_, 18:20:00)
    12. No code is needed to implement those APIs on SDN-C, except those already supported. (bh526r_, 18:20:30)
    13. The value proposition is to enable quick development and deployment of new networking service APIs so as to accelerate time-to-market and improve business agility (bh526r_, 18:21:32)
    14. (2) Then demonstrate a fun use case for interoperability of multiple SDN controllers using Proton API L3VPN. (bh526r_, 18:22:01)
    15. Minimum code is needed to automate passing RT and RD parameters via Proton L3VPN API so as to enable BGP peering among those SDN controllers (bh526r_, 18:22:47)
    16. ACTION: : @georgk figure out a list of parameters needed for BGP peering (bh526r_, 18:33:36)

  4. Planning for Pike (bh526r_, 18:35:58)
    1. Bin will follow up with Sukhdev and Ian regarding RFE "optional network type" and its implementation in Neutron (bh526r_, 18:37:02)
    2. We need more volunteer for other Pike tasks (bh526r_, 18:38:36)
    3. https://wiki.openstack.org/wiki/Gluon/Tasks-Pike (bh526r_, 18:39:02)
    4. All are encouraged to sign up (bh526r_, 18:39:14)

  5. Planning for Forum in Boston (bh526r_, 18:39:38)
    1. Telecom/NFV Etherpad is here: (bh526r_, 18:40:10)
    2. https://etherpad.openstack.org/p/BOS-UC-brainstorming-Telecom&NFV (bh526r_, 18:40:13)
    3. Bin will create an Etherpad for planning a Gluon session (bh526r_, 18:43:16)
    4. Meeting adjourned (bh526r_, 18:49:49)


Meeting ended at 18:49:58 UTC (full logs).

Action items

  1. : @georgk figure out a list of parameters needed for BGP peering


Action items, by person

  1. georgk
    1. : @georgk figure out a list of parameters needed for BGP peering


People present (lines said)

  1. bh526r_ (71)
  2. georgk (21)
  3. jinli (7)
  4. openstack (3)


Generated by MeetBot 0.1.4.